Resolución de pantalla 1600x900

20 envíos / 0 nuevos
Último envío
#1 Sáb, 11/03/2017 - 19:27
asrael
Imagen de asrael
Desconectado/a
se unió: 25/07/16

Resolución de pantalla 1600x900

Estado: 
[SOLUCIONADO]

Hola a todos, he instalado el driver privativo de mi tarjeta de video nvidia con éxito pero no tengo disponible la resolución 1600x900 (tengo actualmente la resolución 1920x1080), he googleado mucho y probado cosas sin exito, el resultado de mi archivo /etc/X11/xorg.conf es

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 375.39  (buildmeister@swio-display-x86-rhel47-09)  Tue Jan 31 20:47:44 PST 2017


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
    Modeline "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1600x900"
    EndSubSection
EndSection

Siguiendo algunos manuales de la red agregue en la sección "Monitor" la línea "Modeline ..." y en la sección  "Screen" la línea "Modes 1600x900", luego reinicié sin éxito alguno, agradecería alguna recomendación.

Saludos

Dom, 12/03/2017 - 13:05
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

Fijate si aca encontras algo 

Tene en cuenta donde pones el archivo de configuracion  /etc/x11.conf.d/10-monitor.conf

Dom, 12/03/2017 - 14:36
asrael
Imagen de asrael
Desconectado/a
se unió: 25/07/16

Agradezco su respuesta y me ha iluminado un poco sobre el archivo 10-monitor.conf.
He seguido este manual aplicando todos los pasos quedando mi archivo /usr/share/X11/xorg.conf.d/10-monitor.conf de la siguiente manera:

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
    Modeline "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "HDMI-0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1920x1080" "1600x900" "1280x720" "1024x768" "800x600"
    EndSubSection
EndSection

Y después de reiniciar noté aparentemente que tengo la resolución 1600x900 "pero" los textos de cualquier ventana no se ven bien, parecen muy forzados

Y cuando ejecuto xrandr me indica que sigo usando actualmente la resolución 1920x1080 por que esta señalado con el asterisco (*), y no existe la resolución 1600x900

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 300mm x 230mm
   1024x768      60.00 +  75.03  
   1920x1080     59.94* 
   1280x720      59.94  
   800x600       75.00    60.32  
   720x480       59.94    59.94  
   640x480       75.00    59.94  
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)

Asumo que en mi archivo 10-monitor.conf se esta ejecutando bien la linea: Modeline "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
pero ignora la línea: Modes  "1920x1080" "1600x900" "1280x720" "1024x768" "800x600"

Alguna recomendación me será de ayuda.

Dom, 12/03/2017 - 14:55
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

Fijate si funciona configurando manualmente ( en forma momentanea) con xrandr.

http://blog.desdelinux.net/xrandr-poderosa-herramienta-para-configurar-tu-monitor/

Edito: ¿por que pusiste  'device HDMI ' ? 

Dom, 12/03/2017 - 15:40 (Responder a #4)
asrael
Imagen de asrael
Desconectado/a
se unió: 25/07/16

caliban wrote:

Fijate si funciona configurando manualmente ( en forma momentanea) con xrandr.

http://blog.desdelinux.net/xrandr-poderosa-herramienta-para-configurar-tu-monitor/

Edito: ¿por que pusiste  'device HDMI ' ? 

Hola, agradezco nuevamente su respuesta.

Agregue HDMI-0 por que así lo recomienda el manual del link que publique líneas arriba, aquí hay otro link donde en resumen lo indican,
Además HDMI-0 es el resultado correcto que me arroja xrand:
 

HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 300mm x 230mm

Y por otro lado, inicialmente intenté configurar la resolución con xrandr tal como lo recomiendan en la red, según mi caso usando cvt 1600 900 ejecuto al final:

xrandr --newmode 1600x900_60.00  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync

Ahora xrandr me devuelve HDMI-0 connected primary... así que ejecuto:

xrandr --addmode HDMI-0 "1600x900_60.00"

Y siempre me devuelve:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  35
  Current serial number in output stream:  36

googleando leí que xrandr no funciona con nvidia link y no pude encontrar solución a ese error por lo cual no pude avanzar con xrandr

Cualquier recomendación me sería de mucha ayuda.

Dom, 12/03/2017 - 15:43
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

Bien tendras que esperar a que alguien que se maneje con nvidia ,yo tengo graficas integradas.

Dom, 12/03/2017 - 19:16
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

¿Usas debian 3? ¿Debian 4? ¿5? ¿6? ¿7? ¿8? ¿Stretch? ¿Unstable? ¿la gráfca es una nvidia fx5200? ¿es un portátil? ¿Es un sobremesa? ¿el monitor es un samsung? ¿es un acer? ¿es un lg? ¿Ha trabajado alguna vez con esa resolución? ¿está usando la nvidia? ¿está usando otra gráfica? ¿tienes una gráfica? ¿tienes 2 gráficas? ¿Tienes un archivo xorg.conf? ¿Tienes un archivo 20-nvidia.conf en xorg.conf.d? ¿Tienes los dos? Y muchas preguntas más que se me pasan por la cabeza...

Nos dices lo que has probado, lo que no va, y no sabemos ni de refilón que equipo tienes ni que sistema usas... Este hilo va para 2 páginas o más sin haberse solucionado fijo...

 

6. Aporta toda la información que puedas sobre tu problema

Proporciona toda la información necesaria sobre el problema en cuestión, como por ejemplo: el tipo de computadora que tienes, versión de Debian, versión del kernel, sistema de escritorio, etc. Describe los pasos que llevaste a cabo para provocar o solucionar el problema.

https://exdebian.org/normas/normas-del-foro

 

  No hay bar que por bien no venga....
Lun, 13/03/2017 - 04:56
asrael
Imagen de asrael
Desconectado/a
se unió: 25/07/16

Tengo Debian testing 64 bits y es de sobremesa, la gráfica es nvidia GeForce GTX 1050 Ti, usando los controladores privativos, monitor Samsung y es la primera vez que uso este monitor en una pc en linux.
Tengo el archivo /etc/X11/xorg.conf y no tengo el archivo 20-nvidia.conf

Espero que esa información sea útil, por mi lado voy googleando mucho sin éxito.

Saludos.

Lun, 13/03/2017 - 09:01
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Busca el modelo de monitor y mira en las especificaciones si soporta dicha resolución. Que la gráfica la soporte no significa que el monitor si. Por otro lado, el archivo xorg.conf no es necesario (y obsoleto). Si necesitas configurar algo, se usan archivos separados en la ruta /etc/X11/xorg.conf.d/

hazte una copia del xorg.conf y eliminalo. Comprueba que no hay nada en la ruta que he dicho que haga referencia a la gráfica y reinicia el sistema. Deberías tener las resoluciones que soporte tu monitor.

Por otro lado, ¿cómo has instalado los drivers privativos?

  No hay bar que por bien no venga....
Lun, 13/03/2017 - 22:22
asrael
Imagen de asrael
Desconectado/a
se unió: 25/07/16

Gracias por responder, no he podido escribir antes por que recién salgo del trabajo, pero volviendo al tema tengo exactamente este monitor y cuando enciendo la pc me indica que la resolución recomendada es 1600x900, este monitor lo había usado antes con windows sin problemas de este tipo.

Y en tanto al archivo xorg, tengo que decir que no tengo el directorio "/etc/X11/xorg.conf.d/" , he eliminado el archivo /etc/X11/xorg.conf y reiniciado sin éxito. la raíz de mi directorio contiene lo siguiente:

root@debian:/etc/X11# ls -l
total 80
drwxr-xr-x 2 root root  4096 mar 10 20:14 app-defaults
drwxr-xr-x 2 root root  4096 mar 10 00:50 cursors
-rw-r--r-- 1 root root    14 mar 10 00:52 default-display-manager
drwxr-xr-x 6 root root  4096 mar 10 00:47 fonts
-rw-r--r-- 1 root root 17394 nov 23 02:30 rgb.txt
drwxr-xr-x 2 root root  4096 mar 10 00:51 xinit
drwxr-xr-x 2 root root  4096 ene 12 05:40 xkb
-rw-r--r-- 1 root root  1325 mar 11 15:24 xorg.conf.backup
-rw-r--r-- 1 root root     0 mar 11 14:19 xorg.conf.nvidia-xconfig-original
-rwxr-xr-x 1 root root   709 nov 23 02:30 Xreset
drwxr-xr-x 2 root root  4096 mar 10 00:37 Xreset.d
drwxr-xr-x 2 root root  4096 mar 10 00:37 Xresources
-rwxr-xr-x 1 root root  3517 nov 23 02:30 Xsession
drwxr-xr-x 2 root root  4096 mar 10 00:52 Xsession.d
-rw-r--r-- 1 root root   265 nov 23 02:30 Xsession.options
drwxr-xr-x 2 root root  4096 mar 10 00:51 xsm
-rw-r--r-- 1 root root    13 dic  5 13:52 XvMCConfig

También comentarte que el driver privativo de mi tarjeta gráfica lo instale sin problemas descargandolo de su página oficial (link)

Cualquier recomendación es bienvenida.

Mar, 14/03/2017 - 11:05
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

ahi dice que la resolución del monitor es de 1.366 x 768

¿probaste instalando el driver privativo desde el repositorio de debian?

Mar, 14/03/2017 - 11:57
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Pues la recomendación es la misma de siempre... No instalar el driver de la página de nvidia a no ser que sea absolutamente necesario (y tendrás que andar buscando la versión para tu sistema, estarte al tanto de cualquier actualización que afecte al kernel y/o a dicho driver para volver a reinstalar a mano...)

Directamente, yo te aconsejaría que desinstalaras ese driver e instalaras el que viene en repositorios, como ya te han dicho: instala y ejecuta nvidia-detect a ver que te dice, y con lo que te diga, buscas el paquete xserver-xorg-video-nvidia equivalente y lo instalas (si te dice nvidia-driver, pues sería xserver-xorg-video-nvidia, si te dice legacy, pues xserver-xorg-video-nvidia-legachy...), y a partir de aquí se sigue configurando a ver que se puede hacer.

 

Edit....

Como también te han dicho, en las especificaciones dice que tiene 1366x768 (al calabozo debería ir el que inventó esa resolución, no encaja nada ahi bien xD), asi que con eso en la mano, por mucho que tu gráfica si soporte esa resoluciones, el monitor pueda con ellas y no te quedará otro remedio.

  No hay bar que por bien no venga....
Mié, 15/03/2017 - 09:08
asrael
Imagen de asrael
Desconectado/a
se unió: 25/07/16

Hola a todos, gracias por sus respuestas, he desinstalado el driver privativo correctamente e instalado nvidia-driver

Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP107 [GeForce GTX 1050 Ti] [10de:1c82] (rev a1)

Checking card:  NVIDIA Corporation GP107 [GeForce GTX 1050 Ti] (rev a1)
Your card is supported by the default drivers.
It is recommended to install the
    nvidia-driver
package.

Y tras reiniciar no tengo alguna diferencia, es decir tengo las mismas resoluciones que el driver privativo estoy actualmente con 1920x1080 forzado a 1600x900.

Me encantaría seguir probando cosas pero estoy saliendo al trabajo, volveré en unas horas a seguir esta batalla, cualquier recomendación es bienvenida.

Saludos.

Mié, 15/03/2017 - 20:46
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

Suponiendo que el monitor soporte 1920x1080, cual es el problema ¿? todo esta muy peque ¿?, porque quieres una inferior 1600x900. Existe la posibilidad que la resolución 1600x900 sea la recomendada para las TTY ¿?. Esa sugerencia que dice exactamente.
El controlador descargado de Nvidia, ofrece un software para administrar el monitor, que paso ¿?

Cuando use Debian + Controlador propietario de Nvidia + Monitor CRT, sucedió algo parecido, la gráfica mandaba la resolución máxima que ofrecía esta, pero el monitor soportaba una inferior, que hice, simplemente del archivo xorg generado, en la sección Screen, subsección Display, elimine la más alta. No agregue nada en la sección Monitor.

La única variante que veo, es que el sistema identifico el monitor que conecte al VGA. Actualmente conecto un ASUS, en /var/log/Xorg.0.log, ves algo parecido a:

[ 162.207] (II) NOUVEAU(0): Monitor name: ASUS
[ 162.207] (II) NOUVEAU(0): EDID (in hex):
[ 162.207] (II) NOUVEAU(0): 00ffffffffffff004dd9...

Y debes aclarar cual es la resolución nativa de ese monitor. Porque usar otra para la cual no fue diseñado.
Si tienes dudas conecta ese monitor a un sistema Windows, y la resolución más alta es la recomendada para ese monitor o arranca un LINUX LiveCD. Aunque no debería ser necesario, la verdad no entiendo cual es el problema, :-)

Mié, 15/03/2017 - 22:05
asrael
Imagen de asrael
Desconectado/a
se unió: 25/07/16

Gracias por responder, mi problema es que tengo una resolución muy alta a mi monitor, y por tal motivo veo los iconos y textos demasiado pequeños (me esta matando la vista) instale los drivers privativos de nvidia y en su configuración tenía una resolución máxima de 1920x1080 (resolución demasiado grande) y una previa de 1280x720 (resolución demasiado pequeño)

Cuando enciendo la pc el monitor me recomienda la resolución de 1600x900
 

Actualmente mi archivo /usr/share/X11/xorg.conf.d/10-monitor.conf tiene:

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "HDMI-0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1600x900" "1280x720" "1024x768" "800x600"
    EndSubSection
EndSection

Sin embargo sigo teniendo las mismas resoluciones de siempre, luego de desinstalar el driver privativo e instalar el driver libre tengo las mismas resoluciones disponibles como pueden ver:

Ya no se que hacer, el contenido de mi archivo /var/log/Xorg.0.log es este: http://pastebin.com/UCcGExiV

Cualquier recomendación es bienvenida.

Jue, 16/03/2017 - 21:36
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

Resumiendo, la resolución nativa del monitor Samsung es 1600x900 como se observa en la imagen. El ejecutable de nvidia, ni el driver nvidia instalado desde los repositorios, ni el driver nouveau la proporcionan. Sospecho que Debian no esta leyendo el identificador de ese monitor. (Porque en la última imagen aparece un monitor DELL E157FP, le cambiaste el otro para no estropearlo) ¿Como conectas el monitor? Esa tarjeta cuenta con puertos DVI, HDMI, displayport. Le conectas de HDMI a HDMI, o usas alguna clase de adaptador ¿?

(A) De algún modo debes obtener el EDID.

(1) Conectar el monitor a un sistema Windows y usar el siguiente software, http://www.nirsoft.net/utils/dump_edid.html ,otro(s).

(2) Conectar el monitor a un sistema Linux:

(2.1) Leer el /var/log/Xorg.0.log

(2.2) $xrandr --verbose

(2.3) $xxd /sys/devices/pci0000\:00/0000\:00\:01.0/0000\:01\:05.0/drm/card0/card0-LVDS-1/edid (Es un ejemplo, debes ayudarte con el comando lspci, 01:05.0 VGA compatible controller, y con xrandr, LVDS connected)

El EDID es algo parecido a esto:

00ffffffffffff00232f9b0400000000 28150103a53c2278226fb1a7554c9e250c505400000001010101010101010101 010101010101565e00a0a0a029503020 350055502100001a000000fc00445541 4c2d4456490a20202020000000fc000a 202020202020202020202020000000fc 000a2020202020202020202020200012

Copy/paste en edid.txt (en /home/asrael)

(B) Convertir esos datos en formato hex a binario,

(1) $ xxd -r -p edid.txt edid.bin

(2) Investiga apt install read-edid edid-decode

(C) Crear un archivo xorg para leer el EDID

(1) Mueve a otro directorio, todos los archivos xorg que haz creado.

(2) La distribución que uso, indica que debo usar este directorio, /etc/X11/xorg.conf.d/. Ignoro cual sea el formato en Debian, pero puedes usar un # mkdir /etc/X11/xorg.conf.d

Es un ejemplo, modificalo según convenga.

# nano /etc/X11/xorg.conf

Section "Device"

Identifier "nvidia"

Driver "nvidia"

Option "CustomEDID" "HDMI-0:/home/asrael/edid.bin"

Option "IgnoreEDID" "false"

Option "UseEDID" "true"

EndSection

 

Vie, 17/03/2017 - 06:25
asrael
Imagen de asrael
Desconectado/a
se unió: 25/07/16

Muchas gracias por responder, en referencia al nombre DELL E157FP , hasta el momento no he cambiado de monitor, es el único monitor que tengo usandp todo el tiempo (marca samsung).
Otra cosa que bien es cierto, estoy usando un adaptador de HDMI hacía VGA ya que mi tarjeta gráfica no tiene un conector hacia VGA y mi monitor si.

Luego he conectado el monitor a una pc en windows y ejecutado el comando de  dump_edid en el cual tengo este resultado pero no me arroja el código EDID:

DumpEDID v1.05

Copyright (c) 2006 - 2015 Nir Sofer

Web site: http://www.nirsoft.net



*****************************************************************

Active                   : Yes

Registry Key             : DISPLAY\DELA022\5&fdf266b&0&UID1048832

Monitor Name             : DELL E157FP

Serial Number            : FJ06677H0XYS

Manufacture Week         : 29 / 2007

ManufacturerID           : 44048 (0xAC10)

ProductID                : 40994 (0xA022)

Serial Number (Numeric)  : 811096403 (0x30585953)

EDID Version             : 1.3

Display Gamma            : 2.20

Vertical Frequency       : 56 - 76 Hz

Horizontal Frequency     : 30 - 63 KHz

Maximum Image Size       : 30 X 23 cm (14.9 Inch)

Maximum Resolution       : 1024 X 768

Support Standby Mode     : No

Support Suspend Mode     : No

Support Low-Power Mode   : Yes

Support Default GTF      : No

Digital                  : No



Supported Display Modes  :

     720 X  400  70 Hz

     640 X  480  60 Hz

     640 X  480  75 Hz

     800 X  600  60 Hz

     800 X  600  75 Hz

    1024 X  768  60 Hz

    1024 X  768  75 Hz



*****************************************************************

Una cosa que me llama la atención, es que en "Supported Display Modes" no tengo la resolución 1600x900, empiezo a dudar ahora de las habilidades de mi monitor, aún así el contenido de mi /var/log/Xorg.0.log es http://pastebin.com/zf4re2wf

Fuí algo curioso y con el comando $xrandr --verbose noté que en una parte me devuelve el EDID de mi monitor:
 

        EDID: 
                00ffffffffffff0010ac22a053595830
                1d110103801e17782e5d40a1544c9426
                175054a54a0001010101010101010101
                01010101010164190040410026301888
                360030e410000018000000ff00464a30
                3636373748305859530a000000fd0038
                4c1e3f08000a202020202020000000fc
                0044454c4c204531353746500a200160
                02031b61230907078301000067030c00
                2000802d43908402e2000f8c0ad08a20
                e02d10103e9600a05a00000000000000
                00000000000000000000000000000000
                00000000000000000000000000000000
                00000000000000000000000000000000
                00000000000000000000000000000000
                00000000000000000000000000000029

Intenté realizar el paso (2.3) pero agradecería mucho si me pudieras especificar un poco más los pasos a realizar en este punto.

Saludos.

Vie, 17/03/2017 - 19:19
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

El adaptador es el que esta metiendo ruido mi amigo, en ambos sistemas, el monitor lo ven como un DELL E157FP ... La sugerencia que te doy es que conectes ese monitor de VGA a VGA y obtengas el EDID "verdadero".

Mi anterior comentario es para "forzar" al sistema a usar el identificador del "Samsung", pese a usar ese "adaptador". No uso Debian, por lo tanto doy opciones por si alguna no se encontrara en Debian.

Debes optener ese dichoso EDID del samsung, sin usar ese "adaptador". Del punto (A) escoge una y solo una.

Del punto (B) conversión de datos, también escoge una.

Del punto (C) todo.

Saludos.

Vie, 17/03/2017 - 19:38 (Responder a #18)
asrael
Imagen de asrael
Desconectado/a
se unió: 25/07/16

Berbellon wrote:

El adaptador es el que esta metiendo ruido mi amigo, en ambos sistemas, el monitor lo ven como un DELL E157FP ... La sugerencia que te doy es que conectes ese monitor de VGA a VGA y obtengas el EDID "verdadero".

Mi anterior comentario es para "forzar" al sistema a usar el identificador del "Samsung", pese a usar ese "adaptador". No uso Debian, por lo tanto doy opciones por si alguna no se encontrara en Debian.

Debes optener ese dichoso EDID del samsung, sin usar ese "adaptador". Del punto (A) escoge una y solo una.

Del punto (B) conversión de datos, también escoge una.

Del punto (C) todo.

Saludos.

Olvidé mencionar que cuando probé el monitor en la pc en windows, lo hice sin un adaptador, es decir que lo conecté de VGA a VGA en la pc en windows y el resultado de dump_edid fue el que publiqué líneas arriba.
Y desconozco por que se reconoce  a mi monitor con el nombre de DELL E157FP, googleando puedo ver que el monitor DELL E157FP es un monitor con resolución máxima de 1024 x 768 tal como muestra el resultado de dump_edid

Entonces eso quiere decir que el EDID que arrojo $xrandr --verbose es del monitor DELL E157FP y no exactamente del samsung 1600x900? parece que mi monitor samsung tuviera una especie de clonacion con el DELL E157FP

Cualquier recomendación es bienvenida.

Sáb, 18/03/2017 - 01:34
asrael
Imagen de asrael
Desconectado/a
se unió: 25/07/16

Hola amigos, he vuelto para cerrar este tema sin antes comentarles lo sucedido.

Como lo sospechaba, mi monitor tiene como una especie de clonación de marca, especularé un poco, ya que esta es mi teoría del problema (corrijanme si me equivoco), en windows cuando extraigo la info de mi monitor marca samsung de 19' con dump_edid  me devuelve como nombre DELL E157FP y dicho nombre es un modelo de la marca DELL y dicho modelo es de 15' y tiene como máximo la resolución 1024 x 768 exactamente como Debien me lo estaba reconociendo.

En debian /var/log/Xorg.0.log también me reconocia el monitor samsung con el nombre DELL E157FP

Por otra parte he probado con el monitor de mi hermano marca LG igualmente de 19' (tambien tiene salida VGA) y dump_edid si me arroja la resolución 1600x900 y la marca tal como debe de ser (en este caso LG HD PLUS)

DumpEDID v1.05

Copyright (c) 2006 - 2015 Nir Sofer

Web site: http://www.nirsoft.net



*****************************************************************

Active                   : Yes

Registry Key             : DISPLAY\GSM5AC5\5&fdf266b&0&UID1048832

Monitor Name             : LG HD PLUS

Serial Number            : 512NTKFA6965

Manufacture Week         : 12 / 2015

ManufacturerID           : 27934 (0x6D1E)

ProductID                : 23237 (0x5AC5)

Serial Number (Numeric)  : 346965 (0x00054B55)

EDID Version             : 1.3

Display Gamma            : 2.20

Vertical Frequency       : 56 - 75 Hz

Horizontal Frequency     : 30 - 83 KHz

Maximum Image Size       : 44 X 25 cm (19.9 Inch)

Maximum Resolution       : 1600 X 900

Support Standby Mode     : Yes

Support Suspend Mode     : Yes

Support Low-Power Mode   : Yes

Support Default GTF      : No

Digital                  : No



Supported Display Modes  :

     720 X  400  70 Hz

     640 X  480  60 Hz

     640 X  480  75 Hz

     800 X  600  56 Hz

     800 X  600  60 Hz

     800 X  600  75 Hz

     832 X  624  75 Hz

    1024 X  768  60 Hz

    1024 X  768  75 Hz

    1280 X  720  60 Hz

    1152 X  864  75 Hz

    1280 X  800  60 Hz

    1440 X  900  60 Hz

    1600 X  900  60 Hz



*****************************************************************

Así que me propuse probar este monitor LG con salida VGA y el mismo adaptador que usaba con mi cpu Debian y el resultado fue que todo quedo a la perfección, resulta que automaticamente ahora si tengo la resolución 1600x900

Por lo tanto le cambie de monitor a mi hermano (aunque el aún no lo sabe) y ahora no pienso volver a usar nunca mas el monitor samsung.

Ahora si soy feliz.

Saludos.