[SOLUCIONADO] Debian Stretch - ETH0 desaparació y no se ve ni la tarjeta ethernet después de actualizar kernel.

13 envíos / 0 nuevos
Último envío
#1 Mié, 15/03/2017 - 11:42
gringoinc
Imagen de gringoinc
Desconectado/a
se unió: 15/03/17

[SOLUCIONADO] Debian Stretch - ETH0 desaparació y no se ve ni la tarjeta ethernet después de actualizar kernel.

Estado: 
[SOLUCIONADO]

Hola a todos, Luego de hacer una actualización de todo mi sistema y entre ella actualizar el Kernel, dejó de funcionar el puerto Ethernet y solo puedo conectarme por WiFi. Cuando hago un LSPCI no lista ningún dispositivo que contenga Ethernet y si miro /etc/network/interfaces no aparece eth0, solo aparece lo.La información que tengo es la siguiente:

~$ cat /etc/*-release PRETTY_NAME="Debian GNU/Linux 9 (stretch)" NAME="Debian GNU/Linux" VERSION_ID="9" VERSION="9 (stretch)" ID=debian HOME_URL="https://www.debian.org/" SUPPORT_URL="https://www.debian.org/support" BUG_REPORT_URL="https://bugs.debian.org/"

Kernel:

~$ uname -a Linux innovation 4.9.0-2-amd64 #1 SMP Debian 4.9.13-1 (2017-02-27) x86_64 GNU/Linux

Dispositivos:

~$ lspci 00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09) 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09) 00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09) 00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03) 00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03) 00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03) 00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3) 00:1c.1 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #2 (rev e3) 00:1c.3 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #4 (rev e3) 00:1c.4 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #5 (rev e3) 00:1c.5 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #6 (rev e3) 00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03) 00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03) 00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03) 00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03) 02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader (rev 01) 03:00.0 Network controller: Intel Corporation Wireless 7265 (rev 48) 04:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Opal PRO [Radeon R7 M260] 05:00.0 SATA controller: Lite-On Technology Corporation Device 0224 (rev 10)

Módulos:

~$ lsmod Module Size Used by rfcomm 77824 2 ctr 16384 4 ccm 20480 2 pci_stub 16384 1 vboxpci 24576 0 vboxnetadp 28672 0 vboxnetflt 28672 0 vboxdrv 454656 3 vboxnetadp,vboxnetflt,vboxpci cmac 16384 1 bnep 20480 2 arc4 16384 2 iwlmvm 245760 0 mac80211 667648 1 iwlmvm amdkfd 139264 1 intel_rapl 20480 0 x86_pkg_temp_thermal 16384 0 intel_powerclamp 16384 0 coretemp 16384 0 kvm_intel 192512 0 radeon 1482752 1 kvm 589824 1 kvm_intel irqbypass 16384 1 kvm iwlwifi 147456 1 iwlmvm rtsx_pci_ms 20480 0 crct10dif_pclmul 16384 0 cfg80211 589824 3 iwlmvm,iwlwifi,mac80211 memstick 20480 1 rtsx_pci_ms crc32_pclmul 16384 0 ttm 98304 1 radeon iTCO_wdt 16384 0 snd_hda_codec_hdmi 49152 1 iTCO_vendor_support 16384 1 iTCO_wdt ghash_clmulni_intel 16384 0 intel_cstate 16384 0 hid_generic 16384 0 hid_plantronics 16384 0 uvcvideo 90112 0 videobuf2_vmalloc 16384 1 uvcvideo videobuf2_memops 16384 1 videobuf2_vmalloc videobuf2_v4l2 24576 1 uvcvideo videobuf2_core 36864 2 uvcvideo,videobuf2_v4l2 videodev 176128 3 uvcvideo,videobuf2_core,videobuf2_v4l2 media 40960 2 uvcvideo,videodev joydev 20480 0 hp_wmi 16384 0 sparse_keymap 16384 1 hp_wmi fuse 98304 3 usbhid 53248 0 hid 122880 3 hid_generic,usbhid,hid_plantronics snd_usb_audio 180224 4 snd_usbmidi_lib 28672 1 snd_usb_audio snd_rawmidi 32768 1 snd_usbmidi_lib snd_seq_device 16384 1 snd_rawmidi btusb 45056 0 btrtl 16384 1 btusb btbcm 16384 1 btusb btintel 16384 1 btusb bluetooth 552960 31 btrtl,btintel,bnep,btbcm,rfcomm,btusb rfkill 24576 8 bluetooth,hp_wmi,cfg80211 intel_uncore 118784 0 intel_rapl_perf 16384 0 pcspkr 16384 0 evdev 24576 21 serio_raw 16384 0 sg 32768 0 lpc_ich 24576 0 tpm_infineon 20480 0 shpchp 36864 0 mei_me 36864 0 snd_hda_codec_realtek 86016 1 mei 102400 1 mei_me i915 1232896 23 snd_hda_codec_generic 69632 1 snd_hda_codec_realtek wmi 16384 1 hp_wmi snd_hda_intel 36864 8 battery 16384 0 snd_hda_codec 135168 4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek drm_kms_helper 155648 2 radeon,i915 snd_hda_core 81920 5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek snd_hwdep 16384 2 snd_hda_codec,snd_usb_audio snd_pcm 110592 5 snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_hda_core,snd_hda_codec_hdmi snd_timer 32768 1 snd_pcm snd 86016 36 snd_hda_intel,snd_hwdep,snd_hda_codec,snd_usb_audio,snd_timer,snd_rawmidi,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_usbmidi_lib,snd_seq_device,snd_hda_codec_realtek,snd_pcm drm 360448 13 radeon,i915,ttm,drm_kms_helper soundcore 16384 1 snd hp_wireless 16384 0 hp_accel 28672 0 button 16384 1 i915 lis3lv02d 20480 1 hp_accel input_polldev 16384 1 lis3lv02d video 40960 1 i915 i2c_algo_bit 16384 2 radeon,i915 ac 16384 0 tpm_tis 16384 0 tpm_tis_core 20480 1 tpm_tis tpm 45056 3 tpm_infineon,tpm_tis,tpm_tis_core parport_pc 28672 0 ppdev 20480 0 lp 20480 0 parport 49152 3 lp,parport_pc,ppdev ip_tables 24576 0 x_tables 36864 1 ip_tables autofs4 40960 2 ext4 585728 1 crc16 16384 2 bluetooth,ext4 jbd2 106496 1 ext4 crc32c_generic 16384 0 fscrypto 28672 1 ext4 ecb 16384 0 mbcache 16384 2 ext4 sd_mod 45056 5 rtsx_pci_sdmmc 24576 0 mmc_core 147456 1 rtsx_pci_sdmmc crc32c_intel 24576 2 aesni_intel 167936 7 aes_x86_64 20480 1 aesni_intel glue_helper 16384 1 aesni_intel lrw 16384 1 aesni_intel gf128mul 16384 1 lrw ablk_helper 16384 1 aesni_intel cryptd 24576 3 ablk_helper,ghash_clmulni_intel,aesni_intel ahci 36864 3 libahci 32768 1 ahci psmouse 135168 0 libata 249856 2 ahci,libahci ehci_pci 16384 0 ehci_hcd 81920 1 ehci_pci xhci_pci 16384 0 xhci_hcd 188416 1 xhci_pci i2c_i801 24576 0 i2c_smbus 16384 1 i2c_i801 scsi_mod 225280 3 sd_mod,libata,sg rtsx_pci 57344 2 rtsx_pci_sdmmc,rtsx_pci_ms usbcore 249856 9 uvcvideo,usbhid,snd_usb_audio,ehci_hcd,xhci_pci,snd_usbmidi_lib,btusb,xhci_hcd,ehci_pci mfd_core 16384 2 lpc_ich,rtsx_pci usb_common 16384 1 usbcore thermal 20480 0 fjes 28672 0

He intentado hacer update y upgrade haber si me baja un nuevo driver, he modificado el archivo "/etc/network/interfaces" adicionandole el ETH0 y nada ha funcionado. Al parecer no reconociera la tarjeta.

La tarjeta está bien, porque si inicio en otro SO(W7) carga y funciona sin problemas.

Por si sirve de algo, mi equipo es un HP Zbook14 G2.

De antemano, mil gracias por la ayuda que me puedan brindar.

Mié, 15/03/2017 - 11:57
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Vamos por partes ,¿que te muestra ? 

ifconfig -a 

Edito : ¿de que modo actualizaste ? ( con cuáles órdenes)

          ¿cual es el contenido de tu archivo /etc/apt/sources.list? 

Por cierto, cuando escribas tu respuesta  utiliza el ícono 'insertar fragmento de código,seleccionando a continuación ,"bash". de tal modo los comandos , y todo aquello que sea distinto a tus comentarios quedara distinguido del resto .

Por ejemplo esto .

 

Mié, 15/03/2017 - 12:25
gringoinc
Imagen de gringoinc
Desconectado/a
se unió: 15/03/17

Hola @caliban, gracias por tu interés en ayudarme.
 

1) Actualicé con 

  aptitude update
  aptitude upgrade
  apt-get install build-essential
  apt autoremove 
  apt-get install module-assistant
  apt-get dist-upgrade 

No me preguntes por que hice eso..... no se en que momento me puse a molestar lo que no debía (Asumo la responsabilidad) solo trataba de actualizar para instalara algo que no era capaz..... acepto, soy muy novato!

2) /etc/apt/sources.list 

# 

# deb cdrom:[Debian GNU/Linux testing _Stretch_ - Official Snapshot amd64 NETINST Binary-1 20161219-05:32]/ stretch main

# deb cdrom:[Debian GNU/Linux testing _Stretch_ - Official Snapshot amd64 NETINST Binary-1 20161219-05:32]/ stretch main

deb http://ftp.us.debian.org/debian/ stretch main non-free contrib
deb-src http://ftp.us.debian.org/debian/ stretch main non-free contrib

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

deb http://download.virtualbox.org/virtualbox/debian stretch contrib

deb http://mirrors.kernel.org/debian/ stretch-updates main contrib non-free
deb-src http://mirrors.kernel.org/debian/ stretch-updates main contrib non-free
deb http://mirrors.kernel.org/debian stretch-proposed-updates main contrib non-free
deb-src http://mirrors.kernel.org/debian stretch-proposed-updates main contrib non-free

# debian-multimedia
# apt-get install deb-multimedia-keyring
deb http://www.deb-multimedia.org stretch main non-free

 

3) ifconfig -a 

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 188  bytes 14716 (14.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 188  bytes 14716 (14.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlo1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 172.0.0.202  netmask 255.255.252.0  broadcast 172.0.3.255
        inet6 fe80::8d27:bf00:c735:b44  prefixlen 64  scopeid 0x20<link>
        ether 64:80:99:fd:3b:ee  txqueuelen 1000  (Ethernet)
        RX packets 95877  bytes 72122575 (68.7 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 43301  bytes 8751805 (8.3 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Vuelvo a agradecer, prometo no seguir metiendo la pata.... Salu2

Jonathan Osorio - @gringoinc

Mié, 15/03/2017 - 12:59
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Intenta iniciar con el kernel anterior.

Un par de dudas,¿tu actualizacion fue  estando en strecht o desde una anterior version de debian ? 

¿el kernel se actualizo junto al resto ,o manualente instalaste alguno desde los repositorios ? (¿ y de que modo ? )

Mié, 15/03/2017 - 13:28 (Responder a #4)
gringoinc
Imagen de gringoinc
Desconectado/a
se unió: 15/03/17

Hola @caliban. cómo inicio con el Kernel Anterior? 

Respondiendo a tus preguntas, es una instalación STRETCH desde el principio, y se actualizó junto al resto!

Gracias por tu apoyo!

Jonathan Osorio - @gringoinc

Mié, 15/03/2017 - 13:52
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Respecto al kernel anterior  ,existe un modo de configurar  /etc/default/grub , para que inicie con un kernel determinado ,

el punto es que como hago esas cosas manualmente ,tendrías que buscarlo ,no obstante si te animas a usar comandos 

durante el inicio,cuando aparece la interfaz de grub, si precionas la tecla 'c' , te llevara a una ventana grub de comandos ,desde ella se puede arrancar cualquier sistema 

grub > ls  #  te mostrara discos y particiones segun grub
grub > ls (hd0,msdos1)  # mostrara la info de esa particion incluida la UUID
grub > ls /hd0,msdos1) / # te mostrara la informacion contenida en / 
grub > set root=(hd0,msdos1)  # setea desde donde bootear el sitema 
grub > linux /boot/vmlinuz-4.9.0-1-686-pae   root=uuid=aca la uid   
grub > initrd /boot/initrd.img-4.9.0-1-686-pae
grub > boot

Aproximadamente con esos comandos  podras arrancar tu sistema ,indicando claro , el disco particion que correspondan ,y la imagen inicial  que corresponda al viejo kernel ,.

Es un metodo que siempre me ha resultado para ahcer pruebas, de todos modos seguramnte alguien te indicara un método mas práctico .

Para mas info 

https://help.ubuntu.com/community/Grub2/Troubleshooting

Y por cierto lo de arrancar con el viejo kernel es, una sospecha ( pero no certeza ) que quiza el problema pase por que el nuevo kernel no reconozca tu interfaz ,

Mié, 15/03/2017 - 13:59
gacs
Imagen de gacs
Conectado
colaborador
se unió: 21/04/16

Por lo que puedo ver en la salida de tu ifconfig -a tu eth0 es wlo1 echale un vistaso a

http://docs.iescdl.es/~josem/redes.html#nombre

https://exdebian.org/foro/nombre-por-defecto-de-la-interfaz-de-red-cableada

 Saludos

 

Mié, 15/03/2017 - 14:19
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Wlo1, deben corresponder a la wifi en uso , al menos asi deberia ser segun la nueva denominación permanente de interfaces de red,, una eth   suele comenzar con  enx, ens, enp 

En general se podría detectar un cambio mirando 

# dmesg | grep -i  eth

Suele mostrar el nuevo  codigo de eth0  o eth1 

Edito: Por cierto se puede comprobar ( y modificar ) en /etc/udev/rules.d/70-persistent-net.rules

 

Mié, 15/03/2017 - 19:45
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

Sin conocer la interfaz de red involucrada dudo que te puedan ayudar. Si no tienes idea de cual puede ser, tienes a Windows 7, en el apartado administrador de dispositivos, ... , AIDA64, etc.
Solo puedo especular:
(1) Compilaste el controlador para una versión de kernel X.
(2) Existe un error en el modulo X para con el nuevo kernel. Puedes obtener información con $dmesg o #journalctl -b -p err. Porque no arranca en el booteo.
(3) Levantar manualmente todo, https://rootsudo.wordpress.com/2014/09/05/conectar-a-internet-por-consola-ethernet-cualquier-distro/

Ejemplo, porque nadie va a investigar el nombre del modulo para la tarjeta ZZZ:
02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter (rev 10)
Kernel modules: 8139cp, 8139too

PD: Toma en consideración el cambio de nombre en las interfaces de red que hace mención Caliban.

Mar, 21/03/2017 - 09:24
gringoinc
Imagen de gringoinc
Desconectado/a
se unió: 15/03/17

SOLUCIONADO (Alguien me explica como cerrar el foro o ponerle solucionado oficialmente?)

Antes que nada, agradecer enormemente a @Berbellon, @caliban y @gacs, que siempre estuvieron prestos a ayudarme a encontrar la solución. Bueno, aunque no me sienta orgulloso de ello, debo ser sincero con ustedes ya que invirtieron su valioso tiempo en tratar de ayudarme. Les cuento que el dispositivo estaba deshabilitado desde la BIOS, aún no me explico por qué, pero así fué. Entré a la BIOS, lo des-habilité y habilité dos veces para evitar confusión y listo! Agradezco a todos, les pido excusas por ser tan Noob y espero poder servirles en adelante. Feliz día!

Jonathan Osorio - @gringoinc

Mar, 21/03/2017 - 09:38 (Responder a #10)
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

gringoinc wrote:

SOLUCIONADO (Alguien me explica como cerrar el foro o ponerle solucionado oficialmente?)

 

Editas el primer mensaje y en ESTADO lo cambias a SOLUCIONADO.

Saludos.

We were but stones. Your light made us stars

Mar, 21/03/2017 - 10:07 (Responder a #11)
gringoinc
Imagen de gringoinc
Desconectado/a
se unió: 15/03/17

moonwatcher wrote:

gringoinc wrote:

SOLUCIONADO (Alguien me explica como cerrar el foro o ponerle solucionado oficialmente?)

 

Editas el primer mensaje y en ESTADO lo cambias a SOLUCIONADO.

Saludos.

 

 

Gracias! Otro aprendizaje mas!

Jonathan Osorio - @gringoinc

Mar, 21/03/2017 - 12:44
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Error de capa 8