Problemas con wifi

12 envíos / 0 nuevos
Último envío
#1 Lun, 12/02/2018 - 08:29
cali
Imagen de cali
Desconectado/a
se unió: 31/10/17

Problemas con wifi

Estado: 
[ABANDONADO]

hola

Tengo instalado Debian 9 con gnome, instale las herramientas wifi, la red la reconoce pero no conecta.

Tengo otra particion con otro sistema operativo y si me funciona wifi.

Saludos y mucha gracias.

Lun, 12/02/2018 - 10:13
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

es importante que completes la información de tu hardware y para eso seria bueno que instales lshw  y pongas el resultado del comando

lshw -short 

lectura recomendada

saludos...

Lun, 12/02/2018 - 11:48
cali
Imagen de cali
Desconectado/a
se unió: 31/10/17

Hola rockyiii gracias por tu respuesta te muestro el resultado del lshw -short.

H/W path       Device           Class          Description
==========================================================
                                system         SMART R9-PE
/0                              bus            SMART R9-PE
/0/0                            memory         64KiB BIOS
/0/28                           memory         4GiB System Memory
/0/28/0                         memory         4GiB DIMM DDR3 1600 MHz (0,6 ns)
/0/28/1                         memory         DIMM [empty]
/0/36                           memory         224KiB L1 cache
/0/37                           memory         2MiB L2 cache
/0/38                           processor      Intel(R) Pentium(R) CPU  N3710  @ 1.60GHz
/0/100                          bridge         Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register
/0/100/2                        display        Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
/0/100/13                       storage        Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SATA Controller
/0/100/14                       bus            Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller
/0/100/14/0    usb1             bus            xHCI Host Controller
/0/100/14/0/4                   communication  802.11n WLAN Adapter
/0/100/14/1    usb2             bus            xHCI Host Controller
/0/100/1a                       generic        Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine
/0/100/1b                       multimedia     Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio Controller
/0/100/1c                       bridge         Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #1
/0/100/1c.1                     bridge         Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #2
/0/100/1c.1/0  ens1             network        RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
/0/100/1f                       bridge         Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU
/0/100/1f.3                     bus            Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx SMBus Controller
/0/1           scsi0            storage        
/0/1/0.0.0     /dev/sda         disk           500GB ST500LM030-2E717
/0/1/0.0.0/1                    volume         99MiB Windows FAT volume
/0/1/0.0.0/2   /dev/sda2        volume         15MiB reserved partition
/0/1/0.0.0/3   /dev/sda3        volume         269GiB Windows NTFS volume
/0/1/0.0.0/4   /dev/sda4        volume         192GiB EXT4 volume
/0/1/0.0.0/5   /dev/sda5        volume         4000MiB Linux swap volume
/0/2           scsi1            storage        
/0/2/0.0.0     /dev/cdrom       disk           DVDRAM GUD0N
/1                              power          Battery Name
/2                              power          Battery Name
/3                              power          Battery Name
/4                              power          Battery Name
/5             wlx38a28cc44919  network        Wireless interface

 

rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

journalctl -b | grep -i firmware
feb 12 11:32:19 debian kernel: usb 1-4: rtl8xxxu: Loading firmware rtlwifi/rtl8723bu_nic.bin
feb 12 11:32:19 debian kernel: usb 1-4: firmware: direct-loading firmware rtlwifi/rtl8723bu_nic.bin
feb 12 11:32:19 debian kernel: usb 1-4: Firmware revision 35.0 (signature 0x5301)
feb 12 11:32:21 debian kernel: bluetooth hci0: firmware: failed to load rtl_bt/rtl8723b_config.bin (-2)
feb 12 11:32:21 debian kernel: bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
feb 12 11:32:21 debian kernel: bluetooth hci0: firmware: direct-loading firmware rtl_bt/rtl8723b_fw.bin
feb 12 11:32:28 debian NetworkManager[493]: <info>  [1518445948.7945] manager[0x56218f9c7050]: monitoring kernel firmware directory '/lib/firmware'.

Lun, 12/02/2018 - 12:26
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

hola cali supongo que seguis teniendo el mismo problema que antes https://exdebian.org/foro/no-puedo-usar-wifi

¿probaste lo que te puso panko?

Panko wrote:

Bueno, pues quitando los errores que no tienen nada que ver, si veo que carga firmware de la wifi, pero tiene un problema con el bluetooth, que no halla el firmware. En los paquetes que hay en sid, no encuentro ese archivo, así que es posible que no haya controlador o tengas que buscar el archivo en otro sitio y meterlo en tu sistema. el comando/servicio rfkill está bloqueando el bluetooth por ese motivo. Es posible que esto interfiera con la wifi si es un modelo que incluye ambos en un solo dispositivo.

Al bluetooth, de momento, le falta un archivo, ya que si carga un firmware, pero no el otro, asi que imagino que tampoco te funciona... Necesitas descargar este archivo https://github.com/lwfinger/rtl8723au_bt/blob/master/Linux_BT_USB_2.11.20140423_8723BE/8723B/rtl8723b_config y luego copiarlo, como root y renombrándolo

sudo cp ARCHIVODESCARGADO /lib/firmware/rtl_bt/rtl8723b_config.bin

Una vez hecho esto, reinicia el sistema y ejecuta el comando rfkill list y nos pones la salida aqui. También otra vez la salida de journalctl -b -p err y journalctl -b | grep -i firmware

Seria bueno que comentes que cosas de las que te comentaron hiciste o si no supiste como hacerlo

saludos...

Lun, 12/02/2018 - 13:48
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

jum... pues es el mismo problema por lo que veo, como bien dice el compañero... y con una rtl... no sé pero puede ser culpa de las nuevas funciones de networkmanager y/o wpasupplicant.

Prueba a editar el archivo /etc/NetworkManager/NetworkManager.conf añadiendo al mismo lo siguiente:

[device]
wifi.scan-rand-mac-address=no

luego reinicia los servicios de networkmanager y prueba, si no funcionara, prueba a reiniciar el sistema.

Es un error que está apareciendo  en varios sistemas con debian 9 y algunos dispositivos wifi. La opción de randomizar la mac para ayudar a anonimizar el escaneo de redes y su conexión provoca estos problemillas, ya no el cambiar la mac para realizar la conexión, sino el cambiarla cuando escanea las redes que existen, y luego la vuelve a cambiar para realizar la conexión.

P.M.: lo he encontrado usando esa cosa tan maja que hay arriba a la derecha, si, esa que dice buscar.

P.M.2: A ver, que me entere yo... ¿Estamos intentando arreglarte en otro hilo de este mismo foro el problema que tenías con el mismo equipo y que dejaste  abandonado  sin respuesta? Claro que si, con dos cojones y un palo,

P.M.2: Joer, si encima empiezas el hilo prácticamente igual que el otro, y te tienen que volver a pedir la información que ni pusiste, ni has puesto... Espero que esta última solución te sirva, porque no pienso echar una mano más en este hilo... Por deferencia a los compañeros que se han molestado, no te voy a borrar el hilo ni nada...

  No hay bar que por bien no venga....
Lun, 12/02/2018 - 13:51
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Y para salir de dudas ,y por probar,  instala wicd  (en reemplazo de networkmanager)e intenta con dicha aplicación .

Lun, 12/02/2018 - 17:19
cali
Imagen de cali
Desconectado/a
se unió: 31/10/17

Hola rockii  Gracias por tu respuesta. Probé con todo y no funciono, escribí este post porque borre el sistema y lo instale de 0.

cambie el archivo y sigue sin funcionar

 

  rfkill list
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

 journalctl -b -p err
-- Logs begin at Mon 2018-02-12 16:36:39 -03, end at Mon 2018-02-12 17:07:56 -03. --
feb 12 16:36:43 debian kernel: bluetooth hci0: firmware: failed to load rtl_bt/rtl8723b_config.bin (-2)
feb 12 16:36:48 debian minissdpd[485]: setsockopt(udp, IP_ADD_MEMBERSHIP)(): No such device
feb 12 16:36:48 debian minissdpd[485]: setsockopt(udp, IPV6_JOIN_GROUP)(FF02::C, ): No such device
feb 12 16:36:48 debian minissdpd[499]: ssdpDiscover: sendto: Network is unreachable
feb 12 16:36:48 debian minissdpd[499]: ssdpDiscover: sendto: Network is unreachable
feb 12 16:36:49 debian avahi-daemon[500]: chroot.c: open() failed: No such file or directory
feb 12 16:36:52 debian bluetoothd[516]: Sap driver initialization failed.
feb 12 16:36:52 debian bluetoothd[516]: sap-server: Operation not permitted (1)
feb 12 16:36:57 debian minissdpd[499]: setsockopt(udp, IPV6_JOIN_GROUP)(FF02::C, ): Address already in use
feb 12 16:36:57 debian minissdpd[499]: setsockopt(udp, IPV6_JOIN_GROUP)(FF02::C, ): Address already in use
feb 12 16:36:58 debian minissdpd[499]: setsockopt(udp, IPV6_JOIN_GROUP)(FF02::C, ): Address already in use
feb 12 16:37:33 debian bluetoothd[516]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
feb 12 16:37:33 debian bluetoothd[516]: RFCOMM server failed for :1.71/Profile/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb: rfcomm_bin
feb 12 16:37:43 debian minissdpd[499]: setsockopt(udp, IPV6_JOIN_GROUP)(FF02::C, ): Address already in use

ournalctl -b | grep -i firmware
feb 12 16:36:43 debian kernel: bluetooth hci0: firmware: failed to load rtl_bt/rtl8723b_config.bin (-2)
feb 12 16:36:43 debian kernel: bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
feb 12 16:36:43 debian kernel: bluetooth hci0: firmware: direct-loading firmware rtl_bt/rtl8723b_fw.bin
feb 12 16:36:43 debian kernel: usb 1-4: rtl8xxxu: Loading firmware rtlwifi/rtl8723bu_nic.bin
feb 12 16:36:43 debian kernel: usb 1-4: firmware: direct-loading firmware rtlwifi/rtl8723bu_nic.bin
feb 12 16:36:43 debian kernel: usb 1-4: Firmware revision 35.0 (signature 0x5301)
feb 12 16:36:52 debian NetworkManager[512]: <info>  [1518464212.2328] manager[0x55ee1c4e5050]: monitoring kernel firmware directory '/lib/firmware'.

 

 

 

Lun, 12/02/2018 - 20:10
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Pues... todo muy majo... sistema nuevo, hilo nuevo, claro que si.

Pues... todo muy majo...  el botón para introducir código y formatear el post, sigues sin verlo no?

Y Claro, un log de cuando la wifi intenta conectarse y esas cosas... tampoco, para que, si lo podemos adivinar (se te había pasado por la cabeza? o es que estás esperando a que te lo pidamos?) .... o igual ir a buscarlo al otro hilo... pero igual voy y no está tampoco, quién sabe...

conlo  majo que queda ver las cosas formateadas y lo cómodo que hace la lectura de un hilo,
vamos a pasar de lo que me recomiendan que haga, que no sirven para nada más que molestar
a los usuarios...

 

  No hay bar que por bien no venga....
Mar, 13/02/2018 - 13:37
cali
Imagen de cali
Desconectado/a
se unió: 31/10/17

Hola. Muchas Gracias Por sus respuestas.

Logre que se conecte al wifi, cambiando el archivo rtl_bt/rtl8723b_config.bin y agregando la linea wifi.scan-rand-mac-address=no en el archivo NetworkManager.conf.

El problema es que si me alejo del router 1 metro pierde la señal. busque por internet y vi que se puede cambiar el valor bit rate, pero me marca un error y no lo puedo realizar

root@debian:/home/usuaruiox# iwconfig
lo        no wireless extensions.

ens1      no wireless extensions.

wlx38a28cc44919  IEEE 802.11  ESSID:"Audissio"  
          Mode:Managed  Frequency:2.432 GHz  Access Point: 4C:81:20:FD:E1:9A   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=48/70  Signal level=-62 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:39   Missed beacon:0

root@debian:/home/usuaruiox# iwconfig wlx38a28cc44919 rate 54M
Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device wlx38a28cc44919 ; Invalid argument.

Gracias nuevamente

Mar, 13/02/2018 - 14:03
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Lo extraño es estar  al lado del router  y tener una señal de -62dbm,  que es un nivel en el limite de lo usable en condiciones normales.O bien  el firmware que estas utilizando no corresponde a dicha interfaz wifi , o el problema ocurre por otro lado .

Insisto hace una prueba deshabilitando nertowrkmanager e instalando wicd.

POr cierto ya te han pedido que uses la etiqueta " insertar fragmento de código"( arriba en la barra de iconos , tercer bloque al lado del símbolo de comillas " !!) y luego seleccionas "bash" 

para poner todo aquello que no sean tus comentarios,como por ejemplo salidas de comandos .o datos de archivos .

Mar, 13/02/2018 - 14:45
gacs
Imagen de gacs
Conectado
colaborador
se unió: 21/04/16

una consulta de donde instalas firmware, no estas utilizando de los repositorio de debian? escribe la salida de lsusb intenta con esto  reinicia y vuelve a poner la salida de  journalctl -b -p err y journalctl -b | grep -i firmware

 

 

 Saludos

 

Mié, 14/02/2018 - 15:19
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Otra opción es probar con debian testing y un kernel más moderno.

Esta es una imagen con firmware non-free por lo cual, desde el momento mismo de la etapa de instalación tendría que reconocer tu placa de red wifi y permitirte hacer la instalación via wifi
http://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/daily-builds/sid_d-i/current/amd64/iso-cd/

las imágenes netinstall requieren completar la instalación via internet por lo cual si al momento de la detección de tu hardware no reconoce tu placa de wifi lo mejor es que canceles la instalación (hasta el momento del particionado no hay problema de cancelar la instalación)
 

saludos y suerte!!!!