Apliacion para desarrollar html

18 envíos / 0 nuevos
Último envío
#1 Sáb, 23/04/2016 - 01:30
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

Apliacion para desarrollar html

Hola que aplicacion me recomienda para el desarrollo de html, estoy comensando y quisiera uno que ayudara con el desarrollo. estoy utilizando debian testing 386, bluefish no se encuentra disponible para testing por lo menos al dia de hoy aptitude search no me mostro disponibilidad

gracias por la ayuda

 

saludos

 

Sáb, 23/04/2016 - 01:56
DenJohX
Imagen de DenJohX
Desconectado/a
colaborador
se unió: 22/04/16

En mi opinión los entornos "que ayudan" suelen ser o muy pesados o muy viejos o estorban o no están en los repos cuando los necesitas. En el campo del desarrollo web me parece que es raro que la gente use algún IDE, las razones pueden ser que la cosa cambia tan rapido todos los días que los IDEs simplemente no pueden seguir el trote y dar buen soporte al mismo tiempo. Es más común usar algún buen editor de texto, diseñado para programar en general, y no para algún lenguaje o entorno en específico.

 

Te comento de algunos:

  • El que uso todos los días: Sublime Text, que no es libre, pero es muy bueno y tiene una enorme cantidad de plugins para lo que quieras.
  • Atom, que sí que es libre y salió de github, pero lo hicieron sobre javascript y por lo mismo a veces se siente un poco lento. 
  • Visual Studio Code, sí, el de MS, no, no bromeo. No lo uso y personalmente no me atrae la atención, pero conozco algunos que les encanta, y sí lo usan sobre algun *nix, lo interesante es que te permite debuggar javascript dentro del mismo editor.
  • NetBeans este sí es un IDE, lo usé hace mucho tiempo para PHP y estuvo bien, pero ya no lo uso más poque se me hace muy pesado, mucho menos que Eclipse/Aptana, que es más pesado todavía.

 

Antes que digan nada, sí, uso software privativo todos los días en mi Debian, y no, no me parece que hacerlo esté mal. La libertad de hacer lo que quieras en tu pc es como la de andar en bolas en tu casa, a que a todos les gusta xD.

Bromas aparte, es importante que uses varias herramientas y tu decidas luego de darles un tiempo. más si piensas desarrollar para ganar dinero.

 

:wq

Sáb, 23/04/2016 - 09:23 (Responder a #2)
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

Muchas gracias por tu comentario voy a probar, he usado netbeans y si sea perdido en algunas ocaciones de los repositorio. pensaba que eclipse era menos pesado que netbeans si lo utilisabas sin tanto plugins.

 

saludos

 Saludos

 

Sáb, 23/04/2016 - 11:07
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

Un buen y completo editor es  Geany (liviano e independiente de cualquier escritorio )Lastima lo de bluefish .

Sáb, 23/04/2016 - 11:36
siddharta
Imagen de siddharta
Desconectado/a
colaborador
se unió: 22/04/16

- Geany (disponible en los repositorios) si se quiere teclear código a mano, con ayuda de sintaxis. Es lo único que uso actualmente en Debian.

- WaveMaker Studio ( https://github.com/cloudjee/wavemaker ) si se quiere usar WYSIWYG, pero hace tiempo que no lo uso así que no sé cuál es su actual estado. Por lo pronto no lo encontré en wavemaker.com

- Weaverslave ( http://thomas.weinert.info/ ). Es lo que uso en Windows, aún cuando está descontinuado.

Sidd.

Sáb, 23/04/2016 - 12:03
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Yo estoy usando Atom y la verdad es que no me puedo quejar, pero Sublime Text es el que usa casi todo el mundo y por eso hay infinidad de tutoriales, video tuturiales y complementos más que para cualquier otro, creo.

Hay otro editor para html que hacen los de adobe que se llama brackets hasta trae un chrome propio para que veas en realtime como va quedando el diseño, pero no sabría decirte que tan bueno es http://brackets.io/

saludos...

 

Dom, 24/04/2016 - 00:14
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

muchas gracias por sus comentarios por lo que pude ver solo Geany se encuentra en debian, tendre que probar con geany.

 

gracias saludos

 Saludos

 

Dom, 24/04/2016 - 05:09 (Responder a #7)
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

gacs wrote:

muchas gracias por sus comentarios por lo que pude ver solo Geany se encuentra en debian, tendre que probar con geany.

 

gracias saludos

si quieres instalar Atom puedes descargar el .deb desde la página oficial:

https://atom.io/

yo lo instalé hace poco y está muy bien.

We were but stones. Your light made us stars

https://linuxveredas.blogspot.com.es/

Dom, 24/04/2016 - 05:49
DenJohX
Imagen de DenJohX
Desconectado/a
colaborador
se unió: 22/04/16

No es necesario que esté en los repos, la mayoría no estará porque son muy nuevos o no son libres, pero ninguno (creo) es difícil de instalar/usar. En algunos casos consigues los .deb o solo los descomprimes y los usas. 

Si vas a dedicarte al desarrollo web en general notarás que cada vez usas menos los repos, porque todo lo usas de fuentes externas más recientes, es bueno acostumbrarse a eso ;)

:wq

Dom, 24/04/2016 - 11:21
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

Muchas gracias señores , voy a probar a instalar desde fuentes externa, en una ocacion instale netbeans desde fuentes externa ya que no estaba en los repos pensaba que era mas pesado y que consumia mas recuersos por eso no me gusta mucho la idea de externos. no comprobe solo pense eso ya que cuando volvio netbeans a los repositorio ya tenia otro equipo y me quede con la idea que era mas libiano el del repo.

Pero como veo me estoy congelando en no usar lo que quiero por mis propios mitos....

 

saludos

 

 

 

 

 Saludos

 

Lun, 25/04/2016 - 21:21
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

he intentado con los sugeridos pero no me cubren la dependencia, atom esta para 64 y no para 32 el equipo que tengo lo tengo en 32 ya que es un rescatado de apenas 2gb. me encontre bluefish pero igual debian testing tiene mucho paquetes menos de echo openjdk menor a la version 8 no estan disponibles, no queria retroceder en version.

sid tiene bluefish pero no creo conveniente instalar sid en mi equipo, aunque ya he utilizado la version sid pero en equipos mas actuales el que tengo actualmente no se si se lleve bien con sid.

comento como quedaria al final

saludos

 

 Saludos

 

Mar, 26/04/2016 - 09:21 (Responder a #11)
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

gacs wrote:

 me encontre bluefish pero igual debian testing tiene mucho paquetes menos de echo openjdk menor a la version 8 no estan disponibles, no queria retroceder en version.

Uff, es difícil entenderte indecision

Si tienes instalado Debian testing.... ¿Cual es el problema para instalar Bluefish desde repositorios?

https://packages.debian.org/es/stretch/bluefish

Es justo la misma versión que está en Sid.

We were but stones. Your light made us stars

https://linuxveredas.blogspot.com.es/

Mar, 26/04/2016 - 10:27
cnicolas
Imagen de cnicolas
Desconectado/a
colaborador
se unió: 21/02/16

Un editor simple y liviano es Scite, tambien puedes usar vim o emacs en modo consola

Debian y GNU/Linux en el core informatico.

Mar, 26/04/2016 - 11:56 (Responder a #13)
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

moonwatcher wrote:

gacs wrote:

 me encontre bluefish pero igual debian testing tiene mucho paquetes menos de echo openjdk menor a la version 8 no estan disponibles, no queria retroceder en version.

Uff, es difícil entenderte indecision

Si tienes instalado Debian testing.... ¿Cual es el problema para instalar Bluefish desde repositorios?

https://packages.debian.org/es/stretch/bluefish

Es justo la misma versión que está en Sid.

Disculpen por no darme entender voy a mejorar eso... 

el bluefish que encontre no me referia al que esta en los repositorio, si no al del desarrollador originale por que como comente anteriormente no estaba en los listados de paquete de los repositorio.de echo lo busque en la web de paquetes de debian stretch https://packages.debian.org/es/stretch/ y no lo encontre solo lo encontre en sid.

siempre busco los paquetes disponibles con aptitude search y en stretch no se encontraba bluefish, pero si en sid. algo raro que me encontre ayer que instale sid es que openjdk-7* no lo lista aptitude search pero si esta listado en la web de los paquetes de sid.

Sigo buscando informacion ya que tengo en mente tu comentario anterior que debo hacerme a la idea que un dia debe instalar de otras fuentes y no solo de los repositorios de debian. luego  comento

gracias 

 

saludos

 

 Saludos

 

Mar, 26/04/2016 - 12:20
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

No llego a captar cual es el problema con la aplicacion bluefish que esta en los repositorios ,en todas las ramas .

Mar, 26/04/2016 - 13:34
DenJohX
Imagen de DenJohX
Desconectado/a
colaborador
se unió: 22/04/16

En la página que enlazaste están las instrucciones para instalarlo en debian 8 desde backports, para testing está en los repos. 

 

Igual veo a bluefish quedándose corto rápidamente... (poner aquí la carita silbando) xD

 

 

 

 

:wq

Mar, 26/04/2016 - 15:33 (Responder a #16)
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

DenJohX wrote:

En la página que enlazaste están las instrucciones para instalarlo en debian 8 desde backports, para testing está en los repos. 

 

Igual veo a bluefish quedándose corto rápidamente... (poner aquí la carita silbando) xD

 

ups... si creo que me limite y no vi los backports , bueno la verdad nunca lo he utilizado me estoy limitando busca como instalar sin los repositorios y no vi que en los repositorios backports estaba el paquete que queria instalar....

gracias por la ayuda

saludos

 Saludos

 

Mar, 26/04/2016 - 15:42 (Responder a #17)
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

caliban wrote:

No llego a captar cual es el problema con la aplicacion bluefish que esta en los repositorios ,en todas las ramas .

un ejemplo de lo que paso en debian testing utilice aptitude search bluefish para ver si estaba disponible y no me dio respuesta de existencia del paquete, me pase a debian sid por que habia visto que si tenia bluefish, en la sentencia siguiente podras ver que openjdk-7* aptitude no muestra que este disponible,  pero en la web de paquetes de debian sid si se puede descargar, eso mismo me paso con bluefish en la version testing. 

# aptitude search openjdk
p   openjdk-8-dbg                  - Entorno de ejecución de Java basado en O
p   openjdk-8-demo                 - Java runtime based on OpenJDK (demos and
i A openjdk-8-doc                  - OpenJDK Development Kit (JDK) documentat
i A openjdk-8-jdk                  - Conjunto de desarrollo de OpenJDK (JDK) 
i A openjdk-8-jdk-headless         - OpenJDK Development Kit (JDK) (headless)
i A openjdk-8-jre                  - OpenJDK Java runtime, using Hotspot JIT 
p   openjdk-8-jre-dcevm            - Alternative VM for OpenJDK 8 with enhanc
i A openjdk-8-jre-headless         - OpenJDK Java runtime, using Hotspot JIT 
p   openjdk-8-jre-jamvm            - Alternative JVM for OpenJDK, using JamVM
p   openjdk-8-jre-zero             - Alternative JVM for OpenJDK, using Zero/
p   openjdk-8-source               - OpenJDK Development Kit (JDK) source fil
p   uwsgi-plugin-jvm-openjdk-8     - Java plugin for uWSGI (OpenJDK 7)       
p   uwsgi-plugin-jwsgi-openjdk-8   - JWSGI plugin for uWSGI (OpenJDK 7)      
p   uwsgi-plugin-ring-openjdk-8    - Closure/Ring plugin for uWSGI (OpenJDK 7
p   uwsgi-plugin-servlet-openjdk-8 - JWSGI plugin for uWSGI (OpenJDK 7)   

gracias por la ayuda saludos

 

GACS

 Saludos