Firefox esr 52.6 no se actualiza en debian 9.4

8 envíos / 0 nuevos
Último envío
#1 Sáb, 29/09/2018 - 16:24
Samo
Imagen de Samo
Desconectado/a
se unió: 10/07/17

Firefox esr 52.6 no se actualiza en debian 9.4

Estado: 
[ACTIVO]

Saludos colegas, tengo una pequeña consulta sobre algo que intento solucionar y no he podido encontrar nada que me ayude.

Tenía instalado debian 8.~ en el cual tenía firefox y se actualizaba solo. Ahora realice una instalación nueva con debian 9.4 que ya trae incluido firefox esr 52 pero no se actualiza solo como lo hacía en debian 8, ya investigué por todos lados que puedo hacer pero no he encontrado una solución, alguien ya lo ha actualizado, cómo lo hizó??

Sáb, 29/09/2018 - 18:11
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

Pues parece que en Debian estable está la version 60 ya.

https://packages.debian.org/es/stretch/firefox-esr

¿como tienes los repositorios?

# nano /etc/apt/sources.list

 

We were but stones. Your light made us stars

https://linuxveredas.blogspot.com.es/

Sáb, 29/09/2018 - 19:58
NerveNet
Imagen de NerveNet
Desconectado/a
colaborador
se unió: 14/03/16

Aparte del sources.list que te piden te cuento lo que con frecuencia vengo haciendo.

De un tiempo a esta parte observo que algunos paquetes no se actualizan quedando estos retenidos, esto me sucede con las versiones 8 y 9.

Dependiendo del paquete que hayas instalado, no es lo mismo instalar un paquete de versión concreta que el meta-paquete de la aplicación, el primero no se actualizará y el segundo sí pero puede quedar retenido en una versión.

No se muy bien como funciona, pero generalmente esas manías las quito de dos formas:

  • Elimino el paquete instalado e instalo el paquete nuevo:
apt-get remove paquete
apt-get purge paquete
apt-get install nuevo_paquete
  • Instalo explícitamente la nueva versión con apt-get install paquete

El metapaquete de Firefox es firefox-esr

Siendo Firefox no tienes por que preocuparte de tu configuración personalizada, esa no se toca cuando desinstalas e instalas una nueva versión.

 

Si no eres muy pulcro con la desinstalación se te quedarán ficheros de configuración del mismo en el sistema, puedes comprobarlo con: dpkg --get-selections | grep deinstall

Eso te lista los paquetes que has desinstalado pero que no has purgado, eliminado sus ficheros de configuración, puedes eliminar esos paquetes con apt-get purge paquete

Hay ocasiones en que algunas aplicaciones tienen un comportamiento extraño debido a la presencia de ficheros de otros paquetes eliminados, en otras quieres conservar esos ficheros, en tales casos haz una copia de seguridad de los mismos antes de purgarlos.

A un clic de distancia de ti...

Mié, 03/10/2018 - 09:03 (Responder a #3)
Samo
Imagen de Samo
Desconectado/a
se unió: 10/07/17

Saludos colega, me disculpo por la demora, aquí te muestro como está mi source list de momento.

Source list

 

El futuro es debian!!

Mié, 03/10/2018 - 09:09 (Responder a #4)
Samo
Imagen de Samo
Desconectado/a
se unió: 10/07/17

Gracias por los consejos, me parece bastente lógico, lo intentaré el fin de semana y te haré saber el resultado, saludos.

El futuro es debian!!

Mié, 03/10/2018 - 10:56
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

y la pregunta del millón es... ¿Cual es la salida de la consola cuanto intentas hacer apt upgrade?

¿Has probado con aptitude safe-upgrade o aptitude full-upgrade? Éste te da la opción de escojer una solución que te parezca adecuada si no te sirve la primera que te da.

Como bien te han dicho, el uso de metapaquetes facilita la instalación de software y asegura que sólo se actualice cuando todo está acorde a sus dependencias, pero también provoca que se retengan paquetes. En el caso de firefox-esr, puede ocurrir que haya un cambio demasiado grande de una versión a otra, con lo que tocaría esperar a que el metapaquete correspondiente "vea" que se satisfacen todas las dependencias y lleve configurado que hay que desinstalar algún paquete para que se pueda realizar la actualización (es posible que tenga que ver con los archivos de idioma, por ejemplo, que me suena que la forma de usarlos cambió en alguna versión de firefox e incluso de thunderbird).

Como he comentado, estaría bien ver que te dice la salida de apt upgrade o aptitude safe-upgrade (o incluso aptitude full-upgrade), de ese modo se puede mirar que paquete entra en conflicto con otro que ya exista en el sistema y poder comprobar si es seguro desinstalarlo o esperar un poco más.

  No hay bar que por bien no venga....
Jue, 04/10/2018 - 23:48 (Responder a #6)
Samo
Imagen de Samo
Desconectado/a
se unió: 10/07/17

Saludos Panko, realmente no estaba intentando actualizar usando upgrade, si no que, actualmente firefox actualiza de forma automática, pero ya en debian 9 no lo hacía en mi instalación nueva.

Pero hoy sorpresivamente se actualizó a la última versión, pero no realicé ningún cambio, no llegué a hacer lo que aconsejan los compañeros de arriba.

Con esto mi problema se soluciona indecision pueden cerrar el tema y gracias por su apoyo.

 

El futuro es debian!!

Sáb, 06/10/2018 - 06:36
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Entonces se trataba del asunto que se ha mencionado. Al no estar todavía las dependencias correctas subidas al repositorio de debian, esos paquetes se quedan bloqueados. En el momento que se han subido las dependencias necesarias, el mismo sistema realiza la actualización. Además, por lo que dices, imagino que tendrás el centro de software (gnome/gtk) o plasma-discover (plasma/kde) para gestionar actualizaciones, de ahí que no veas realmente la razón del bloqueo al no hacerlo tu en consola.

  No hay bar que por bien no venga....