Problema con los repositorios

5 envíos / 0 nuevos
Último envío
#1 Lun, 08/10/2018 - 19:25
kev440
Imagen de kev440
Desconectado/a
se unió: 08/10/18

Problema con los repositorios

Estado: 
[SOLUCIONADO]

Siempre que agrego un repositorio nuevo, con su respectiva key, me sale este mensaje de error al hacer el update, obviamente tampoco me deja instalar la aplicacion despues. Y no solo es con el PPA Manager, si no con cualquier repositorio que agregue, tengo debian 9 strecth.

W: El repositorio «http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu stretch Release» no tiene un fichero de Publicación.
N: Los datos de un repositorio como este no se pueden autenticar y por tanto su uso es potencialmente peligroso.
N: Vea la página de manual apt-secure(8) para los detalles sobre la creación de repositorios y la configuración de usuarios.
E: Fallo al obtener http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu/dists/stretch/main/source/Sources  404  Not Found
E: No se han podido descargar algunos archivos de índice, se han omitido, o se han utilizado unos antiguos en su lugar.

Mar, 09/10/2018 - 13:52
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Sería una buena idea que publiques el contenido de tu sources.list

cat /etc/apt/sources.list
ls -l /etc/apt/sources.list.d/

saludos...

Mar, 09/10/2018 - 14:14
kev440
Imagen de kev440
Desconectado/a
se unió: 08/10/18

La sources.list

#

# stretch-oficiales
deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.us.debian.org/debian/ stretch main contrib non-free

# stretch-actualizaciones-seguridad
deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free

# debian-multimedia
deb http://www.deb-multimedia.org stretch main non-free

# últimas actualizaciones de seguridad
deb http://security.debian.org/ stretch/updates main contrib non-free

# adiciones propuestas para una versión de Debian 9
deb http://ftp.us.debian.org/debian stretch-proposed-updates main contrib non-free

#Y PPA Manager
deb http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu stretch main
deb-src http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu stretch main

La /sources.list.d/

total 24
 

-rw-r--r-- 1 root root 224 oct  8 16:46 morphis-ubuntu-anbox-support-cosmic.list
-rw-r--r-- 1 root root 222 oct  8 16:46 morphis-ubuntu-anbox-support-cosmic.list.save
-rw-r--r-- 1 root root 351 oct  8 16:46 webupd8team-ubuntu-java-cosmic.list
-rw-r--r-- 1 root root 351 oct  8 16:46 webupd8team-ubuntu-java-cosmic.list.save
-rw-r--r-- 1 root root 203 oct  8 16:46 xenatt-ubuntu-xenlism-cosmic.list
-rw-r--r-- 1 root root 203 oct  8 16:46 xenatt-ubuntu-xenlism-cosmic.list.save

...pero estos ultimos del /sources.list.d/ no estan en uso, o sea estan des-clickeados en el "software & updates", excepto el java-cosmic.

Mar, 09/10/2018 - 15:29
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

El problema lo estas teniendo con

.....
#Y PPA Manager
deb http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu stretch main
deb-src http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu stretch main

vos lo estas apuntando a stretch cuando en realidad no esta en la lista de dists http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu/dists/ la solucion seria apuntarlo a artful  o bionic etc. y sino solo lo comentas con un # adelante y desactivas esa entrada en tu sources.list

Ejemplo desactivando el repo

.....
#Y PPA Manager
#deb http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu stretch main
#deb-src http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu stretch main

Ejemplo apuntando el repo a una versión de ubuntu "compatible con debian stretch"

.....
#Y PPA Manager
deb http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu zesty main 
deb-src http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu zesty main 

 

Mié, 10/10/2018 - 12:56
kev440
Imagen de kev440
Desconectado/a
se unió: 08/10/18

Si era problema de compatibilidad, busque las versiones compatibles con debian 9 y eran artful, yakkety, zesty y xenial. Lo probé con zesty y si funciono, muchas gracias.