Al actualizar debian Jessie no arranca el equipo

3 envíos / 0 nuevos
Último envío
#1 Vie, 29/12/2017 - 22:56
scscalleros
Imagen de scscalleros
Desconectado/a
se unió: 22/06/16

Al actualizar debian Jessie no arranca el equipo

Estado: 
[SOLUCIONADO]

Buena noches, un saludo a todos. Después de no actualizar Debian me decidí a hacerlo con resultados catastróficos. Me dispongo a actualizar con aptitude, actualizo y por las prisas no lei bien los errores que me mando, reinicio y como resultado ya no bootea el equipo. Trato de arrancar con un live CD/DVD y con ninguno arranca, ni con el de Debian Stretch. Quito el disco duro, lo coloco en otro equipo y desde ahi booteo con el live dvd de debian stretch y ejecutando chroot me doy cuenta del problema: el kernel parcialmente instalado y no me deja corregirlo.

No quiero hacer una instalación de zero porque tengo muchas configuraciones y aplicaciones medio complicadas de echar a andar. Esto lo escribo desde el live cd de debian stretch.

La versión de debian instalada:

root@debian:/# cat /etc/debian_version 
8.8

Lo que arroja aptitude:

root@debian:/# aptitude
Obteniendo informes de fallo... Finalizado
Analizando información Encontrada/Corregida... Finalizado
Fallos critical del paquete linux-image-3.16.0-4-amd64 (3.16.39-1+deb8u2 → 3.16.51-3) <Pendientes>
 b1 - #884762 - linux-image-3.16.0-4-amd64: Kernel panic on boot (rest_init / build_sched_domains) make system unbootable
Fallos grave del paquete xserver-xorg-core (2:1.16.4-1 → 2:1.16.4-1+deb8u2) <Pendientes>
 b2 - #868068 - [xserver-xorg-core] Upgrade from 2:1.16.4-1 to 2:1.16.4-1+deb8u1 loses keyboard and mouse
Fallos serious del paquete dns-root-data (2014060201+2 → 2017072601~deb8u1) <Corregidos en alguna versión>
 b3 - #877683 - jessie version of dns-root-data lacks new ksk in root.ds (Corregido: dns-root-data/2017072601~deb8u2 dns-root-data/2017072601~deb9u1)
Resumen:
 linux-image-3.16.0-4-amd64(1 fallo), dns-root-data(1 fallo), xserver-xorg-core(1 fallo)
¿Está seguro de que desea instalar/actualizar los paquetes mostrados anteriormente? [Y/n/?/...] y
Can't set locale; make sure $LC_* and $LANG are correct!
Leyendo lista de cambios... Hecho.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LANG = "es_ES.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Extracting templates from packages: 100%
Preconfiguring packages ...
Setting up udev (215-17+deb8u7) ...
addgroup: The group `input' already exists as a system group. Exiting.
A chroot environment has been detected, udev not started.
A chroot environment has been detected, udev not started.
update-initramfs: deferring update (trigger activated)
insserv: warning: script 'K01smfpd' missing LSB tags and overrides
insserv: warning: script 'smfpd' missing LSB tags and overrides
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service smfpd and rmnologin if started
insserv:  loop involving service rmnologin at depth 9
insserv:  loop involving service smfpd at depth 1
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package udev (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 udev
E: Sub-process /usr/bin/dpkg returned an error code (1)
Failed to perform requested operation on package.  Trying to recover:
Setting up udev (215-17+deb8u7) ...
addgroup: The group `input' already exists as a system group. Exiting.
A chroot environment has been detected, udev not started.
A chroot environment has been detected, udev not started.
update-initramfs: deferring update (trigger activated)
insserv: warning: script 'K01smfpd' missing LSB tags and overrides
insserv: warning: script 'smfpd' missing LSB tags and overrides
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service smfpd and rmnologin if started
insserv:  loop involving service rmnologin at depth 9
insserv:  loop involving service smfpd at depth 1
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package udev (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of bluez:
 bluez depends on udev (>= 170-1); however:
  Package udev is not configured yet.

dpkg: error processing package bluez (--configure):
 dependency problems - leaving unconfigured
Setting up rpcbind (0.2.1-6+deb8u2) ...
insserv: warning: script 'K01smfpd' missing LSB tags and overrides
insserv: warning: script 'smfpd' missing LSB tags and overrides
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service smfpd and rmnologin if started
insserv:  loop involving service rmnologin at depth 9
insserv:  loop involving service smfpd at depth 1
insserv: Starting smfpd depends on rmnologin and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package rpcbind (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of initramfs-tools:
 initramfs-tools depends on udev; however:
  Package udev is not configured yet.

dpkg: error processing package initramfs-tools (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-3.16.0-4-amd64:
 linux-image-3.16.0-4-amd64 depends on initramfs-tools (>= 0.110~) | linux-initramfs-tool; however:
  Package initramfs-tools is not configured yet.
  Package linux-initramfs-tool is not installed.
  Package initramfs-tools which provides linux-initramfs-tool is not configured yet.

dpkg: error processing package linux-image-3.16.0-4-amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-amd64:
 linux-image-amd64 depends on linux-image-3.16.0-4-amd64; however:
  Package linux-image-3.16.0-4-amd64 is not configured yet.

dpkg: error processing package linux-image-amd64 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 udev
 bluez
 rpcbind
 initramfs-tools
 linux-image-3.16.0-4-amd64
 linux-image-amd64
Press Return to continue.

Gracias de antemano y espero me proporcionen alguna pista de como solucionarlo.

Saludos.

Sáb, 30/12/2017 - 07:55
esbrinartot
Imagen de esbrinartot
Desconectado/a
se unió: 28/02/16

Hola,

Lo que haría... Arranca con el Kernel que tenias instalado previamente. Desde el grub lo podrás hacer.

Una vez arrancado el equipo desinstalas el antiguo kernel y lo vuelves a instalar.

Saludos

Sáb, 30/12/2017 - 20:42 (Responder a #2)
scscalleros
Imagen de scscalleros
Desconectado/a
se unió: 22/06/16

Buenas tardes, gracias por responder, al final logré hacer arrancar el equipo con los siguientes comandos mediante chroot. Cabe mencionar que fue lo primero que intenté hacer y que no dieron resultado y no sé por qué.
# dpkg-reconfigure grub-pc
# nano /etc/default/grub

Saludos.

Edito:
Lo correcto es:
# dpkg-reconfigure grub-pc
# update-grub