al instalar debian stretch, no me aparece un disco que sí me aparece con fdisk -l y en el menú de arranque del pc.

9 envíos / 0 nuevos
Último envío
#1 Jue, 01/11/2018 - 16:23
jesus
Imagen de jesus
Desconectado/a
se unió: 01/11/18

al instalar debian stretch, no me aparece un disco que sí me aparece con fdisk -l y en el menú de arranque del pc.

Estado: 
[SOLUCIONADO]

al hacer la instalación stretch, y cuando detecta los discos, aparecen solo 3, cuando si paso a consola y con fdisk -l , me aprecen los 4 que tengo, así como también aparecen en el menú boot. Todos los discos son sata y en linux mint también aparecen los 4. ¿alguna explicación? gracias.

Sáb, 03/11/2018 - 20:04
zero
Imagen de zero
Desconectado/a
se unió: 31/10/18

y si lo montas manualmente puedes acceder a el? si es así crea la correspondiente entrada en /etc/fstab y debería estar

..:: 0 ::..

Sáb, 03/11/2018 - 20:54
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16
  No hay bar que por bien no venga....
Dom, 04/11/2018 - 12:18
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

Pues se necesita mas información, agrega la salida de fdisk -l y de df -h, tambien el contenido del archivo fstab.

# fdisk -l

 

df -h 

 

cat /etc/fstab

 

 

 Saludos

 

Dom, 04/11/2018 - 18:51
jesus
Imagen de jesus
Desconectado/a
se unió: 01/11/18

manualmente no puedo montarlo, porque todavía no tengo sistema, pues me pasa como digo, al detectar discos al instalar debian stretch. En ese paso de la instalación, puedo ir a consola f3, y hacer fdisk -l y ahí me aparece. Tampoco puedo incluirlo en fstab porque todavía no he creado las particiones. Me aparece y accedo,si arranco con linux mint.

boot menu

1. IDE HDD: WDC WD3200AAJS-22L7A0-(S1)

2  250G

3. 2.000G

4. 2.000g

5. CD:

El 1 es el que no me aparece en la detección de discos que hace la instalación de debian stretch. y el listado fdisk -l es idéntico que el que si aparece de 250G.

¿no habrá un límite de 3 discos al instalar?

gracias por el interés.

 

Dom, 04/11/2018 - 18:53
jesus
Imagen de jesus
Desconectado/a
se unió: 01/11/18

voy a probar a ver si con sólo 3 me aparece.

Dom, 04/11/2018 - 19:07
jesus
Imagen de jesus
Desconectado/a
se unió: 01/11/18

voy a probar a ver si con sólo 3 me aparece.

Pues ha sido que no. NO me aparece para particionar, y si con fdisk -l.

Lun, 05/11/2018 - 09:20
jesus
Imagen de jesus
Desconectado/a
se unió: 01/11/18

lo he formateado a bajo nivel, dd if=/dev/zero of=/dev/sd? y se acabaron los problemas, ha aparecido y he podido crear las particiones que quería.

gracias, aunque me quedo sin saber la causa.

Dom, 11/11/2018 - 15:34
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Un par de comentarios:

manualmente no puedo montarlo, porque todavía no tengo sistema, ....

Si es por eso si que puedes.

Desde el propio disco de instalación, te vas a la consola 2 o a la 3, y desde allí puedes montar y desmontar

discos y particiones según la sintaxis usual.

Otra cosa es donde montarlos, y que no confunda al sistema o te lo sobrescriba.

Yo se que el disco en que está trabajando cuando instala lo tiene en /target.

 

 

lo he formateado a bajo nivel, dd if=/dev/zero of=/dev/sd? y se acabaron los problemas,

Huummmm ... Bueno, si nos entendemos, vamos a dejarlo así,  pero usualmente por "formatear a bajo nivel" se entiende otra cosa.

Es una operación antigua y muy específica de cada disco, por la cual se le dotaba de las marcas e identificaciones que luego

permiten al programa de formateo reconocer la unidad como un hdd y saber cuales son sus parámetros y donde escribir las pistas.

 

Lo que has hecho tu es llenar esas pistas con ceros,  con lo cual, si había alguna identificación o dato que le confundía, desapareció.

En este caso, este debía ser el problema. Algún dato o identificación inadecuada tirada por ahí como residuo anterior.

 

 Como dicen, "bien está lo que bien acaba".

 

 Saludos, Jesus.