Apt, esto es lo que ocurre cuando detecta un problema de seguridad al descargar

6 envíos / 0 nuevos
Último envío
#1 Vie, 03/11/2017 - 07:12
pvaldes
Imagen de pvaldes
Desconectado/a
colaborador
se unió: 07/04/16

Apt, esto es lo que ocurre cuando detecta un problema de seguridad al descargar

La primera vez que me ocurre este caso. Lo dejo aquí como curiosidad, referencia por si alguien no sabía que errores da Debian en éstos casos y para su debate si os apetece. Parece que un par de archivos han sido modificados durante el trayecto. Apt lo ha detectado como se esperaría, y ha evitado descargarlos

apt update

...

Err:22 http://ftp.fr.debian.org/debian sid/non-free amd64 DEP-11 Metadata
  La suma hash difiere
  Hashes of expected file:
   - Filesize:65721 [weak]
   - SHA256:0eb5ea70b4c46a7c0889e9601d16cedf3eb4ff55bf3b77ef2af2bcd3dcf48cec
   - MD5Sum:68fdfbc3bc806010ba4c9fc8d4cb133b [weak]

  Hashes of received file:
   - SHA256:5fa520cd26eac94e183632f84371643219fdf905dfd351b53bbcd7afa5c3b848
   - MD5Sum:875dd6824d698bfa73c6517307f692f5 [weak]
   - Filesize:65721 [weak]

  Last modification reported: Mon, 30 Oct 2017 21:09:03 +0000

  Release file created at: Fri, 03 Nov 2017 02:41:19 +0000
Descargados 348 kB en 5s (63,2 kB/s)
Leyendo lista de paquetes... Hecho

E: Fallo al obtener store:/var/lib/apt/lists/partial/ftp.fr.debian.org_debian_dists_sid_non-free_dep11_Components-amd64.yml.xz  La suma hash difiere
   Hashes of expected file:
    - Filesize:65721 [weak]
    - SHA256:0eb5ea70b4c46a7c0889e9601d16cedf3eb4ff55bf3b77ef2af2bcd3dcf48cec
    - MD5Sum:68fdfbc3bc806010ba4c9fc8d4cb133b [weak]

   Hashes of received file:
    - SHA256:5fa520cd26eac94e183632f84371643219fdf905dfd351b53bbcd7afa5c3b848
    - MD5Sum:875dd6824d698bfa73c6517307f692f5 [weak]
    - Filesize:65721 [weak]

   Last modification reported: Mon, 30 Oct 2017 21:09:03 +0000
   Release file created at: Fri, 03 Nov 2017 02:41:19 +0000

E: No se han podido descargar algunos archivos de índice, se han omitido, o se han utilizado unos antiguos en su lugar.

Vie, 03/11/2017 - 07:15
pvaldes
Imagen de pvaldes
Desconectado/a
colaborador
se unió: 07/04/16

Veo que al intentar actualizar desde otro repositorio al azar (dinamarca en éste caso) sigue ocurriendo. Exactamente la  misma modificación en ambos md5 y sha. Parece que no es algo que ocurra sólo en un servidor. Curioso.

Vie, 03/11/2017 - 07:46
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

Pues ayer me pasó algo similar. Estaba intentando actualizar con aptitude y me mostró mensajes parecidos y la descarga se paró el el 96%. Pensé que era problemas de conexión. Lo cierto es que un rato después, cuando volví a pc, probé con apt upgrade y continuó la descarga en el 96% y se actualizó.

Ahora mismo no recuerdo donde, ni tengo tiempo de busca un log para ver si los mensajes eran los mismos. Yo diría que si, porque me llamó la atención que hacia referencia y se parecía a los típicos mensajes que lanza Slackware sobre MD5Sum al actualizar (mensajes que no se suelen ver en Debian).

Saludos.

We were but stones. Your light made us stars

https://linuxveredas.blogspot.com.es/

Vie, 03/11/2017 - 08:40
pvaldes
Imagen de pvaldes
Desconectado/a
colaborador
se unió: 07/04/16

Se ha solucionado en un tiempo record...

Vie, 03/11/2017 - 09:34
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Puede ser debido tanto a un fallo de descarga, como a una falta de sincronización de repositorios. Una cosa a probar, es irte al directorio /var/cache/apt/archives/partial y ver que no hay nada ahi. Si no hay nada, es una de las dos anteriores, si hay algo, lo borras y vuelves a realizar el update a ver si no da error.

  No hay bar que por bien no venga....
Sáb, 04/11/2017 - 19:20 (Responder a #5)
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

pvaldes wrote:

Esto es lo que ocurre cuando apt detecta un problema de seguridad al descargar

Oh ... Aunque, tengo la sensación de que pacman, xbps, pkg (otros Binary Package Management), realizan algo similar, antes de actualizar/instalar algún paquete ...