Apt-get; "Formato de ejecutable incorrecto"

13 envíos / 0 nuevos
Último envío
#1 Lun, 10/09/2018 - 00:34
Jhonnychip
Imagen de Jhonnychip
Desconectado/a
se unió: 05/09/18

Apt-get; "Formato de ejecutable incorrecto"

Estado: 
[ACTIVO]

Buenas estaba realizando una instalación en mi maquina pero cuando quise realizar un apt-get update me arrojo el siguiente mensaje:

bash: /usr/bin/apt-get: cannot execute binary file: Formato de ejecutable incorrecto

Soy nuevo y es probable que cuando trate de instalar mi aplicación dañe algún archivo, ya trate incluso de instalar otras herramientas que requiero para un proyecto en Django pero me sigue saliendo este mensaje.

A lo mejor es algo sencillo de solucionar pero como les comente soy novato en este campo.

Si me pueden ayudar gracias.

Lun, 10/09/2018 - 11:51
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

No das suficiente información, 

¿Que versión de debian instalaste?

¿Que es lo que intentaste instalar ? 

¿de que modo lo intentaste? 

En definitiva, para tener una pista de lo que pudo ( o puede) estar ocurriendo tenes que referir a los detalles que estan en tu cabeza, pero no en la nuestra.

Lun, 10/09/2018 - 13:50
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Podrías poner todo lo que pone cuando haces apt update

Como te dicen, falta información

Saludos...

Mar, 11/09/2018 - 00:42 (Responder a #3)
Jhonnychip
Imagen de Jhonnychip
Desconectado/a
se unió: 05/09/18

La versión es Debian 9 stretch

Quise hacer un update con el comando "apt-get update" y me arrojo el mensaje que ya había comentado.

También, cuando quise instalar otras aplicaciones con dicho comando me arrojo el mismo mensaje.

En el caso de las instalaciones de las aplicaciones utilice dicho comando como superusuario.

No se que mas decirles.

Mar, 11/09/2018 - 11:57
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

fijate con

su -

 

Jue, 13/09/2018 - 00:37 (Responder a #5)
Jhonnychip
Imagen de Jhonnychip
Desconectado/a
se unió: 05/09/18

Probe lo que me dijeron pero aun no solucionar el error o lo que lo ocasiona, esto es lo que sale en terminal cuando realizo cualquier comando relacionado con el apt-get;

root@debian:/home/jhonny# apt-get update
bash: /usr/bin/apt-get: cannot execute binary file: Formato de ejecutable incorrecto
root@debian:/home/jhonny# apt-get full-upgrade
bash: /usr/bin/apt-get: cannot execute binary file: Formato de ejecutable incorrecto

 

Si me pueden decir como corregir este caso, gracias

Jue, 13/09/2018 - 10:43
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

A lo mejor puede ser un tema de permisos pone el contenido de:

ls -l $(/usr/bin/which apt-get)

si ejecutas el update con aptitude o con apt también te da error?

su
apt update
aptitude update

que pone el comando

su
journalctl -b -p err

 

cuando pongas código, utiliza la etiqueta "insertar fragmento de código"

Vie, 14/09/2018 - 01:07 (Responder a #7)
Jhonnychip
Imagen de Jhonnychip
Desconectado/a
se unió: 05/09/18

Gracias por todo el apoyo recibido pero no me han servido los comandos que ha aportado seguire buscando opciones, si saben de algo mas por favor me indican estare al pendiente

 

Vie, 14/09/2018 - 09:55 (Responder a #8)
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Jhonnychip wrote:

Gracias por todo el apoyo recibido pero no me han servido los comandos que ha aportado seguire buscando opciones, si saben de algo mas por favor me indican estare al pendiente

 

la idea es que compartas la información de los comando que te pedimos que ejecutes, de lo contrario es casi imposible que podamos encontrar alguna forma de ayudarte

Vie, 14/09/2018 - 13:37
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Como te han dicho, los comandos anteriores no son para que solucionen nada, son para que nos muestres la salida que te dan a ver si vemos algun error relacionado.

Por otro lado, la salida del comando

dpkg --print-architecture

puede ser de ayuda, no sea que hayas instalado un sistema híbrido y esté usando el comando de x86_64 en un sistema  x86. Esto se puede hacer ejecutando comandos de x86 en sistemas x86_64, pero no al contrario (usualmente).

  No hay bar que por bien no venga....
Sáb, 15/09/2018 - 01:07 (Responder a #10)
Jhonnychip
Imagen de Jhonnychip
Desconectado/a
se unió: 05/09/18

Disculpa, no habia entendido, esto es lo que me arroja:

root@debian:/home/jhonny# dpkg --print-architecture
i386

root@debian:~# ls -l $(/usr/bin/which apt-get)
-rwxr-xr-x 1 root root 1 sep 15 01:47 /usr/bin/apt-get

root@debian:~# apt update
-su: /usr/bin/apt: cannot execute binary file: Formato de ejecutable incorrecto

root@debian:~# aptitude update
-su: aptitude: no se encontró la orden

root@debian:~# journalctl -b -p err
-- Logs begin at Fri 2018-09-14 00:01:24 -04, end at Sat 2018-09-15 10:17:11 -04. --
sep 14 00:01:31 debian kernel: rtl8192se 0000:02:00.0: firmware: failed to load rtlwifi/rtl8192sefw.bin (-2)
sep 14 00:01:40 debian avahi-daemon[466]: chroot.c: open() failed: No such file or directory
sep 14 00:01:49 debian kernel: r8169 0000:04:00.0: firmware: failed to load rtl_nic/rtl8168d-1.fw (-2)
sep 14 00:02:07 debian colord-sane[555]: io/hpmud/musb.c 2101: Invalid usb_open: Permission denied
sep 14 00:02:07 debian colord-sane[555]: io/hpmud/musb.c 2101: Invalid usb_open: Permission denied
sep 14 00:02:07 debian colord-sane[555]: io/hpmud/musb.c 2101: Invalid usb_open: Permission denied
sep 14 00:02:07 debian colord-sane[555]: io/hpmud/musb.c 2101: Invalid usb_open: Permission denied
sep 14 00:04:10 debian pulseaudio[1007]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error
sep 14 10:24:59 debian colord-sane[4022]: io/hpmud/musb.c 2101: Invalid usb_open: Permission denied
sep 14 10:24:59 debian colord-sane[4022]: io/hpmud/musb.c 2101: Invalid usb_open: Permission denied
sep 14 10:24:59 debian colord-sane[4022]: io/hpmud/musb.c 2101: Invalid usb_open: Permission denied
sep 14 10:24:59 debian colord-sane[4022]: io/hpmud/musb.c 2101: Invalid usb_open: Permission denied
sep 14 11:20:04 debian colord-sane[4262]: io/hpmud/musb.c 2101: Invalid usb_open: Permission denied
sep 14 11:20:04 debian colord-sane[4262]: io/hpmud/musb.c 2101: Invalid usb_open: Permission denied
sep 14 11:20:04 debian colord-sane[4262]: io/hpmud/musb.c 2101: Invalid usb_open: Permission denied
sep 14 11:20:04 debian colord-sane[4262]: io/hpmud/musb.c 2101: Invalid usb_open: Permission denied
sep 14 11:20:07 debian /hpfax[4312]: [4312]: error: Failed to create /var/spool/cups/tmp/.hplip
sep 14 18:11:27 debian kernel: usb 2-1.2: device descriptor read/64, error -71
sep 14 18:11:33 debian python3[5975]: io/hpmud/musb.c 2216: invalid busnum:devnum 002:008
sep 14 18:11:33 debian python3[5975]: io/hpmud/musb.c 153: unable get_string_descriptor -9: Resource temporarily unavailabl
sep 14 18:11:33 debian python3[5975]: io/hpmud/musb.c 2111: invalid serial id string ret=-9
sep 14 18:11:33 debian /hp-config_usb_printer[5975]: hp-config_usb_printer[5975]: error: This is not a valid device
lines 1-23

Sáb, 15/09/2018 - 11:31
Jhonnychip
Imagen de Jhonnychip
Desconectado/a
se unió: 05/09/18

No se que mas hacer, incluso entre a la carpeta donde se encuentra el fichero apt;

nano /usr/bin/apt-get, y esta vacia

Sáb, 15/09/2018 - 13:31
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

descargarte el archivo apt y volve a instalarlo

wget http://ftp.us.debian.org/debian/pool/main/a/apt/apt_1.4.8_i386.deb
su 
dpkg -i apt_1.4.8_i386.deb