Como activar sonido automaticamente en debian 9.5

15 envíos / 0 nuevos
Último envío
#1 Vie, 20/07/2018 - 15:20
adal01
Imagen de adal01
Desconectado/a
se unió: 19/02/16

Como activar sonido automaticamente en debian 9.5

Estado: 
[ACTIVO]

Hola, espero me ayuden, es el siguiente: Tenia el problema de estar sin sonido en debian 9.5, buscando lo solucione mediante consola 

con el comando en root: #alsactl init

Si me ayudaran porque cada vez que reinicio/apago la laptop, al iniciar sesion tengo que ir a consola y darle el comando anteriormente escrito, como hago para que ese comando lo introduzca automaticamente debian al inicio. Gracias de antemano

Vie, 20/07/2018 - 15:47
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Podes poner esa tarea en el crontab  para que ejecute la tarea en cada reinicio ,

editas con  

crontab -e

Y para que la tarea se ejecute en cada reincio  

@reboot <comando o tarea>

De todos modos ,quizá no sea el mejor camino que tengas que ejecutar dicha órden para habilitar audio cada vez .

Vie, 20/07/2018 - 16:04
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

No, no creo que vaya a ser precisamente la mejor forma de arreglar el problema. Si el sonido funciona ejecutando esa orden, es porque al iniciar el sistema no se inicia correctamente el sistema de sonido, lo que provoca que tengas que hacerlo tu. Es más que probable que falle algún servicio al inicio, puedes ejecutar

journalctl -b -p err

y ver que errores te aparecen.

En Debian Stretch, en realidad no es que se use alsactl init, si no que existen 3 servicios de alsa: alsa-state, alsa-restore, alsa-utils. El último está vacío y deshabilitado, los otros dos se encargan de guardar y recuperar el estado de la tarjeta de audio (activa/inactiva, volumenes...). Es posible que uno de estos falle, ya sea durante el apagado o durante el encendido. Hay que tener en cuenta que el funcionamiento del sonido ha cambiado con pulseaudio, ahora se inicia solo cuando se inicia sesión con algún user, y esto lo hace el entorno automáticamente, pero eso si, desconozco si ya era así durante el lanzamiento de strecth o es posterior.

Además del comando anterior, la salida de estos otros dos comandos puede decirnos algo con  suerte:

systemctl status alsa-restore.service
systemctl status alsa-state.service

usualmente, el primero debería devolverte "active (exited)· y el segundo "inactive (dead)".

  No hay bar que por bien no venga....
Vie, 20/07/2018 - 16:25
adal01
Imagen de adal01
Desconectado/a
se unió: 19/02/16

Gracias Caliban por la ayuda, pero desafortunadamente no funciono.

Hare lo que escribio Panko, muchas gracias y publicare lo que muestre esos comandos.

Vie, 20/07/2018 - 18:00
adal01
Imagen de adal01
Desconectado/a
se unió: 19/02/16

Esto me mostro la consola

1. Comando: journalctl -b -p err
-- Logs begin at Fri 2018-07-20 13:21:28 CST, end at Fri 2018-07-20 13:28:04 CST
jul 20 13:21:28 adal-debian kernel: ACPI Error: [CAPB] Namespace lookup failure,
jul 20 13:21:28 adal-debian kernel: ACPI Error: Method parse/execution failed [\
jul 20 13:21:32 adal-debian kernel: uvcvideo: Failed to query (129) UVC probe co
jul 20 13:21:32 adal-debian kernel: uvcvideo: Failed to initialize the device (-
jul 20 13:21:41 adal-debian avahi-daemon[650]: chroot.c: open() failed: No such 
jul 20 13:21:45 adal-debian kernel: r8169 0000:09:00.0: firmware: failed to load
jul 20 13:22:37 adal-debian pulseaudio[1312]: [pulseaudio] pid.c: Daemon already
jul 20 13:22:37 adal-debian pulseaudio[1326]: [pulseaudio] pid.c: Daemon already
...skipping...
-- Logs begin at Fri 2018-07-20 13:21:28 CST, end at Fri 2018-07-20 13:28:04 CST
jul 20 13:21:28 adal-debian kernel: ACPI Error: [CAPB] Namespace lookup failure,
jul 20 13:21:28 adal-debian kernel: ACPI Error: Method parse/execution failed [\
jul 20 13:21:32 adal-debian kernel: uvcvideo: Failed to query (129) UVC probe co
jul 20 13:21:32 adal-debian kernel: uvcvideo: Failed to initialize the device (-
jul 20 13:21:41 adal-debian avahi-daemon[650]: chroot.c: open() failed: No such 
jul 20 13:21:45 adal-debian kernel: r8169 0000:09:00.0: firmware: failed to load
jul 20 13:22:37 adal-debian pulseaudio[1312]: [pulseaudio] pid.c: Daemon already
jul 20 13:22:37 adal-debian pulseaudio[1326]: [pulseaudio] pid.c: Daemon already

2. Comando: systemctl status alsa-restore.service
● alsa-restore.service - Save/Restore Sound Card State
   Loaded: loaded (/lib/systemd/system/alsa-restore.service; static; vendor preset: enabled)
   Active: active (exited) since Fri 2018-07-20 13:21:43 CST; 9min ago
     Docs: man:alsactl(1)
  Process: 663 ExecStart=/usr/sbin/alsactl -E HOME=/run/alsa restore (code=exited, status=0/SUCCESS)
 Main PID: 663 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   CGroup: /system.slice/alsa-restore.service

jul 20 13:21:41 adal-debian systemd[1]: Starting Save/Restore Sound Card State...

jul 20 13:21:43 adal-debian systemd[1]: Started Save/Restore Sound Card State.

 

3. Comando: systemctl status alsa-state.service
● alsa-state.service - Manage Sound Card State (restore and store)
   Loaded: loaded (/lib/systemd/system/alsa-state.service; static; vendor preset: enabled)
   Active: inactive (dead)
Condition: start condition failed at Fri 2018-07-20 13:21:39 CST; 10min ago
           └─ ConditionPathExists=/etc/alsa/state-daemon.conf was not met
     Docs: man:alsactl(1)

 

Vie, 20/07/2018 - 19:55
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16
jul 20 13:22:37 adal-debian pulseaudio[1312]: [pulseaudio] pid.c: Daemon already
jul 20 13:22:37 adal-debian pulseaudio[1326]: [pulseaudio] pid.c: Daemon already

Si usa un DM, posiblemente no necesite los archivos pulseaudioXXX.desktop de /etc/xdg/autostart. Si no esta seguro, solo renombre a pulseaudioXXX.desktop.orig

Puede intentar lo siguiente:

$ alsactl --help

store     <card>  save current driver setup for one or each soundcards
                  to configuration file
restore   <card>  load current driver setup for one or each soundcards
                  from configuration file
init      <card>  initialize driver to a default state

#alsactl init

$alsamixer -.- Active los canales y ajuste los niveles de audio

$aplay /usr/share/sounds/alsa/No_Uso_Debian_prueba_algún_archivo -.- Prueba de sonido

Posiblemente en /etc/, haya un archivo llamado asound.state. Renombra a asound.state.orig

#alsactl store -.- Creara un nuevo archivo asound.state, grabando las opciones de alsamixer que configuro.

Reinicie.

Vie, 20/07/2018 - 21:00
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

[off-topic]

No haga nada en /etc/xdg/autostart.

Cambie al runlevel 3, renombre los archivos pulseaudio.desktop, el script rc.pulseaudio no es ejecutable ... Y aún así hay un proceso pulseaudio.

> ps ax | grep pulse
 1093 ?        Sl     0:01 /usr/bin/pulseaudio --start --log-target=syslog
 1102 ?        S      0:00 /usr/libexec/pulse/gconf-helper
 1887 pts/5    S+     0:00 grep pulse

Mágico :-) ... https://unix.stackexchange.com/questions/204522/how-does-pulseaudio-start

[/off-topic]

Sáb, 21/07/2018 - 10:32
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Bien, así me gusta, un post bien formateado como se te ha dicho... cómo de leer y tal... y con la salida de la consola cortada. Tienes varios problemas además del del sonido, pero ninguno afecta a éste. Algo tienes mal configurado y me atrevo a decir que es pulseaudio (sin entrar en el asunto del autostart que te han comentado, que posiblemente sea otro caso y no necesites tocar nada de ahi, como tamibén te han dicho).

Sería interesante saber, una vez iniciado el entorno gráfico, que usuario es el que está ejecutando pulseaudio, cosa que puedes mirar con htop mismo.

 

Y por favor, repito, usa los botones de formateo cuando vayas a postear algo, compara tu post con los que ha puesto el compañero a ver que tal se lee uno y el otro...

  No hay bar que por bien no venga....
Sáb, 21/07/2018 - 23:55
adal01
Imagen de adal01
Desconectado/a
se unió: 19/02/16

Tendre cuidado al postear, y probare las indicaciones de Berbellon, gracias.

 

Lun, 23/07/2018 - 13:29
adal01
Imagen de adal01
Desconectado/a
se unió: 19/02/16

En el enlace de Berbellon "Magico" al final utilice este comando:

adal# journalctl -b | grep pulseaudio
jul 23 09:39:21 adal-debian pulseaudio[1300]: [pulseaudio] pid.c: Daemon already running.
jul 23 09:39:21 adal-debian pulseaudio[1302]: [pulseaudio] pid.c: Daemon already running.

Osea tengo iniciado dos veces, y que resuelve el problema en /etc/pulse/client.conf

autospawn = yes
daemon-binary = /bin/true

mi duda es que en mi archivo client.conf muestra:

autospawn = yes
daemon-binary = /usr/bin/pulseaudio

tengo que cambiar aparte de yes a no en autospawn

en daemon-binary de /usr/bin/pulseaudio a /bin/true.

Luego revisar los scripts en todos los /etc/rc(0-5).d, para que no halla problema en todo el sistema.

 

 

 

Lun, 23/07/2018 - 14:16
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

No tengo leído todo el post pero, no entiendo bien como llegaste a tener alsa ni que escritorio estas usando ni porque pulseaudio se inicia como demonio cuando entendería que en debian no se inicia como tal en forma predeterminada.

saludos...

 

Lun, 23/07/2018 - 16:47
adal01
Imagen de adal01
Desconectado/a
se unió: 19/02/16

Estoy usando escritorio Mate v1.18

Lun, 23/07/2018 - 22:10
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Yo creo que lo mejor que podrías hacer es purgar todos los paquetes de alsa y de pulseaudio, ademas de cualquier configuración que hubieras realizado.

luego instalar

pulseaudio pulseaudio-utils alsa-tools alsa-utils

como extra podes instalar

pavucontrol

si aún asi seguis teniendo probleas con el sonido  fijate si alguna de las recomendaciones de este post te logran ser de utilidad https://exdebian.org/foro/sin-sonido-en-debian-jessie-activo

otra opción es la de instalar un kernel más moderno como el 4.16 de stretch-backports.

saludos...

Mar, 24/07/2018 - 00:50
adal01
Imagen de adal01
Desconectado/a
se unió: 19/02/16

Gracias rockyiii, es un lio esta tarjeta de sonido intel.   

Mar, 24/07/2018 - 21:38
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Directamente... ¿Cómo es que tienes esas líneas en /etc/pulse/client.conf? Esas líneas vienen comentadas por defecto, por lo que si las tienes, las has modificado tú en algún momento...

; default-sink =
; default-source =
; default-server =
; default-dbus-server =

; autospawn = yes
; daemon-binary = /usr/bin/pulseaudio
; extra-arguments = --log-target=syslog

; cookie-file =

; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB

; auto-connect-localhost = no
; auto-connect-display = no

como ves, esas líneas tienen un ; delante, lo que indica en este caso que están comentadas y no tienen efecto sobre la configuración. Aun así, que te diga que ya está en marcha, es que está iniciado por algo/algún usuario, y por defecto solo lo inicia el usuario que inicia sesión.

¿no habrás tocado algo antes en /etc/pulse/daemon.conf, /etc/pulse/system.pa, o /etc/pulse/default.pa? Podrías poner el contenido de estos archivos a ver si hay algo que no debería estar...

  No hay bar que por bien no venga....