Debian 9 32 bits y Geforce FX serie 5xxx corrupcion video en arranque

9 envíos / 0 nuevos
Último envío
#1 Dom, 03/09/2017 - 09:36
tigreci
Imagen de tigreci
Desconectado/a
colaborador
se unió: 31/07/17

Debian 9 32 bits y Geforce FX serie 5xxx corrupcion video en arranque

Estado: 
[ACTIVO]

Buenas tardes, os cuento la problematica:

Dispongo de un equipo antiguo concretamente con las siguientes caracteristicas

CPU: AMD Athlon XP 3200+

Memoria: 3Gb RAM DDR400

Placa Base: asus a7v8x-x

2 discos duros de la misma marca y capacidad de 120 Gigas en modo raid 1 por software

Gráfica (tengo 2 y en las dos ocurre lo mismo) Una Geforce 5200 FX  de 256 vram y Geforce 5500 FX de 256 vram

Fuente de alimentacion de 450w

Bien el problema es que despues de la instalacion (por cierto logrado con PXE que me costo configurarlo en una maquina virtual con ubuntu ya creare un post al respecto) continuo: 

Despues de la instalación veo que la pantalla se corrompe al arrancar, se muestra bien cuando esta en modo texto pero luego hace como un cambio y se muestra un fondo azul distorsionado a rallas en el que se puede apreciar vagamente el logo de debian y no puedo hacer nada, cuando se queda en este estado puedo acceder al equipo mediante ssh pero tarda muchisimo en responder y si lanzo un apagado  no hace nada y vuelve al simbolo del sistema y si hago un reboot se desconecta pero no reinicia (sintomas circunstanciales)

 

La cosa es que he visto que el problema viene dado con el driver neuveau y puede que el problema venga dado por el DRM, lo medio soluciono indicando el en grub en la entrada linux nomodeset, pero claro esto hace que me quede sin entorno grafico ya que se queda en negro y solo tengo disponibles las consolas TTY

Se dejo de dar soporte por parte de nvidia desde la version 176.x.x (no recuerdo ahora mismo el numero) pero al parecer solo es compatible hasta la version de wheezy con lo que la version privativa del driver no es una opcion a pesar de haberlo intentado ya que al parecer la ultima version compatible de las xorg es la 1.5, aunque nvidia reconoce que deberia funcionar sin problemas en la 1.6.

 

Conoceis alguna forma de que pueda tener entorno grafico, me da igual la aceleracion 3D, a ser posible con buena resolucion, dicho de otro modo que driver me vendria bien para hacerlo funcionar? porque recuerdo que en otros sistemas operativos tenias la opcion generica de usar el driver svga que si bien no tienes aceleracion 3D si que dispones de entorno grafico para ello.

 

Una cosa que no entiendo es porque los fabricantes si algo esta obsoleto y le vas a dejar de dar soporte porque no liberan los drivers o al menos dejan uno decente para aceleracion 2D.

 

Seria el problema que tengo relativo al DRM? se puede desactivar solo esa parte?

 

Un saludo y sigo buscando como solucionar el problema

 

P.D: El sistema lo quiero mas bien para montarme un servidor casero, pero con posibilidad de arrancar las X para realizar configuraciones mas complejas con un poco mas de ayuda sin tener que estar buscando info en otro equipo.

P.D2: La grafica la 5500 es nueva, no es de segunda mano, consegui una que andaba por ahi de stock en una tienda olvidada de la mano de dios, pensando que la 5200 estaba mal, fuente de alimentacion nueva por si se os ocurria que pudiera ser que no le ofrece la suficiente energia, los 3 modulos de memoria son nuevos de 1 Gb cada uno de la misma marca

Ahora estoy viendo la pagina oficial de nouveau a ver si me aclaro algo de la corrupcion de video porque al parecer el driver nouveau viene integrado como modulo kernel, al menos la parte DRM.

Dom, 03/09/2017 - 10:22
tigreci
Imagen de tigreci
Desconectado/a
colaborador
se unió: 31/07/17

Se me olvido comentar un detalle que quizas sea importante la pantalla es una TV samsung plana de 19 pulgadas relativamente moderna

El texto aparece como distorsionado vamos como tiritando, la pantalla funciona bien con mis otros sistemas operativos incluido otra debian que tengo la diferncia es que el otro equipo es un i3 con una nvidia gforce 620m  y salida hdmi y en este caso es salida puerto vga, 

 

Aprovechando voy a intercambiar la placa y meter de nuevo la 5200 fx a ver si hay alguna diferencia pero creo recordar que ocurria lo mismo.

Autodidacta sin remedio.

Dom, 03/09/2017 - 10:30
tigreci
Imagen de tigreci
Desconectado/a
colaborador
se unió: 31/07/17

Al parecer es de la grafica, enchufe la 5200 fx y se ve bien, ahora bien realizare mas pruebas con live cds, sobre todo probare con una ubuntu antigua que cargue los drivers privativos de nvidia para la 5500 a ver si funciona, si falla ya sabemos que la grafica esta mal.

Autodidacta sin remedio.

Dom, 03/09/2017 - 11:01
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Lamentablemente debian solo da soporte para los controladores privativos a partir de GPUs GeForce 6xxx y 7xxx asi que para las 5xxx solo te queda noveau
https://wiki.debian.org/es/NvidiaGraphicsDrivers#stretch-304xx

No hace mucho tiempo atras otro usuario menciono problemas de rendimiento con noveau. Lo que se me ocurre es que pruebes de buscar si existen configuraciones de noveau para xorg por ejemplo: https://wiki.archlinux.org/index.php/Nouveau_(Espa%C3%B1ol)
 

No me queda muy claro que es eso de  "...El texto aparece como distorsionado vamos como tiritando...". No se si esto puede ayudar pero en este blog muestran una especie de tuto para mejorar el renderizado de fuentes  https://salmorejogeek.com/2016/09/02/consigue-un-renderizado-de-fuentes-perfecto-en-tu-distro-linux/

No se que escritorio estas usando, a lo mejor también puede ser un tema de configuración

Dom, 03/09/2017 - 22:59
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

Ese comportamiento que mencionas lo he visto con las gráficas de AMD, y por ello la necesidad de "firmware-linux-nonfree".

Detalles del paquete: Package: xserver-xorg-video-nouveau

"This package provides 2D support including EXA acceleration, Xv and RandR. 3D functionality is provided by the libgl1-mesa-dri package."

Tigreci: Seria el problema que tengo relativo al DRM? se puede desactivar solo esa parte? NPI, algo en los logs.

  1. kernel command line with: nomodeset, drm.modeset=0, nouveau.modeset=0 or similar
  2. modprobe.conf or modprobe.d/ adding the module options drm modeset=0 or nouveau modeset=0

Algo curioso paso con mi equipo, nada relacionado, pero vamos: Tarjeta Nvidia, controlador Nouveau, conector VGA. Pongo en funcionamiento el equipo, -> startx, sesión openbox, perfecto, pero al cabo de unos minutos, los colores se vuelven opacos (no nítidos), pipipi. Solución: toma el cable VGA e intercambia las conexiones, es decir, el conector que esta unido a la TV Sony (mi caso) desconecta y conectalo a la gráfica. Y viceversa. jajajajajajajajajajajajajajajaja. Falto leer las especificaciones del VGA, :-)

Alguna risita.

 

Vie, 08/09/2017 - 15:53
tigreci
Imagen de tigreci
Desconectado/a
colaborador
se unió: 31/07/17

Bueno no se se supone que son la misma serie mismo modelo misma cantidad de memoria y mismo tipo es decir una nv34, la diferencia es que una es una fx 5500 y la otra una fx5200 (ni ultra ni nada de eso) al final deje la fx5200 porque funciona bien, la otra lo que me referia con texto distorsionado me voy a intentar explicar mejor lo de texto distorsionado me refiero a la consola, es decir el texto se ve bien es legible pero como que se mueve de izquierda a derecha un pixel constantemente como una distorsión, de todos modos los doy por solucionado porque despues de probar la 5200 que es una grafica de la misma familia misma cantidad de memoria y casi mismas especificaciones exceptuando la cpu que la 5500 tiene 270 Mhz y la otra 250 y que la 5500 es nv34B y la 5200 nv34, entiendo que esa B deberia dar igual no? porque en las especificaciones de la nouveau indica igualmente que es la nv34

Autodidacta sin remedio.

Vie, 08/09/2017 - 16:01 (Responder a #6)
tigreci
Imagen de tigreci
Desconectado/a
colaborador
se unió: 31/07/17

Berbellon wrote:

Ese comportamiento que mencionas lo he visto con las gráficas de AMD, y por ello la necesidad de "firmware-linux-nonfree".

Detalles del paquete: Package: xserver-xorg-video-nouveau

"This package provides 2D support including EXA acceleration, Xv and RandR. 3D functionality is provided by the libgl1-mesa-dri package."

Tigreci: Seria el problema que tengo relativo al DRM? se puede desactivar solo esa parte? NPI, algo en los logs.

  1. kernel command line with: nomodeset, drm.modeset=0, nouveau.modeset=0 or similar
  2. modprobe.conf or modprobe.d/ adding the module options drm modeset=0 or nouveau modeset=0

Algo curioso paso con mi equipo, nada relacionado, pero vamos: Tarjeta Nvidia, controlador Nouveau, conector VGA. Pongo en funcionamiento el equipo, -> startx, sesión openbox, perfecto, pero al cabo de unos minutos, los colores se vuelven opacos (no nítidos), pipipi. Solución: toma el cable VGA e intercambia las conexiones, es decir, el conector que esta unido a la TV Sony (mi caso) desconecta y conectalo a la gráfica. Y viceversa. jajajajajajajajajajajajajajajaja. Falto leer las especificaciones del VGA, :-)

Alguna risita.

 

 

jajajaja que va tio, igualmente realice esa prueba, pero fallaba del mismo modo solo arrancaba poniendo en grub nomodeset, porque al parecer se activa por defecto el driver nouveau en instalacion nueva si detecta la grafica claro, lo de pagina deformada es que ni llega a entrar al entorno grafico se corrompe desde el principio cuando hace el cambio de modo texto a grafico (GDI??) no recuerdo si se llama asi pero dicho de otro modo cuando da el control, por decirlo de algun modo al framebuffer. 

 

Suena a un problema parecido que tenia en un portatil en el que la grafica estaba mal salian bandas rojas en la pantalla, y solo funcionaba poniendo el driver vga (en windows) en Debian creo recordar que el driver era vesa, que es lo unico de verdad que no he probado, porque puede que la grafica en 2D funcione y en 3D no, esto lo pregunte mas que nada por si alguien tenia funcionando una fx5500 en debian 9, por si tenia los mismos problemas que yo y descartar, pero la verdad es que para 15 euros que me costó la tarjeta me da igual la verdad, total la otra placa base que tengo tiene grafica integrada con lo que no me voy a quedar sin grafica para el segundo servidor nas

 

Perdonad las tildes y demas estoy con el movil

Autodidacta sin remedio.

Dom, 24/09/2017 - 20:38
tigreci
Imagen de tigreci
Desconectado/a
colaborador
se unió: 31/07/17

Una cosa lo dejo abierto el hilo porque, realizare la prueba final con un live cd de ubuntu antigua, para indicar al final si es problema de la grafica, ademas de realizar otra prueba con vesa asi ya me aseguro de que realmente la grafica esté mal, porque a bote pronto la 5200fx funciona correcto con el driver nouveau, eso si bajo rendimiento pero tampoco se puede pedir potencia a aun seat 600 XD, que puede ir mejor? si, que quiero software obsoleto, pues no, quiero tener lo mas reciente posible en version LTS

Autodidacta sin remedio.

Dom, 15/10/2017 - 13:36
tigreci
Imagen de tigreci
Desconectado/a
colaborador
se unió: 31/07/17

Definitivo, la grafica esta mal, instale el innombrable del que dispongo los drivers en un disco duro en deshuso y ni siquiera arranca al instalar el driver solo funciona en modo texto cierro el hilo 

Autodidacta sin remedio.