debian no me arranca

23 envíos / 0 nuevos
Último envío
#1 Vie, 25/01/2019 - 14:11
Angelique
Imagen de Angelique
Desconectado/a
se unió: 25/01/19

debian no me arranca

hola les cometaba que debian no me carga bien a veces tengo que apagar fozado para que cargue el entorno grafico de xfce y toda la parte del /grub lo hace bien pero cuando eso termina se que en plase waiting y carga la primera linea

/dev/sda1 clean , 181621/4685824 files, 2601390/18743080 blocks

************************************************************************************************

( 9.533084) (drm:r100_cp_init) *error* failed to load frimware!

(9.533140) radeon 000:01:05.0:  failed to initializin cp (-12).

(9.533185) radeon 000:01:05.0: disablig gpu aceleration

************************************************************************************

a veces se queda en la primera linea (nota los asteriscos no aparecen)

tengo una portatil gateway ml 3109 con debian jessie 8.5

/////////////////////////////////////////////////////////////////////////////////////////////////////////////

resultado lscpu

Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                1
On-line CPU(s) list:   0
Thread(s) per core:    1
Core(s) per socket:    1
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 15
Model name:            Intel(R) Celeron(R) M CPU        520  @ 1.60GHz
Stepping:              6
CPU MHz:               1596.157
BogoMIPS:              3192.31
L1d cache:             32K
L1i cache:             32K
L2 cache:              1024K
NUMA node0 CPU(s):     0

$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$

 

root@debian:/home/migue# lsb_release -a
No LSB modules are available.
Distributor ID:    Debian
Description:    Debian GNU/Linux 8.11 (jessie)
Release:    8.11
Codename:    jessie

Vie, 25/01/2019 - 14:12
Angelique
Imagen de Angelique
Desconectado/a
se unió: 25/01/19

necesito ayuda la verdad es que no tengo mucha experiencia en esta rama.

 

NOTA: olvide algo que si conecto un teclado usb carga bien no se congela para nada pero cuando ya esta en uso no me reconoce, teclado, raton, touch pad y tarjeta de red, es decir la red.

 

Vie, 25/01/2019 - 15:18
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

desde una terminal como root ejecuta:

su
journalctl -b -p err

 

Vie, 25/01/2019 - 17:06
Angelique
Imagen de Angelique
Desconectado/a
se unió: 25/01/19

:/home/migue# journalctl -b -p err
-- Logs begin at vie 2019-01-25 14:00:06 CST, end at vie 2019-01-25 14:03:14 CST
ene 25 14:00:10 debian kernel: radeon 0000:01:05.0: firmware: failed to load rad
ene 25 14:00:10 debian kernel: [drm:r100_cp_init] *ERROR* Failed to load firmwar
ene 25 14:00:10 debian kernel: radeon 0000:01:05.0: failed initializing CP (-12)
ene 25 14:00:10 debian kernel: radeon 0000:01:05.0: Disabling GPU acceleration
ene 25 14:01:00 debian pulseaudio[1041]: [pulseaudio] pid.c: Daemon already runn
lines 1-6/6 (END)...skipping...
-- Logs begin at vie 2019-01-25 14:00:06 CST, end at vie 2019-01-25 14:03:14 CST. --
ene 25 14:00:10 debian kernel: radeon 0000:01:05.0: firmware: failed to load radeon/R300_cp.bin (-2)
ene 25 14:00:10 debian kernel: [drm:r100_cp_init] *ERROR* Failed to load firmware!
ene 25 14:00:10 debian kernel: radeon 0000:01:05.0: failed initializing CP (-12).
ene 25 14:00:10 debian kernel: radeon 0000:01:05.0: Disabling GPU acceleration
ene 25 14:01:00 debian pulseaudio[1041]: [pulseaudio] pid.c: Daemon already running

 

me dio este resultado.

Vie, 25/01/2019 - 20:44
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16
Sáb, 26/01/2019 - 17:58
Angelique
Imagen de Angelique
Desconectado/a
se unió: 25/01/19

amigos no me funcionó, de echo ni siquiera me dejó instalarlo cuando descargue el paquete..

 

este resultado me dio.

e# apt install /home/migue/Descargas/firmware-amd-graphics_20161130-4_all.deb
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete /home/migue/Descargas

 pero también creo que el paquete esta en mal estado pues me dice que no se puede desempaquetar, con xarchiver

manda un mensaje que dice falló ejecutar el proceso hijo !!ar!! (no existe el fichero o directorio)

Sáb, 26/01/2019 - 18:48
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Es que estas indicando  una ruta  de un archivo  ,no el nombre del paquete , el nombre correcto es :

firmware-amd-graphics    

Por lo tanto para instalarlo 

apt-get  install firmware-amd-graphics

cuando tengas dudas sobre el nombre de un paquete podes  buscarlo en internet  por ejemplo  " linux debian  firmware-amd-graphics ,  y seguramente te llevara a la pagina de paquetes de debian  para confirmar que existe 

Tambien podes usar apt, para buscar desde un terminal si existe dicho paquete 

apt-cache search firmware-amd-graphics

 

Sáb, 26/01/2019 - 20:06
Angelique
Imagen de Angelique
Desconectado/a
se unió: 25/01/19

ya los ejecute y no pasó nada,

cunado lo instalo dice:

apt-get  install firmware-amd-graphics
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete firmware-amd-graphics

&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&

y cuando lo busco pues:

no aparece nada

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

cuando lo descargo de Internet lo abro con xachiver y me dice:

No se puede ejecutar el programa de compresión

Falló al ejecutar el proceso hijo «ar» (No existe el fichero o el directorio)

será que el paquete está dañado.?

 

nota: la verdad amigos que desconozco mucho de esta rama.

Sáb, 26/01/2019 - 20:21
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Bien, vamos por partes , como no sabemos como instalaste tu sistema ni en que estado esta  necesitamos algunos datos .

En un terminal ejecutas este comando , como usuario común 

cat /etc/apt/sources.list

Copias el resultado  y lo pegas acá , asi podemos ver ese archivo ,  que contiene el listado de tus repositorios .

Para que entiendas algo , cuando intentas instar un paquete en tu sistema  mediante la herramienta  apt , o ,apt-get , o aptitude ( cualquiera de las tres ) , lo primero que hacen dichas aplicaciones es fijarse desde donde bajar dichos paquetes, esos lugares se llaman repositorios , cada rama de debian tiene sus propios repositorios  ,si el listado de repositorios  esta mal o es icompleto dichas herramientas no sabra desde donde bajar lo que le pedís ,o no  tendrá dicho paquete en su listado .  

El listado de repositorios se encuentra en el archivo  que esta en  /etc/apt/sources.list 

podes leer :

https://exdebian.org/wiki/introducción-los-repositorios-de-debian

Sáb, 26/01/2019 - 22:12
Angelique
Imagen de Angelique
Desconectado/a
se unió: 25/01/19

migue@debian:~$ cat /etc/apt/sources.list
#

# deb cdrom:[Debian GNU/Linux 8.5.0 _Jessie_ - Official Multi-architecture amd64/i386 NETINST #1 20160604-19:56]/ jessie main

#deb cdrom:[Debian GNU/Linux 8.5.0 _Jessie_ - Official Multi-architecture amd64/i386 NETINST #1 20160604-19:56]/ jessie main

deb http://ftp.sv.debian.org/debian/ jessie main
deb-src http://ftp.sv.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://ftp.sv.debian.org/debian/ jessie-updates main
deb-src http://ftp.sv.debian.org/debian/ jessie-updates main

 

 

 

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

NOTA ADEMAS EL ENTORNO ES XFCE

Sáb, 26/01/2019 - 22:57
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

 edita tu sources.list y agrega los repositorios non-free y contrib

su
nano /etc/apt/sources.list

agrega los contrib y non-free y el backports


#

# deb cdrom:[Debian GNU/Linux 8.5.0 _Jessie_ - Official Multi-architecture amd64/i386 NETINST #1 20160604-19:56]/ jessie main

#deb cdrom:[Debian GNU/Linux 8.5.0 _Jessie_ - Official Multi-architecture amd64/i386 NETINST #1 20160604-19:56]/ jessie main

deb http://ftp.sv.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.sv.debian.org/debian/ jessie main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

# jessie-updates, previously known as 'volatile'
deb http://ftp.sv.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.sv.debian.org/debian/ jessie-updates main contrib non-free

# jessie-backports
deb http://ftp.de.debian.org/debian jessie-backports main non-free

Para guardar los cambios CTRL + o
Para salir CTRL + x 

por ultimo actualiza y vuelve a instalarlo

su
apt-get update 
apt-get upgrade
apt-get  install firmware-amd-graphics
o sino tambien
apt-get install firmware-linux-nonfree

 

Dom, 27/01/2019 - 14:17
Angelique
Imagen de Angelique
Desconectado/a
se unió: 25/01/19

gracias amigos quiero agradecer, que si, se solucionaron los problemas  de los firmware, pero aun se congela, solo que ahora se congela en

 

/dev/sda1 clean , 181621/4685824 files, 2601390/18743080 block

siempre como antes, tengo que volver a apagarlo forzado y encenderlo nuevamente.

 

NOTA:, en otro sitio encontré que podía aplicar $mv run run.old

seria esta una opción correcta?

Dom, 27/01/2019 - 18:07
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

No entiendo bien a que te referis con que se congela. ¿es durante el inicio? ¿es pasado GRUB? ¿es antes de llegar a la pantalla de login?. ¿cuando se te cuelga si haces un CTRL+ALT+F1 o F2, etc. Te aparece una tty donde te podes loguear? ¿este problema te apareció desde el mismo momento que instalaste debian? ¿o el problema te apareció de buenas a primeras un buen día, luego de que actualizaste, instalaste algo, o se tildo y forzaste el apagado, etc? ¿te paso esto con otras distros?
sobre el tema de

puedes probar de instalar firmware-linux-nonfree de los repos de backports y tambien un kernel mas moderno

su
apt-get update
apt-get -t jessie-backports install  libgl1-mesa-dri libgl1-mesa-glx xserver-xorg-video-ati xserver-xorg-video-radeon firmware-linux-nonfree

otra que podrias probar es

su
nano /etc/X11/xorg.conf.d/20-radeon.conf

la carpeta xorg.conf.d si no existe la creas

su
mkdir /etc/X11/xorg.conf.d

luego pones

 Section "Device"
    Identifier "Radeon"
    Driver     "radeon"
    Option	"AccelMethod"           "EXA" #opciones válidas XAA y EXA. EXA es el método más reciente para la aceleración y es la opción predeterminada
    Option	"RenderAccel"           "on"  #activado por defecto en todos los hardware radeon

 EndSection

https://exdebian.org/wiki/gr%C3%83%C2%A1ficas-ati-en-debian
https://wiki.debian.org/es/ATIProprietary#configure
https://wiki.archlinux.org/index.php/ATI_(Espa%C3%B1ol)

 

------------- si todo falla no seria mala idea hacer una instalación limpia y probar las imágenes de debian con firmware no libre -----------------

Esta es una imagen de debian 8.11 con firmware nonfree para

 Esta es una imagen de debian 9.07 con firmware nonfree para

 Esta es una imagen de debian 10 con firmware nonfree para

 

Las imágenes netinstall requieren tener conexión a Internet porque una gran parte de la instalación se realiza por dicha via.
En la parte de elección de escritorio te conviene elegir xfce o mate que son escritorios bastante completos y que consumen pocos recursos.
Como tenes 2GB de ram puede que te convenga utilizar las imágenes de 32bits aunque con las de 64 también te andarían bien solo que consumen un poquito mas de ram

saludos...

 

Dom, 27/01/2019 - 20:29
Angelique
Imagen de Angelique
Desconectado/a
se unió: 25/01/19

si amigo contestando tu pregunata es, que se traba entre el grub y el login, y cuando aplico el ctrol alt + f1 no pasa nada

root@debian:/home/migue# apt-get -t jessie-backports install  libgl1-mesa-dri libgl1-mesa-glx xserver-xorg-video-ati xserver-xorg-video-radeon firmware-linux-nonfree
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 firmware-linux-nonfree : Depende: firmware-amd-graphics (= 20161130-3~bpo8+1) pero 20161130-4~deb8u1 va a ser instalado
                          Recomienda: intel-microcode pero no va a instalarse
                          Recomienda: amd64-microcode pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

esto fue cuando aplique tu sugerencia pero me aparecieron paquetes rotos ¿como soluciono eso?

Dom, 27/01/2019 - 21:14
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

el tema de los paquetes rotos lo solucionas con:

su
apt-get -f install

fijate de hacer la instalación con aptitude

su
aptitude -t jessie-backports install  libgl1-mesa-dri libgl1-mesa-glx xserver-xorg-video-ati xserver-xorg-video-radeon firmware-linux-nonfree

aptitude , si encuentra problemas de dependencias te va a dar opciones, elije la opción que te permita instalar los firmware de backports

* tendría que estar instalado pero si no es el caso: apt-get install aptitude

Lun, 28/01/2019 - 11:01
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Dependiendo de en que estado tenes tu sistema ,si es reciente , con pocas configuraciones y/o  archivos personales, también sugiero que hagas una nueva y limpia instalación , al actual debian stable .(9)   y asi partís desde cero 

Luego antes de ponerte a instalar nuevas cosas o modificar configuraciones preguntas .

 

 

Lun, 28/01/2019 - 15:27 (Responder a #16)
Angelique
Imagen de Angelique
Desconectado/a
se unió: 25/01/19

de que sitio podria descargar la version que me sugieres?

nota: roki IV me sugiere unos, puedo descargar de esos?

 

Lun, 28/01/2019 - 15:48
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

https://cdimage.debian.org/debian-cd/current/i386/iso-cd/debian-9.7.0-i386-xfce-CD-1.iso

Ahi tenes un enlace para bajarte una iso , CD  debian stable  +xfce , cuando lo tengas grabado en el cd ,simplemente  arrancas tu máquina y comenzas a instalar desde aahi 

Lun, 28/01/2019 - 16:43
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Puede que le convenga instalar un debian con firmware-nonfree asi ya salta los pasos que tuvo que hacer y como  debian 10 ya casi va a ser la nueva estable, lo mejor es que instale un debian 10
http://cdimage.debian.org/cdimage/unofficial/non-free/images-including-firmware/weekly-builds/i386/iso-cd/

Mar, 29/01/2019 - 17:54
Angelique
Imagen de Angelique
Desconectado/a
se unió: 25/01/19

gracias amigos, les agradezco su tiempo y su interés..

 

solo una ultima petición, tal ves consiga una computadora mejor, mas reciente,,, he pensado en una con arquitectura de 64 bit, para que me regalen un enlace para poder descargar una imagen completa en cd o dvd..

Mar, 29/01/2019 - 18:25
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

El enlace que te paso caliban trae una imagen completa con el escritorio xfce con debian 9 la actual estable.