ERROR Upgrade: No se borrar/ eliminar dependencias para poder actualizar

2 envíos / 0 nuevos
Último envío
#1 Lun, 21/05/2018 - 14:36
duven
Imagen de duven
Desconectado/a
se unió: 21/05/18

ERROR Upgrade: No se borrar/ eliminar dependencias para poder actualizar

Estado: 
[ACTIVO]

Hola gente, llevo un par de semanas sin poder actualizar (apt update / upgrade) mi Debian 9 en mi laptop Dell Inspiron.

Tiene algun problema de dependencias y cuando consigo borrar alguna al darle un apt update me la vuelve a bajar y tampoco se muy bien lo que tengo que hacer. Creo que es una tonteria pero no encuentro nada en google que me ayude.

Alquien me puede echar una mano?
Gracias
 

root@unknown4c80932ec2be:/home/homa# apt --fix-broken install
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
  libqt4-designer libqt4-qt3support libqt4-script
Utilice «apt autoremove» para eliminarlos.
Se instalarán los siguientes paquetes adicionales:
  anthy kasumi libanthyinput0 libuim-custom2 libuim-scm0 libuim8 uim uim-anthy uim-data uim-fep uim-gtk2.0 uim-gtk2.0-immodule uim-gtk3
  uim-gtk3-immodule uim-plugins uim-qt5 uim-qt5-immodule uim-xim
Los siguientes paquetes se ELIMINARÁN:
  libanthy0 libuim-plugins uim-qt uim-utils
Se instalarán los siguientes paquetes NUEVOS:
  anthy libanthyinput0 uim uim-data uim-fep uim-gtk2.0-immodule uim-gtk3 uim-gtk3-immodule uim-plugins uim-qt5 uim-qt5-immodule
Se actualizarán los siguientes paquetes:
  kasumi libuim-custom2 libuim-scm0 libuim8 uim-anthy uim-gtk2.0 uim-xim
7 actualizados, 11 nuevos se instalarán, 4 para eliminar y 976 no actualizados.
Se necesita descargar 0 B/1.991 kB de archivos.
Se utilizarán 5.347 kB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n] S
dpkg: considerando la desconfiguración de uim-anthy, ya que lo rompería la instalación de `uim-data' ...
dpkg: sí, se desconfigurará uim-anthy (roto por uim-data)
(Leyendo la base de datos ... 211220 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../uim-data_1%3a1.8.8-2_all.deb ...
Desconfigurando uim-anthy (1:1.8.6+gh20161003.0.d63dadd-2) ...
Error: in load: file "/usr/share/uim/lib/sigscheme-init.scm" not found
dpkg: error al procesar el archivo /var/cache/apt/archives/uim-data_1%3a1.8.8-2_all.deb (--unpack):
 installed uim-anthy package pre-removal script subprocess returned error exit status 1
Se encontraron errores al procesar:
 /var/cache/apt/archives/uim-data_1%3a1.8.8-2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Lun, 21/05/2018 - 17:13
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

Intenta desinstalar uim, purgándolo , luego actualiza el sistema , y finalmente volves a instalar uim ( que supongo sera lo que produce el conflicto )