Error:fallo al satisfacer todas las dependencias (caché corrupto)

9 envíos / 0 nuevos
Último envío
#1 Lun, 19/02/2018 - 02:16
Eijirou
Imagen de Eijirou
Desconectado/a
se unió: 19/02/18

Error:fallo al satisfacer todas las dependencias (caché corrupto)

Estado: 
[ACTIVO]

Antes que nada Hola. Me acabo de registrar en la comunidad .soy nuevo también en linux sé solo lo que puedo intuir xd. Y ya lei las normas"No son un soporte técnico". no se preocupen no soy toxico.

quiero descargar un paquete "discord" el cual necesita satisfacer una dependencia "Libatomic1". siguiendo la cadena me encontré que libatomic1 (también tiene dependencias). Por la que vengo es por" gcc-6-base_6.3.0-18_amd64" resulta que me dice que el cache es corrupto, intente descargar el paquete de otras pag y me sale lo mismo, lo que me hace pensar que no es la pagina donde lo descargue o algo asi.

lo que me dice para resolver el problema es ejecutar un comando "sudo apt-get install -f" lo hago. pero lo que hace es desinstalarme lo que se logro instalar.

el error

Aun no estoy seguro de que si es cosa del paquete o otra cosacool

Lun, 19/02/2018 - 07:53
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

Ese paquete discord parece que no está en los repositorios oficiales, al menos con ese nombre. ¿desde donde lo estás intentando instalar? ¿alguno repositorio?

Los paquetes libatomic1 y gcc-6-base si están en los repositorios oficiales, asi que no tienes que descargarlo desde ninguna pagina extraña. ESTO NO ES WINDOWS!!

Por cierto, dices que has leído las normas , pero parece que no te las aplicas. Por lo menos decir que versión de Debian tienes, que escritorio ....etc.

We were but stones. Your light made us stars

https://linuxveredas.blogspot.com.es/

Lun, 19/02/2018 - 07:57
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

Mirando en la red sobre ese paquete, supongo que es un .deb que te habrás descargado desde la pagina oficial.

Ya que te pide esos paquetes instálalos antes con:

# apt install libatomic1 gcc-6-base

E intenta instalar después el .deb con dpkg -i

We were but stones. Your light made us stars

https://linuxveredas.blogspot.com.es/

Lun, 19/02/2018 - 09:55 (Responder a #3)
Eijirou
Imagen de Eijirou
Desconectado/a
se unió: 19/02/18

Gracias por responder... Lo olvide xd ya lo puse nose si me falta algo.

 Es este:

no me aparecen el mis repositorios. sera por mi versión de debian?

Lun, 19/02/2018 - 11:06
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

1 ¿Qué versión de debian estas usando? es debian o camaina? de ser este último tenes los repositorios de camaina o de debian ???

2 Podrías poner el contenido de tu sources.list ???

cat /etc/apt/sources.list

3 El programa es https://discordapp.com/download ? de ser asi según el paquete las dependencias son:

libc6, libasound2, libatomic1, libgconf-2-4, libnotify4, libnspr4, libnss3, libstdc++6, libxss1, libxtst6, libappindicator1, libc++1

4 Ejecutá la instalación desde la terminal con dpkg como te dijo moonwatcher y pone el contenido del error

su
dpkg -i /home/rocky/Descargas/discord-0.0.4.deb

saludos...

Lun, 19/02/2018 - 13:43 (Responder a #5)
Eijirou
Imagen de Eijirou
Desconectado/a
se unió: 19/02/18

Si es canaima. La versión de debian ya la puse. (Sistema operativo:GNU/Linux V. 3.13.0 Debian: V.4.7.2-5)

este es el contenido de la sources.list.

# Repositorios de Canaima GNU/Linux
#

# Repositorio Estable (4.0)
deb http://paquetes.canaima.softwarelibre.gob.ve/ kerepakupai main aportes no-libres
#deb http://paquetes.canaima.softwarelibre.gob.ve/ kukenan main aportes no-libres
#deb-src http://paquetes.canaima.softwarelibre.gob.ve/ kerepakupai main aportes no-libres

#
# Repositorios de Canaima Educativo GNU/Linux
#

# Repositorio Estable
#deb http://edu.repositorio.canaima.softwarelibre.gob.ve/ kerepakupai usuarios
deb http://repositorio.canaimaeducativo.gob.ve/ auyantepuy usuarios

# Repositorio de Desarrollo
#deb http://repositorio.canaimaeducativo.gob.ve/ kukenan usuarios aportes no-libres.

pues si veo que tiene mas dependencias aparte libatomic1. y quiero descargarlas todas. pero libatomic1 por el momento es mi prioridad xd.

Probé con el comando y me dice esto:

root@canaima-educativo:/home/canaima# sudo dpkg -i /home/canaima/Descargas/libatomic1_6.3.0-18_amd64.deb
Seleccionando el paquete libatomic1:amd64 previamente no seleccionado.
(Leyendo la base de datos ... 174111 ficheros o directorios instalados actualmente.)
Desempaquetando libatomic1:amd64 (de .../libatomic1_6.3.0-18_amd64.deb) ...
dpkg: problemas de dependencias impiden la configuración de libatomic1:amd64:
 libatomic1:amd64 depende de gcc-6-base (= 6.3.0-18); sin embargo:
  El paquete `gcc-6-base' no está instalado.

dpkg: error al procesar libatomic1:amd64 (--install):
 problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
 libatomic1:amd64

este es lo que me dice cuando lo intento con gcc-6-base:

root@canaima-educativo:/home/canaima# sudo dpkg -i /home/canaima/Descargas/gcc-6-base_6.3.0-18_amd64.deb
dpkg: acerca de .../gcc-6-base_6.3.0-18_amd64.deb que contiene gcc-6-base:amd64:
 gcc-6-base rompe gcc-4.7-base (<< 4.7.3)
  gcc-4.7-base:amd64 (versión 4.7.2-5) está presente y instalado.

dpkg: error al procesar /home/canaima/Descargas/gcc-6-base_6.3.0-18_amd64.deb (--install):
 si se instalara gcc-6-base:amd64 se rompería gcc-4.7-base:amd64, y
 no es posible desconfigurarlo (--auto-deconfigure puede ayudar)
Se encontraron errores al procesar:
 /home/canaima/Descargas/gcc-6-base_6.3.0-18_amd64.deb
root@canaima-educativo:/home/canaima#

ese paquetes gcc-4.7-base es muy importante?

Gracias por responder.

 

Lun, 19/02/2018 - 16:10
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Primero que nada este es un foro de debian y no de canaima, y si bien esta última esta basada en debian, tiene su propios repositorios, con lo cual no estarias cumpliendo el punto 3 de las normas del foro https://exdebian.org/normas/normas-del-foro

3. Envía sólo dudas relacionadas con Debian

En exDebian sólo se podrán enviar consultas sobre problemas relacionados con la distribución Debian. Para información acerca del uso de otro tipo de distribución (Fedora, Suse, Mandriva, etc) puedes consultar las webs de ayuda específica. Para el caso de las distribuciones basadas en Debian solo se permitirán consultas sobre aquellas que empleen los repositorios oficiales de Debian. En caso de duda quedara a discreción de la moderación permitir o no la consulta en el foro.

El tema de la restricción no es un capricho, cuando se dice "basado en debian" parece como si dicha distribución fuera un debian, pero no es asi, ya que al tener sus repositorios propios, no sabes como compilaron los paquetes, ni como los nombran ni nada.
Esto no quiere decir que te cerremos el post o que no te tratemos de ayudar, pero es importante que entiendas que no es el foro adecuado donde plantear tu problema ya que "sabemos" de Debian pero no de canaima, con lo cual puede que los consejos o "soluciones" que te planteemos no sean acertados para tu sistema operativo.

Yo te preguntaba la versión de debian porque de esa manera se puede saber si tenes o no las versiones de los paquetes que son dependientes del programa que queres instalar
Ejemplo, si yo ejecuto  lsb_release -a me sale.

lsb_release -a
No LSB modules are available.
Distributor ID:	Debian
Description:	Debian GNU/Linux 9.3 (stretch)
Release:	9.3
Codename:	stretch

Con esa información yo se que es un Debian 9 llamado stretch

* Esta información se pide al momento de generar un post asi  evitamos tener que preguntarla en forma reiterada

Con la información que diste de los repositorios y buscando por Internet entiendo que la versión que tenes instalada es canaima 4 Kerepakupai que esta basada en debian 7 Wheezy

Desconozco si estas usando 32bits o 64bits pero te aclaro que el programa que intentas instalar es de 64bits

Para sacarnos la duda pone el contenido de

uname -a

Te aclaro que si estas en un sistema de 32bits para poder instalar un programa de 64bits necesitas tener instalado multi arquitectura (multiarch)

Otro de los problemas que veo, es que el programa depende de los siguientes paquetes:

libc6, libasound2, libatomic1, libgconf-2-4, libnotify4, libnspr4, libnss3, libstdc++6, libxss1, libxtst6, libappindicator1, libc++1

Y, al margen del tema de la arquitectura, los paquetes libatomic1 y libc++1 estan a partir de debian 8 jessie y no en Debian 7 wheezy. Si camaina 5 esta basado en debian 8 se podrían agregar los repositorios de canaima 5 y tomar los paquetes que faltan con el método apt pinning

Otra opción que puede que sea la mejor, es que instales un Debian puro con escritorio mate o xfce4 en 64bits y asi no vas a tener problemas
 

PD: cuando pongas información de código, que te pedimos, utiliza la etiqueta "insertar fragmento de código" asi el post se hace mas simple de leer wink

saludos...

Lun, 19/02/2018 - 20:14
Eijirou
Imagen de Eijirou
Desconectado/a
se unió: 19/02/18

Pues si estaba un poco desubicado frown Perdonen mi ignorancia xd.
Mejor me cambio a debían Gracias por los consejos.

Por cierto si. la canaima es de 64 bits.

Gracias de todos modos.

 

Lun, 19/02/2018 - 21:58 (Responder a #8)
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Eijirou wrote:

Pues si estaba un poco desubicado frown Perdonen mi ignorancia xd.
Mejor me cambio a debían Gracias por los consejos.

Por cierto si. la canaima es de 64 bits.

Gracias de todos modos.

 

No tienes porque pedir perdon, aquí estamos para aprender y de ser posible compartir o ayudar a que otros puedan resolver por si mismos sus problemas relacionados con debian/software libre.

Entendería que las computadoras del programa canaima no tendrían que tener hardware que requiera controladores privativos.

Por las dudas te paso un enlace de una imagen de debian estable y otra de debian testing con firmware non-free

las imágenes netinst traen el instalador y el sistema base con algunas cositas más, pero para realizar una instalación completa de debian requieren de conexión a internet

si queres descargar la imagen via torrent, o el liveCD de debian o investigar el repositorio http://cdimage.debian.org/cdimage/

Cualquier cosa no dudes en consultar

PD: si no tenes 4GB de RAM puede que la mejor opción para el escritorio podría ser Xfce4 o Mate y si no vas a usarla para trabajar, a lo mejor te convendría tener testing que trae softwarre más moderno aunque requiere de actualizaciones casi diarias

saludos...