Fallo instalacion paquetes basicos

8 envíos / 0 nuevos
Último envío
#1 Jue, 08/03/2018 - 08:35
Uno_wos
Imagen de Uno_wos
Desconectado/a
se unió: 04/08/17

Fallo instalacion paquetes basicos

Estado: 
[SOLUCIONADO]

He pasado de debian 9 64 bits a una instalacion de debian 9 32 bit (formateo por medio)
He tenido problemas con el driver nvidia-legacy-304xx y he tenido que instalarlo con backports.
La cosa es que ahora intento instalar paquetes basicos (hplip, catfish,..) y me dice que no

apt-get install catfish

Los siguientes paquetes tienen dependencias incumplidas:
 catfish : Depende: python3-gi-cairo pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

Parece que pide python3 mayor

 

apt-get install hplip

No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 hplip : Depende: python3-dbus (>= 0.80) pero no va a instalarse
         Depende: python3-pil pero no va a instalarse
         Depende: python3-reportlab pero no va a instalarse
         Depende: python3 (< 3.6) pero 3.6.4-1 va a ser instalado
         Recomienda: printer-driver-postscript-hp pero no va a instalarse
         Recomienda: sane-utils pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

tampoco libreoffice...

y paquetes del estilo

¿tan abandonada esta la arquitectura i386 pae686?

¿que solucion hay?

Jue, 08/03/2018 - 12:46
javier_macross
Imagen de javier_macross
Desconectado/a
se unió: 10/08/16

Mmmm, a ver. Sería interesante saber cómo estás instalando el sistema operativo. Como antes mencioné yo instalé el driver de Nvidia sin la necesidad de recurrir a Backports (que en la página recomienda instalar con cuidado, por no decir que de preferencia no los uses), tengo una Nvidia ge6200 y mi arquitectura es i386.

La instalación del driver la hice manual (sin usar apt-get) y tampoco necesité crear un archivo de lista negra, pues el mismo driver lo genera. También recuerdo que antes, era necesario purgar todos los archivo de nouveau. Eso ya tampoco se hace.

No sé si el paquete roto que tienes, sea a raíz de instalar precisamente backports. Después comentas que tampoco libreoffice, em ¿tampoco qué? ¿tampoco lo pudiste instalar? ¿Qué versión quieres instalar?

Saludos.

smiley

 

Jue, 08/03/2018 - 12:47
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Copia y pega acá tu sources.list .

¿Luego de instalar hiciste una actualización del sistema ?

Jue, 08/03/2018 - 14:22
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

Uno_wos:

¿tan abandonada esta la arquitectura i386 pae686?

No, no creo. Si bien yo lo instalé para cpus inferiores, no me dió todos estos problemas. Solo uno de los

ordenadores que lo recibieron no me aceptó instalar directamente el escritorio. (Pero la consola de texto si,

 sin problemas).

 

El problema que refleja es que le faltan varios paquetes, (problema de dependencias ).

Si lo haces por ti mismo es cuestión de ir revisando el log de instalación en busca de errores que hubieran,

y que después se van acumulando impidiendo la instalación de paquetes que dependen de los primeros.

 

La solución bestia, es ir instalando por separado cada uno de los paquetes requeridos, -en la versión

indicada o posterior-, para finalmente instalar de nuevo los paquetes que te interesaban.

 

 Dos preguntas, ¿a partir de que método hiciste la instalación?, ( netinstall, dvd-rom, ...)

 Y ¿instalaste la versión estable, u otra?.

 

 

Jue, 08/03/2018 - 19:39
Uno_wos
Imagen de Uno_wos
Desconectado/a
se unió: 04/08/17

Lo descargué de aqui

https://cdimage.debian.org/debian-cd/current/i386/iso-cd/

 

Lo toste con dd en una usb

Lo bootee

Instale

(hubo una peculiaridad, no me pidió firmware del WiFi, y aun así me lo reconoció [Intel 3945], pero no se conectó a mi wifi)

la instalación fue bien.

llegó el momento de usar una replica

lo dejé sin nada para poner las sources a mano posteriormente

Reinicia y ya está

 

Lo primero que hice fue poner las sources :

deb http://ftp.es.debian.org/debian/ stable main contrib non-free
deb http://ftp.es.debian.org/debian/ stable-updates main contrib non-free
deb http://security.debian.org/ stable/updates main contrib non-free

 

Apt-get update

Espero instale el driver de Nvidia-legacy-304xx que no me funcionó y por eso puse en las sources el stretch-backports y lo instalé y funcionó.

 

Supongo, no se porque, me ha instalado python3 de backports. Porque, lo he forzado a la versión estable, que era la 3.5 y he podido instalar. La cosa es que desde synaptic me tira paquetes rotos y desde la terminal si que instala bien. Pero, ya no se que cosas se han instalado de backports...

 

Creo que está solucionado, pero agradezco guía.

¿Qué hice mal en la instalación?

¿Hay un método mejor?

¿Qué fallo?

¿Por qué Nvidia no me funcionó a la primera?

 

 

Jue, 08/03/2018 - 22:16
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

primero que nada hace un

su
aptitude update && aptitude upgrade

y luego trata de instalar el paquete con aptitude ya que este te da otras opciones, Y, N y Q si te convence la solución que te propone le das Y si no te convence le das N y te va a buscar otra solución y si nada te convence le das Q

Si el caso es que te instaló paquetes de otra rama (backports creo) aptitude puede desactualizar los paquete que estan en conflicto a la versión estable.

En realidad, tener el repositorio de backports no afecta en nada ya que la única forma de actualizar o instalar paquetes de backports es con el comando apt install -t stretch-backports paquete.

Eso si, en caso que utilices synaptic puede que este este configurado para instalar los paquetes en su versión mas alta, en ese caso si te puede dar problemas el repositorio backports pero eso se soluciona poniendo instalar paquetes estables wink

Es verdad que tener el sistema base en estable, da tranquilidad, estabilidad, seguridad, etc. pero eso no quita que un navegador web, un editor de imágenes, etc, etc, etc se los pueda tener en su versión más alta y precompilada para estable.

 

saludos...

Vie, 09/03/2018 - 06:46 (Responder a #6)
Uno_wos
Imagen de Uno_wos
Desconectado/a
se unió: 04/08/17

Parece que forzando desde synaptic a usar stable, y hacer un downgrade a python3 (3.5) funciono todo.

Cosas raras de este mundo...

 

Gracias

Mar, 13/03/2018 - 15:35
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 De esto queda visto, que lo mejor es instalar primero estable, si es posible desde un "repositorio estable", (p.e. una .iso),

 ver que funciona como debe,

 y luego ya actualizaremos y haremos los experimentos que correspondan.

smiley