Instalar debian en Msi GF62

21 envíos / 0 nuevos
Último envío
#1 Mié, 25/07/2018 - 09:18
Delos
Imagen de Delos
Desconectado/a
se unió: 25/07/18

Instalar debian en Msi GF62

Estado: 
[SOLUCIONADO]

En primer lugar posicionarme admitiendo que soy bastante nuevo en cuanto a sistemas operativos basados en GNU/Linux (me he dedicado a instalar alguna que otra maquina virtual y poco más) y hace un par de días compré un msi GF62 8Rd sin sistema operativo. tenía ganas de meterme en el mundo GNU/Linux y me decanté por instalar debian, quería saber opiniones sobre si debería instalar debian como S.O. principal o si es incompatible con el pc. https://www.msi.com/Laptop/GF62-8RD/Specification

En segundo lugar, voy a querer tener debian en el equipo si o si y me da problemas a la hora de conectarme mediante wifi y no consigo de ningún modo arreglarlo.

Muchas gracias de antemano y espero no ocasionaros ninguna molestia.

 

Mié, 25/07/2018 - 10:27
debiatonix
Imagen de debiatonix
Desconectado/a
se unió: 07/01/18

hola Delos y bienvenido!!

Decirte que todo tiene solución menos la muerte, entra en debian package y te bajas el firmware-atheros, luego instalas el paquete con  dpkg -i firmware-atheros

Saludos!

Pd:Doy por sentado que sabes lo que es el super usuario o el sudo para instalar paquetes!!

Pon una debian en tu vidayes

Mié, 25/07/2018 - 12:37
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

No conseguís conectarte y la interfaz wifi funciona ? 

¿La interfaz wifi no funciona   siquiera ? ¿o que ?

¿El sistema detecta la interfaz activa?

iwconfig 

¿Al menos la detecta ?

ip a

 

Bien, si es el caso como te indican que necesitas el paquete firmware-atheros,  simplemente lo instalas con 

apt-get install firmware-atheros 
## apt-get, apt ,aptitude,  da igual 

Claro siempre y cuando tengas conectividad mediante la interfaz ethernet ( cable) y acceso a Internet, caso contrario como te indicaron ,te bajas el paquete, lo guardas en algún medio atraíble, y luego  lo que te han dicho para instalar.

Ahora, en todo caso    deberás determinar cual es la wifi ( si lo anterior no funciona)

lshw -class network
lspci

Edito:Parece que la wifi es una intel ( habría que confirmarlo ) si es el caso entonces :

https://www.intel.la/content/www/xl/es/support/articles/000005511/network-and-i-o/wireless-networking.html

Que instalarías con el paquete  firmware-iwlwifi

Vie, 27/07/2018 - 12:43
Delos
Imagen de Delos
Desconectado/a
se unió: 25/07/18

Volví a instalar debian, debido a que dudaba de haber instalado algo de más que puediera afectar a vuestras recomendaciones.

Arrancado el nuevo sistema coloqué estos repositorio (los pongo por si la he cagado en algo, voy leyendome la guía pero nunca se sabe).

deb http://ftp.es.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.es.debian.org/debian/ stretch main  contrib non-free

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

deb http://ftp.es.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.es.debian.org/debian/ stretch-updates main contrib non-free

Intalé el paquete firmware-atheros y coloco la salida de iwconfig e ip a y lshw:
 

sudo iwconfig
enp2s0    no wireless extensions.

lo        no wireless extensions.

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 30:9c:23:8e:71:d9 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.142/24 brd 192.168.1.255 scope global dynamic enp2s0
       valid_lft 65156sec preferred_lft 65156sec
    inet6 fe80::329c:23ff:fe8e:71d9/64 scope link
       valid_lft forever preferred_lft forever

sudo lshw -class network
  *-network UNCLAIMED       
       description: Network controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 14.3
       bus info: pci@0000:00:14.3
       version: 10
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix cap_list
       configuration: latency=0
       resources: memory:a4314000-a4317fff
  *-network
       description: Ethernet interface
       product: Killer E2400 Gigabit Ethernet Controller
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 10
       serial: 30:9c:23:8e:71:d9
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=alx duplex=full ip=192.168.1.142 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:127 memory:a4200000-a423ffff ioport:3000(size=128)

lspci
 

00:00.0 Host bridge: Intel Corporation Device 3ec4 (rev 07)
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Device 3e9b
00:12.0 Signal processing controller: Intel Corporation Device a379 (rev 10)
00:14.0 USB controller: Intel Corporation Device a36d (rev 10)
00:14.2 RAM memory: Intel Corporation Device a36f (rev 10)
00:14.3 Network controller: Intel Corporation Device a370 (rev 10)
00:16.0 Communication controller: Intel Corporation Device a360 (rev 10)
00:17.0 SATA controller: Intel Corporation Device a353 (rev 10)
00:1b.0 PCI bridge: Intel Corporation Device a343 (rev f0)
00:1e.0 Communication controller: Intel Corporation Device a328 (rev 10)
00:1f.0 ISA bridge: Intel Corporation Device a30d (rev 10)
00:1f.3 Audio device: Intel Corporation Device a348 (rev 10)
00:1f.4 SMBus: Intel Corporation Device a323 (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Device a324 (rev 10)
01:00.0 3D controller: NVIDIA Corporation Device 1c8c (rev a1)
02:00.0 Ethernet controller: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller (rev 10)

Al observar que se trataba de una intel instalé el paquete -iwlwifi pero sigue sin funcionar. Gracias y lo siento si he aportado información irrelevante.

 

Vie, 27/07/2018 - 13:10
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Fijate en este enlace , leelo con cuidado y fijate si has seguido todos los pasos ,o si te da una pista extra para saber si tu interfaz esta soportada por el modulo de firmware

https://wiki.debian.org/iwlwifi

Por cierto tu lista de repositorios en principios esta bien , no hagas caso (necesariamente) a lo que indica en la wiki lo importante es tener incluidos los repositorios  non-free (cualquiera de ellos ) , haces un update e instalas luego ,lo que haga falta .

Vie, 27/07/2018 - 13:32
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Hay que usar "insertar fragmento de código" sino no se entiende nada

Sáb, 28/07/2018 - 22:37
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Tampoco estaría de más la salida del comando

journalctl -b -p err

veo un  dispositivo de comunicaciones indicado en el sistema, tanto en la salida de lshw como en la de lspci (a lo mejor sería mejor que usaras lspci -k), pero no aparece reconocido como dispositivo wifi o ethernet, el sistema sólo reconoce un dispositivo de red, y esa es la tarjeta por cable y no  por wifi.

  No hay bar que por bien no venga....
Dom, 29/07/2018 - 07:35
debiatonix
Imagen de debiatonix
Desconectado/a
se unió: 07/01/18

Vamos a ver!! tu tarjeta inalámbrica después de la salida que te ha dado es esta:
 

*-network UNCLAIMED       
       description: Network controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 14.3
       bus info: pci@0000:00:14.3
       version: 10
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix cap_list
       configuration: latency=0
       resources: memory:a4314000-a4317fff

Seguramente sea que ese modelo monta la wifi "intel", por tanto necesitas el firmware de "intel"
Me extraña porque mi msi -https://es.msi.com/Laptop/GE73VR-7RE-Raider/Specification- me tira el siguiente mensaje:

 *-network                 
       description: Wireless interface
       product: QCA6174 802.11ac Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 32
       serial: 9c:b6:d0:67:ef:eb
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath10k_pci driverversion=4.17.0-0.bpo.1-amd64 firmware=WLAN.RM.4.4-00022-QCARMSWPZ-2 ip=xxxxxxxx latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:135 memory:df200000-df3fffff

Busca el firmware de intel a ver si se te soluciona el problema!!!

Suerte!!

Pon una debian en tu vidayes

Dom, 29/07/2018 - 13:08 (Responder a #8)
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

debiatonix wrote:

Seguramente sea que ese modelo monta la wifi "intel", por tanto necesitas el firmware de "intel"
 

Busca el firmware de intel a ver si se te soluciona el problema!!!

Suerte!!

 

https://www.intel.la/content/www/xl/es/support/articles/000005511/network-and-i-o/wireless-networking.html

https://wiki.debian.org/iwlwifi

Por lo tanto,lo dicho   : firmware-iwlwifi 

Edito: Por lo que he visto algunos modelos  bloquean por defecto la wifi en todo caso 

rfkill  list 

Y en el caso de estar bloqueada 

rfkill  unblock all 

Y de paso , distintos modelos portan  unos chipset atheros, y otros chipset  intel ,  habrá que ver 

Lun, 30/07/2018 - 22:49
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Pues mirando, diría que si, que monta la intel y seguramente le faltará el firmware, que debería ser uno de estos cuatro archivos (todos ellos contenidos en el paquete firmware-iwlwifi, al menos en su versión de Debian Unstable)

/lib/firmware/iwlwifi-9000-pu-b0-jf-b0-34.ucode
/lib/firmware/iwlwifi-9000-pu-b0-jf-b0-38.ucode
/lib/firmware/iwlwifi-9260-th-b0-jf-b0-34.ucode
/lib/firmware/iwlwifi-9260-th-b0-jf-b0-38.ucode

y además juraría que a esa tarjeta le tocaría el primero, el 34 según la página de soporte de intel (su tarjeta creo que es la primera de la tabla).

De todas formas, la salida del comando journalctl -b |grep -i firmware lo confirmará.

 

Edit...

Además, por lo que dice ahí, es para una versión de kernel 4.14, no recuerdo con qué kernel se lanzó Stretch, pero creo que era menor a ese, así que aún instalando el paquete (que pueda que su versión no incluya ese firmware) o copiando directamente el firmware de la página de intel no acabe de funcionarle, con lo que posiblemente tendría que tirar de backports e instalar un kernel más nuevo, así como una versión más nueva del paquete firmware-iwlwifi si la hubiera.

  No hay bar que por bien no venga....
Jue, 09/08/2018 - 08:52
Delos
Imagen de Delos
Desconectado/a
se unió: 25/07/18

Disculpar la tardanza pero me ha sido imposible ponerme con ello. Intenté añadir el firmware de la tarjeta de red manualmente pero no me funcionó y acabé borrándolo. Os adjunto los comandos que me habéis pedido.

root@Delos-WW:/lib/firmware# journalctl -b -p err
-- Logs begin at Thu 2018-08-09 13:01:34 CEST, end at Thu 2018-08-09 13:37:57 CEST. --
ago 09 13:01:34 Delos-WW kernel: ACPI Error: [\_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20160831/dswload-210)
ago 09 13:01:34 Delos-WW kernel: ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20160831/psobject-238)
ago 09 13:01:34 Delos-WW kernel: ACPI Exception: AE_NOT_FOUND, (SSDT:xh_cfhd4) while loading table (20160831/tbxfload-228)
ago 09 13:01:34 Delos-WW kernel: ACPI Error: 1 table load failures, 7 successful (20160831/tbxfload-246)
ago 09 13:01:34 Delos-WW kernel: ACPI Error: [_SB_.PCI0.RP05.PXSX] Namespace lookup failure, AE_NOT_FOUND (20160831/dswload2-191)
ago 09 13:01:34 Delos-WW kernel: ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20160831/psobject-238)
ago 09 13:01:34 Delos-WW kernel: ACPI Error: Method parse/execution failed [\_SB.PCI0.RP04.PXSX] (Node ffff9dbaacdbe500), AE_NOT_FOUND (20160831/psparse-543)
ago 09 13:01:34 Delos-WW kernel: ACPI Error: [_SB_.PCI0.RP09.PXSX] Namespace lookup failure, AE_NOT_FOUND (20160831/dswload2-191)
ago 09 13:01:34 Delos-WW kernel: ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20160831/psobject-238)
ago 09 13:01:34 Delos-WW kernel: ACPI Error: Method parse/execution failed [\_SB.PCI0.RP08.PXSX] (Node ffff9dbaacdbde60), AE_NOT_FOUND (20160831/psparse-543)
ago 09 13:01:34 Delos-WW kernel: ACPI Error: [_SB_.PCI0.RP13.PXSX] Namespace lookup failure, AE_NOT_FOUND (20160831/dswload2-191)
ago 09 13:01:34 Delos-WW kernel: ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20160831/psobject-238)
ago 09 13:01:34 Delos-WW kernel: ACPI Error: Method parse/execution failed [\_SB.PCI0.RP12.PXSX] (Node ffff9dbaacdbb4d8), AE_NOT_FOUND (20160831/psparse-543)
ago 09 13:01:34 Delos-WW kernel: ACPI Exception: AE_NOT_FOUND, Evaluating _PRS (20160831/pci_link-176)
ago 09 13:01:34 Delos-WW kernel: ACPI Exception: AE_NOT_FOUND, Evaluating _PRS (20160831/pci_link-176)
ago 09 13:01:34 Delos-WW kernel: ACPI Exception: AE_NOT_FOUND, Evaluating _PRS (20160831/pci_link-176)
ago 09 13:01:34 Delos-WW kernel: ACPI Exception: AE_NOT_FOUND, Evaluating _PRS (20160831/pci_link-176)
ago 09 13:01:34 Delos-WW kernel: ACPI Exception: AE_NOT_FOUND, Evaluating _PRS (20160831/pci_link-176)
ago 09 13:01:34 Delos-WW kernel: ACPI Exception: AE_NOT_FOUND, Evaluating _PRS (20160831/pci_link-176)
ago 09 13:01:34 Delos-WW kernel: ACPI Exception: AE_NOT_FOUND, Evaluating _PRS (20160831/pci_link-176)
ago 09 13:01:34 Delos-WW kernel: ACPI Exception: AE_NOT_FOUND, Evaluating _PRS (20160831/pci_link-176)
ago 09 13:01:34 Delos-WW kernel: nouveau 0000:01:00.0: unknown chipset (137000a1)
ago 09 13:01:34 Delos-WW avahi-daemon[593]: chroot.c: open() failed: No such file or directory
ago 09 13:02:06 Delos-WW pulseaudio[1379]: [pulseaudio] pid.c: Daemon already running.
root@Delos-WW:~# journalctl -b | grep -i firmware
ago 09 13:01:34 Delos-WW kernel: Spectre V2 : Enabling Restricted Speculation for firmware calls
ago 09 13:01:34 Delos-WW NetworkManager[576]: <info>  [1533812494.9321] manager[0x559bc47fb040]: monitoring kernel firmware directory '/lib/firmware'.
ago 09 13:18:59 Delos-WW NetworkManager[576]: <info>  [1533813539.4045] manager: kernel firmware directory '/lib/firmware' changed

PD: Intenté solucionar el problema mediante una VBox en Windows pero tampoco conseguí nada incluso instalé desde los backports pero no me instalaban los controladores de Wireless-AC 9560.

Jue, 09/08/2018 - 08:56
Delos
Imagen de Delos
Desconectado/a
se unió: 25/07/18

Panko, has dado en el clavo, se me pasó lo del kernel, parece que tengo la versión 4.9 y piden la 4.14 como mínimo. Voy a informarme sobre como actualizar kernel y pruebo, ya os comentaré que tal.

Jue, 09/08/2018 - 11:28
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Fijate que kernel tenes disponibles 

aptitude  search linux-image

Y en todo caso , incluí en tu lista de repositorios los backports  y nuevamente fijate que kernel tenes disponible  

http://jensd.be/818/linux/install-a-newer-kernel-in-debian-9-stretch-stable

Cuidado , por ahora NO desinstales ningún kernel , en caso de problemas siempre podas iniciar con un kernel viejo y funcional , mas adelante si hace falta desinstalaras los mas viejos

Vie, 10/08/2018 - 07:05
Delos
Imagen de Delos
Desconectado/a
se unió: 25/07/18

Comento un poco la situación, instalé kernel perfectamente pero a los minutos me salio un error que bloqueaba el sistema "NMI watchdog: BUG: soft lockup" algo así y observé por paginas webs que se arreglaba al instalar los controladores de la gráfica.

mike@Delos-WW:~$ lspci -nn | egrep -i "3d|display|vga"
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:3e9b]
01:00.0 3D controller [0302]: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] [10de:1c8c] (rev ff)

Mi gráfica es híbrida según la guía, por lo tanto instale bumblebee, y ahora estoy a la espera de observar que todo vaya bien (parece que sí) en cuanto a la tarjeta de red sigue sin funcionar y no se me descarga el firmware para soportar la Intel® Wireless-AC 9560.

He probado estos comandos.

"sudo apt-get upgrade firmware-iwlwifi"

"sudo apt-get -t stretch-backports upgrade firmware-iwlwifi"

Gracias y un saludo.

Vie, 10/08/2018 - 07:11
Delos
Imagen de Delos
Desconectado/a
se unió: 25/07/18

Salida del comando journalctl -b | grep -i firmware:

root@Delos-WW:/home/mike# journalctl -b | grep -i firmware
ago 10 11:58:07 Delos-WW kernel: Spectre V2 : Enabling Restricted Speculation for firmware calls
ago 10 11:58:07 Delos-WW NetworkManager[662]: <info>  [1533895087.9573] manager[0x55e1879eb040]: monitoring kernel firmware directory '/lib/firmware'.
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-38.ucode (-2)
ago 10 11:58:08 Delos-WW kernel: firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-38.ucode failed with error -2
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-37.ucode (-2)
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-37.ucode failed with error -2
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-36.ucode (-2)
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-36.ucode failed with error -2
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-35.ucode (-2)
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-35.ucode failed with error -2
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-34.ucode (-2)
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-34.ucode failed with error -2
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-33.ucode (-2)
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-33.ucode failed with error -2
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-32.ucode (-2)
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-32.ucode failed with error -2
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-31.ucode (-2)
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-31.ucode failed with error -2
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-30.ucode (-2)
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-9000-pu-b0-jf-b0-30.ucode failed with error -2
ago 10 11:58:08 Delos-WW kernel: iwlwifi 0000:00:14.3: check git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
ago 10 11:58:08 Delos-WW kernel: i915 0000:00:02.0: firmware: failed to load i915/kbl_dmc_ver1_04.bin (-2)
ago 10 11:58:08 Delos-WW kernel: i915 0000:00:02.0: Direct firmware load for i915/kbl_dmc_ver1_04.bin failed with error -2
ago 10 11:58:08 Delos-WW kernel: i915 0000:00:02.0: Failed to load DMC firmware i915/kbl_dmc_ver1_04.bin. Disabling runtime power management.
ago 10 11:58:08 Delos-WW kernel: i915 0000:00:02.0: DMC firmware homepage: https://01.org/linuxgraphics/downloads/firmware
ago 10 11:58:08 Delos-WW kernel: Bluetooth: hci0: Minimum firmware build 1 week 10 2014
ago 10 11:58:08 Delos-WW kernel: bluetooth hci0: firmware: failed to load intel/ibt-17-16-1.sfi (-2)
ago 10 11:58:08 Delos-WW kernel: bluetooth hci0: Direct firmware load for intel/ibt-17-16-1.sfi failed with error -2
ago 10 11:58:08 Delos-WW kernel: Bluetooth: hci0: Failed to load Intel firmware file (-2)
ago 10 11:58:08 Delos-WW systemd[1]: Startup finished in 8.249s (firmware) + 2.580s (loader) + 2.528s (kernel) + 1.630s (userspace) = 14.989s.

Ahora si que veo el firmware que necesito.

Vie, 10/08/2018 - 10:08
Delos
Imagen de Delos
Desconectado/a
se unió: 25/07/18

Chicos he conseguido instalarlo! He desinstalado el paquete iwlwifi y he copiado el controlador específico iwlwifi-9000-pu-b0-jf-b0-34.ucode en el directorio /lib/firmware.

Muchísimas gracias a todos por haber aportado algo de vuestros conocimientos, de verdad, muy agradecido por vuestra ayuda.

Un saludo y nos vemos por el foro.

GRACIAS!

Vie, 10/08/2018 - 15:01
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

puede que iwlwifi-9000-pu-b0-jf-b0-38.ucode este en firmware-iwlwifi de buster (debian 10) y no en stretch (debian 9)

https://packages.debian.org/es/stretch/firmware-iwlwifi

https://packages.debian.org/es/buster/firmware-iwlwifi

lamentablemente stretch-backports no da información de si soporta iwlwifi-9000-pu-b0-jf-b0-38.ucode https://packages.debian.org/es/stretch-backports/firmware-iwlwifi

Dom, 12/08/2018 - 04:08
Delos
Imagen de Delos
Desconectado/a
se unió: 25/07/18

¿Y qué solución debo tomar? ¿Es necesario reparar ese error? es que el wifi ya funciona.

Al ingresar el comando journalctl me aparecen aún varios errores, estoy intentando resolverlos, por ejemplo el del bluetooth que según lo que dice no carga bien el firmware de intel.

Por último tengo un problemilla con las ventanas en general, resulta que por ejemplo cuando ejecuto Konsole se queda fija en la parte izquierda superior de la pantalla y no hay forma de moverla y si intento escribir en una aplicación mientras ejecuto Konsole se teclea todo en la terminal, impidiendome usar Konsole junto a otras aplicaciones (uso kde y antes de actualizar el kernel no me ocurría).

Gracias y si pensáis que debería abrir otro post o documentarme más decírmelo sin problema, yo ya intento solucionarlo por mi cuenta pero si podéis ayudar se agradece la verdad.

mike@Delos:~$ sudo dmesg | grep -i blue
[    2.987532] Bluetooth: Core ver 2.22
[    2.987538] Bluetooth: HCI device and connection manager initialized
[    2.987539] Bluetooth: HCI socket layer initialized
[    2.987540] Bluetooth: L2CAP socket layer initialized
[    2.987543] Bluetooth: SCO socket layer initialized
[    3.005754] Bluetooth: hci0: Bootloader revision 0.1 build 42 week 52 2015
[    3.007131] Bluetooth: hci0: Device revision is 2
[    3.007132] Bluetooth: hci0: Secure boot is enabled
[    3.007132] Bluetooth: hci0: OTP lock is enabled
[    3.007133] Bluetooth: hci0: API lock is enabled
[    3.007133] Bluetooth: hci0: Debug lock is disabled
[    3.007134] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
[    3.007275] bluetooth hci0: firmware: failed to load intel/ibt-17-16-1.sfi (-2)
[    3.007276] bluetooth hci0: Direct firmware load for intel/ibt-17-16-1.sfi failed with error -2
[    3.007278] Bluetooth: hci0: Failed to load Intel firmware file (-2)
[    3.492797] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    3.492798] Bluetooth: BNEP filters: protocol multicast
[    3.492800] Bluetooth: BNEP socket layer initialized
mike@Delos:~$ sudo journalctl -r -p err
-- Logs begin at Sun 2018-08-12 08:17:32 CEST, end at Sun 2018-08-12 08:46:59 CEST. --
ago 12 08:17:33 Delos kernel: Bluetooth: hci0: Failed to load Intel firmware file (-2)
ago 12 08:17:33 Delos kernel: bluetooth hci0: firmware: failed to load intel/ibt-17-16-1.sfi (-2)
ago 12 08:17:32 Delos avahi-daemon[647]: chroot.c: open() failed: No such file or directory
ago 12 08:17:32 Delos kernel: i915 0000:00:02.0: firmware: failed to load i915/kbl_dmc_ver1_04.bin (-2)
ago 12 08:17:32 Delos kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-35.ucode (-2)
ago 12 08:17:32 Delos kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-36.ucode (-2)
ago 12 08:17:32 Delos kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-37.ucode (-2
ago 12 08:17:32 Delos kernel: firmware_class: See https://wiki.debian.org/Firmware for information about missing firmwar
ago 12 08:17:32 Delos kernel: iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-9000-pu-b0-jf-b0-38.ucode (-2)
ago 12 08:17:32 Delos kernel: iTCO_wdt iTCO_wdt: can't request region for resource [mem 0x00c5fffc-0x00c5ffff]
ago 12 08:17:32 Delos kernel: tpm tpm0: A TPM error (378) occurred get tpm pcr allocation

 

Dom, 12/08/2018 - 05:31
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Bueno, sigue faltando tener instalado el paquete firmware-iwlwifi, ya que busca otros firmwares aparte del que usa tu tarjeta wifi.

Puedes tener ese paquete instalado y, como hiciste, copiar el firmware al mismo sitio que lo hiciste, no son incompatibles. Por lo demás, muchas veces busca firmwares que en realidad no le hacen falta. A veces trata de cargar varios para el mismo dispositivo (por ejemplo, las gráficas intel nuevas, o alguno que ya no es necesario, pero aún no se ha quitado del código). Mientras te funcione todo, no deberías hacer mucho caso a esa falta de firmware, pero si algo no te funciona, miras si es precisamente la falta de ese firmware y con el comando apt-file search ARCHIVO te dirá que paquete contiene ese ARCHIVO y así podrás instalarlo. p.e:

~$ apt-file search ibt-17-16-1.sfi
firmware-iwlwifi: /lib/firmware/intel/ibt-17-16-1.sfi

esto indica que el firmware que está buscando está en el paquete firmware-iwlwifi (ojo, igual tu no lo tienes, ya que la versión que yo uso es más nueva).

  No hay bar que por bien no venga....
Lun, 13/08/2018 - 03:59
Delos
Imagen de Delos
Desconectado/a
se unió: 25/07/18

Al final mediante unas actualizaciones que me mostró el entorno de escritorio se instalaron los drivers que me faltaban. Sin embargo, parece que persiste el problemilla de poder mover ventanas o que al ejecutar terminal tenga que cerrarla para poder escribir en otras aplicaciones.

mike@Delos:~$ sudo journalctl -r -p err
[sudo] password for mike: 
-- Logs begin at Mon 2018-08-13 08:39:17 CEST, end at Mon 2018-08-13 08:55:27 CEST. --
ago 13 08:39:18 Delos bluetoothd[684]: sap-server: Operation not permitted (1)
ago 13 08:39:18 Delos bluetoothd[684]: Sap driver initialization failed.
ago 13 08:39:18 Delos bluetoothd[684]: Failed to obtain handles for "Service Changed" characteristic
ago 13 08:39:18 Delos avahi-daemon[700]: chroot.c: open() failed: No such file or directory
ago 13 08:39:18 Delos kernel: iTCO_wdt iTCO_wdt: can't request region for resoure [mem 0x00c5fffc-0x00c5ffff]
ago 13 08:39:18 Delos kernel: tpm tpm0: A TPM error (378) occurred get tpm pcr allocation

 

Mar, 14/08/2018 - 12:13
Delos
Imagen de Delos
Desconectado/a
se unió: 25/07/18

Haciendo uso de synaptic busqué kde-window manager y descargue algunos paquetes que según la terminal debería borrar, pero sin ellos no puedo manejar las ventanas a mi antojo, así que los dejaré. Gracias a todos y que la suerte os acompañe.