IPV6 en varias interfaces a la vez: eth0, eth1 y eth2

10 envíos / 0 nuevos
Último envío
#1 Lun, 26/06/2017 - 22:37
kelvi
Imagen de kelvi
Desconectado/a
se unió: 26/06/17

IPV6 en varias interfaces a la vez: eth0, eth1 y eth2

Estado: 
[ACTIVO]

Hola a todos, 
Tengo un servidor con Debian 8, con tres tarjetas física de red. Están configuradas con ip fijas en /etc/network/interfaces. En la configuración IPV4 esta perfecta y cada interfaces (eth0, eth1 y eth2) toma la ip configurada. El problema esta cuando configuro IPV6, sólo me la toma la IPV6 fija la primera interfaces, eth0. Las otras dos interfaces solo toman la ipV6 de enlace, no global a peser que se la configuro. 
Gracias por la ayuda,

kelvi

Lun, 26/06/2017 - 23:19
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

El título no es descriptivo del problema y das muy poca información, además no explicas que escritorio usas ni informas sobre como es la configuración de interfaces ni la de esa red interna

Te recomiendo que leas las normas del foro https://exdebian.org/normas/normas-del-foro

 

En especial:

4. Escribe títulos adecuados y descriptivos

Es obligatorio escribir títulos descriptivos: debe explicar breve y concisamente sobre qué trata el mensaje completo. No se permiten asuntos como "AYUDA" o "TENGO UN PROBLEMA", dado que no informan en absoluto sobre el contenido del mensaje. No deben de estar en mayúscula. Si el asunto es explícito se facilitará la búsqueda por parte de terceros.

6. Aporta toda la información que puedas sobre tu problema

Proporciona toda la información necesaria sobre el problema en cuestión, como por ejemplo: el tipo de computadora que tienes, versión de Debian, versión del kernel, sistema de escritorio, etc. Describe los pasos que llevaste a cabo para provocar o solucionar el problema.

 

Lun, 26/06/2017 - 23:36 (Responder a #2)
kelvi
Imagen de kelvi
Desconectado/a
se unió: 26/06/17

Ok, aqui la configuracion de /etc/network/interfaces

 

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).
source /etc/network/interfaces.d/*
# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
#LAN
iface eth0 inet static
        address x.90.171.99
        netmask 255.255.252.0
        network x.90.168.0
        broadcast 159.90.171.255
        gateway x.90.168.1
iface eth0 inet6 static
        address xxxx:100:0:168:3::10
        netmask 64
        gateway xxxx:100:0:168::1
        dns-nameservers 2001:4860:4860::8888 2001:4860:4860::8844

#WLAN Libre
auto eth1
allow-hotplug eth1
iface eth1 inet static
        address x.90.175.1
        netmask 255.255.255.0
        network x.90.175.0
        broadcast x.90.175.255
        gateway x.90.171.99
iface eth1 inet6 static
        address xxxx:100:0:168:4::10
        netmask 64
        gateway XXXX:100:0:168:3::10
        dns-nameservers 2001:4860:4860::8888 2001:4860:4860::8844

#WLAN Privada
auto eth2
allow-hotplug eth2
iface eth2 inet static
        address X.90.174.1
        netmask 255.255.255.0
        network X.90.174.0
        broadcast X.90.174.255
        gateway X.90.171.99
iface eth2 inet6 static
        address xxxx:100:0:168:5::10
        netmask 64
        gateway xxxx:100:0:168:3::10
        dns-nameservers 2001:4860:4860::8888 2001:4860:4860::8844

Lun, 26/06/2017 - 23:36
kelvi
Imagen de kelvi
Desconectado/a
se unió: 26/06/17

La x en las dirección es por seguridad. 

Mar, 27/06/2017 - 12:20
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

Por lo que entiendo estas armando una red estática y la funcion allow-hotplug eth0 eth1 eth2 es para redes dhcp
fuentes:

Mar, 27/06/2017 - 22:38
kelvi
Imagen de kelvi
Desconectado/a
se unió: 26/06/17

Hola Rocky, no la linea de comando allow-hotplug es para

 

allow-hotplug ethX: Permite la conexión y desconexión “en caliente” (Sin apagar la máquina) de la interfaz de red ehtX. 

De todos modos comento la linea en las tres eth, reinicio y da igual.  También, no es que este haciendo una red estática sino que el servidor que estoy montando posee tres tarjetas de red por supuesto de forma estática. 

Tambien, añadir las siguientes líneas a /etc/sysctl.conf:
net.ipv6.conf.all.disable_ipv6 = 0
net.ipv6.conf.default.disable_ipv6 = 0
net.ipv6.conf.lo.disable_ipv6 = 0
net.ipv6.conf.eth0.disable_ipv6 = 0
net.ipv6.conf.eth1.disable_ipv6 = 0

net.ipv6.conf.eth2.disable_ipv6 = 0

Igual, antes de después de cambiar sysctl.conf da el mismo resultado. 

Saludos,

 

Mié, 28/06/2017 - 12:49
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Bien,quizá debieras explicar en modo simple que intentas implementar y que resultados obtener.

Por lo que se ve en tu configuracion   la subred de eth0  sale por una determinada puerta de enlace ( router ? ,hacia internet? ) , y las otras  eth1 y eth2  ,estan enrutadas mediante  eth0 , (supongo que es lo que intentas lograr ) 

En principio  y respecto a cada interfaz de red , que te devuelve ( respecto a ipv6 ) 

ifconfig  ethx 
## o usando  ip
ip -6 addr show dev ethx

Para algunas arquitecturas  debe utilizarse un modulo ,en algunos casos se incluye en la configuracion 

pre-up modprobe ipv6

 

Mié, 28/06/2017 - 14:03 (Responder a #7)
kelvi
Imagen de kelvi
Desconectado/a
se unió: 26/06/17

Se me habia pasado anexar ifconfig, aqui lo anexo, las XXX son por confidencialidad, en realidad son numero

root@tesis1:/home/piloto# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:23:ae:70:4d:b7
          inet addr:XXX.90.171.99  Bcast:159.90.171.255  Mask:255.255.252.0
          inet6 addr: XXXX:100:0:168:3::10/64 Scope:Global
          inet6 addr: fe80::223:aeff:fe70:4db7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:83508 errors:0 dropped:409 overruns:0 frame:0
          TX packets:73524 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:12569484 (11.9 MiB)  TX bytes:10729616 (10.2 MiB)
          Interrupt:21 Memory:fe6e0000-fe700000

eth1      Link encap:Ethernet  HWaddr 18:a6:f7:01:85:ea
          inet addr:XXX.90.175.1  Bcast:159.90.175.255  Mask:255.255.255.0
          inet6 addr: fe80::1aa6:f7ff:fe01:85ea/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:204 errors:0 dropped:0 overruns:0 frame:0
          TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:31753 (31.0 KiB)  TX bytes:9634 (9.4 KiB)

eth2      Link encap:Ethernet  HWaddr ec:08:6b:06:30:f7
          inet addr:XXX.90.174.1  Bcast:159.90.174.255  Mask:255.255.255.0
          inet6 addr: fe80::ee08:6bff:fe06:30f7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:182 errors:0 dropped:0 overruns:0 frame:0
          TX packets:74 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:25297 (24.7 KiB)  TX bytes:9910 (9.6 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:35 errors:0 dropped:0 overruns:0 frame:0
          TX packets:35 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3781 (3.6 KiB)  TX bytes:3781 (3.6 KiB)

 

Mié, 28/06/2017 - 15:09
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Bien te he editado para mejor comprension ,cuando pongas código o indicaciones fuera de tu texto usa el icono que dice " insertar fragmento de codigo >> bash "

Como seguís sin indicar que pretendes hacer, quizá el siguiente enlace te aclare un poco el asunto 

https://www.jumpingbean.co.za/blogs/mark/set-up-ipv6-lan-with-linux

Por cierto ,los numeros que faltan ,no representan en realidad un riesgo si los mostras, francamente ,,,,, 

Mié, 28/06/2017 - 17:01 (Responder a #9)
kelvi
Imagen de kelvi
Desconectado/a
se unió: 26/06/17

Hola Caliban,

Lo que deseo hacer es un simple servidor con 3 tarjetas de red, con ip fijas, como todo servidor. El servidor es con debian 8 y la interface eth0 es para salir a internet. Las otras dos son para conexiones internas, dos LAN. El gateway de las dos LAN (eth1 y eth2) es eth0. Esta habilitada el reenvio en ipv4 y ipv6 entre las eth en sysctl.conf. En ipv4 funciona bien y en internet hay bastante documentación al respecto. El problema esta en IPV6, que sólo toma la dirección fija en eth0 y en las otras dos (eth1 y eth2) no las toma a pesar de que la configuro. El servidor tiene que tener doble pila, IPV4 y IPV6, ya que estoy haciendo una tesis la cual es una implementación  de IPV6 en una red IPV4 ya existente. El servidor no instale desde cero, y las tarjetas las reconoce bien.

saludos