kodi

30 envíos / 0 nuevos
Último envío
#1 Vie, 07/09/2018 - 07:29
gi0
Imagen de gi0
Desconectado/a
se unió: 07/09/18

kodi

Estado: 
[SOLUCIONADO]

Hola compañeros mi duda es que tengo debian wheezy 7.11 y me gustaria saber la forma mas segura para instalarlo y que funcione correctamente (para manazas). he probado alguna ppa pero tras hacer update da fallos de not found y cosas asi.

Vie, 07/09/2018 - 10:16
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Hola, Asumo que lo estas instalando kodi desde los repos https://launchpad.net/~team-xbmc/+archive/ubuntu/ppa y que por lo que decís de  "...he probado alguna ppa pero tras hacer update da fallos de not found y cosas asi..." te tunciona hasta que realizas un upgrade de debian. En ese caso te sugeriría que los apuntes a precise (ubuntu 12.04) que creo que emplea la misma versión del kernel de debian 7, puede que eso ayude en el sentido que estan compilados para una versión similar a la de debian.
Si usas kodi 17 puedes probar la versión 16 que mucha gente sigue usando y dicen que es mucho mas estable https://launchpad.net/~team-xbmc/+archive/ubuntu/kodi-old

Kodi aparece oficialmente en los repositorios de Debian, en los backports de jessie asi que la otra opción que podes emplear es agregar a tus repos de wheezy los de jessie y jessie-backports y realizar la instalación desde debian o actualizar tu debian a jessie.

https://kodi.wiki/view/Installing_XBMC_for_Linux

 

 

Vie, 07/09/2018 - 11:12
gi0
Imagen de gi0
Desconectado/a
se unió: 07/09/18

buenas rocky he probado con esto add-apt-repository ppa:team-xbmc/ppa y creo que este  ppa:heyarje/libav-11 ahora que lo veo diria que alomejor este era para el tema de livabcodec que tb me ha dado problemas hasta que cambie la configuracion de firefox media.livacodec de false a true en about:config.  Mi kernel: Linux debian 3.2.0-4-686-pae #1 SMP Debian 3.2.78-1 i686 GNU/Linux. Seria posible actualizar a jessie conservando el gnome 3 o enviromen ( no se bien como se dice) tengo miedo de actualizar y que no me funcione bien la maquina. gracias por tu respuesta

Vie, 07/09/2018 - 11:54
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

no nos estamos entendiendo. Lo que te estoy sugiriendo es que el repositorio ppa:team-xbmc/ppa lo apuntes a precise para que la copilación de los paquetes coincidan a una versión "similar" a la de tu debian de lo contrario te vas a encontrar, muy seguramente, con conflictos de versiones de dependencias, o que necesite paquetes que no estan para esa versión de debian. 

tu /etc/apt/sources.list o tu /etc/apt/sources.list.d/kodi debería estar asi:

deb http://ppa.launchpad.net/team-xbmc/ppa/ubuntu precise main 
deb-src http://ppa.launchpad.net/team-xbmc/ppa/ubuntu precise main 

prueba esto y luego nos cuentas

Sobre el tema de mezclar repositorios de distintas versiones de debian te recomiendo la lectura de: https://exdebian.org/wiki/sistemas-mixtos-apt-pinning
En tu caso lo mejor es que al crear /etc/apt/apt.conf.d/local pongas  APT::Default-Release "wheezy";

sobre el tema de ppa:heyarje/libav-11 no entiendo bien para que lo instalas y/o quien lo necesita kodi o frefox. hasta me inclinaría a pensar que es ese paquete el que te esta causando el problema. Lo mejor seria que purgues todo lo que tengas instalado de kodi y elimines ese repositorio de ppa:heyarje/libav-11 (al quitar el repositorio en synaptic podes ver los paquetes que se instalaron de libav-11 en la parte locales u obsoletos) con las teclas CTRL+e trata de desactualizarlos a la versión de wheezy

 

Vie, 07/09/2018 - 18:32
gi0
Imagen de gi0
Desconectado/a
se unió: 07/09/18

 

Gracias por responder

probe con esos repositorios y esto es lo que me muestra la terminal.

root@debian:/home/gi0# nano /etc/apt/sources.list
root@debian:/home/gi0# apt-get update
Des:1 http://ppa.launchpad.net precise Release.gpg [316 B]
Obj http://ftp.debian.org wheezy-updates Release.gpg                        
Obj http://ftp.debian.org wheezy Release.gpg                                
Des:2 http://ppa.launchpad.net precise Release [12,9 kB]                    
Obj http://security.debian.org wheezy/updates Release.gpg                   
Obj http://ftp.debian.org wheezy-updates Release                            
Obj http://ftp.debian.org wheezy Release                                    
Obj http://security.debian.org wheezy/updates Release                       
Obj http://ftp.debian.org wheezy-updates/main Sources                       
Des:3 http://ppa.launchpad.net precise/main Sources [8.278 B]               
Obj http://security.debian.org wheezy/updates/main Sources                  
Obj http://ftp.debian.org wheezy-updates/contrib Sources                    
Obj http://http.debian.net wheezy-backports Release.gpg                     
Obj http://ftp.debian.org wheezy-updates/main i386 Packages/DiffIndex       
Obj http://security.debian.org wheezy/updates/contrib Sources               
Obj http://ftp.debian.org wheezy-updates/contrib i386 Packages              
Obj http://ftp.debian.org wheezy-updates/contrib Translation-en             
Obj http://security.debian.org wheezy/updates/main i386 Packages            
Obj http://ftp.debian.org wheezy-updates/main Translation-en/DiffIndex      
Obj http://security.debian.org wheezy/updates/contrib i386 Packages         
Obj http://ftp.debian.org wheezy/main Sources                               
Obj http://http.debian.net wheezy-backports Release                         
Obj http://security.debian.org wheezy/updates/contrib Translation-en        
Obj http://ftp.debian.org wheezy/main i386 Packages                         
Obj http://ftp.debian.org wheezy/main Translation-es                        
Obj http://security.debian.org wheezy/updates/main Translation-en           
Obj http://ftp.debian.org wheezy/main Translation-en                        
Des:4 http://ppa.launchpad.net precise/main i386 Packages [15,0 kB]         
Obj http://http.debian.net wheezy-backports/main i386 Packages/DiffIndex    
Obj http://http.debian.net wheezy-backports/main Translation-en/DiffIndex   
Des:5 http://ppa.launchpad.net precise/main Translation-en [6.782 B]
Descargados 43,3 kB en 5seg. (8.486 B/s)                     
Leyendo lista de paquetes... Hecho
root@debian:/home/gi0# apt-get install kodi
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 kodi : Depende: kodi-bin (>= 2:14.2~git20150327.1058-final-0precise) pero no va a instalarse
        Depende: kodi-bin (< 2:14.2~git20150327.1058-final-0precise.1~) pero no va a instalarse
        Depende: libafpclient0 pero no es instalable
        Depende: libshairport2 pero no es instalable o
                 libshairport1 pero no va a instalarse
        Depende: libshairplay0 pero no va a instalarse
        Depende: libcec2 (>= 2.1.1)
        Recomienda: libvdpau1 pero no va a instalarse
        Recomienda: libva-intel-vaapi-driver
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

 

Vie, 07/09/2018 - 19:10
gi0
Imagen de gi0
Desconectado/a
se unió: 07/09/18

a continuacion intente esto otro:

root@debian:/home/gi0#  apt-get autoremove
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
0 actualizados, 0 se instalarán, 0 para eliminar y 290 no actualizados.

root@debian:/home/gi0# apt-get autoclean
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Del flashplugin-nonfree 1:3.2+wheezy1 [18,3 kB]

root@debian:/home/gi0# apt-get -f install
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
0 actualizados, 0 se instalarán, 0 para eliminar y 290 no actualizados.

otro apt-get update mas pero con los repositorios multimedia que antes estaban desactivados ...

y apt.get install kodi con identico resultado al anterior post

Vie, 07/09/2018 - 19:56
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Por lo que veo te estan faltando paquetes que necesita kodi y que no estan en tus repos de debian 7, si queres, te puedo hacer una pequeña guia de como configurar un sistema "mixto"  o semi "mixto" y ver de instalar kodi desde el repositorio de debian 8 backport. 

Antes de iniciar necesitaría la siguiente info:

cat /etc/apt/sources.list
ls -l /etc/apt/sources.list.d/

 

Vie, 07/09/2018 - 20:44
gi0
Imagen de gi0
Desconectado/a
se unió: 07/09/18

los repos que tengo sin comentar en /etc/apt/sources.list

deb http://ftp.debian.org/debian/ wheezy-updates main contrib
deb-src http://ftp.debian.org/debian/ wheezy-updates main contrib

deb ftp://ftp.deb-multimedia.org wheezy main non-free
deb-src ftp://ftp.deb-multimedia.org wheezy main non-free

deb http://http.debian.net/debian wheezy-backports main
deb http://ftp.debian.org/debian/ wheezy main
deb-src http://ftp.debian.org/debian/ wheezy main
deb http://ppa.launchpad.net/team-xbmc/ppa/ubuntu precise main
deb-src http://ppa.launchpad.net/team-xbmc/ppa/ubuntu precise main

 ls -l /etc/apt/sources.list.d/

-rw-r--r-- 1 root root  0 sep  5 22:55 heyarje-libav-11-wheezy.listy el
-rw-r--r-- 1 root root 69 sep  5 22:55 heyarje-libav-11-wheezy.list.save
-rw-r--r-- 1 root root  0 sep  6 02:09 team-xbmc-ppa-wheezy.list
-rw-r--r-- 1 root root 66 sep  6 02:09 team-xbmc-ppa-wheezy.list.save
-rw-r--r-- 1 root root  0 sep  5 22:13 videolan-stable-daily-wheezy.list
-rw-r--r-- 1 root root 74 sep  5 22:13 videolan-stable-daily-wheezy.list.save

 

Vie, 07/09/2018 - 20:51
gi0
Imagen de gi0
Desconectado/a
se unió: 07/09/18

curioso estos -ls -l /etc/apt/sources,list.d/ pues utilice : #radd-apt-repository --remove  ppa:heyarje/libav-11  pensando que asi los borraba :O no entiendo

Vie, 07/09/2018 - 23:18
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

A los archivos /etc/apt/sources.list.d/ ponele un # adelante por ejemplo
 

#deb http://ppa.launchpad.net/team-xbmc/ppa/ubuntu precise main

o sino directamente elimina cada archivo, por ejemplo:

su
rm  /etc/apt/sources.list/team-xbmc-ppa-wheezy.list
rm  /etc/apt/sources.list/team-xbmc-ppa-wheezy.list.save
rm  /etc/apt/sources.list/heyarje-libav-11-wheezy.list
rm  /etc/apt/sources.list/heyarje-libav-11-wheezy.list.save

en tu sources.list

su
nano /etc/apt/sources.list

y pone

#Debian wheezy
deb http://ftp.debian.org/debian/ wheezy main contrib non-free
deb-src http://ftp.debian.org/debian/ wheezy main contrib non-free


deb http://http.debian.net/debian wheezy-backports main

#deb-multimedia
deb ftp://ftp.deb-multimedia.org wheezy main non-free
deb-src ftp://ftp.deb-multimedia.org wheezy main non-free

#Debian jessie
deb http://ftp.debian.org/debian/ jessie main contrib non-free
deb http://http.debian.net/debian jessie-backports main

luego crea el archivo

su
nano /etc/apt/apt.conf.d/local

con el siguiente texto

APT::Default-Release "wheezy";
APT::Cache-Limit 55000000;
APT::Get::Purge;
APT::Clean-Installed;
APT::Get::Fix-Broken;
APT::Get::Fix-Missing;
APT::Get::Show-Upgraded "true";

Luego actualizas e instalas kodi de jeesie-backports

su
apt update && apt upgrade
aptitude -t jessie-backports kodi

* te puse aptitude para instalar kodi porque puede ser util con sus opciones en caso de tener que resolver alguna dependencia.

El sistema te va a quedar apuntando a wheezy pero vas a poder instalar alguno que otro programa de jessie
PD: podrias instalar debian 9 con xfce4 o mate
saludos...

Sáb, 08/09/2018 - 07:27
gi0
Imagen de gi0
Desconectado/a
se unió: 07/09/18
root@debian:/etc/apt/sources.list.d# rm *.list
root@debian:/etc/apt/sources.list.d# ls
heyarje-libav-11-wheezy.list.save  videolan-stable-daily-wheezy.list.save
team-xbmc-ppa-wheezy.list.save

root@debian:/etc/apt/sources.list.d# rm *.save
rm: no se puede borrar «*.save»: No existe el fichero o el directorio

root@debian:/etc/apt/sources.list.d# ls -l

total 0 ( raro lo de no se puede borrar y que se borren igual)

el sources.list con los  repositorios que me distes

aqui cambie apt update y apt upgrade por apt-get update y apt-et upgrade (no encontraba orden apt) y un largo proceso con descargas, desempaquetados, borrados, añadidos etc .. (todo sin ningun fallo a mi vista)

root@debian:/etc/apt/sources.list.d# aptitude -t jessie-backports kodi
Orden desconocida "kodi"
aptitude 0.6.8.2
Modo de uso: aptitude [-S nombre_fichero] [-u|-i]
       aptitude [opciones] <acción> ...
  Acciones (si no se especifica ninguna, aptitude entrará en modo interactivo):

 install      -  Instala/actualiza paquetes.
 remove       -  Elimina paquetes.
 purge        - Elimina paquetes junto con sus ficheros de configuración.
 hold         - Bloquea paquetes.
 unhold       - Desbloquea un paquete.
 markauto     - Marca paquetes como instalados manualmente.
 unmarkauto   - Desmarca paquetes como instalados manualmente.
 forbid-version - prohíbe a aptitude actualizar a una versión específica de un paquete.
 update       - Descarga las listas de paquetes nuevos/actualizables.
 safe-upgrade - Realiza una actualización segura.
 full-upgrade - Realiza una actualización, posiblemente instalando
                y eliminando paquetes.
 build-dep    - Install the build-dependencies of packages.
 forget-new   - Olvida qué paquetes son "nuevos".
 search       - Busca un paquete por nombre y/o expresión.
 show         - Muestra información detallada de un paquete.
 versions     - Displays the versions of specified packages.
 clean        - Elimina los ficheros de paquetes descargados.
 autoclean    - Elimina los ficheros de paquetes descargados obsoletos.
 changelog    - Muestra el registro de cambios del paquete.
 download     - Descarga los ficheros .deb para un paquete.
 reinstall    - Descarga y (posiblemente) reinstala un paquete ya instalado.
 why         - Muestra los paquetes manualmente instalados que necesitan un paquete
               o por qué uno de los paquetes necesita un paquete concreto.

 why-not      - Mostrar los paquetes manualmente instalados que llevan a un
                conflicto con un paquete determinado, o por qué si se isntalaran
                uno o más paquetes llevarían a un conflicto con dicho paquete.

  Opciones:
-h              Este texto de ayuda.
 --no-gui          No use la interfaz GTK aunque este disponible.
-s              Simula las acciones, pero en realidad no las realiza.
-d              Sólo descarga paquetes, no instala o desinstala nada.
-p              Siempre pide confirmación de las acciones.
-y              Supone que la respuesta a preguntas simples del tipo sí/no es «sí».
-F formato      Especifica el formato para mostrar los resultados de las
                búsquedas, lea el manual.
-O orden        Especifica como se deben ordenar los resultados de la búsqueda,
                lea el manual.
-w ancho        Especifica el ancho del visor para dar formato a los resultado
                de la búsqueda.
-f              Trata de arreglar paquetes rotos de forma agresiva.
-V              Muestra la versión de los paquetes a instalar.
-D              Muestra las dependencias de los paquetes cambiados automáticamente.
-Z            Muestra el cambio del tamaño instalado de cada paquete.
-v              Muestra información extra (puede darse más de una vez).
-t [distrib]    Establece la distribución desde la que se instalan los paquetes.
 -q             No muestra los indicadores de progreso incrementales
                en el modo de línea de órdenes.
 -o opconf=val     Establecer directamente la opción de configuración llamada «opconf».
 --with(out)-recommends,    Especifica si se tratan o no las
                recomendaciones como dependencias fuertes.
-S fnombre: lee la información de estado extendida de aptitude de fnombre.
-u       : Descarga una nueva lista de paquetes al arrancar.
                  (terminal interface only)
-i       : Realiza una instalación al arrancar.
                  (terminal interface only)

                  Este aptitude no tiene poderes de Super Vaca.

 

de todas formas parece que va bien la cosa pero esto de super vaca me deja a cuadros.Se me ocurre probar aptitude -t jessie-backport install kodi pero ni idea.

 

Sáb, 08/09/2018 - 07:36
gi0
Imagen de gi0
Desconectado/a
se unió: 07/09/18
root@debian:/etc/apt/sources.list.d# aptitude -t jessie-backports install kodi
Se instalarán los siguiente paquetes NUEVOS:      
  cgmanager{a} cups-browsed{a} cups-core-drivers{a} cups-daemon{a}
  cups-filters-core-drivers{a} cups-server-common{a} fonts-dejavu-core{a}
  fonts-roboto{a} gcc-4.9-base{ab} gdisk{a} init-system-helpers{a} iproute2{a}
  javascript-common{a} kodi kodi-bin{a} kodi-data{a}
  kodi-visualization-spectrum{a} libalgorithm-c3-perl{a} libapparmor1{a}
  libarchive-extract-perl{a} libasound2-data{a} libass5{a} libatm1{a}
  libatomic1{a} libaudit-common{ab} libaudit1{a} libavcodec57{a} libavfilter6{a}
  libavformat57{a} libavresample3{a} libavutil55{a} libbs2b0{a} libcec3v4{a}
  libcgi-fast-perl{a} libcgi-pm-perl{a} libcgmanager0{a} libchromaprint1{a}
  libclass-c3-perl{a} libclass-c3-xs-perl{a} libcpan-meta-perl{a}
  libcrossguid0v4{a} libdata-optlist-perl{a} libdata-section-perl{a} libdb5.3{a}
  libegl1-mesa{a} libfcgi-perl{a} libffi6{a} libfftw3-double3{a}
  libfftw3-long3{a} libfftw3-single3{a} libfontembed1{a} libgbm1{a}
  libgcrypt20{a} libglew1.10{a} libgnutls-deb0-28{a} libgraphite2-3{a}
  libharfbuzz0b{a} libhogweed2{a} libjim0.75{a} libjpeg62-turbo{a}
  libjs-iscroll{a} libjs-jquery{a} libldb1{a} liblog-message-perl{a}
  liblog-message-simple-perl{a} liblzo2-2{a} libmicrohttpd10{a}
  libmodule-build-perl{a} libmodule-pluggable-perl{a} libmodule-signature-perl{a}
  libmro-compat-perl{a} libnfs4{a} libnih-dbus1{a} libnih1{a} libntdb1{a}
  libnuma1{a} libopencv-core2.4{a} libopencv-imgproc2.4{a} libopenjp2-7{a}
  libopenjpeg5{a} libp8-platform2v4{a} libpackage-constants-perl{a}
  libpam-systemd{a} libparams-util-perl{a} libparted2{a} libpcrecpp0{a}
  libpgm-5.1-0{a} libplist2{a} libpod-latex-perl{a} libpod-readme-perl{a}
  libpoppler46{a} libpostproc54{a} libproxy1{a} libpython-stdlib{a}
  libpython2.7-minimal{a} libpython2.7-stdlib{a} libqpdf13{a}
  libregexp-common-perl{a} librtmp1{a} librubberband2{a} libsdl2-2.0-0{a}
  libseccomp2{a} libshine3{a} libsmartcols1{a} libsnappy1{a} libsodium13{a}
  libsoftware-license-perl{a} libsoxr0{a} libssh-4{a} libssh-gcrypt-4{a}
  libsub-exporter-perl{a} libsub-install-perl{a} libswresample2{a} libswscale4{a}
  libsystemd0{a} libtasn1-6{a} libterm-ui-perl{a} libtevent0{a}
  libtext-soundex-perl{a} libtext-template-perl{a} libtiff5{a} libtinyxml2.6.2{a}
  libudev1{a} libudisks2-0{a} libva-drm1{a} libvdpau1{a} libwayland-client0{a}
  libwayland-cursor0{a} libwayland-egl1-mesa{a} libwayland-server0{a} libwebp5{a}
  libx264-142{a} libx265-87{a} libxcb-dri3-0{a} libxcb-present0{a}
  libxcb-sync1{a} libxkbcommon0{a} libxshmfence1{a} libxtables10{a} libzmq3{a}
  parted{a} python-crypto{a} python-ldb{a} python-ntdb{a} python-samba{a}
  python-talloc{a} python-tdb{a} qpdf{a} rename{a} samba-libs{a} systemd{a}
  systemd-shim{a} udisks2{a}
Se ELIMINARÁN los siguientes paquetes:
  aptdaemon{u} libgssglue1{u} libjim0debian2{u} libslp1{u} python-aptdaemon{u}
  python-defer{u} python-pkg-resources{u}
Se actualizarán los siguientes paquetes:
  alsa-base avahi-daemon bash-completion cli-common consolekit cups cups-bsd
  cups-client cups-common cups-filters{b} cups-ppdc dmsetup dpkg fontconfig
  fontconfig-config gir1.2-glib-2.0 glib-networking glib-networking-common
  glib-networking-services ifupdown install-info iproute iptables kmod libasound2
  libblkid1 libbluray1 libbsd0 libc-bin libc6 libck-connector0 libcups2
  libcupsfilters1 libdevmapper1.02.1 libdrm2 libfftw3-3 libflac8 libflite1
  libfontconfig1 libgirepository-1.0-1 libglib2.0-0{b} libgmp10 libgomp1
  libgpg-error0 libgssapi-krb5-2 libio-socket-ip-perl libk5crypto3 libkeyutils1
  libkmod2 libkrb5-3 libkrb5support0 libmount1 libmpeg2-4 libnettle4 libp11-kit0
  libpcre3 libpipeline1 libselinux1 libsmbclient libsocket-perl libstdc++6
  libtag1-vanilla libtag1c2a libtalloc2 libtdb1 libtirpc1 libva1 libwbclient0
  libxcb1 locales man-db mount perl perl-base perl-modules python python-gi
  python-minimal python2.7 python2.7-minimal samba-common samba-common-bin
  ttf-dejavu-core udev usb-modeswitch usb-modeswitch-data util-linux
Se RECOMIENDAN los siguientes paquetes, pero NO se instalarán:
  i965-va-driver libfglrx-amdxvba1 mesa-va-drivers va-driver-all vdpau-va-driver
  xvba-va-driver
87 paquetes actualizados, 153 nuevos instalados, 7 para eliminar y 1310 sin actualizar.
Necesito descargar 109 MB de ficheros. Después de desempaquetar se usarán 150 MB.
No se satisfacen las dependencias de los siguientes paquetes:
 libpurple0 : Depende: perlapi-5.14.2 que es un paquete virtual.
 libglib-perl : Depende: perlapi-5.14.2 que es un paquete virtual.
 libpango-perl : Depende: perlapi-5.14.2 que es un paquete virtual.
 python-aptdaemon.gtk3widgets : Depende: python-aptdaemon (= 0.45-2+deb7u1) pero no será instalado.
 gcc-4.9-base : Rompe: gcc-4.7-base (< 4.7.3) pero está instalado 4.7.2-5.
 libglib2.0-bin : Depende: libglib2.0-0 (= 2.33.12+really2.32.4-5) pero se va a instalar 2.48.0-1~bpo8+1.
 libcupscgi1 : Depende: libcups2 (= 1.5.3-5+deb7u8) pero se va a instalar 2.2.1-8+deb9u1~bpo8+1.
 lsof : Depende: libperl4-corelibs-perl pero no será instalado. o
                 perl (< 5.12.3-7) pero se va a instalar 5.20.2-3+deb8u11.
 smbclient : Depende: samba-common (= 2:3.6.6-6+deb7u16) pero se va a instalar 2:4.2.14+dfsg-0+deb8u9.
 libnet-ssleay-perl : Depende: perlapi-5.14.2 que es un paquete virtual.
 liblocale-gettext-perl : PreDepende: perlapi-5.14.2 que es un paquete virtual.
 libfile-fcntllock-perl : Depende: perlapi-5.14.2 que es un paquete virtual.
 libalgorithm-diff-xs-perl : Depende: perlapi-5.14.2 que es un paquete virtual.
 libcupsmime1 : Depende: libcups2 (= 1.5.3-5+deb7u8) pero se va a instalar 2.2.1-8+deb9u1~bpo8+1.
 libc-dev-bin : Depende: libc6 (< 2.14) pero se va a instalar 2.19-18+deb8u10.
 libhtml-parser-perl : Depende: perlapi-5.14.2 que es un paquete virtual.
 cups-filters : Entra en conflicto: foomatic-filters pero 4.0.17-1+deb7u1 está instalado y retenido.
                Entra en conflicto: ghostscript-cups pero está instalado 9.05~dfsg-6.3+deb7u8.
 libtext-charwidth-perl : Depende: perlapi-5.14.2 que es un paquete virtual.
 python-gi-cairo : Depende: python-gi (= 3.2.2-2) pero se va a instalar 3.14.0-1.
 libxml-parser-perl : Depende: perlapi-5.14.2 que es un paquete virtual.
 libaudit-common : Rompe: libaudit0 pero está instalado 1:1.7.18-1.1.
 util-linux-locales : Depende: util-linux (< 2.20.1.0-0) pero se va a instalar 2.25.2-6.
 libc6-i686 : PreDepende: libc6 (= 2.13-38+deb7u12) pero se va a instalar 2.19-18+deb8u10.
 libcupsppdc1 : Depende: libcups2 (= 1.5.3-5+deb7u8) pero se va a instalar 2.2.1-8+deb9u1~bpo8+1.
 gir1.2-freedesktop : Depende: gir1.2-glib-2.0 (= 1.32.1-1) pero se va a instalar 1.42.0-2.2.
 libnet-dbus-perl : Depende: perlapi-5.14.2 que es un paquete virtual.
 libgtk2-perl : Depende: perlapi-5.14.2 que es un paquete virtual.
 libpython2.7 : Depende: python2.7 (= 2.7.3-6+deb7u4) pero se va a instalar 2.7.9-2+deb8u1.
 libuuid-perl : Depende: perlapi-5.14.2 que es un paquete virtual.
 libcupsdriver1 : Depende: libcups2 (= 1.5.3-5+deb7u8) pero se va a instalar 2.2.1-8+deb9u1~bpo8+1.
 libtext-iconv-perl : Depende: perlapi-5.14.2 que es un paquete virtual.
 libperl5.14 : Depende: perl-base (= 5.14.2-21+deb7u6) pero se va a instalar 5.20.2-3+deb8u11.
 libpam-ck-connector : Depende: libck-connector0 (= 0.4.5-3.1) pero se va a instalar 0.4.6-5.
 libc6-dev : Depende: libc6 (= 2.13-38+deb7u12) pero se va a instalar 2.19-18+deb8u10.
 libglib2.0-0 : Rompe: libgnome-desktop-3-2 (< 3.4.2-2) pero está instalado 3.4.2-1.
 libcupsimage2 : Depende: libcups2 (= 1.5.3-5+deb7u8) pero se va a instalar 2.2.1-8+deb9u1~bpo8+1.
 pidgin : Depende: perlapi-5.14.2 que es un paquete virtual.
 libcairo-perl : Depende: perlapi-5.14.2 que es un paquete virtual.
 libxcb1-dev : Depende: libxcb1 (= 1.8.1-2+deb7u1) pero se va a instalar 1.10-3+b1.
 perlmagick : Depende: perlapi-5.14.2 que es un paquete virtual.
abierto: 971; cerrado: 3293; diferido: 501; conflicto: 632                           .Las acciones siguientes resolverán estas dependencias

       Eliminar los paquetes siguientes:                                              
1)       caribou                                                                      
2)       caribou-antler                                                               
3)       cheese                                                                       
4)       colord                                                                       
5)       consolekit                                                                   
6)       cpp-4.7                                                                      
7)       cups                                                                         
8)       cups-filters                                                                 
9)       empathy                                                                      
10)      evolution                                                                    
11)      evolution-data-server                                                        
12)      evolution-plugins                                                            
13)      g++-4.7                                                                      
14)      gcc-4.7                                                                      
15)      gcc-4.7-base                                                                 
16)      gdm3                                                                         
17)      gir1.2-goa-1.0                                                               
18)      gir1.2-javascriptcoregtk-3.0                                                 
19)      gir1.2-rb-3.0                                                                
20)      gir1.2-webkit-3.0                                                            
21)      gnome                                                                        
22)      gnome-applets                                                                
23)      gnome-bluetooth                                                              
24)      gnome-color-manager                                                          
25)      gnome-contacts                                                               
26)      gnome-control-center                                                         
27)      gnome-core                                                                   
28)      gnome-documents                                                              
29)      gnome-online-accounts                                                        
30)      gnome-orca                                                                   
31)      gnome-packagekit                                                             
32)      gnome-panel                                                                  
33)      gnome-power-manager                                                          
34)      gnome-screensaver                                                            
35)      gnome-session                                                                
36)      gnome-session-fallback                                                       
37)      gnome-settings-daemon                                                        
38)      gnome-shell                                                                  
39)      gnome-shell-extensions                                                       
40)      gnome-sushi                                                                  
41)      gnome-system-log                                                             
42)      gnome-user-guide                                                             
43)      gnome-user-share                                                             
44)      hplip                                                                        
45)      libcanberra-pulse                                                            
46)      libcupsdriver1                                                               
47)      libedata-book-1.2-13                                                         
48)      libevolution                                                                 
49)      libfolks-eds25                                                               
50)      libgail-common                                                               
51)      libglib2.0-bin                                                               
52)      libgnome-desktop-3-2                                                         
53)      libgoa-1.0-0                                                                 
54)      librhythmbox-core6                                                           
55)      libstdc++6-4.7-dev                                                           
56)      libwebkitgtk-1.0-0                                                           
57)      libwebkitgtk-3.0-0                                                           
58)      libyelp0                                                                     
59)      metacity                                                                     
60)      nautilus                                                                     
61)      nautilus-sendto                                                              
62)      nautilus-sendto-empathy                                                      
63)      packagekit                                                                   
64)      packagekit-tools                                                             
65)      policykit-1                                                                  
66)      policykit-1-gnome                                                            
67)      printer-driver-gutenprint                                                    
68)      printer-driver-hpcups                                                        
69)      printer-driver-postscript-hp                                                 
70)      printer-driver-splix                                                         
71)      pulseaudio                                                                   
72)      pulseaudio-module-x11                                                        
73)      python-aptdaemon.gtk3widgets                                                 
74)      python-pyatspi                                                               
75)      python-pyatspi2                                                              
76)      rhythmbox                                                                    
77)      rhythmbox-plugin-cdrecorder                                                  
78)      rhythmbox-plugins                                                            
79)      shotwell                                                                     
80)      smbclient                                                                    
81)      software-properties-gtk                                                      
82)      task-gnome-desktop                                                           
83)      task-print-server                                                            
84)      yelp                                                                         
85)      zenity                                                                       

       Instalar los paquetes siguientes:                                              
86)      adwaita-icon-theme [3.14.0-2 (oldstable)]                                    
87)      cpp-4.9 [4.9.2-10+deb8u1 (oldstable)]                                        
88)      g++-4.9 [4.9.2-10+deb8u1 (oldstable)]                                        
89)      gcc-4.9 [4.9.2-10+deb8u1 (oldstable)]                                        
90)      gtk2-engines-pixbuf [2.24.25-3+deb8u2 (oldstable)]                           
91)      libasan1 [4.9.2-10+deb8u1 (oldstable)]                                       
92)      libcilkrts5 [4.9.2-10+deb8u1 (oldstable)]                                    
93)      libcloog-isl4 [0.18.2-1+b2 (oldstable)]                                      
94)      libcolord2 [1.2.1-1+b2 (oldstable)]                                          
95)      libgcc-4.9-dev [4.9.2-10+deb8u1 (oldstable)]                                 
96)      libgnome-desktop-3-10 [3.14.1-1 (oldstable)]                                 
97)      libisl10 [0.12.2-2 (oldstable)]                                              
98)      libmpc3 [1.0.2-1 (oldstable)]                                                
99)      libpango-1.0-0 [1.36.8-3 (oldstable)]                                        
100)     libpangocairo-1.0-0 [1.36.8-3 (oldstable)]                                   
101)     libpangoft2-1.0-0 [1.36.8-3 (oldstable)]                                     
102)     libpangox-1.0-0 [0.0.2-5 (oldstable)]                                        
103)     libpangoxft-1.0-0 [1.36.8-3 (oldstable)]                                     
104)     libstdc++-4.9-dev [4.9.2-10+deb8u1 (oldstable)]                              
105)     libubsan0 [4.9.2-10+deb8u1 (oldstable)]                                      
106)     lxsession [0.5.1-2 (oldstable)]                                              
107)     mpage [2.5.6-1 (oldoldstable, oldstable)]                                    
108)     wm2 [4+svn20090216-3 (oldstable)]                                            

       Mantener los paquetes siguientes en la versión actual:                         
109)     avahi-daemon [0.6.31-2 (now, oldoldstable)]                                  
110)     cgmanager [Sin instalar]                                                     
111)     cups-browsed [Sin instalar]                                                  
112)     cups-core-drivers [Sin instalar]                                             
113)     cups-daemon [Sin instalar]                                                   
114)     cups-ppdc [1.5.3-5+deb7u8 (now, oldoldstable)]                               
115)     ifupdown [0.7.8 (now, oldoldstable)]                                         
116)     init-system-helpers [Sin instalar]                                           
117)     libaudit-common [Sin instalar]                                               
118)     libaudit1 [Sin instalar]                                                     
119)     libcgi-fast-perl [Sin instalar]                                              
120)     libclass-c3-xs-perl [Sin instalar]                                           
121)     libcpan-meta-perl [Sin instalar]                                             
122)     libdata-optlist-perl [Sin instalar]                                          
123)     libdata-section-perl [Sin instalar]                                          
124)     libfcgi-perl [Sin instalar]                                                  
125)     libmodule-build-perl [Sin instalar]                                          
126)     libpam-systemd [Sin instalar]                                                
127)     libparams-util-perl [Sin instalar]                                           
128)     libsocket-perl [2.002-1 (now, oldoldstable)]                                 
129)     libsoftware-license-perl [Sin instalar]                                      
130)     libsub-exporter-perl [Sin instalar]                                          
131)     libtext-soundex-perl [Sin instalar]                                          
132)     perl [5.14.2-21+deb7u6 (now, oldoldstable)]                                  
133)     perl-base [5.14.2-21+deb7u6 (now, oldoldstable)]                             
134)     perl-modules [5.14.2-21+deb7u6 (now, oldoldstable)]                          
135)     systemd [Sin instalar]                                                       
136)     systemd-shim [Sin instalar]                                                  
137)     udev [175-7.2 (now, oldoldstable)]                                           
138)     udisks2 [Sin instalar]                                                       

       Actualizar los paquetes siguientes:                                            
139)     binutils [2.22-8+deb7u3 (now, oldoldstable) -> 2.25-5+deb8u1 (oldstable)]    
140)     cpp [4:4.7.2-1 (now, oldoldstable) -> 4:4.9.2-2 (oldstable)]                 
141)     eog [3.4.2-1+build1+deb7u1 (now, oldoldstable) -> 3.14.1-1 (oldstable)]      
142)     g++ [4:4.7.2-1 (now, oldoldstable) -> 4:4.9.2-2 (oldstable)]                 
143)     gcc [4:4.7.2-1 (now, oldoldstable) -> 4:4.9.2-2 (oldstable)]                 
144)     gimp [2.8.2-2+deb7u3 (now, oldoldstable) -> 2.8.14-1+deb8u2 (oldstable)]     
145)     gimp-data [2.8.2-2+deb7u3 (now, oldoldstable) -> 2.8.14-1+deb8u2 (oldstable)]
146)     gir1.2-freedesktop [1.32.1-1 (now, oldoldstable) -> 1.42.0-2.2 (oldstable)]  
147)     gnome-desktop3-data [3.4.2-1 (now, oldoldstable) -> 3.14.1-1 (oldstable)]    
148)     gnome-themes-standard [3.4.2-2.1 (now, oldoldstable) -> 3.14.2.2-1 (oldstable
149)     gnome-themes-standard-data [3.4.2-2.1 (now, oldoldstable) -> 3.14.2.2-1 (olds
150)     gsettings-desktop-schemas [3.4.2-3 (now, oldoldstable) -> 3.14.1-1 (oldstable
151)     libatk1.0-0 [2.4.0-2 (now, oldoldstable) -> 2.14.0-1 (oldstable)]            
152)     libatk1.0-data [2.4.0-2 (now, oldoldstable) -> 2.14.0-1 (oldstable)]         
153)     libc-dev-bin [2.13-38+deb7u12 (now, oldoldstable) -> 2.19-18+deb8u10 (oldstab
154)     libc6-dev [2.13-38+deb7u12 (now, oldoldstable) -> 2.19-18+deb8u10 (oldstable)
155)     libc6-i686 [2.13-38+deb7u12 (now, oldoldstable) -> 2.19-18+deb8u10 (oldstable
156)     libcairo2 [1.12.2-3+deb7u1 (now, oldoldstable) -> 1.14.0-2.1+deb8u2 (oldstabl
157)     libcupscgi1 [1.5.3-5+deb7u8 (now, oldoldstable) -> 2.2.1-8+deb9u1~bpo8+1 (jes
158)     libcupsimage2 [1.5.3-5+deb7u8 (now, oldoldstable) -> 2.2.1-8+deb9u1~bpo8+1 (j
159)     libcupsmime1 [1.5.3-5+deb7u8 (now, oldoldstable) -> 2.2.1-8+deb9u1~bpo8+1 (je
160)     libcupsppdc1 [1.5.3-5+deb7u8 (now, oldoldstable) -> 2.2.1-8+deb9u1~bpo8+1 (je
161)     libexif12 [0.6.20-3 (now, oldoldstable) -> 0.6.21-2 (oldstable)]             
162)     libgail-3-0 [3.4.2-7+deb7u1 (now, oldoldstable) -> 3.14.5-1+deb8u1 (oldstable
163)     libgail18 [2.24.10-2 (now, oldoldstable) -> 2.24.25-3+deb8u2 (oldstable)]    
164)     libgcc1 [1:4.7.2-5 (now, oldoldstable) -> 1:4.9.2-10+deb8u1 (oldstable)]     
165)     libgdk-pixbuf2.0-0 [2.26.1-1+deb7u8 (now, oldoldstable) -> 2.31.1-2+deb8u7 (o
166)     libgdk-pixbuf2.0-common [2.26.1-1+deb7u8 (now, oldoldstable) -> 2.31.1-2+deb8
167)     libgfortran3 [4.7.2-5 (now, oldoldstable) -> 4.9.2-10+deb8u1 (oldstable)]    
168)     libgimp2.0 [2.8.2-2+deb7u3 (now, oldoldstable) -> 2.8.14-1+deb8u2 (oldstable)
169)     libgtk-3-0 [3.4.2-7+deb7u1 (now, oldoldstable) -> 3.14.5-1+deb8u1 (oldstable)
170)     libgtk-3-bin [3.4.2-7+deb7u1 (now, oldoldstable) -> 3.14.5-1+deb8u1 (oldstabl
171)     libgtk-3-common [3.4.2-7+deb7u1 (now, oldoldstable) -> 3.14.5-1+deb8u1 (oldst
172)     libgtk2.0-0 [2.24.10-2 (now, oldoldstable) -> 2.24.25-3+deb8u2 (oldstable)]  
173)     libgtk2.0-bin [2.24.10-2 (now, oldoldstable) -> 2.24.25-3+deb8u2 (oldstable)]
174)     libitm1 [4.7.2-5 (now, oldoldstable) -> 4.9.2-10+deb8u1 (oldstable)]         
175)     liblcms2-2 [2.2+git20110628-2.2+deb7u2 (now, oldoldstable) -> 2.6-3+deb8u1 (o
176)     libmpfr4 [3.1.0-5 (now, oldoldstable) -> 3.1.2-2 (oldstable)]                
177)     libpam-ck-connector [0.4.5-3.1 (now, oldoldstable) -> 0.4.6-5 (oldstable)]   
178)     libpango1.0-0 [1.30.0-1 (now, oldoldstable) -> 1.36.8-3 (oldstable)]         
179)     libpixman-1-0 [0.26.0-4+deb7u2 (now, oldoldstable) -> 0.32.6-3 (oldstable)]  
180)     libpython2.7 [2.7.3-6+deb7u4 (now, oldoldstable) -> 2.7.9-2+deb8u1 (oldstable
181)     libquadmath0 [4.7.2-5 (now, oldoldstable) -> 4.9.2-10+deb8u1 (oldstable)]    
182)     librsvg2-2 [2.36.1-2+deb7u3 (now, oldoldstable) -> 2.40.5-1+deb8u2 (oldstable
183)     librsvg2-common [2.36.1-2+deb7u3 (now, oldoldstable) -> 2.40.5-1+deb8u2 (olds
184)     libxcb1-dev [1.8.1-2+deb7u1 (now, oldoldstable) -> 1.10-3+b1 (oldstable)]    
185)     printer-driver-c2esp [24-2 (now, oldoldstable) -> 27-2 (oldstable)]          
186)     python-gi-cairo [3.2.2-2 (now, oldoldstable) -> 3.14.0-1 (oldstable)]        
187)     util-linux-locales [2.20.1-5.3 (now, oldoldstable) -> 2.25.2-6 (oldstable)]  

       Dejar las siguientes dependencias sin resolver:                                
188)     acpi-support recomienda xscreensaver | gnome-screensaver                     
189)     acpi-support-base recomienda consolekit                                      
190)     foomatic-filters recomienda colord                                           
191)     ghostscript-cups recomienda cups                                             
192)     ghostscript-cups recomienda colord                                           
193)     libsane-hpaio recomienda hplip (= 3.12.6-3.1+deb7u2)                         
194)     libreoffice-evolution recomienda evolution                                   
195)     udisks recomienda policykit-1                                                
196)     alacarte recomienda gnome-panel                                              
197)     argyll recomienda consolekit                                                 
198)     brasero recomienda yelp                                                      
199)     libcolord1 recomienda colord                                                 
200)     empathy recomienda nautilus-sendto-empathy                                   
201)     empathy-common recomienda yelp                                               
202)     nautilus-sendto-empathy recomienda nautilus-sendto (>= 3.0)                  
203)     evolution-common recomienda evolution                                        
204)     libfolks25 recomienda libfolks-eds25                                         
205)     printer-driver-foo2zjs recomienda cups                                       
206)     foomatic-db-compressed-ppds recomienda cups                                  
207)     openprinting-ppds recomienda cups                                            
208)     foomatic-db-engine recomienda cups                                           
209)     gcalctool recomienda yelp                                                    
210)     gedit recomienda zenity                                                      
211)     gedit recomienda yelp                                                        
212)     gnome-control-center-data recomienda gnome-control-center (>= 1:3.4.3.1-2)   
213)     gnome-media recomienda pulseaudio                                            
214)     gnome-media recomienda gnome-control-center                                  
215)     gnome-online-accounts recomienda gnome-control-center                        
216)     gnome-panel recomienda gnome-control-center                                  
217)     gnome-panel-data recomienda gnome-panel                                      
218)     gnome-session recomienda gnome-session-fallback                              
219)     gnome-session recomienda gnome-power-manager                                 
220)     gnome-shell recomienda gnome-contacts                                        
221)     gnome-shell recomienda gnome-control-center                                  
222)     gnome-shell recomienda gnome-session-fallback                                
223)     gnome-terminal recomienda yelp                                               
224)     gucharmap recomienda yelp                                                    
225)     libproxy0 recomienda libmozjs10d | libwebkitgtk-1.0-0                        
226)     printer-driver-min12xxw recomienda cups                                      
227)     mousetweaks recomienda gnome-control-center                                  
228)     nautilus-data recomienda nautilus                                            
229)     network-manager recomienda policykit-1                                       
230)     network-manager-gnome recomienda gnome-bluetooth                             
231)     libpackagekit-glib2-14 recomienda packagekit-system-interface | packagekit (=
232)     packagekit-backend-aptcc recomienda packagekit (= 0.7.6-3)                   
233)     python-packagekit recomienda packagekit                                      
234)     printer-driver-all recomienda printer-driver-gutenprint                      
235)     printer-driver-all recomienda printer-driver-hpcups                          
236)     printer-driver-all recomienda printer-driver-postscript-hp                   
237)     printer-driver-all recomienda printer-driver-splix                           
238)     rhythmbox-data recomienda rhythmbox                                          
239)     shotwell-common recomienda shotwell                                          
240)     speech-dispatcher recomienda pulseaudio                                      
241)     synaptic recomienda software-properties-gtk                                  
242)     task-desktop recomienda task-gnome-desktop | task-kde-desktop | task-lxde-des
243)     task-gnome-desktop recomienda gnome                                          
244)     totem-plugins recomienda gnome-settings-daemon                               
245)     upower recomienda policykit-1                                                
246)     libcolord2 recomienda colord                                                 
247)     eog recomienda yelp                                                          
248)     libcgi-pm-perl recomienda libcgi-fast-perl (>= 1:2.01)                       
249)     libclass-c3-perl recomienda libclass-c3-xs-perl                              
250)     libmodule-build-perl recomienda libsoftware-license-perl (>= 0.103009)       
251)     libmro-compat-perl recomienda libclass-c3-xs-perl                            
252)     lxsession recomienda lxde-common                                             
253)     perl-modules recomienda libtext-soundex-perl                                 
254)     cups-daemon recomienda cups-browsed                                          
255)     cups-daemon recomienda avahi-daemon (>= 0.6.31-3~)                           
256)     kodi-bin recomienda udisks2 

              ¿Acepta esta solución? [Y/n/q/?]        

q fue la respuesta parece que hay que cambiar muchas cosas ni idea la verda         

Sáb, 08/09/2018 - 12:31
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Una de las ventajas de aptitude es que cuando se producen conflictos de dependencias te permite elegir entre una serie de opciones
En la parte de

¿Acepta esta solución? [Y/n/q/?]

si pones n te va a dar otra posible solución, y asi hasta que des con una que te ayude o no encuentres ninguna y salgas de aptitude con la letra q

También puedes configurar aptitude para que no te trate de instalar los paquetes sugeridos ni te auto-elimine los huérfanos, para ello solo tipeas la palabra aptitude , luego haces clic a opciones, preferencias, bajas el cursor hasta encontrar la parte de gestor de dependencias y quitas la opción "instalar paquetes recomendados de forma automática" y "eliminar paquetes no usados automáticamente".
Seguramente si quitas estas opciones la lista de paquetes que te quiera instalar junto con kodi se reducirá drasticamente

https://exdebian.org/wiki/tutorial-de-aptitude

Ten presente que esta opción de instalar kodi implica mezclar paquetes que han sido compilados para una versión de debian mucho mas moderna con lo cual existe la posibilidad que al final no sea viable, en cuyo caso te van a quedar 2 opciones:

1 probar de instalar kodi desde /team-xbmc/ppa apuntando a lucid posiblemnte una version más vieja traiga menos conflictos. En ese caso tu sources.list quedaría asi:
 

#Debian wheezy
deb http://ftp.debian.org/debian/ wheezy main contrib non-free
deb-src http://ftp.debian.org/debian/ wheezy main contrib non-free


deb http://http.debian.net/debian wheezy-backports main

#deb-multimedia
deb ftp://ftp.deb-multimedia.org wheezy main non-free
deb-src ftp://ftp.deb-multimedia.org wheezy main non-free

#Debian jessie
#deb http://ftp.debian.org/debian/ jessie main contrib non-free
#deb http://http.debian.net/debian jessie-backports main

# kodi launchpad
deb http://ppa.launchpad.net/team-xbmc/ppa/ubuntu lucid main 
deb-src http://ppa.launchpad.net/team-xbmc/ppa/ubuntu lucid main 

2 actualizar tu sistema operativo de wheezy a jessie con los riesgos que conlleva tamaña actualización y la logística previa de resguardar datos importantes, etc.

PD: cuando pongas código, etc utiliza la etiqueta "insertar fragmento de código" de lo contrario se hace muy engorroso diferenciar que es texto y que es código
saludos...
 

Sáb, 08/09/2018 - 13:31
gi0
Imagen de gi0
Desconectado/a
se unió: 07/09/18

ok la verdad es que me quede agusto copiando y pegando... intentare poner el codigo en etiquetas.

a lo de la versión mas antigua de kodi me parece una buena opcion de todas formas este S0 los puse hace poco antes tenia wheezy 7.8 (en este consegui instalar kodi pero segun lo abría con la misma se me cerraba). En el 7.11 que tengo ahora no hay nada que me interese demasiado solo le puse el ilwifi y el wpasupplicant actualice iceweasel a firefoxESR y poco mas ...

con el upgrade  este proceso se me desinstalo flashplugin ... pero puse

root@debian:/home/gi0# aptitude -t jessie-backports install flashplugin-nonfree

instalo bien solo que me dijo algo de que era sin identificar o algo asi puse "si" y di "enter" y ya volvio a funcionar supongo que por eso no debo preocuparme.

y la verdad que lo de lucid no se a que te refieres toy googleando a ver que es. (gracias x tu tiempo) ok un version de ubuntu jeje

 

 

 

 

Sáb, 08/09/2018 - 13:40
gi0
Imagen de gi0
Desconectado/a
se unió: 07/09/18

entonce deberia poner los repos de lucid y hacer

# aptitude install kodi

¿o hay que hacer algo para apuntar que quiero una version de kodi mas antigua?

Sáb, 08/09/2018 - 13:53
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

lucid es la versión 10.04 de ubuntu (precise la 12.04). Los repositorios de https://launchpad.net con los que comentaste que habías instalado kodi al principio,  apuntan a las versiones de ubuntu por lo que sus paquetes han sido precompilados para dicho sistema. Solo decia, que si el repositorio de jessie (debian 8) implica poner de cabeza el sistema operativo, pruebes nuevamente con los repos de launchpad a lo mejor apuntando a lucid (14.04) o una versión un poco más moderna como trusty (11.04).

sobre flashplugin-nonfree no esta en jessie-backports o lo instalas de wheezy o de jessie

aptitude install flashplugin-nonfree
o
aptitude -t jessie install flashplugin-nonfree

saludos...

Sáb, 08/09/2018 - 14:32
gi0
Imagen de gi0
Desconectado/a
se unió: 07/09/18

pero con poner los repositorios de lucid ya estoy apuntando al (14.04) o como tengo que hacer para apuntar?

lo del flashplugin non free me dio resultado con los repos  backport de jessie o por lo menos eso creo (por esto no te preocupes)

Sáb, 08/09/2018 - 18:09
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

perdon trusty es 14.04 , precise 12.04 y lucid 10.04

Dom, 09/09/2018 - 11:46
gi0
Imagen de gi0
Desconectado/a
se unió: 07/09/18

probe con lucid y me dijo esto con el update tb ignoro otras cosas

Leyendo lista de paquetes... Hecho
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package sagenb-export
W: Ignoring Provides line with DepCompareOp for package sagenb-export
W: Tal vez quiera ejecutar «apt-get update» para corregir estos problemas
root@debian:/home/gi0# apt-get install kodi
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 kodi : Depende: kodi-bin (>= 16.1+dfsg1-2~bpo8+2) pero no va a instalarse
        Depende: kodi-bin (< 16.1+dfsg1-2~bpo8+2.1~) pero no va a instalarse
        Depende: kodi-data pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos

y con trustly le puse lo mismo en sources.list pero cambiando la palabra lucid por trustly

root@debian:/home/gi0# apt-get install kodi
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 kodi : Depende: kodi-bin (>= 16.1+dfsg1-2~bpo8+2) pero no va a instalarse
        Depende: kodi-bin (< 16.1+dfsg1-2~bpo8+2.1~) pero no va a instalarse
        Depende: kodi-data pero no va a instalarse
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package sagenb-export
W: Ignoring Provides line with DepCompareOp for package sagenb-export
W: Tal vez quiera ejecutar «apt-get update» para corregir estos problemas
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

 

Dom, 09/09/2018 - 13:37
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Asegurarte de haber desinstalado completamente kodi. Ejecuta un  apt-get update como te dice el instalador de apt-get. Proba de hacer la instalación con aptitude y las opciones que te da cunado pones la letra n todas las veces que sea necesario hasta que des con una solución que te ayude a resolver los conflictos de dependencias.

Tene presente que estas utilizando una versión de debian que proto va a pasar a los repositorios de archive asi que puede que la idea de tener kodi funcionando puede que no sea una empresa exitosa.

Dom, 09/09/2018 - 13:56
gi0
Imagen de gi0
Desconectado/a
se unió: 07/09/18

si empiezo a pensar que o aprendo a compilar o me paso a jessie :D. ¿si instalo jessie y mantengo el entorno grafico actual tb tendre problemas con las dependencias ? el update estaba recien hecho supongo que el apt lo lo dice x decir

Necesito descargar 22,4 MB de ficheros. Después de desempaquetar se usarán 55,7 MB.
No se satisfacen las dependencias de los siguientes paquetes:
 kodi-bin : Depende: libasound2 (>= 1.0.27) pero está instalado 1.0.25-4.
            Depende: libatomic1 (>= 4.8) pero no será instalado.
            Depende: libavcodec57 (>= 7:3.2.5) pero no será instalado. o
                     libavcodec-extra57 (>= 7:3.2.5) pero no será instalado.
            Depende: libavfilter6 (>= 7:3.2.5) pero no será instalado. o
                     libavfilter-extra6 (>= 7:3.2.5) pero no será instalado.
            Depende: libavformat57 (>= 7:3.2.5) pero no será instalado.
            Depende: libavutil55 (>= 7:3.2.5) pero no será instalado.
            Depende: libc6 (>= 2.17) pero está instalado 2.13-38+deb7u12.
            Depende: libcrossguid0v4 (>= 0.0+git200150803) pero no será instalado.
            Depende: libglew1.10 (>= 1.10.0) pero no será instalado.
            Depende: libjpeg62-turbo (>= 1.3.1) pero no será instalado.
            Depende: liblzo2-2 pero no será instalado.
            Depende: libmicrohttpd10 (>= 0.9.20) pero no será instalado.
            Depende: libpcre3 (>= 1:8.35) pero está instalado 1:8.30-5.
            Depende: libpcrecpp0 (>= 7.7) pero no será instalado.
            Depende: libpostproc54 (>= 7:3.2.5) pero no será instalado.
            Depende: libsdl2-2.0-0 (>= 2.0.0) pero no será instalado.
            Depende: libsmbclient (>= 2:4.0.3+dfsg1) pero está instalado 2:3.6.6-6+deb7u16.
            Depende: libssh-4 (>= 0.6.1) pero no será instalado.
            Depende: libstdc++6 (>= 4.9) pero está instalado 4.7.2-5.
            Depende: libswresample2 (>= 7:3.2.5) pero no será instalado.
            Depende: libswscale4 (>= 7:3.2.5) pero no será instalado.
            Depende: libtag1c2a (>= 1.9.1) pero está instalado 1.8-dmo1.
            Depende: libtiff5 (>= 4.0.3) pero no será instalado.
            Depende: libtinyxml2.6.2 pero no será instalado.
            Depende: libudev1 (>= 183) pero no será instalado.
 fonts-dejavu-core : Rompe: ttf-dejavu-core (< 2.33+svn2514-2~) pero está instalado 2.33-3.
abierto: 44; cerrado: 124; diferido: 14; conflicto: 16                         .Las acciones siguientes resolverán estas dependencias

     Mantener los paquetes siguientes en la versión actual:
1)     fonts-dejavu-core [Sin instalar]                    
2)     kodi [Sin instalar]                                 
3)     kodi-bin [Sin instalar]                             
4)     kodi-data [Sin instalar] 

y otra opcion mas pero igual de mala pinta.