Lag al instalar el Driver de Nvidia

10 envíos / 0 nuevos
Último envío
#1 Dom, 06/08/2017 - 19:29
javier_macross
Imagen de javier_macross
Desconectado/a
se unió: 10/08/16

Lag al instalar el Driver de Nvidia

Hola amigos de esta estupenda comunidad. No sé si sea debido a que Debian Stretch aún está en fase de depuración o si tengo algún problema con el driver privativo de Nvidia. Mientras uso el driver Nouveau, todo parece más fluido. Sin embargo, al instalar el driver privativo nvidia-legacy-304xx-driver y todas sus dependencias, al reiniciar parece que ahora las animaciones de las ventanas cuando se abren y cierran, se ven con lag.

Cuando realizo un scroll dentro de una ventana con muchos archivos, también puedo notar un lag muy evidente y en general todo parece tener un pequeño lag, cosa que cuando tenía instalado Nouveau, todo parecía ir más fluido. ¿Esto es normal o tengo algún problema en el sistema o es el driver?

Mi sistema es de las siguientes características.

Sistema operativo: Debian Stretch 9.1 con entorno de escritorio Cinnamon 3.2.7-4

Procesador: Pentium IV ht a 3.2 GHZ

1GB de memoria ram

Tarjeta gráfica: 512mb EVGA PCI DDR2 GE Force 6200

Agradezco mucho de antemano su ayuda.

Saludos.

smiley

Dom, 06/08/2017 - 20:50
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Te aclaro que las 6200 ya estan al borde de quedarse sin soporte privativo y que si tenias aceleracion 3D con el driver libre no creo que encuentres mucha diferencia con el driver de nvidia.

Si bien no das muchas explicaciones de como instalaste el diver legacy, fíjate de instalar nvidia-settings-legacy ahí vas a poder optar de mejorar el rendimiento en pos de la calidad. 

La otra es modificar el xorg creado, agregándole parámetros personalizados https://wiki.archlinux.org/index.php/NVIDIA_(Espa%C3%B1ol)

Podrias ejecutar un journal -b -p err para ver si tira algun error

Dom, 06/08/2017 - 21:31
javier_macross
Imagen de javier_macross
Desconectado/a
se unió: 10/08/16

Gracias por contestar. El driver lo he instalado mediante gdebi, usando los paquetes .deb del repositorio de debian. Perdona la ignorancia pero, ¿Cómo sé si tengo aceleración 3D con Nouveau?

Saludos.

laugh

 

Lun, 07/08/2017 - 06:02 (Responder a #3)
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

javier_macross wrote:

 ¿Cómo sé si tengo aceleración 3D con Nouveau?

Saludos.

laugh

Abre una terminal y ejecuta:

$ glxinfo

Mira en la tercera línea. Si tienes aceleración 3D te debe salir esto:

direct rendering: Yes

 

We were but stones. Your light made us stars

https://linuxveredas.blogspot.com.es/

Lun, 07/08/2017 - 11:07 (Responder a #4)
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

javier_macross wrote:

Gracias por contestar. El driver lo he instalado mediante gdebi, usando los paquetes .deb del repositorio de debian. Perdona la ignorancia pero, ¿Cómo sé si tengo aceleración 3D con Nouveau?

Saludos.

laugh

gdebi? usando los paquetes? ¿Y no habría sido más sencillo usar apt install xserver-xorg-video-nvidia-legacy-XXXXX que te instalará todas las dependencias, construirá el módulo para tu kernel y el sistema detectará si es mejor usar nvidia o nouveau automáticamente?

  No hay bar que por bien no venga....
Lun, 07/08/2017 - 12:30
javier_macross
Imagen de javier_macross
Desconectado/a
se unió: 10/08/16

Habría sí, si en esa PC tuviera internet. cheeky

Saludos.

 

Lun, 07/08/2017 - 17:44
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

pues entonces me atrevería a decir que te falta alguna dependencia...

  No hay bar que por bien no venga....
Lun, 07/08/2017 - 20:00
javier_macross
Imagen de javier_macross
Desconectado/a
se unió: 10/08/16

No creo, siempre reviso las dependencias según las va pidiendo gdebi. Al ejecutar el comando glxinfo, aparece direct rendering: Yes ¿Qué será?

Saludos.

sad

 

Mar, 08/08/2017 - 16:33
Uno_wos
Imagen de Uno_wos
Desconectado/a
se unió: 04/08/17

Tienes un Pentium IV y 512 mb de RAM

Cinamon esta "sacado" de gnome 3.

Yo te recomiendo XFCE para ese equipo

Por otro lado, sin conocer muy bien tu situacion, tiene que haber alguna opcion en el gestor de ventanas que habilite/deshabilite el "composite" del escritorio. Desactivarlo ayudaria. Y luego lo que te comentan. En el nvidia-settings, busca la opcion de "performance", en vez de "high quality.

 

Suerte

Mar, 08/08/2017 - 19:59
javier_macross
Imagen de javier_macross
Desconectado/a
se unió: 10/08/16

Tengo 512 mb de memoria pero en la tarjeta gráfica, en el sistema tengo 1GB de RAM. Lo de Nvidia ya lo he hecho y no parece haber cambio. Pregunta; ¿Qué requerimientos tienen entonces cinnamon para que con una pc como la que tengo no ande bien? surprise

Saludos.

angry