Micrófono interno no captura correctamente el sonido

13 envíos / 0 nuevos
Último envío
#1 Mié, 01/08/2018 - 05:04
Liberto
Imagen de Liberto
Desconectado/a
se unió: 12/03/16

Micrófono interno no captura correctamente el sonido

Estado: 
[ACTIVO]

Buen día.

Estoy teniendo problemas con el sonido de entrada en Debian Strecht.

Si bien el micrófono parece capturar algo, lo único que se escucha tras la grabación es ruido.

El caso es que haciendo lshw -short no encuentro el micrófono.

¿Qué puede estar pasando?

Un saludo

 

Jue, 02/08/2018 - 12:39
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

lshw -short no te va a mostrar el micrófono, como mucho, te va a mostrar el dispositivo de audio que tienes.

¿Has comprobado alguna vez que el micrófono funciona correctamente aunque no puedas grabar nada con el mismo? Muchas veces es asunto de configuración, ya sea cosa de pulseaudio, o sea cosa de la forma en que el sistema detecta la tarjeta de sonido.

En algunos casos, o hay que configurar con alsamixer o paprefs (o pavucontrol, o desde systemsettings en plasma) los dispositivos correctamente, o buscar tu tarjeta de sonido y pasarle al sistema algún parámetro en la carga del módulo al inicio, ya que a veces "se confunde" y toma como fuente por defecto el micro externo en lugar del interno, p.e.

la salida del comando

aplay -l

te dirá que tarjeta(s) de audio tienes y el orden en el cual las reconoce el sistema, mientras que la salida del comando

aplay -L

te dirá todos los dispositivos reconocidos y cual está configurado por defecto, tanto de salida como de entrada.

Para empezar, yo probaría desde la consola con alsamixer a ver que está tomando como dispositivo de captura y tratar de configurarlo desde ahí antes que nada.

  No hay bar que por bien no venga....
Jue, 02/08/2018 - 14:07
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Estoy con Panko.  Lo primero será entrar en los ajustes de audio, o en el desplegable de las fuentes de entrada/salida

 que van a veces con el menú del volumen, y ver que no tengas bajo el nivel de entrada del micrófono, que es ajustable.

 Algunos menús llevan además un control o un check-in de amplificación adicional, por si el micro no da lo suficiente.

 

 Busca alguna entrada o algún menú o aplicación que te muestre la barra de vu-metro de la señal del micro, y ajústalo

 a un nivel razonable, (no es necesario que llegue al 100%).

 

Después de esto ya deberías poder grabar correctamente,  -siempre que el micro esté bien y la configuración sea correcta-.

 

 

 Siendo micrófono interno, no te extrañes si mezclado con tu señal se oye el motor del ventilador, o el disco duro, o

 el dvd que se pone en marcha ...

 Yo ya lo experimenté una vez, y siempre se oía de fondo el ruido de hdd.  [roll eyes] , laugh.

 

 

 

 

Mié, 08/08/2018 - 17:08
Liberto
Imagen de Liberto
Desconectado/a
se unió: 12/03/16

Hola.

He probado configurar a través de alsamixer y pulseaudio de todas las maneras posibles. Y la salida que hace del sonido capturado es ruido. Nada más. He probado todas las combinaciones.

En relación a los comandos que comenta Panko, esto es lo que sale, y la verdad no entiendo nada:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: Generic Analog [Generic Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

 

aplay -L
default
    Playback/recording through the PulseAudio sound server
null
    Discard all samples (playback) or generate zero samples (capture)
sysdefault:CARD=PCH
    HDA Intel PCH, Generic Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    Front speakers
surround21:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
hdmi:CARD=PCH,DEV=0
    HDA Intel PCH, HDMI 0
    HDMI Audio Output
hdmi:CARD=PCH,DEV=1
    HDA Intel PCH, HDMI 1
    HDMI Audio Output
hdmi:CARD=PCH,DEV=2
    HDA Intel PCH, HDMI 2
    HDMI Audio Output
dmix:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    Direct sample mixing device
dmix:CARD=PCH,DEV=3
    HDA Intel PCH, HDMI 0
    Direct sample mixing device
dmix:CARD=PCH,DEV=7
    HDA Intel PCH, HDMI 1
    Direct sample mixing device
dmix:CARD=PCH,DEV=8
    HDA Intel PCH, HDMI 2
    Direct sample mixing device
dsnoop:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    Direct sample snooping device
dsnoop:CARD=PCH,DEV=3
    HDA Intel PCH, HDMI 0
    Direct sample snooping device
dsnoop:CARD=PCH,DEV=7
    HDA Intel PCH, HDMI 1
    Direct sample snooping device
dsnoop:CARD=PCH,DEV=8
    HDA Intel PCH, HDMI 2
    Direct sample snooping device
hw:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    Direct hardware device without any conversions
hw:CARD=PCH,DEV=3
    HDA Intel PCH, HDMI 0
    Direct hardware device without any conversions
hw:CARD=PCH,DEV=7
    HDA Intel PCH, HDMI 1
    Direct hardware device without any conversions
hw:CARD=PCH,DEV=8
    HDA Intel PCH, HDMI 2
    Direct hardware device without any conversions
plughw:CARD=PCH,DEV=0
    HDA Intel PCH, Generic Analog
    Hardware device with all software conversions
plughw:CARD=PCH,DEV=3
    HDA Intel PCH, HDMI 0
    Hardware device with all software conversions
plughw:CARD=PCH,DEV=7
    HDA Intel PCH, HDMI 1
    Hardware device with all software conversions
plughw:CARD=PCH,DEV=8
    HDA Intel PCH, HDMI 2
    Hardware device with all software conversions

 

Y la verdad es que no sé interpretarlos...

"O inventamos o erramos" (Simón Rodríguez)

Jue, 09/08/2018 - 01:59
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

No se trata de interpretar nada en realidad, eso solo te muestra lo que tienes.

Por lo que veo, el orden en que están detectados los dispositivos de audio (primer comando), es el  correcto. Y la salida del segundo comando es prácticamente igual a la mía, con lo que también me parece que está bien (esa salida son todos los componentes de los dispositivos de audio y su configuración).

A mí me sigue pareciendo que es cosa de alguna parte de tu configuración, la verdad, aunque siendo un modelo de dispositivo de audio algo diferente al mío, puede ser falta de algo más, pero me sigue sonando a problemas de configuración como he dicho... Ten en cuenta que tendrás dos micrófonos, aunque solo uno integrado, que es el micro interno (usualmente, colocado cerca de la webcam), y la entrada de micrófono externo, a ver si se te ha pasado algo y no has configurado correctamente el dispositivo de captura, no se.

Fíjate bien en alsamixer, pulsando f6 puedes cambiar de pulseaudio a la tarjeta de sonido pch. En esta parte es más que probable que veas Mic y más a la derecha Internal Mic. Comprueba que Mic esté a 0 y el otro ligeramente subido para empezar. Luego te sales de ahí y te vas a las preferencias de pulseaudio y comprueba que está correctamente seleccionado el micro interno. Como ejemplo te dejo como me sale a mí en alsamixer, fíjate que Mic está a 0, mientras que a la derecha Internal (no se mic, pero se refiere a eso), están ligeramente subidos.

┌────────────────────────────────────── AlsaMixer v1.1.6 ───────────────────────────────────────┐
│ Card: HDA Intel PCH                                                   F1:  Help               │
│ Chip: Realtek ALC270                                                  F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All                              F6:  Select sound card  │
│ Item: Master [dB gain: -3,00]                                         Esc: Exit               │
│     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐                       ┌──┐     ┌──┐     │
│     │  │     │  │     │▒▒│     │▒▒│     │  │     │  │                       │  │     │  │     │
│     │▒▒│     │  │     │▒▒│     │▒▒│     │  │     │  │                       │  │     │  │     →
│     │▒▒│     │  │     │▒▒│     │▒▒│     │  │     │  │                       │  │     │  │     →
│     │▒▒│     │  │     │▒▒│     │▒▒│     │  │     │  │                       │  │     │  │     →
│     │▒▒│     │  │     │▒▒│     │▒▒│     │  │     │  │                       │  │     │  │     →
│     │▒▒│     │  │     │▒▒│     │▒▒│     │  │     │  │                       │  │     │  │     →
│     │▒▒│     │  │     │▒▒│     │▒▒│     │  │     │  │                       │  │     │▒▒│     →
│     │▒▒│     │  │     │▒▒│     │▒▒│     │  │     │  │                       │▒▒│     │▒▒│     │
│     ├──┤     ├──┤     ├──┤     └──┘     ├──┤     └──┘     ┌──┐   Enabled    ├──┤     └──┘     │
│     │OO│     │MM│     │OO│              │MM│              │MM│              │MM│              │
│     └──┘     └──┘     └──┘              └──┘              └──┘              └──┘              │
│      88      0<>0   100<>100 100<>100   0<>0     0<>0                      10<>10   20<>20    │
│  < Master >Headphon Speaker    PCM      Mic    Mic Boos  S/PDIF  Auto-Mut Internal Internal   │
└───────────────────────────────────────────────────────────────────────────────────────────────┘

 

  No hay bar que por bien no venga....
Jue, 09/08/2018 - 09:15
Liberto
Imagen de Liberto
Desconectado/a
se unió: 12/03/16

Gracias Panko.

Veo que tu configuración de Alsamixder es casi idéntica a la mía. Solo veo una cosa.

Cuando abro Alsamixer, la opción por defecto que sale es esta:

https://ibb.co/e2f5rU

Y tras hacer F6, configurar y salir, lo dejo así.

https://ibb.co/coBpJ9

Pero luego al volver a abrir alsamixer me sale la opción "default".

¿Puede tener algo que ver?, ¿cómo podría hacer en ese caso para que la opción por defecto sea la segunda?

 

"O inventamos o erramos" (Simón Rodríguez)

Jue, 09/08/2018 - 12:04
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Podes guardar las configuraciones de alsa   investiga sobre '  

alsactl store 

Emmm fijate esta completa guia  ( hacia el final tratan sobre el microfono )

Jue, 09/08/2018 - 13:37
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Como te salga alsamixer no importa, el resultado final será el mismo, veas todo lo que tiene la tarjeta de audio, o veas sólo el master de pulseaudio. En lo que tienes que fijarte, es en lo que dice arriba a la izquierda:

View: F3:[Playback] F4: Capture  F5: All

Ahí te está diciendo que lo que ves, en tu primera imagen, es sólo lo que tiene el dispositivo de salida (aunque aparezca el micro, fíjate que Playback está entre corchetes, lo que significa que es lo que estás viendo. En ese caso, necesitas pulsar F4 para seleccionar Capture y ahí ver que y como está configurado, tanto en pulseaudio como en la misma tarjeta (recuerda que cambias entre ellos pulsando F6). Aquí un ejemplo de como se me ve a mí con la tarjeta de audio seleccionada:

┌────────────────────────────────────── AlsaMixer v1.1.6 ───────────────────────────────────────┐
│ Card: HDA Intel PCH                                                   F1:  Help               │
│ Chip: Realtek ALC270                                                  F2:  System information │
│ View: F3: Playback  F4:[Capture] F5: All                              F6:  Select sound card  │
│ Item: Mic Boost [dB gain: 0,00, 0,00]                                 Esc: Exit               │
│                 ┌──┐               ┌──┐               ┌──┐               ┌──┐                 │
│                 │  │               │▒▒│               │  │               │  │                 │
│                 │  │               │▒▒│               │  │               │  │                 │
│                 │  │               │▒▒│               │  │               │  │                 │
│                 │  │               │▒▒│               │  │               │  │                 │
│                 │  │               │▒▒│               │  │               │  │                 │
│                 │  │               │▒▒│               │  │               │  │                 │
│                 │  │               │▒▒│               │  │               │  │                 │
│                 │  │               │▒▒│               │▒▒│               │▒▒│                 │
│                 │  │               │▒▒│               │▒▒│               │▒▒│                 │
│                 └──┘              L└──┘R              └──┘               └──┘                 │
│                                  CAPTURE                                                      │
│                 0<>0             100<>100            24<>24             20<>20                │
│         <    Mic Boost     >     Capture            Digital       Internal Mic Boost          │
└───────────────────────────────────────────────────────────────────────────────────────────────┘

Fíjate que ahora está entre corchetes Capture y no Playback.

A ver si entre el enlace del compañero y los ejemplos conseguimos algo, que si está todo bien hay que buscar la forma en que es detectada tu tarjeta y toquetear algo más, y eso se hace algo más complicado que pasarte un día o dos repasando todas las configuraciones, la verdad.

 

  No hay bar que por bien no venga....
Jue, 09/08/2018 - 15:04
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Hola.

 

 Yo lo que veo en la 1ª imagen Liberto es que el microfono, (internal mic), está bastante bajo,  ¿como un 20% quizás?.

 si no se te oye, no tengas miedo y haz como la canción, "pop up the volume, pop up the volume", (sube el volumen,

 pero no el de salida, si no el del control del micro). Lo más que puede pasar es que sature y no se entienda, pero

 al menos ya sabremos que funciona.

 Aunque no soy usuario de este tipo de hardware las pocas veces que he hecho una prueba el control me quedaba

 entre 1/3 y mitad del recorrido.

 Tip:  Localiza por donde queda el micro y chasquea los dedos delante suyo mientras grabas. debería apreciarse

 el pico de sonido en la barra-vumetro si tienes. o si no, al menos oírse algún ruido coincidente con ello en la grabación.

 

 Una cosa al principio del aplay me ha llamado la atención:

aplay -L

default

Playback/recording through the PulseAudio sound server

null

Discard all samples (playback) or generate zero samples (capture)

 No estoy seguro de si este descarte es normal que esté ahí o si indica algún problema con las muestras.

 ¿Podrias comprobarlo en el tuyo Panko?.

 

Vie, 10/08/2018 - 00:18
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Eso es correcto, @percontador, el mío aparece igual (y en la mayoría de sistemas debería aparecer, ya que es una opción más del dispositivo/sistema de audio), con eso no debería haber problema. Esperemos que compruebe bien otra vez todas las configuraciones.

  No hay bar que por bien no venga....
Sáb, 11/08/2018 - 10:47
Liberto
Imagen de Liberto
Desconectado/a
se unió: 12/03/16

Gracias compas por vuestra ayuda.

Bueno, revisado y probado con diferentes programas el micrófono, veo que el problema solamente ocurre con la aplicación de Telegram Desktop.

Es decir, el problema está solucionado en cuanto que no se trata de un problema de hardware ni de incompatibilidad.

Lo he informado a Debian como un posible bug de la última versión. Dejo el tema abierto porque sigo investigando.

"O inventamos o erramos" (Simón Rodríguez)

Dom, 12/08/2018 - 05:35
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Si sólo te ocurre con la aplicación de Telegram, no es un bug que debas reportar a Debian, ya que el micro funciona en realidad. Deberías reportarlo contra el paquete de telegram si lo instalaste de repositorios (a Debian, pero a dicho paquete, puedes usar reportbug-ng que facilita bastante la tarea). Si lo instalaste de su página, deberías reportar allí mismo, ya que no tiene que ver con el sistema.

  No hay bar que por bien no venga....
Dom, 12/08/2018 - 19:04
Liberto
Imagen de Liberto
Desconectado/a
se unió: 12/03/16

"O inventamos o erramos" (Simón Rodríguez)