Netbook Samsung N150 - Error ACPI durante el inicio

8 envíos / 0 nuevos
Último envío
#1 Mié, 31/10/2018 - 19:53
zero
Imagen de zero
Desconectado/a
se unió: 31/10/18

Netbook Samsung N150 - Error ACPI durante el inicio

Hola, escribo mi primera consulta, espero hacerlo bien.

Durante los mensajes de inicio aparece el siguiente error:

oct 31 19:32:00 netbook kernel: ACPI BIOS Error (bug): Failure creating [\_SB.PCI0._OSC.CAPB], AE_ALREADY_EXISTS (20180531/d
oct 31 19:32:00 netbook kernel: ACPI Error: Method parse/execution failed \_SB.PCI0._OSC, AE_ALREADY_EXISTS (20180531/pspars

 

oct 31 19:32:00 netbook kernel: ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKD (20180531/dspkginit-414)
 

 

He estado haciendo los deberes y después de probar varias soluciones como pasarle a grub la orden noacpi y acpi=off, pero ninguna hace efecto, al final he dado con artículos que aconsejaban actualizar la BIOS (no existe actualización), el problema al parecer es que las reglas ACPI del portátil no siguen los estándares y a partir de no se que versión del kernel es mas restrictivo con las reglas ACPI y se produce este mensaje. Según he leído no es un mensaje preocupante.

 

Así pues obtenida esa información mi pregunta es ¿Existe alguna manera de que al menos no se muestren?

Mié, 31/10/2018 - 21:04
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

En realidad no es que se trate de un error, la "solución" que podes hacer es evitar que esas molestas notificaciones se muestren. Fijate si esto te es de ayuda:

su
nano /etc/default/grub

en la parte que dice:

....
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
....

agregale

GRUB_CMDLINE_LINUX_DEFAULT="quiet libata.noacpi=1"

luego actualiza grub

su
update-grub2

al reiniciar no tendrías que ver esas notificaciones

fuente: https://www.quijotelibre.com/2017/10/12/acpi-error-una-tonteria-de-gnulinux-que-me-ha-vuelto-loco/
https://exdebian.org/foro/cuelgues-aleatorios
https://gnulinuxvagos.es/topic/6369-libatanoacpi1-%C2%BFsoluci%C3%B3n-real-o-fake-a-los-errores-acpi/
https://lists.debian.org/debian-user-spanish/2017/10/msg00041.html

saludos...

Jue, 01/11/2018 - 06:45 (Responder a #2)
zero
Imagen de zero
Desconectado/a
se unió: 31/10/18

Gracias por responder. 

La solución que comentas ya la había intentando también (he hecho un nuevo intento) y a pesar de que a mucha gente le ha funcionado no tiene ningún resultado en mi equipo. He estado leyendo los parámetros que se le pueden pasar al kernel:

https://www.kernel.org/doc/html/v4.10/admin-guide/kernel-parameters.html

 

y he probado nomodeset y acpi_osi= con identico resultado, el único que me ha servido es loglevel=3 pero quizás sea un poco excesivo esconder todos los mensajes de inicio.

 

 

 

 

 

..:: 0 ::..

Jue, 01/11/2018 - 11:20
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

de esa lista de parámetros para el kernel ¿probaste acpi_os_name=\"Microsoft Windows\" ? o acpi_osi=!! o acpi_osi=Windows acpi_osi=Linux

https://unix.stackexchange.com/questions/123360/etc-default-grub-syntax-error

https://wiki.archlinux.org/index.php/Talk:ASUS_E403SA

Aca tienes muchos parámetros para probar https://gnulinuxvagos.es/topic/6377-configuracion-de-energia-optimizada/

Jue, 01/11/2018 - 17:18 (Responder a #4)
zero
Imagen de zero
Desconectado/a
se unió: 31/10/18

Muchas gracias, ahí tengo material bastante, esos que mencionas si los he probado sin resultados, pero a esos enlaces no había llegado, probaré opciones y comunico resultados

..:: 0 ::..

Jue, 01/11/2018 - 19:18
zero
Imagen de zero
Desconectado/a
se unió: 31/10/18

He estado probando infinidad de parámetros y nada, he probado con todas las versiones de windows que podrían cuadrar y tampoco.

Aprovecho por si alguien le sirve las versiones para pasar por parámetro son:

https://docs.microsoft.com/en-us/windows-hardware/drivers/acpi/winacpi-osi

 

Después de tantas veces que he visto el error me he percatado del siguiente mensaje:

 

root@netbook:~# dmesg | grep bug
[    0.074434] PCI: Using host bridge windows from ACPI; if necessary, use "pci=nocrs" and report a bug
[    0.092180] ACPI BIOS Error (bug): Failure creating [\_SB.PCI0._OSC.CAPB], AE_ALREADY_EXISTS (20180531/dsfield-179)
[    8.865361] ehci-pci 0000:00:1d.7: debug port 1
[  135.418768] SGI XFS with ACLs, security attributes, realtime, no debug enabled

 

He probado pero tampoco soluciona nada.

..:: 0 ::..

Jue, 01/11/2018 - 19:33
zero
Imagen de zero
Desconectado/a
se unió: 31/10/18

Añado todos los mensajes que salen en el inicio respecto a ACPI por si pudieran ser de ayuda:

 

root@netbook:~# dmesg | grep ACPI
[    0.000000] BIOS-e820: [mem 0x000000007f5b0000-0x000000007f5bffff] ACPI data
[    0.000000] BIOS-e820: [mem 0x000000007f5c0000-0x000000007f5c2fff] ACPI NVS
[    0.000000] ACPI: Early table checksum verification disabled
[    0.000000] ACPI: RSDP 0x00000000000F7DA0 000024 (v02 PTLTD )
[    0.000000] ACPI: XSDT 0x000000007F5B8DB7 00006C (v01 SECCSD LH43STAR 06040000  LTP 00000000)
[    0.000000] ACPI: FACP 0x000000007F5BFC92 0000F4 (v03 INTEL           06040000 PTL  00000002)
[    0.000000] ACPI: DSDT 0x000000007F5BA01F 005B7F (v01 INTEL  BEARG31A 06040000 MSFT 03000001)
[    0.000000] ACPI: FACS 0x000000007F5C2FC0 000040
[    0.000000] ACPI: FACS 0x000000007F5C2FC0 000040
[    0.000000] ACPI: MCFG 0x000000007F5BFD86 00003C (v01 PTLTD    MCFG   06040000  LTP 00000000)
[    0.000000] ACPI: HPET 0x000000007F5BFDC2 000038 (v01 PTLTD  HPETTBL  06040000  LTP 00000001)
[    0.000000] ACPI: APIC 0x000000007F5BFDFA 000068 (v01 PTLTD  ? APIC   06040000  LTP 00000000)
[    0.000000] ACPI: BOOT 0x000000007F5BFE62 000028 (v01 PTLTD  $SBFTBL$ 06040000  LTP 00000001)
[    0.000000] ACPI: SLIC 0x000000007F5BFE8A 000176 (v01 SECCSD LH43STAR 06040000  LTP 00000000)
[    0.000000] ACPI: SSDT 0x000000007F5B93BF 00025F (v01 PmRef  Cpu0Tst  00003000 INTL 20050624)
[    0.000000] ACPI: SSDT 0x000000007F5B9319 0000A6 (v01 PmRef  Cpu1Tst  00003000 INTL 20050624)
[    0.000000] ACPI: SSDT 0x000000007F5B8E23 0004F6 (v02 PmRef  CpuPm    00003000 INTL 20050624)
[    0.000000] ACPI: Local APIC address 0xfee00000
[    0.000000] ACPI: PM-Timer IO Port: 0x1008
[    0.000000] ACPI: Local APIC address 0xfee00000
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 high edge)
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
[    0.000000] ACPI: IRQ0 used by override.
[    0.000000] ACPI: IRQ9 used by override.
[    0.000000] Using ACPI (MADT) for SMP configuration information
[    0.000000] ACPI: HPET id: 0xffffffff base: 0xfed00000
[    0.000000] ACPI: Core revision 20180531
[    0.036877] PM: Registering ACPI NVS region [mem 0x7f5c0000-0x7f5c2fff] (12288 bytes)
[    0.040271] ACPI: bus type PCI registered
[    0.040271] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
[    0.044454] ACPI: Added _OSI(Module Device)
[    0.044457] ACPI: Added _OSI(Processor Device)
[    0.044460] ACPI: Added _OSI(3.0 _SCP Extensions)
[    0.044464] ACPI: Added _OSI(Processor Aggregator Device)
[    0.044467] ACPI: Added _OSI(Linux-Dell-Video)
[    0.053696] ACPI: 4 ACPI AML tables successfully acquired and loaded
[    0.053771] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKD (20180531/dspkginit-414)
[    0.053871] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKH (20180531/dspkginit-414)
[    0.053965] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKD (20180531/dspkginit-414)
[    0.054057] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKC (20180531/dspkginit-414)
[    0.054147] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKA (20180531/dspkginit-414)
[    0.054237] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKG (20180531/dspkginit-414)
[    0.054327] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKA (20180531/dspkginit-414)
[    0.054418] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKB (20180531/dspkginit-414)
[    0.054509] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKC (20180531/dspkginit-414)
[    0.054601] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKD (20180531/dspkginit-414)
[    0.054693] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKA (20180531/dspkginit-414)
[    0.054805] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKA (20180531/dspkginit-414)
[    0.054898] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKB (20180531/dspkginit-414)
[    0.055038] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKC (20180531/dspkginit-414)
[    0.055175] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKD (20180531/dspkginit-414)
[    0.055327] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKB (20180531/dspkginit-414)
[    0.055465] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKC (20180531/dspkginit-414)
[    0.055604] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKD (20180531/dspkginit-414)
[    0.055743] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKA (20180531/dspkginit-414)
[    0.055895] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKC (20180531/dspkginit-414)
[    0.056029] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKD (20180531/dspkginit-414)
[    0.056167] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKA (20180531/dspkginit-414)
[    0.056304] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKB (20180531/dspkginit-414)
[    0.056456] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKD (20180531/dspkginit-414)
[    0.056600] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKA (20180531/dspkginit-414)
[    0.056740] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKB (20180531/dspkginit-414)
[    0.056878] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKC (20180531/dspkginit-414)
[    0.057031] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKF (20180531/dspkginit-414)
[    0.057170] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKG (20180531/dspkginit-414)
[    0.057307] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKH (20180531/dspkginit-414)
[    0.057444] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKE (20180531/dspkginit-414)
[    0.057582] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKE (20180531/dspkginit-414)
[    0.064763] ACPI: Dynamic OEM Table Load:
[    0.064780] ACPI: SSDT 0x00000000F551E000 000203 (v02 PmRef  Cpu0Ist  00003000 INTL 20050624)
[    0.065479] ACPI: Dynamic OEM Table Load:
[    0.065497] ACPI: SSDT 0x00000000F540B800 0006A5 (v02 PmRef  Cpu0Cst  00003001 INTL 20050624)
[    0.066791] ACPI: Dynamic OEM Table Load:
[    0.066804] ACPI: SSDT 0x00000000F55C2900 0000D4 (v02 PmRef  Cpu1Ist  00003000 INTL 20050624)
[    0.067194] ACPI: Dynamic OEM Table Load:
[    0.067206] ACPI: SSDT 0x00000000F54CD000 000085 (v02 PmRef  Cpu1Cst  00003000 INTL 20050624)
[    0.068087] ACPI: EC: EC started
[    0.068090] ACPI: EC: interrupt blocked
[    0.069651] ACPI: \_SB_.PCI0.LPC0.H_EC: Used as first EC
[    0.069658] ACPI: \_SB_.PCI0.LPC0.H_EC: GPE=0x11, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.069663] ACPI: \_SB_.PCI0.LPC0.H_EC: Used as boot DSDT EC to handle transactions
[    0.069665] ACPI: Interpreter enabled
[    0.069732] ACPI: (supports S0 S3 S4 S5)
[    0.069736] ACPI: Using IOAPIC for interrupt routing
[    0.069825] PCI: Ignoring host bridge windows from ACPI; if necessary, use "pci=use_crs" and report a bug
[    0.070389] ACPI: Enabled 10 GPEs in block 00 to 1F
[    0.088941] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-3f])
[    0.089135] ACPI BIOS Error (bug): Failure creating [\_SB.PCI0._OSC.CAPB], AE_ALREADY_EXISTS (20180531/dsfield-179)
[    0.089287] ACPI Error: Method parse/execution failed \_SB.PCI0._OSC, AE_ALREADY_EXISTS (20180531/psparse-516)
[    0.102138] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 10 *11 12 14 15)
[    0.102333] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 *4 5 6 7 10 11 12 14 15)
[    0.102522] ACPI: PCI Interrupt Link [LNKC] (IRQs *3 4 5 6 7 10 11 12 14 15)
[    0.102712] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 *10 11 12 14 15)
[    0.102912] ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
[    0.103113] ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
[    0.103313] ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 *7 10 11 12 14 15)
[    0.103513] ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 *5 6 7 10 11 12 14 15)
[    0.104717] ACPI: EC: interrupt unblocked
[    0.104751] ACPI: EC: event unblocked
[    0.104771] ACPI: \_SB_.PCI0.LPC0.H_EC: GPE=0x11, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.104777] ACPI: \_SB_.PCI0.LPC0.H_EC: Used as boot DSDT EC to handle transactions and events
[    0.105011] PCI: Using ACPI for IRQ routing
[    0.146779] pnp: PnP ACPI init
[    0.147935] system 00:00: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.148099] pnp 00:01: Plug and Play ACPI device, IDs PNP0b00 (active)
[    0.148230] pnp 00:02: Plug and Play ACPI device, IDs PNP0303 (active)
[    0.148315] pnp 00:03: Plug and Play ACPI device, IDs PNP0f13 (active)
[    0.149240] pnp: PnP ACPI: found 4 devices
[    6.406354] ACPI: Thermal Zone [TZ00] (53 C)
[    8.693753] ACPI: Lid Switch [LID0]
[    8.695216] ACPI: Power Button [PWRB]
[    8.698362] ACPI: Sleep Button [SLPB]
[    8.703012] ACPI: Power Button [PWRF]
[    8.705469] ACPI: AC Adapter [ADP1] (on-line)
[    8.785045] ACPI: Battery Slot [BAT1] (battery present)
[    8.911228] ACPI: bus type USB registered
[    9.394810] ACPI: Video Device [IGD0] (multi-head: yes  rom: no  post: no)
 

..:: 0 ::..

Vie, 02/11/2018 - 18:29
zero
Imagen de zero
Desconectado/a
se unió: 31/10/18

Finalmente despues de probarlo todo me quedo con loglevel=3  plymouth y la debian mas bonita que jamás he instalado. La única opción que me quedaba era editar las instrucciónes ACPI 

https://www.kernel.org/doc/Documentation/acpi/initrd_table_override.txt

 

pero es algo que se todavía se me escapa. Gracias por la ayuda si encontrara alguna solución la añado al tema.

 

 

..:: 0 ::..