NetworkManager no detecta la tarjeta de red inalámbrica

16 envíos / 0 nuevos
Último envío
#1 Mié, 09/03/2016 - 16:51
esbrinartot
Imagen de esbrinartot
Desconectado/a
se unió: 28/02/16

NetworkManager no detecta la tarjeta de red inalámbrica

Hoy en testing se han actualizado varios paquetes de networkmanager. 

Después de la actualización NetworkManager ha dejado de reconocer mi tarjeta inálambrica, así que ahora solo me puedo conectar a través de cable y esto para mi es un problema.

Parece que Network manager no levanta la interfaz Wlan0

El resultado de iwconfig es:

sudo ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.129  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 ------------------  prefixlen 64  scopeid 0x20<link>
        ether --------  txqueuelen 1000  (Ethernet)
        RX packets 2080  bytes 1127429 (1.0 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2155  bytes 549563 (536.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 192  bytes 15552 (15.1 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 192  bytes 15552 (15.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

El resultado de iwconfig es:

eth0      no wireless extensions.

wlan0     unassociated  Nickname:"rtl_wifi"
          Mode:Auto  Access Point: Not-Associated   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

La configuración de network manager es:

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

Puedo levanta la red haciedno un 

sudo ifconfig wlan0 up

y usando

sudo iwlist wlan0 scan

Puedo escanear los puntos de acceso inálambrico... Pero Networkmanager no los detecta... ni levanta wlan0 cuando inicia.
 

Llebo ya tiempo intentando solucionar esto... Pero no lo consigo 

Mié, 09/03/2016 - 17:27
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

¿Te fijaste si networkmanager esta activo ??

¿intentaste reinstalarlo ? 

Mié, 09/03/2016 - 17:49 (Responder a #2)
esbrinartot
Imagen de esbrinartot
Desconectado/a
se unió: 28/02/16

La respuesta es que si en ambos casos. He realizado un remove purge de los paquetes network-manager y network-manager.gnome

con el comando systemctl status NetworkManager.service obtengo resultados que pueden dar pistas. Son los siguientes

wlan0: driver does not support SSID scans (scan_capa 0x00)

wlan0: Using next for wifi dedice control.

 

 

Mié, 09/03/2016 - 19:26
kamikaze
Imagen de kamikaze
Desconectado/a
colaborador
se unió: 04/03/16

  Hola

 Tambien estoy en Testing usando Gnome, y sin problemas, mira que en "/etc/network/interfaces" solo este la interfaz local activa

# The loopback network interface
auto lo
iface lo inet loopback

 Si tienes algo mas comentalo. Ya que si tienes alguna otra configurada manualmente aqui, prevalece, sin hacer caso a lo que este puesto en Network-Manager.

 Por otro lado, date una vuelta por la herramienta grafica "Dispositivos - Herramientas de Red" de Gnome y mira que en tu interfaz Wifi este todo correcto.

  Un Saludo

Mié, 09/03/2016 - 19:38 (Responder a #4)
esbrinartot
Imagen de esbrinartot
Desconectado/a
se unió: 28/02/16

en "/etc/network/interfaces" tengo exactamente lo mismo que tu tienes.

en la herramienta de gnome no me aparece nada de la interfaz wifi porque como he dicho antes no se levanta.Si la levanto manualmente tampoco me aparece alli

Jue, 10/03/2016 - 11:44
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

No sea cosa que systemd-networkd esté activado y por eso Networkmanager no esté manejando las configuraciones

¿que te tira el siguiente comando?

systemctl status systemd-networkd.service

saludos...

Jue, 10/03/2016 - 12:00
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Yo creo que la configuracion de networkmanager.conf  debe llevar 

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=True  ##  no false

Luego configurar cada conexión .

No uso Networkmanager para gestionar mis redes, asi que bien puedo estar errado,nada cuesta con intentarlo ,

Por cierto ¿es una pc de escritorio o una portátil ?

Jue, 10/03/2016 - 17:20 (Responder a #7)
esbrinartot
Imagen de esbrinartot
Desconectado/a
se unió: 28/02/16

El  resultado que me da es el siguiente:

 

systemctl status systemd-networkd.service
● systemd-networkd.service - Network Service
   Loaded: loaded (/lib/systemd/system/systemd-networkd.service; disabled; vendo
   Active: inactive (dead)
     Docs: man:systemd-networkd.service(8)
lines 1-4/4 (END)...skipping...
● systemd-networkd.service - Network Service
   Loaded: loaded (/lib/systemd/system/systemd-networkd.service; disabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:systemd-networkd.service(8)

si lo arranco de forma manual me deja arrancarlo. Lo he arrancado y he reiniciado NetworkManager y de momento todo sigue igual. (Me hace lo mismo que hacia)

Jue, 10/03/2016 - 17:43
esbrinartot
Imagen de esbrinartot
Desconectado/a
se unió: 28/02/16

Ya cansado con el tema estoy usando Wicd. Wicd me funciona así que se quedará y veremos como funciona.

¿Alguien sabe los paquetes que deberia desinstalar para desacerme completamente de NetworkManager? ¿O que comando usar para ello?

Jue, 10/03/2016 - 20:19
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

esbrinartot no se si te fijaste lo que te marcaba caliban. en /etc/NetworkManager/NetworkManager.conf la configuración debería ser true y no false como ponías en la info.

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=true

Con respecto a tu ultima pregunta entiendo que seria suficiente purgando network-manager y network-manager-gnome, pero podría ser útil ejecutar un apt-get autoremove para eliminar algún paquete que se haya instalado junto con networkmanager 

Jue, 10/03/2016 - 20:50
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Pues parece que hay un par de bugs reportados que pueden tener algo que ver con lo que te pasa. Network Manager está teniendo algún problema que otro con ciertas wifis de alguna que otra marca (parece que con BCM se presenta bastante)... No estaría de más saber que hardware tienes para comprobar eso (hay uno que incluso se arregla ejecutando reiniciando el servicio, ya que detecta mal la wifi al inicio confundiendola con una ethernet), y el error que te aparece simple y llanamente dice que el dispositivo no soporta el escaneo de SSID (lo que no soporta una ethernet, vamos, la busqueda de redes wifi). https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=817123

 

Por otra parte, en el archivo de configuración, yo tengo puesto Managed=false desde hace eones y no tengo problemas, en realidad los problemas los tiene si se encuentra la interfaz definida en /etc/network/interfaces, que es cuando network-manager deja de gestionarla

  No hay bar que por bien no venga....
Jue, 10/03/2016 - 21:04
esbrinartot
Imagen de esbrinartot
Desconectado/a
se unió: 28/02/16

Rocky: Probé lo que me recomendo Caliban. No funciono

Me temos que es lo que dice panco. En mi caso he visto mensajes de que "No soporta el escaneo". También en iwconfig y en ifconfig en wlan0 he visto la palabra ethernet.

En mi caso la tarjeta wifi que tengo es:

Bus 005 Device 004: ID 0bda:8171 Realtek Semiconductor Corp. RTL8188SU 802.11n WLAN Adapter

 Wicd me funciona bien. Solo tiene la pega que no te permite conectar a VPN's. He probado KVpnc pero no me funciona. No se si hay mas alternativas.

Vie, 11/03/2016 - 13:34 (Responder a #12)
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

¿has probado a reiniciar el servicio? Tal y como dicen en el reporte que enlacé, a alguien se le soluciona con solo reiniciar el servicio una vez ha iniciado el sistema: sudo systemctl restart network-manager.service

  No hay bar que por bien no venga....
Vie, 11/03/2016 - 18:15 (Responder a #13)
esbrinartot
Imagen de esbrinartot
Desconectado/a
se unió: 28/02/16

Sí. Lo probé y no me funciono. También borre y volví a instalar Networtk-manager

Voy a usar durante una termporada Wicd. Con Wicd además se han terminado los problemas con dnsmasq. Actualmente network-manager está en la versión 1.1.91-1. Dentro de un tiempo volveré a a probar a ver que tal y si encuentro una solución para los vpn Wicd ya va bien. 

 

Lun, 14/03/2016 - 06:18
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Por si interesa https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=817115

bug corregido. suponiendo que sea al final el que te afecta.

  No hay bar que por bien no venga....
Mié, 04/05/2016 - 22:40
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

No era necesario eliminar network-manager, solo con desactivar el *.service via systemctl sería suficiente. Para posteriormente hacer un systemctl start connman.service - systemctl enable connman.service, p.e.

Yo conservo ambos por las dudas.

Saludos.