No inicia debian 9 xorg server-xorg

15 envíos / 0 nuevos
Último envío
#1 Dom, 01/04/2018 - 17:04
Pablo
Imagen de Pablo
Desconectado/a
se unió: 01/01/18

No inicia debian 9 xorg server-xorg

hola
iva bien con debian hasta que me llego la ultima actualizacion de seguridad, cuando inicio debian me sale https://www.facebook.com/pablo.criscuolo/videos/10214373022452702/?l=6306136529851546335 

/dev/sdb1: Superblock last mount time is in the future........ (1)

/deb/sdb1: clean, 31.................. files, 27....... blocks          (2)

[   3.59......]    [drm:radeon_pci_probe [radeon]] *ERROR radeon ................. requires firmware-and-graphics.   (3)

[4.55..........] r8169 .............. : firmware:failed to load rtl_nic.................    (4)

(1) el reloj esta fuera de hora...no lo entiendo por que mando time a consola y me aparece la hora actual

(2) nada

(3) el mismo problema de siempre

(4) son 2 controladores viejos de antena externa para wifi (uno por usb y otro directo), no entiendo por que pero reinstalo 1 y 100 veces debian y me aparece siempre

de ahi va a consola sin poder cargar graficos entorno (gnome) nada
si pongo startx

https://www.facebook.com/pablo.criscuolo/videos/10214372989651882/?l=9003038742976816185

aborta.....[KMS] drm report modesetting isn't supported
xinit:connection to X  server........

de ahi quiero restaurar xorg, nada remove purge install y nada

xorg-server nada, lo hice como 20 veces

supuestamente la idea es que es automatico, o sea, desistalo instalo update y se configura solo, la cuestion es que siempre vuelvo a consola

alguna sugerencia, gracias

Dom, 01/04/2018 - 17:14
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

¿Asumís que todo el mundo tiene facebook para ver lo que subiste? 

Dom, 01/04/2018 - 17:40
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

si tenes problemas para iniciar en modo gráfico y no podes pegar el contenido del comando lshw -short podes usar pasteblin

inicias y en la pantalla de login apretas CTRL+Alt+F1 y entras a una tty luego te logues como usuario y pones:

su
apt update && apt install pastebinit lshw 

luego ejecutas

lshw -short | pastebinit

copia la url y pegala aca

También ejecuta y pega la url de

journalctl -b -p err | pastebinit
ls -l /etc/X11/
ls -l /etc/X11/xorg.conf.d/
cat /etc/apt/sources.list

 

seria bueno que comentes que escritorio estas usando y si instalaste firmware-and-graphics

por sobre todo no desinstales ningun xorg*

saludos...

Dom, 01/04/2018 - 19:27
Pablo
Imagen de Pablo
Desconectado/a
se unió: 01/01/18

¿Asumís que todo el mundo tiene facebook para ver lo que subiste? 

no..... asumo que en facebook puedo guardar una foto y publicarla, tengas o no facebook, o sea, me garantiza que los demas la puedan ver (dado que me rompi la cabeza subiendo fotos a https://es.imgbb.com/ la mando en el icono Imagen pego la url y naaaaaaaaaaaa), no problem, la proxima google facepopular... o buscare un simill de facebook en china

lshw -short | pastebinit

http://paste.debian.net/1018048/

journalctl -b -p err | pastebinit

http://paste.debian.net/1018049/

ls -l /etc/X11/

http://paste.debian.net/1018050/

ls -l /etc/X11/xorg.conf.d/

http://paste.debian.net/1018051

cat /etc/apt/sources.list

http://paste.debian.net/1018053/

firmware-and-graphics

no tiene un candidato para la instalacion....ya le busco 1

Debian me odia.....

Dom, 01/04/2018 - 20:39
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

(1) problemas de configuración de la hora ¿es un sistema con arranque dual? Si es así, poco has buscado, tema tratado ya en el foro

(2) es normal, viene provocado por el error anterior.

(3) te falta algún firmware o actualización del controlador radeon  (no, firmware-and-graphics no existe, imagino que se refiere a "firmware-amd-graphics" (lo dice bien claro en la salida de journalctl -b  -p err, pero veo que era mas cool escribir el error como a ti te parece en lugar de como aparece)).

(4) no es ningún controlador wifi viejo para antenas externas, es un firmware faltante de la placa de red ethernet (también dice cual és en el error de la salida de journalctl -b -p err). Para tu información, posiblemente sea el paquete firmware-realtek. Este paquete no contiene firmwares solo para wifi, también para ethernet y bluetooth, y la misma ruta del archivo ya indica casi con toda certeza de que se trata del firmware de la tarjeta ethernet y no de una wifi  o un bluetooth.

(5) y  este lo pongo yo. "[KMS] drm report modesetting isn't supported". Otro error que te dice claramente lo que ocurre. Soluciona primero el (3) con la instalación del paquete correcto a ver si se arregla y si no, una simple búsqueda indicará como añadir modeset=0 a las opciones de arranque o a las opciones del módulo correspondiente a la gráfica (tema ya también tratado aquí y largamente en la red en general). El archivo 20-fglrx.conf.back imagino que era la configuración del antiguo driver fglrx y que ya no lo necesitas y por eso lo renombraste.

(6) También mío. No, no todos usan/tienen facebook, y hay miles de servicios para subir imágenes, ya sea con registro y o sin registro, y ya sea permanentemente o temporalmente, poco te has molestado en buscar...

 

Para mi, que si hubieras colocado los errores bien en el primer post y no como se te ha ocurrido, se habrían visto de primeras, ya que yo mismo los he intuido antes de que pusieras la salida del comando que se te ha pedido. De verdad ¿con 10 publicaciones en este foro sin contar las 2 de este hilo no te has leído siquiera por encima las normas?

 

 

  No hay bar que por bien no venga....
Dom, 01/04/2018 - 21:47
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

sobre el tema del sources.list dejalo de la siguiente manera:

# deb cdrom:[Debian GNU/Linux 9.3.0 _Stretch_ - Official amd64 NETINST 20171209-12:10]/ stretch main

# stretch-oficiales
deb http://deb.debian.org/debian/ stretch main contrib non-free
deb-src http://deb.debian.org/debian/ stretch main contrib non-free

# stretch-actualizaciones-seguridad
deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free

# debian-multimedia
deb http://www.deb-multimedia.org stretch main non-free

# stretch-backports
deb http://httpredir.debian.org/debian stretch-backports main contrib non-free

El repositorio de stretch-backports es optativo pero te puede servir para tener algunos programas, firmware y controladores más modernos.

una vez modificado el sources.list es necesario que actualices haciendo un apt update, apt upgrade y un apt full-upgrade luego instala como te dijo panko los paquetes firmware-amd-graphics y firmware-realtek posiblemtne tengas que utilizar el comando apt install --reinstall paquete

una vez instalado el driver de amd controla que en /etc/X11/xorg.conf.d/ tengas un archivo 20-fglrx.conf más el archivo de 20-fglrx.conf.back el cual podrias eliminar con el comando rm

con eso tendrias que poder entrar en la sesión gráfica nuevamente

saludos...

 

 

 

Lun, 02/04/2018 - 20:11
Pablo
Imagen de Pablo
Desconectado/a
se unió: 01/01/18

hola otra vez

gracias por contestar rockyiii

el repositorio listo, apt update...nada (0 0 0) apt upgrade nada apt full-upgrade nada

instale los 2 paquetes indicados sin problema

apt update nada

el archivo 20-fglrx.conf en el directorio  /etc/X11/xorg.conf.d/ no existe si en cambio el archivo de 20-fglrx.conf.back

a lo que tengo 3 opciones

le saco el .back al que esta y veo como explota (no creo q sea la mejor)

https://wiki.debian.org/es/ATIProprietary

Configuración

Como el controlador fglrx no es detectado automáticamente por Xorg, se debe crear un archivo de configuración. Por ejemplo:

/etc/X11/xorg.conf.d/20-fglrx.conf

Section "Device"

............Identifier "My GPU"

............Driver "fglrx" EndSection

<<<<<<<<<lo edito

El archivo de configuración anterior puede ser creado usando los siguientes comandos:

# mkdir /etc/X11/xorg.conf.d # echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "fglrx"\nEndSection' > /etc/X11/xorg.conf.d/20-fglrx.conf

<<<<<<<<<lo creo

voy bien?? te agradezco tu opinion

como dato problemas (1) y (2) persisten y me queda una mension que hace a radeon por ahi pero que no aparece al inicio sino que al tiempo casi al mismo momento que salgo de esa pantalla y va a login lo que me hace dificil firmarla con el celular... el resto ya no figura

pd: al cerrar debian me tira un error "failed unmounting /var" pero lei (https://unix.stackexchange.com/questions/378678/why-do-i-get-the-error-failed-unmounting-var-during-shutdown) y no creo que tenga que ver con el tema, lo pongo solo para no dejar huecos

Debian me odia.....

Lun, 02/04/2018 - 20:29
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

ejecuta un

su
apt install --reinstall firmware-amd-graphics firmware-realtek

 

Lun, 02/04/2018 - 21:07
Pablo
Imagen de Pablo
Desconectado/a
se unió: 01/01/18

lo hice, el resultado es el mismo, si mando startx aborta

el archivo 20-fglrx.conf en el directorio  /etc/X11/xorg.conf.d/ no aparece

Debian me odia.....

Mar, 03/04/2018 - 05:42
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Pues...  volvemos a lo mismo...

inicias hasta que "explota", pulsas CTRL + ALT + F2 y te identificas con tu usuario y contraseña en la consola, ejecutas

journalctl -b -p err |pastebinit
journalctl -b |grep -i radeon |pastebinit
lspci -k |pastebinit

y con esto podremos conocer el estado del sistema en ese momento y el controlador que asigna a cada dispositivo, y la detección de tu tarjeta gráfica.

 

  No hay bar que por bien no venga....
Mié, 04/04/2018 - 22:49
Pablo
Imagen de Pablo
Desconectado/a
se unió: 01/01/18

journalctl -b -p err |pastebinit

htto://paste.debian.net/1018720/

journalctl -b |grep -i radeon |pastebinit

htto://paste.debian.net/1018721/

lspci -k |pastebinit

htto://paste.debian.net/1018722/

Debian me odia.....

Jue, 05/04/2018 - 00:04 (Responder a #11)
gacs
Imagen de gacs
Conectado
colaborador
se unió: 21/04/16

Pablo wrote:

journalctl -b -p err |pastebinit

http://paste.debian.net/1018720/

journalctl -b |grep -i radeon |pastebinit

http://paste.debian.net/1018721/

lspci -k |pastebinit

http://paste.debian.net/1018722/

corrijo los link

 Saludos

 

Vie, 06/04/2018 - 15:01
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Pues.... no se si será cosa de drivers desactualizados o que. El error que aparede de radeon, por lo que veo por ahí es algo que no debería afectar a su funcionamiento, el driver se asigna a la gráfica y carga los firmwares correctamente. La verdad, no tengo ni idea de lo que te pasa, y al no tener una radeon como  esa no puedo ayudarte más. Te toca esperar que alguien en tu mismo caso vea esto y sepa algo más al respecto, o empezar a buscar por la red a ver si encuentras algo... sorry.

Si quieres probar una cosa a ver si sonara la flauta... Crea el archivo /etc/modprobe.d/radeon.conf y dentro le metes

options radeon modeset=0

lo guardas, ejecutas, también como root

update-initramfs -u -k all

para que se incorporen a la imagen del kernel los cambios y reinicias a ver que pasa.

Si no consigues que funcione con esto, elimina ese archivo, vuelve a ejecutar el comando anterior y reinicia el sistema, dándole a la 'e' cuando te aparezca grub para editar la entrada y añades a la línea de arranque, antes de quiet splash, el parámetro radeon.modeset=0 y pulsas f10 para que arranque con ese parámetro a ver si hay suerte.

 

  No hay bar que por bien no venga....
Dom, 08/04/2018 - 00:07
Pablo
Imagen de Pablo
Desconectado/a
se unió: 01/01/18

mala suerte
creo el archivo y lo cargo

ejecuto

update-initramfs -u -k all

sale
update-initramfs: Generating /boot/initrd.img-4.9.0-6-amd64

update-initramfs: Generating /boot/initrd.img-4.9.0-5-amd64

mando startx...lo mismo

reinicio me sale lo del reloj Superblock ......... y /dev/sdb1: clean......' invalid for parameter 'modeset'

elimino el archivo ejecuto el mismo comando sale lo mismo

update-initramfs: Generating /boot/initrd.img-4.9.0-6-amd64

update-initramfs: Generating /boot/initrd.img-4.9.0-5-amd64

y queda igual ...reinicio el sistema.... lo mismo la cosa del reloj../dev/sdb1:..... files y blocks (nada mas)....y radeon 0000:08:00.0: Invalid PCI ROM header signature e.. 0xaa55, got 0xffff

intente lo del grub ....antes de quiet splash (debo tener la maquina mas atravesada del debian) pero no lo vi asi que lo mande en la 1 linea despues de "setparams... (mando foto)

me sale el mismo error

lo del reloj Superblock ......... y /dev/sdb1: clean......' invalid for parameter 'modeset'

voy a ver si puedo sacarle algun error...el del reloj o el q sea
sino reinstalo debian...sin tocar home por q pierdo todo lo q tengo y despu montare el home y recupero todo mi trabajo...espero

Debian me odia.....

Dom, 08/04/2018 - 03:55
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

La línea a la que tienes que añadir ese parámetro es la que empieza por

linux   /boot/vmlinuz....

si no tiene "quiet splash", simplemente añades lo que te dije al final de la misma y pruebas a iniciar.

Lo del reloj, ya te lo dije y no contestaste si era un sistema con arranque dual o no (es la principal causa de ese error, inconsistencias en la forma de tratar el reloj del sistema entre ambos sistemas).

Reinstalar debian, no creo que te sirva de mucho, a lo mejor para evitar el problema del reloj y que te haga el fsck a cada inicio...

Y, ahora que pienso... si todo esto viene tras alguna actualización, en algún sitio tiene que haber un log de la misma... así que estaría bien saber como la hiciste para decirte que log buscar y saber lo que se actualizó y pasó durante la misma.

 

P.D.: Otra vez poniendo las cosas como quieres?

lo del reloj Superblock ......... y /dev/sdb1: clean......' invalid for parameter 'modeset'

si tu crees que eso es una forma de ponernos un error que te ha dado el sistema, vamos por buen camino... poca ayuda acabarás recibiendo si no sigues las simples normas que se indican en el foro, la verdad.

Añun así, me gustaría saber como has puesto lo de modeset para que te diga que es un parámetro inválido, cuando el mismo módulo me está diciendo que si forma parte de los que utiliza, tal y como me cuanta la salida del comando modinfo radeon:

parm:           modeset:Disable/Enable modesetting (int)

asi que modeset=1 (activado) o modeset=0 (desactivado) no es un parámetro incorrecto, o funciona en el archivo, o funciona añadiendolo al arranque como te he dicho...

  No hay bar que por bien no venga....