Nvidia GT218 en Debian GNU/Linux buster/sid falla de video al instalar driver privativos

9 envíos / 0 nuevos
Último envío
#1 Dom, 09/07/2017 - 22:01
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

Nvidia GT218 en Debian GNU/Linux buster/sid falla de video al instalar driver privativos

Estado: 
[SOLUCIONADO]

Estaba utilizando el controlador nouveau, aunque me daba un error no miraba la necesidad de instalar controlador privativo ya que tenia imagen pero he visto que de repente tengo parpadeo en la pantalla que son algo molesto además que no veo que tenga un mejor rendimiento teniendo la tarjeta de video nvidia que la que viene en la placa.

Este es fallo que me da nouveau

journalctl -b -p err                                 
-- Logs begin at Sun 2017-07-09 14:56:01 CST, end at Sun 2017-07-09 18:19:15 CST. --
jul 09 14:56:04 pcgacs kernel: nouveau 0000:01:00.0: bios: OOB 1 01452301 01452301
jul 09 14:56:04 pcgacs kernel: nouveau 0000:01:00.0: bios: OOB 1 222349ed 222349ed
jul 09 14:56:04 pcgacs kernel: nouveau 0000:01:00.0: bios: OOB 1 222349ed 222349ed
jul 09 14:56:04 pcgacs kernel: nouveau 0000:01:00.0: bios: OOB 1 222349ed 222349ed

Escritorio que estoy utilizando

Kde plasma 5.8.7

Qt version : 5.7.1

Linux 4.11.0-1-amd64 #1 SMP Debian 4.11.6-1 (2017-06-19) x86_64 GNU/Linux

Anteriormente utilizaba cinnamon y el mismo problema tenia, intente instalar el controlador privativo  xserver-xorg-video-nvidia-legacy-340xx , bueno digo que es el que le corresponde por la salida que me da aptitude show, por que nvidia-detect no detecto nada

 

# nvidia-detect
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218 [GeForce 8400 GS Rev. 3] [10de:10c3] (rev a2)

Checking card:  NVIDIA Corporation GT218 [GeForce 8400 GS Rev. 3] (rev a2)
Uh oh. Failed to identify your Debian suite.
#aptitude show xserver-xorg-video-nvidia-legacy-340xx 

Paquete: xserver-xorg-video-nvidia-legacy-340xx  
Versión: 340.102-2
Estado: sin instalar
Sección: non-free/x11
Desarrollador: Debian NVIDIA Maintainers <pkg-nvidia-.........
 GPUs: GeForce 205 [GT218], GeForce 210 [GT216], GeForce 210 [GT218],
 GeForce 305M [GT218M], GeForce 310 [GT218], GeForce 310M [GT218M], GeForce 315 [GT216], GeForce 315 [GT218], GeForce 315M [GT218M],
 GeForce 320M [MCP89], GeForce 405 [GT216], GeForce 405 [GT218], GeForce 8100 / nForce 720a [C77], GeForce 8200 [C77], GeForce 8200M [C77],
 GeForce 8200M G [C77], GeForce 8200M G [MCP79], GeForce 8300 [C77], GeForce 8300 GS [G84], GeForce 8300 GS [G86], GeForce 8300 GS [G98],
 GeForce 8400 [G98], GeForce 8400 GS [G84], GeForce 8400 GS [G86], GeForce 8400 GS Rev. 2 [G98], GeForce 8400 GS Rev. 3 [GT218], GeForce
 8400 SE [G86], GeForce 8400M G [G86M], GeForce 8400M GS [G86M], ........

Lo que he podido encontra que desde la versión 4.10 del nucleo, nouveau esta enviando ese mensaje de error , y que la solucion seria instalar los privativos, mientra sale el nucleo 4.12 que donde ya esta solucion, pero no he podido hacer que me funcione los privativos con el nucleo 4.11 que esta en sid.

Las dos veces que intente instalar el controlador privativo pues tuve que reinstalar el sistema y en otra conectar otro monitor al video integrado en la placa base para poder accesar a un tty y purgar toda la instalacion del controlador privativo. 

Asta el momento eso he podido hacer pero no he solucionado por lo que solicito su ayuda para que me indique por donde buscar para resolver. gracia de antemano

Lun, 10/07/2017 - 10:52
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

De momento, ¿sabes que privativos necesitas? porque nvidia-detect no te lo ha dicho...

asi que instalar sin ton ni son  un driver de nvidia no te va a solucionar nada. Voy a ver para tu nvidia, que te hace falta.

 

Vale, ya veo que habías acertado con el necesario

como dije en otro hilo hace nada:

aptitude install xserver-xorg-video-nvidia-legacy-340xx nvidia-legacy-340xx-kernel-dkms

echo -e "blacklist nouveuau" > /etc/modprobe.d/blacklist-nouveau.conf

Luego comprueba que no tengas ningun /etc/X11/xorg.conf que haga referencia a la configuración de tu gráfica ni un archivo en la ruta /etc/X11/xorg.conf.d/ que haga referencia a ella. Si los tienes, renombralos con una extensión .bak y reinicia el sistema. El mismo debería detectar que nouveau está en la blacklist para no usarlo y que el correcto a usar es el driver nvidia, que te funcionará sin configuración alguna necesaria.

 

P.D.: la salida del comando lspci -k completa no nos vendría mal para ver que hardware tienes y que está usando.

P.D.2: No es la 1ª, ni la 2ª, ni la 3ª, ni la... que se dice lo mismo en el foro... que ya llevas un tiempecito por aqui hombre!

  No hay bar que por bien no venga....
Lun, 10/07/2017 - 12:11 (Responder a #2)
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

Panko wrote:

como dije en otro hilo hace nada:

aptitude install xserver-xorg-video-nvidia-legacy-340xx nvidia-legacy-340xx-kernel-dkms echo -e "blacklist nouveuau" > /etc/modprobe.d/blacklist-nouveau.conf

P.D.: la salida del comando lspci -k completa no nos vendría mal para ver que hardware tienes y que está usando.

P.D.2: No es la 1ª, ni la 2ª, ni la 3ª, ni la... que se dice lo mismo en el foro... que ya llevas un tiempecito por aqui hombre!

Que paso sensai no quiso leer mi post xdd,  la información del hardware la detalle donde  dice Información técnica, pensé que había puesto asta información de mas pero ahorita pongo esa salida que no la sabia soy sincero en decirle, por otro lado como escribí en el primer comentario ya intente de varias maneras incluyendo la del hilo anterior, de echo probé de dos maneras  lo del blacklist por que pensé que era algún dedazo " nouveuau"

#echo -e "blacklist nouveuau" > /etc/modprobe.d/blacklist-nouveau.conf

y

#echo -e "blacklist nouveau" > /etc/modprobe.d/blacklist-nouveau.conf
lspci -k
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
        Subsystem: ASRock Incorporation 2nd Generation Core Processor Family DRAM Controller
        Kernel driver in use: snb_uncore
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
00:02.0 Display controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
        Subsystem: ASRock Incorporation 2nd Generation Core Processor Family Integrated Graphics Controller
        Kernel driver in use: i915
        Kernel modules: i915
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
        Subsystem: ASRock Incorporation 6 Series/C200 Series Chipset Family MEI Controller
        Kernel driver in use: mei_me
        Kernel modules: mei_me
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
        Subsystem: ASRock Incorporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller
        Kernel driver in use: ehci-pci
        Kernel modules: ehci_pci
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
        Subsystem: ASRock Incorporation 6 Series/C200 Series Chipset Family High Definition Audio Controller
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
        Subsystem: ASRock Incorporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller
        Kernel driver in use: ehci-pci
        Kernel modules: ehci_pci
00:1f.0 ISA bridge: Intel Corporation H61 Express Chipset Family LPC Controller (rev 05)
        Subsystem: ASRock Incorporation H61 Express Chipset Family LPC Controller
        Kernel driver in use: lpc_ich
        Kernel modules: lpc_ich
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family SATA AHCI Controller (rev 05)
        Subsystem: ASRock Incorporation 6 Series/C200 Series Chipset Family SATA AHCI Controller
        Kernel driver in use: ahci
        Kernel modules: ahci
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
        Subsystem: ASRock Incorporation 6 Series/C200 Series Chipset Family SMBus Controller
        Kernel driver in use: i801_smbus
        Kernel modules: i2c_i801
01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 8400 GS Rev. 3] (rev a2)
        Subsystem: eVga.com. Corp. GT218 [GeForce 8400 GS Rev. 3]
        Kernel driver in use: nouveau
        Kernel modules: nouveau
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
        Subsystem: eVga.com. Corp. High Definition Audio Controller
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 02)
        Subsystem: ASRock Incorporation Motherboard (one of many)
        Kernel driver in use: r8169
        Kernel modules: r8169
lspci -k | grep -A 2 -i "VGA"
01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 8400 GS Rev. 3] (rev a2)
        Subsystem: eVga.com. Corp. GT218 [GeForce 8400 GS Rev. 3]
        Kernel driver in use: nouveau
        Kernel modules: nouveau
--
        Subsystem: eVga.com. Corp. High Definition Audio Controller
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel

 

también había comprobado lo del xorg.conf que en mi caso esta en /usr/share/X11/xorg.conf.d/ y no me instala nada referente a nvidia, antes de hacer el cambio de nucleo habia un archivo de nvidia que apuntaba a otro archivo que no recuerdo su ubicación pero después del cambio de núcleo ya no lo vi mas.

ls /usr/share/X11/xorg.conf.d/
10-amdgpu.conf  10-quirks.conf  10-radeon.conf  40-libinput.conf  70-wacom.conf

Como comente tengo video con un mensaje de error claro, además del parpadeo y mas cuando estoy viendo algún video.  note tambie que la tarjeta de video no le baja la carga al procesador.

gracias, por la ayuda que me brinden para resolver,

 Saludos

 

Lun, 10/07/2017 - 15:39
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

Listo

logre instalar los controladores y sin perder video solo cambie un poco el orden de las sentencia de Panko y agregue nvidia-xconfig al final de la instalación del controlador privativo,  los pasos serian asi:

#apt update
#apt upgrade
# echo -e "blacklist nouveau" > /etc/modprobe.d/blacklist-nouveau.conf
#apt install xserver-xorg-video-nvidia-legacy-340xx nvidia-legacy-340xx-kernel-dkms
#nvidia-xconfig

Veo un cambio en las aplicaciones de plasma con respecto al tamaño de la letra, las que son gtk que utilizo en kde pues no tuvieron ese cambio (firefox, netbeans,thunderbird ...) , asta conky sufrio cambio en el tamaño de la letra, las letras de los titulos de las ventanas sufrieron cambios también. la resolucion se mantiene como la tenia antes de instalar el driver privativo (1360x768) pero la calidad de la letra cambio 

# xrandr
Screen 0: minimum 8 x 8, current 1360 x 768, maximum 8192 x 8192
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1360x768+0+0 (normal left inverted right x axis y axis) 510mm x 287mm
   1280x720      60.00 +  59.94    50.00  
   1920x1080     59.94    50.00    60.05    60.00    50.04  
   1360x768      60.02* 
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00    50.08  
   720x480       59.94    60.05  
   640x480       59.94    59.93  

conforme al titulo de este post lo doy post solucionado. gracias

Agrego un pantallazo de como se ve deterioro la calidad de las letras de titulo de ventanas , en la aplicacion konsole y conky.

pantalla

 Saludos

 

Lun, 10/07/2017 - 16:12
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

solucione los de las letras activando, Forzando ppp lo de los tipos de letra, que se encuentra en la configuración de tipo de letras de Kde

gracias,

 Saludos

 

Lun, 10/07/2017 - 17:29
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

em....

tienes dos graficas, es un pc o una laptop?

eso me despisto, nvidia-xconfig juraría que no te hace falta para nada, si es un pc, lo que tienes que hacer es desactivar la integrada en la placa base en la bios, porque si te fijas, en tu lspci -k estabas aun usando nouveau, ahora debería salirte nvidia

Efectivamente, yo no tengo nvidia-xconfig instalado, nunca usé nvidia-settings... etc, y me han funcionado las nvidia. La diferencia es que la mia (aunque ahora es secundaria y no la uso, que esto es Optimus), funciona con el driver "normal", no con el legacy

pero me alegro de que ahora te vaya mejor.

Lo de blacklistear nouveuao, p.e., es simplemente porque es más comodo que desinstalarlo si en un futuro quieres seguir con él en lugar del privativo, basta con quitarlo de la blacklist y el sistema volverá a usarlo si lo cree conveniente.

P.D.: Soy mucho más partidario de usar lspci -k para ver el hardware que lswh --short, la verdad xD

 

P.D.: Si te fijas, el cambio de fuentes ha sido debido a la resolución, la salida de xrandr te está indicando que estás usando una menor a la que puede tu gráfica, no se si por falta de configuración, o por culpa del monitor. si antes te funcionaba a la máxima resolución (ahora estás en 1360 en lugar de 1920), mira por la config de tu sistema o como hacer un archivo en xorg.conf.d para que te deje usarla.

Por otro lado, la ruta /usr/share/X11/xorg.conf.d/ suelen ser ejemplos, y llevan opciones "comunes", incluso algunos no llevan ninguna que haga efecto, pero están ahi para que las veas. Digamos que tu copiarias ese archivo a la ruta que dije y a partir de ahi lo tomas como base para tu configuración.

Mírate lo de la resolución, que igual si te hace falta toquetear algo (no con nvidia-settings, por favor, eso es un cáncer), busca en la red.

 

P.D.otravez: lo de las veces y el tiempo que llevas tampoco era bronca, hombre, que ya casi nos empezamos a conocer xD, a veces es muy dificil que se note la ironía en el leguaje escrito xD

 

Edit

 

 

Lo de la resolución, lo tienes en la app systemsettings, en la parte de hardware, display, mira a ver si te deja ponerla mayor, y tendrás todo como tenías, cuando deshagas los cambios que hiciste para que se viera bien al haberte cambiado el tamaño de letras, que no siempre toma la mayor.

  No hay bar que por bien no venga....
Lun, 10/07/2017 - 20:11 (Responder a #6)
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

Panko wrote:

em....

tienes dos graficas, es un pc o una laptop?......

Mírate lo de la resolución, que igual si te hace falta toquetear algo (no con nvidia-settings, por favor, eso es un cáncer), busca en la red.......


 

Es una pc y tengo como tarjeta primaria la nvidia, pensando que me respondería mejor que la de la tarjeta base. la resolución utilizo la 1360 por que la 1920 me reduce mucho la apariencia de dialogos, panel y contextos de algunas aplicaciones(navegadores). las aplicaciones de plasmas pues no resulta dificil adaptarlas a la nueva resolución pero otras aplicaciones (netbeans, breackets, firefox....)   hay que estar una por una modificando lo que no es muy amigable y al final no da una buena apariencia. me imagino que el monitor no esta capacitado para esa resolución y por eso da esa falla.

Encontre por ahi que el nucleo 4.12 ya incorpora la corrección de nouveau para mi tarjeta nvidia, pero compilar el nucleo aun no me atrevo mejor espero un poco que veo que los amigos desarrolladores de Debian estan avanzando con todo.

gracias de nuevo.

 

 Saludos

 

Mar, 11/07/2017 - 10:49
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Nada, mientras te vaya, no problem. es lo que tiene nouveau, que como siempre, nvidia no suelta prenda, y se lo han currado a base de ingenieria inversa y con lo poco que ha dado nvidia (dicen que hay partes que no pueden liberar porque no son suyas o algo asi). Encima, ahora mismo en Sid nvidia-detect no sirve para nada. Sid ya no es Stretch, y tampoco es Buster, así que el paquete no está actualizado y no sabe para que versión de debian debe recomendar, a mi me dice lo mismo que a tí, que no ha podido saber que estás usando xD

Cuando se "arregle" el asunto de nouveau, simplemente borras (o comentas la línea en el archivo que te dije) el archivo blacklist-nouveau.conf y reinicias. Teniendo ambos controladores instalados. Así compruebas cual es el que el sistema prefiere. Si no te apaña el resultado, haces lo mismo con nvidia, lo metes en una blacklist (puedes hacerlo en el mismo archivo que ya tienes, asi es más comodo comentar/descomentar la linea y usar el que quieras). De este modo, si no te importa tener el privativo instalado, tienes la ventaja de que si se te vuelve a presentar un problema similar, con el cambio en esa linea cambias de driver y te ahorras jaleos y trabajo.

  No hay bar que por bien no venga....
Mar, 11/07/2017 - 11:17 (Responder a #8)
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

Panko wrote:

Nada, mientras te vaya, no problem. es lo que tiene nouveau, que como siempre, nvidia no suelta prenda, y se lo han currado a base de ingenieria inversa y con lo poco que ha dado nvidia (dicen que hay partes que no pueden liberar porque no son suyas o algo asi). Encima, ahora mismo en Sid nvidia-detect no sirve para nada. Sid ya no es Stretch, y tampoco es Buster, así que el paquete no está actualizado y no sabe para que versión de debian debe recomendar, a mi me dice lo mismo que a tí, que no ha podido saber que estás usando xD

Cuando se "arregle" el asunto de nouveau, simplemente borras (o comentas la línea en el archivo que te dije) el archivo blacklist-nouveau.conf y reinicias. Teniendo ambos controladores instalados. Así compruebas cual es el que el sistema prefiere. Si no te apaña el resultado, haces lo mismo con nvidia, lo metes en una blacklist (puedes hacerlo en el mismo archivo que ya tienes, asi es más comodo comentar/descomentar la linea y usar el que quieras). De este modo, si no te importa tener el privativo instalado, tienes la ventaja de que si se te vuelve a presentar un problema similar, con el cambio en esa linea cambias de driver y te ahorras jaleos y trabajo.

ok gracias sensei, eso mismo are yes 

 Saludos