Problema de instalacion de gcc

11 envíos / 0 nuevos
Último envío
#1 Vie, 03/02/2017 - 10:10
dapt
Imagen de dapt
Desconectado/a
se unió: 03/02/17

Problema de instalacion de gcc

Estado: 
[SOLUCIONADO]

Buen dia compañeros, el presente post es para tratar de solventar un percance que presenta uno de mis equipos al tratar de instalar el compilador Gcc en debian 8.7 mate de arquitectura i386.

la cuestion en si es que no me lo deja instalar a traves del terminal con el comando:

sudo apt-get install gcc

Lo cual me obliga a bajar el paquete directamente de la pagina de paquetes de debian:

https://www.debian.org/distrib/packages.es.html

​pero al tratar de instalarlo me genera confictos de dependencias y al aplicar la orden: 

sudo apt-get -f install

lo que hace es borrarme la aplicacion antes mensionada.

les agradeceria mucho si me pudiesen dar nuevas ideas para solventar este percanse porque ese esquipo lo uso para estudiar lenguaje c.

 

Vie, 03/02/2017 - 10:32
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

Veamos, ¿que mensaje te lanza al intentar instalar desde repositorios?

# aptitud install gcc

Muestranos tu source.list:

# nano /etc/apt/sources.list

Veo que la instalación es automatica ¿seguro que no lo tienes instalado?

pablo@debian:~$ aptitude show gcc
Paquete: gcc                                     
Versión: 4:6.3.0-1
Estado: instalado
Instalado automáticamente: sí
Prioridad: opcional
Sección: devel
Desarrollador: Debian GCC Maintainers <debian-gcc@lists.debian.org>
Arquitectura: amd64

Saludos.

We were but stones. Your light made us stars

https://linuxveredas.blogspot.com.es/

Vie, 03/02/2017 - 12:05
dapt
Imagen de dapt
Desconectado/a
se unió: 03/02/17

dejame llegar a casa para intentarlo y te respondo.

"Dapt" cheeky

Sáb, 04/02/2017 - 22:53
dapt
Imagen de dapt
Desconectado/a
se unió: 03/02/17

esto es lo que me arroja cuando uso el "aptitude"

root@dapt:/etc/apt# aptitud install gcc
bash: aptitud: no se encontró la orden
root@dapt:/etc/apt# aptitude install gcc
No se encontró ninguna versión candidata para gcc 
No se encontró ninguna versión candidata para gcc
No se instalará, actualizará o eliminará ningún paquete.
0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 0 B de ficheros. Después de desempaquetar se usarán 0 B.
                                                  
root@dapt:/etc/apt# gcc --version
bash: gcc: no se encontró la orden

y este es mi archivo /etc/apt/sources.list

# 

# deb cdrom:[Debian GNU/Linux 8.7.1 _Jessie_ - Official i386 DVD Binary-1 20170116-10:09]/ jessie contrib main

#deb cdrom:[Debian GNU/Linux 8.7.1 _Jessie_ - Official i386 DVD Binary-1 20170116-10:09]/ jessie contrib main

deb http://security.debian.org/ jessie/updates main contrib
deb-src http://security.debian.org/ jessie/updates main contrib

# jessie-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
# deb http://ftp.debian.org/debian/ jessie-updates main contrib
# deb-src http://ftp.debian.org/debian/ jessie-updates main contrib

de ese documento solo e corregido una linea agregandole "#", dicha linea es la segunda linea que dice:  "deb cdrom:[Debian GNU/Linux 8.7.1 _Jess...". la he comentado porque cada vez que iva a instalar algo me pedia el dvd de debian.

"Dapt" cheeky

Sáb, 04/02/2017 - 22:56
dapt
Imagen de dapt
Desconectado/a
se unió: 03/02/17

algo debo haber hecho mal al instalar el debian (eso fue la semana pasada), porque yo uso debian mate amd64 en mi trabajo y es hermosamente perfecto. *-*

"Dapt" cheeky

Dom, 05/02/2017 - 02:24 (Responder a #5)
arctica
Imagen de arctica
Desconectado/a
colaborador
se unió: 06/04/16

Hola. Te faltan repositorios. Sólo tienes habilitados los security.

Dom, 05/02/2017 - 06:09 (Responder a #6)
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

Si, como te dice arctica, tienes los repositorios incompletos. Debes descomentar las 2 ultimas líneas, además puedes añadir los non-free y el repositorio multimedia por ejemplo. Pásate por aqui:

http://exdebian.org/wiki/introducci%C3%B3n-los-repositorios-de-debian

 

We were but stones. Your light made us stars

https://linuxveredas.blogspot.com.es/

Dom, 05/02/2017 - 11:37
dapt
Imagen de dapt
Desconectado/a
se unió: 03/02/17

leei el articulo, pero pareciera que los repositorios que salen son de USA. alguien me podria pasar los repositorios que me faltan de los suyos? gracias.

"Dapt" cheeky

Dom, 05/02/2017 - 11:50
dapt
Imagen de dapt
Desconectado/a
se unió: 03/02/17

mejor dejenlo así, ya esta resuelto. ya tengo el compilador gcc y pude instalar otras aplicaciones tambien. gracias a todos y saludos.

"Dapt" cheeky

Dom, 05/02/2017 - 18:07 (Responder a #9)
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

Te falto detallar como solucionaste, el repositorio que utilizo es de estados unidos y me va bien.

 

#debian
deb http://ftp.us.debian.org/debian/ sid main contrib non-free

 

 Saludos

 

Dom, 05/02/2017 - 18:11
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16