Reproducir videos por consola con mplayer

4 envíos / 0 nuevos
Último envío
#1 Vie, 02/03/2018 - 23:21
reval
Imagen de reval
Desconectado/a
se unió: 02/03/18

Reproducir videos por consola con mplayer

Estado: 
[ACTIVO]

Hola muy buenas , este es mi primer post , agradeceria me puedan ayudar .

tengo instalado un Debian 8 jessie (netinstall) mininal , todo entorno consola o texto , sin nada de entorno grafico.

bien hacindo un lspci -v 

 

00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
    Subsystem: Intel Corporation Device d613
    Flags: bus master, fast devsel, latency 0, IRQ 44
    Memory at e0000000 (64-bit, non-prefetchable) [size=4M]
    Memory at d0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at f0f0 [size=8]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915

00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
    Subsystem: Intel Corporation Device d613
    Flags: bus master, fast devsel, latency 0, IRQ 45
    Memory at e0600000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel

debian ha reconocido    correctamente el hardware y a cargado los modulos de  video , sonido y red , todo me funciona perfectamente , puedo reproducir archivos de audio en formato wav, atraves de alsa, tengo conexion a internet por  wifi o cableado..

lo que me faltaria es saber si , se puede reproducir videos  pero por consola o modo texto, en algunos foros he visto que se puede ,  yo tambien he podido reproducir videos  con el programa  Mplayer pero todo esto en entorno grafico, es decir , se configura el framebufer, con vesafb y luego se se ingresa a una terminal y  se ejecuta el siguiente comando :

mplayer -vo fbdev2 /dev/fb0  video.mp4 y normal se puede reproducir los videos.

todo esto esta muy bien pero todo eso es en un entorgo grafico , ejecutando  en una  terminal cosa que no he podido lograr  en mi debian todo modo texto.

 

Segun  en los tutoriales, que he visto por internet  se debe activar el framebuffer para que trabaje con el modulo vesafb,

En primer lugar debemos agregar nuestro usuario al grupo "video". Para ello ingresamos el siguiente Comando de Organización,

yo he probado agregando mi usuario al grupo video ,y tambien  al usuario root

En segundo lugar, debemos verificar que el archivo "/etc/modprobe.d/blacklist-framebuffer.conf " contenga la siguiente línea: #blacklist vesafb.

el cual tengo que crearlo , ya que dicho archivo en este debian , no existe . luego 

 

"/etc/initramfs-tools/modules" 

agregar  fbcon y vesafb , 

luego hacer un "update-initramfs -u"

editar el "/etc/default/grub"  editar el 

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"  

por 

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vga=789"

luego  hago un update-grub2  y tras el reinicio me aparece un error "Module modprobe vesafb not found in modules.dep" luego de cargar todo 

ejecuto el comando 

mplayer -vo fbdev2 /dev/fb0  video.mp4 , el cual  solo reproduce el sonido  mas no el video , pense que podria ser por problemas de codecs  pero tengo instalado  el libav-utils , ffmpeg y aun asi no es capas de reproducir el video .

Sáb, 03/03/2018 - 05:17
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

luego  hago un update-grub2  y tras el reinicio me aparece un error "Module modprobe vesafb not found in modules.dep" luego de cargar todo 

El problema de seguir tutoriales sin saber lo que se está haciendo es lo que tiene....

La línea que te comentan en el archivo, es para evitar que ese módulo sea cargado, si le añades # al inicio, la comentas y el modulo podrá ser cargado. Si ese archivo no exite, o te falta algo en la instalación, o estás siguiendo un tutorial que no sirver para tu sistema, o está en otra parte, o simplemente no es un paso necesario en tu sistema.

Por otro lado, el mismo error que comentas y he citado, ya te ha dado una razón más que suficiente para saber que no iba a funcionar, dado que te está diciendo que ese módulo no existe. Posiblemente, si exista el módulo uvesafb, prueba a cambiar uno por otro... (de hecho, ese error ya te lo daría al hacer update-initramfs, pero no habrá salido en consola al venir por defecto que no muestre lo que está haciendo).

Y por otro lado, mirate la sintaxis del comando update-initramfs también, ya que otros parámetros te vendrían bien (el -u es para actualizar una imagen del kernel ya existente, pero no le dices cual, usualmente se puede usar -u -k all, con lo que le dices que actualice todas las existentes, o -u -k imagen-a-actualizar para actualizar solo una en concreto).

  No hay bar que por bien no venga....
Sáb, 03/03/2018 - 12:59
Devoto
Imagen de Devoto
Desconectado/a
colaborador
se unió: 17/04/16

Pues bueno, además de lo que ya te han comentado, yo uso la siguiente orden para reproducir videos en el framebuffer. Esto es, dentro de fbterm:

 

mplayer -vo fbdev2 archivo.algo

 

Cabe mencionar, que al instalar Debian, únicamente he dejado el sistema base sin hacer otras configuraciones excepto instalar los programas que uso (fbterm, graphics magick, fdclone, ne, ffmpeg, crawl, htop etc). Acá una captura de pantalla de mplayer:

 

mplayer_framebuffer

 

Saludos.

 

firma_debian

Sáb, 03/03/2018 - 13:56
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Quiza el punto, como te han comentado es que con poca experiencia comenzaste a experimentar con algo que necesita de ciertos conocimientos basicos, dicho esto a ver si estos enlaces te dan una pista para investigar mas:

https://unix.stackexchange.com/questions/33596/no-framebuffer-device-how-to-enable-it

http://hacklab.cz/2012/04/22/usefulness-linux-framebuffer-virtual-console

https://wiki.sabayon.org/index.php?title=HOWTO:_Using_Custom_Framebuffer_Resolution_with_GRUB2

https://help.ubuntu.com/community/ConsoleFramebuffer

Y un  extra mas practico.