Sin acceso al sistema

28 envíos / 0 nuevos
Último envío
#1 Lun, 11/02/2019 - 13:31
palmi
Imagen de palmi
Desconectado/a
se unió: 30/08/18

Sin acceso al sistema

Estado: 
[SOLUCIONADO]

Hola a todos, me llamo Palmira, tengo una intetl corte i7 de 7 gen vino en cero, instalé para probar varias diestro desde cero, dejé un tiempo manjaro con xfce pero me dio problemas con el kernel, no suoe que hacer, me quedé sin poder entrar a ka máquina, volví a formatearla y decidí ir por lo seguro, puse debian 9.7 estable con gnome, estaba todo bien, le instalé lis scrpits de spectre y meldown ya me faltaba solo la máquina virtual y no logro loguearme, no puedo estar al sistema, esta vez no creo sea un asunto del kernel, solo tengo acceso a la pantalla negra que si acepta la clave de robot pero no se que hacer. En un blog de ubuntu dice que es un tema de Xauthoritis pero yo no puedo teclear alt ctrl f1 porque no hace nada. No se si que pasa, primera vez que me pasa esto, ¿es un problema de hardware? ¿Que puedo hacer?

Lun, 11/02/2019 - 13:41
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

Por partes 

¿Instalaste el sistema y en algún momento funciono normal ? si es el caso ¿luego de instalar meltdown y spectre , dejo de hacerlo ?

¿Cuando inicias  te deja un terminal tty ( la patalla negra que decís ) que te permite identificarte como root ?

Intenta ser un poco mas clara en tu redacción 

Lun, 11/02/2019 - 13:52 (Responder a #2)
palmi
Imagen de palmi
Desconectado/a
se unió: 30/08/18

Instale todo normal, funcionó esta semana normal, spectre y meldown al correrlos mostraban algunos puntos como vulnerables, pero la gran mayoría decian protegidos. Siguió normal todo, hasta esta mañana. Encendí la computadora, puse mi usuario y contra seña y me rebota otra vez para que coloque otra vez usuario y contraseña, lo hice varias veces y siguió igual, entonces reinicie y puse mido recovery de debian que cae en la pantalla negra con root y allí estoy sin saber que hacer...

Lun, 11/02/2019 - 14:14
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

Tenes alguna grafica nvidia o ati? de ser asi ¿le instalaste algun driver privativo? ¿de donde y como?. 
Aparentemente tu problema se inicio cuando instalaste dichos scrpits de spectre y meldown. ¿podrías contarnos de donde sacaste esos script?. No estoy seguro pero tengo entendido que el kernel de debian 9.7 ya trae los parches de seguridad y que ademas hay un paquete en los repos de debian con los script para saber si se esta protegido.

En principio el escritorio gnome requiere de aceleración 3d asi que probablemente por ahí debe venir el problema. ¿llegas al momento de logueo o solo se te queda en pantalla en negra?.

Si estuviste actualizando posiblemente instalaste una versión más moderna del kernel, asi que fijate si en grub te aparecen mas de una versión de kernel, de ser asi fíjate con un kernel mas viejo te permite entrar.
Sino también, desde grub podes iniciar el bajo la opción de recovery mode y con tu contraseña de root inicias en modo tty. en esta forma no vas a tener, en principio, acceso a Internet pero eso se soluciona. desde una tty podes fijarte eso que comentas de Xauthority es el problema 

ls -l /home/palmi/.Xauthority

palmi seria el nombre de usuario, en teoría no debería existir porque no has iniciado sesión como ese usuario

Lun, 11/02/2019 - 14:18
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

Bien estas en modo recovery  y como root , fijate   a quien pertenerce el archivo /home/usuario/.Xauthority , esto lo haces con el siguiente comando 

ls -la  /home/usuario  
###  donde usuario es TU usuario , debiera mostrarte algo similar a esto :
---------------------------------------------
-rw-------   1 usuario  usuario         148 ene  1  2018 .Xauthority

A ver si el problema es ese ,que dicho archivo no pertenezca a tu usuario.(en principio ) 

Bien nos superpusimos en las respuestas ,pero es lo mismo 

Lun, 11/02/2019 - 14:29 (Responder a #5)
palmi
Imagen de palmi
Desconectado/a
se unió: 30/08/18

Hola, gracias por la ayuda, no recuerdo pero si estoy segura que no es NVIDIA la tarjeta gráfica. Drivers privativos como tal bajarlos e instalarlo no, lo iba a hacer pero el WiFi funcionó bien y no lo hice, es intel, debian lo hizo solo.  Spectre y meldown lo baje del sitio de debian de los repositorios backport, luego instalé como decía en la página de debian y los corrí, salían tres colores, recuerdo que decía algunos puntos vulnerables, pero siguió todo normal hasta hoy. Al iniciar no se ve opción para otro kernel, la semana pasada instalé debian desde cero y ha costado mucho por lo lento del internet. Si llego a gnome y pide usuario y luego la contraseña, pero rebota y pide usuario y contraseña, no deja entrar ni como root, por eso reinicié el sistema y entré debian recovery, allí estoy como root, pero dice que /Xauthority no existe

Lun, 11/02/2019 - 14:32
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

Presta atención  el archivo es .Xauthority  ( fijate el punto al inicio ) , usa el comando que te puse eso te listara todo 

o en todo caso 

ls -la ~/ |grep .X

ls  = listar 

-l  =mostrar permisos 

-a = mostrar ocultos 

grep .X  filtrar mostrando los que comiencen con .X

Lun, 11/02/2019 - 14:33
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

sobre el comando lshow no te preocupes porque no biene por defecto en debian, hay que instalarlo y entrando desde el recovery a la tty no tenes iniciado networkmanager.

Por lo que entiendo si podes llegar al gestor de inicio de sesión de gnome (gdm3) una cosa que podes comprobar es que en la ventana donde elegis tu usuario y te aparece para poner la contraseña, exite una especie de engranaje o algo abajo a tu derecha (o por lo menos era asi) donde te permite elegir distintos tipos de escritorios gnome wayland, gnome clasico, gnome X11, fijate de elegir gnome X11  y si asi entra a tu sesion

Lun, 11/02/2019 - 14:33 (Responder a #8)
palmi
Imagen de palmi
Desconectado/a
se unió: 30/08/18

Al poner ls - la /home/Palmi sale el listado de archivos y se ven los ocultos, pero no existe /.Xauthority y no sale lo que índicas, solo lista los archivos

Lun, 11/02/2019 - 14:41 (Responder a #9)
palmi
Imagen de palmi
Desconectado/a
se unió: 30/08/18

Tengo muchos gnome, será eso? System X11 default, gnome, gnome clásico, gnome flashbck, gnome metacity, gnome en wayland, 

Logré entrar en gnome compiz, ahora que debo hacer????

Lun, 11/02/2019 - 14:46
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

Bueno si lograste entrar con gnome compiz, cerra sesión y trata de entrar con System X11 default o sino el que pone solo gnome. sobre compiz y gnome no te sabria decir si funciona porque hace mucho que no utilizo compiz.
A lo mejor instalaste compiz y ese fue el que causo el problema

Lun, 11/02/2019 - 14:49
palmi
Imagen de palmi
Desconectado/a
se unió: 30/08/18

Srs Caliban y Rocky mil gracias, logré entrar el gnome compiz, pero si tengo dudas, ¿debo desinstalar los backport y spectre y meldown?  ¿ que sugieren? Y para ayudar a otros ysusriodt, que buscan el viejo gnome, di ese fue el problema, que hacer, perdonen tantas preguntas... No se si está ya solucionado, y solo basta con entrar siempre en gnome compiz??? De todos modos voy a colocar ahora si las respuestas de los comandos desde la computadora....

Lun, 11/02/2019 - 15:00
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

La otra opcion seria desinstalar compiz, No se que utilizaste para instalar compiz pero si es apt-get o aptitude se puede averiguar el historial de instalaciones.
Gnome es un excelente escritorio pero consume mucha mas ram que un xfce o mate, y si le sumas compiz, seguramente el consumo de ram será mayor a lo mejor este último sea mas interesante de tener cuando se tienen escritorios como mate.
 

Lun, 11/02/2019 - 15:05 (Responder a #13)
palmi
Imagen de palmi
Desconectado/a
se unió: 30/08/18

Hice lo que medijo, gnome default no deja entrar, gnome solo tampoco, gnome clasico tampoco, solo la opcion gnome compiz deja entrar. No se si es apropiado dejarla asi, o si volver a formatear la maquina y dejar simplemente gnome, tambien como utilizo muchos programas astronomia, planetarios y el unico que corre en linux de astrologia, instalo muchas cosas de kde, pero kde que me encanta, tiene un bug dice error api framework de plasma y a mi me afecta, por eso volvi con gnome, ahora no se si, instalar los planetarios de kde dan algun problema con gnome...

Lun, 11/02/2019 - 15:16
palmi
Imagen de palmi
Desconectado/a
se unió: 30/08/18

root@Jupiter:/home/palmi# lshw -short
H/W path             Device      Class          Description
===========================================================
                                 system         10MQA0YN00 (LENOVO_MT_10MQ_BU_LE
/0                               bus            3111
/0/0                             memory         64KiB BIOS
/0/3e                            memory         16GiB System Memory
/0/3e/0                          memory         8GiB SODIMM DDR4 Synchronous Unb
/0/3e/1                          memory         8GiB SODIMM DDR4 Synchronous Unb
/0/43                            memory         256KiB L1 cache
/0/44                            memory         1MiB L2 cache
/0/45                            memory         8MiB L3 cache
/0/46                            processor      Intel(R) Core(TM) i7-7700T CPU @
/0/100                           bridge         Intel Corporation
/0/100/2                         display        Intel Corporation
/0/100/14                        bus            Intel Corporation
/0/100/14/0          usb1        bus            xHCI Host Controller
/0/100/14/0/3                    communication  Bluetooth wireless interface
/0/100/14/0/5                    input          Lenovo Black Silk USB Keyboard
/0/100/14/0/6                    input          Lenovo USB Optical Mouse
/0/100/14/0/8        scsi6       storage        Mass Storage Device
/0/100/14/0/8/0.0.0  /dev/cdrom  disk           DVDRW SHW-1635S
/0/100/14/1          usb2        bus            xHCI Host Controller
/0/100/14.2                      generic        Intel Corporation
/0/100/16                        communication  Intel Corporation
/0/100/17                        storage        Intel Corporation
/0/100/1c                        bridge         Intel Corporation
/0/100/1c/0          wlp1s0      network        Intel Corporation
/0/100/1f                        bridge         Intel Corporation
/0/100/1f.2                      memory         Memory controller
/0/100/1f.3                      multimedia     Intel Corporation
/0/100/1f.4                      bus            Intel Corporation
/0/100/1f.6          enp0s31f6   network        Ethernet Connection (2) I219-V
/0/1                 scsi0       storage        
/0/1/0.0.0           /dev/sda    disk           500GB WDC WD5000LPLX-0
/0/1/0.0.0/1         /dev/sda1   volume         27GiB EXT4 volume
/0/1/0.0.0/2         /dev/sda2   volume         437GiB Extended partition
/0/1/0.0.0/2/5       /dev/sda5   volume         15GiB Linux swap volume
/0/1/0.0.0/2/6       /dev/sda6   volume         421GiB EXT4 volume
/1                               power          To Be Filled By O.E.M.
root@Jupiter:/home/palmi#

Lun, 11/02/2019 - 15:19
palmi
Imagen de palmi
Desconectado/a
se unió: 30/08/18

root@Jupiter:/home/palmi# lshw -short
H/W path             Device      Class          Description
===========================================================
                                 system         10MQA0YN00 (LENOVO_MT_10MQ_BU_LE
/0                               bus            3111
/0/0                             memory         64KiB BIOS
/0/3e                            memory         16GiB System Memory
/0/3e/0                          memory         8GiB SODIMM DDR4 Synchronous Unb
/0/3e/1                          memory         8GiB SODIMM DDR4 Synchronous Unb
/0/43                            memory         256KiB L1 cache
/0/44                            memory         1MiB L2 cache
/0/45                            memory         8MiB L3 cache
/0/46                            processor      Intel(R) Core(TM) i7-7700T CPU @
/0/100                           bridge         Intel Corporation
/0/100/2                         display        Intel Corporation
/0/100/14                        bus            Intel Corporation
/0/100/14/0          usb1        bus            xHCI Host Controller
/0/100/14/0/3                    communication  Bluetooth wireless interface
/0/100/14/0/5                    input          Lenovo Black Silk USB Keyboard
/0/100/14/0/6                    input          Lenovo USB Optical Mouse
/0/100/14/0/8        scsi6       storage        Mass Storage Device
/0/100/14/0/8/0.0.0  /dev/cdrom  disk           DVDRW SHW-1635S
/0/100/14/1          usb2        bus            xHCI Host Controller
/0/100/14.2                      generic        Intel Corporation
/0/100/16                        communication  Intel Corporation
/0/100/17                        storage        Intel Corporation
/0/100/1c                        bridge         Intel Corporation
/0/100/1c/0          wlp1s0      network        Intel Corporation
/0/100/1f                        bridge         Intel Corporation
/0/100/1f.2                      memory         Memory controller
/0/100/1f.3                      multimedia     Intel Corporation
/0/100/1f.4                      bus            Intel Corporation
/0/100/1f.6          enp0s31f6   network        Ethernet Connection (2) I219-V
/0/1                 scsi0       storage        
/0/1/0.0.0           /dev/sda    disk           500GB WDC WD5000LPLX-0
/0/1/0.0.0/1         /dev/sda1   volume         27GiB EXT4 volume
/0/1/0.0.0/2         /dev/sda2   volume         437GiB Extended partition
/0/1/0.0.0/2/5       /dev/sda5   volume         15GiB Linux swap volume
/0/1/0.0.0/2/6       /dev/sda6   volume         421GiB EXT4 volume
/1                               power          To Be Filled By O.E.M.
root@Jupiter:/home/palmi#

 

root@Jupiter:/home/palmi# lsb_release -a
No LSB modules are available.
Distributor ID:    Debian
Description:    Debian GNU/Linux 9.7 (stretch)
Release:    9.7
Codename:    stretch
root@Jupiter:/home/palmi#

Lun, 11/02/2019 - 15:32
palmi
Imagen de palmi
Desconectado/a
se unió: 30/08/18

root@Jupiter:/home/palmi# ls -al
total 116
drwxr-xr-x 22 palmi palmi 4096 feb 11 13:59 .
drwxr-xr-x  4 root  root  4096 feb  6 12:35 ..
-rw-------  1 palmi palmi 1498 feb 10 17:44 .bash_history
-rw-r--r--  1 palmi palmi  220 feb  6 12:35 .bash_logout
-rw-r--r--  1 palmi palmi 3526 feb  6 12:35 .bashrc
drwx------ 18 palmi palmi 4096 feb 11 13:59 .cache
drwx------  3 palmi palmi 4096 feb 11 13:58 .compiz
drwx------ 20 palmi palmi 4096 feb 11 13:39 .config
drwx------  3 palmi palmi 4096 feb  7 12:38 .dbus
drwxr-xr-x  3 palmi palmi 4096 feb  8 14:31 Descargas
drwxr-xr-x  2 palmi palmi 4096 feb  7 17:28 Documentos
drwxr-xr-x  2 palmi palmi 4096 feb  6 12:38 Escritorio
drwx------  4 palmi palmi 4096 feb  8 14:48 .gconf
-rw-r-----  1 palmi palmi    0 feb  7 11:37 .gksu.lock
drwx------  3 palmi palmi 4096 feb  7 12:38 .gnome
drwx------  3 palmi palmi 4096 feb  7 11:28 .gnupg
-rw-------  1 palmi palmi 7378 feb 11 13:59 .ICEauthority
drwxr-xr-x  2 palmi palmi 4096 feb  6 12:38 Imágenes
drwx------  3 palmi palmi 4096 feb  8 14:48 .kde
drwxr-xr-x  3 palmi palmi 4096 feb  6 12:38 .local
drwx------  5 palmi palmi 4096 feb  6 12:38 .mozilla
drwxr-xr-x  2 palmi palmi 4096 feb  6 12:38 Música
drwx------  3 palmi palmi 4096 feb  7 12:38 .pki
drwxr-xr-x  2 palmi palmi 4096 feb  6 12:38 Plantillas
-rw-r--r--  1 palmi palmi  675 feb  6 12:35 .profile
drwxr-xr-x  2 palmi palmi 4096 feb  6 12:38 Público
drwx------  2 palmi palmi 4096 feb  7 11:28 .ssh
drwxr-xr-x  2 palmi palmi 4096 feb  6 12:38 Vídeos
-rw-r--r--  1 palmi palmi  180 feb  6 13:48 .wget-hsts
root@Jupiter:/home/palmi#

 

no existe /.Xauthority

Lun, 11/02/2019 - 15:46
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

si queres podemos ver de desinstalar compiz y ver si asi te deja entrar a gnome default
entrás dede recovery mode a una tyy como root y desde una terminal pones:
 

systemctl start NetworkManager

eso te va a dar acceso a internet (tarda un rato), luego das un enter y pones
 

aptitude update && aptitude upgrade
aptitude search compiz

lo primero es para actualizar el sistema y lo segundo es para ver que paquetes de compiz tenes instalados (que tiene una i ) y luego eliminas los instalados
por ejemplo:

aptitude purge compiz-core compiz-plugins-default compiz-gnome 
apt-get autoremove

salis con CTRL+d o sino con el comando reboot al iniciar tendria que poder permitirte iniciar gnome normalmente sino vasta con volver a instalar los programas eliminados y reiniciar en gnome compiz
PD:
yo de kde no tengo casi idea, pero en el foro hay muchos conocedores de kde plasma que te pueden dar una mano
PD2: existe un instalador que se llama flatpak y otro snap con los que podes instalar programas y tenerlos separados del sistema, asi podes tener programas de kde sin tener que lidiar con 8mil dependencias etc.  https://flathub.org/apps/category/All https://snapcraft.io/

Lun, 11/02/2019 - 16:26 (Responder a #18)
palmi
Imagen de palmi
Desconectado/a
se unió: 30/08/18

Mil gracias, voy a hacer lo que me indicas, instale compiz desde synaptic, por si acaso voy a copiar en un papel lo que me indicas y lo voy a hacer. Debo añadir acá, porque lo acabo de encontrar y me funciono y puede ser útil en el futuro este comando dconf reset -f / me dejó el escritorio como estaba. (https://www.linuxadictos.com/dconf-restablecer-los-parametros-defecto-entorno-escritorio.html) En verdad mil gracias.

Lun, 11/02/2019 - 16:31
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

En synaptic tenes el historial que es muy útil para saber que se instaló es Archivo/Histórico y te fijas que programas se instalaron ese dia. Copias los de compiz y los eliminas

Lun, 11/02/2019 - 17:31 (Responder a #20)
palmi
Imagen de palmi
Desconectado/a
se unió: 30/08/18

hice todo tal cual, pero solo deja entrar por la opción gnome metacity, y me desmontó el disco externo de 1 tera, no lo reconoce, como sino existiera. Elimine skychart un planetario que me estaba causando problemas con los repositorios. Algo ayer instalando me desconfiguró las cosas, en el disco de 1 tera esta windows 7 y mucha información, lo tengo como respaldo, al entrar lo lee, pero una vez te logueas como sino existiera y el gnome es como gnome 2