webcam Realtek 0bda:57cc en portatil acer ha dejado de funcionar

9 envíos / 0 nuevos
Último envío
#1 Dom, 10/06/2018 - 14:20
ejjp80
Imagen de ejjp80
Desconectado/a
se unió: 10/06/18

webcam Realtek 0bda:57cc en portatil acer ha dejado de funcionar

Estado: 
[ACTIVO]

Hola,

harto de buscar y no encuentro nada que solucione mi problema. Estoy pensando que puede que la webcam esté fisicamente rota pero antes de desistir quería dejar esto escrito por si alguien me puede orientar o simplemente para hacer saber a otro que esté en la misma situación. Vamos allá, espero no olvidarme de nada.

0) todo actualizado con aptitude
1) Es un portátil Acer, el problema está en la web cam integrada. Aparentemente funciona pero solo me da una imagen blanca (en Skype, Cheese, VLC, mplayer, guvcview... en todos)
2) Hace 2 o 3 meses la webcam funcionaba perfectamente (al menos con Skype y con Cheese, pero no con el hangouts)
3) El portatil lleva debian estable, aunque en la carpeta sources.list.d veo morralla como google-talkplugin.list skype-stable.list skype-unstable.list
4) No he podido probar la webcam en windows7 o xp pese a que los tengo virtualizados. la máquinas virtuales estan desconectadas de internet y habría que bajarse algun driver y algun programa para probar la camara. Y no quiero.

4.a) Ya he probado a cambiar los controles de brillo, hue, contrast...etc en gucview, en cheese en
4.b) existe /dev/video0
v4l2-ctl --list-devices
HD WebCam (usb-0000:00:14.0-7):
/dev/video0

5) dmesg | grep uvcvideo

[ 12.293114] uvcvideo: Found UVC 1.00 device HD WebCam (0bda:57cc)
[ 12.295872] usbcore: registered new interface driver uvcvideo
[ 2241.227171] uvcvideo: Failed to query (SET_CUR) UVC control 10 on unit 2: -32 (exp. 2).
[ 2269.791890] uvcvideo: Failed to query (SET_CUR) UVC control 10 on unit 2: -32 (exp. 2).
[ 2269.791892] uvcvideo 1-7:1.0: reset_resume error -5
[ 3667.273957] uvcvideo: Found UVC 1.00 device HD WebCam (0bda:57cc)
[ 3745.188572] uvcvideo: Found UVC 1.00 device HD WebCam (0bda:57cc)

6) lsusb
Bus 003 Device 002: ID 8087:8000 Intel Corp.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 005: ID 0bda:57cc Realtek Semiconductor Corp.

7)
lsmod | grep uvc
uvcvideo 79048 0
videobuf2_vmalloc 12816 1 uvcvideo
videobuf2_core 47787 1 uvcvideo
videodev 126451 3 uvcvideo,v4l2_common,videobuf2_core
media 18305 2 uvcvideo,videodev
usbcore 195468 9 ath3k,btusb,uvcvideo,rtsx_usb,usb_storage,ehci_hcd,ehci_pci,usbhid,xhci_hcd

Alguna idea de que puede estar pasando?

Dom, 10/06/2018 - 14:24
ejjp80
Imagen de ejjp80
Desconectado/a
se unió: 10/06/18

Y esto tambien creo que es importante

v4l2-compliance
Driver Info:
Driver name : uvcvideo
Card type : HD WebCam
Bus info : usb-0000:00:14.0-7
Driver version: 3.16.51
Capabilities : 0x84000001
Video Capture
Streaming
Device Capabilities
Device Caps : 0x04000001
Video Capture
Streaming

Compliance test for device /dev/video0 (not using libv4l2):

Required ioctls:
fail: v4l2-compliance.cpp(320): !(caps & V4L2_CAP_EXT_PIX_FORMAT)
test VIDIOC_QUERYCAP: FAIL

Allow for multiple opens:
test second video open: OK
fail: v4l2-compliance.cpp(320): !(caps & V4L2_CAP_EXT_PIX_FORMAT)
test VIDIOC_QUERYCAP: FAIL
test VIDIOC_G/S_PRIORITY: OK

Debug ioctls:
test VIDIOC_DBG_G/S_REGISTER: OK (Not Supported)
test VIDIOC_LOG_STATUS: OK (Not Supported)

Input ioctls:
test VIDIOC_G/S_TUNER/ENUM_FREQ_BANDS: OK (Not Supported)
test VIDIOC_G/S_FREQUENCY: OK (Not Supported)
test VIDIOC_S_HW_FREQ_SEEK: OK (Not Supported)
test VIDIOC_ENUMAUDIO: OK (Not Supported)
test VIDIOC_G/S/ENUMINPUT: OK
test VIDIOC_G/S_AUDIO: OK (Not Supported)
Inputs: 1 Audio Inputs: 0 Tuners: 0

Output ioctls:
test VIDIOC_G/S_MODULATOR: OK (Not Supported)
test VIDIOC_G/S_FREQUENCY: OK (Not Supported)
test VIDIOC_ENUMAUDOUT: OK (Not Supported)
test VIDIOC_G/S/ENUMOUTPUT: OK (Not Supported)
test VIDIOC_G/S_AUDOUT: OK (Not Supported)
Outputs: 0 Audio Outputs: 0 Modulators: 0

Input/Output configuration ioctls:
test VIDIOC_ENUM/G/S/QUERY_STD: OK (Not Supported)
test VIDIOC_ENUM/G/S/QUERY_DV_TIMINGS: OK (Not Supported)
test VIDIOC_DV_TIMINGS_CAP: OK (Not Supported)
test VIDIOC_G/S_EDID: OK (Not Supported)

Test input 0:

Control ioctls:
fail: v4l2-test-controls.cpp(240): missing control class for class 00980000
test VIDIOC_QUERYCTRL/MENU: FAIL
warn: v4l2-test-controls.cpp(367): s_ctrl returned EIO
test VIDIOC_G/S_CTRL: OK
warn: v4l2-test-controls.cpp(604): s_ext_ctrls returned EIO
fail: v4l2-test-controls.cpp(625): g_ext_ctrls(0) invalid error_idx 0
test VIDIOC_G/S/TRY_EXT_CTRLS: FAIL
test VIDIOC_(UN)SUBSCRIBE_EVENT/DQEVENT: OK
test VIDIOC_G/S_JPEGCOMP: OK (Not Supported)
Standard Controls: 10 Private Controls: 0

Format ioctls:
test VIDIOC_ENUM_FMT/FRAMESIZES/FRAMEINTERVALS: OK
test VIDIOC_G/S_PARM: OK
test VIDIOC_G_FBUF: OK (Not Supported)
test VIDIOC_G_FMT: OK
test VIDIOC_TRY_FMT: OK
warn: v4l2-test-formats.cpp(804): Could not set fmt2
test VIDIOC_S_FMT: OK
test VIDIOC_G_SLICED_VBI_CAP: OK (Not Supported)

Codec ioctls:
test VIDIOC_(TRY_)ENCODER_CMD: OK (Not Supported)
test VIDIOC_G_ENC_INDEX: OK (Not Supported)
test VIDIOC_(TRY_)DECODER_CMD: OK (Not Supported)

Buffer ioctls:
test VIDIOC_REQBUFS/CREATE_BUFS/QUERYBUF: OK
test VIDIOC_EXPBUF: OK (Not Supported)

Total: 38, Succeeded: 34, Failed: 4, Warnings: 3

Dom, 10/06/2018 - 15:00
gorylong
Imagen de gorylong
Desconectado/a
se unió: 04/12/16

Ni idea!!!

Pero no te desanimes, igual cuando empecé tuve muchos problemas con la webcam, nunca funcionó al 100, funcionaba cuando quería y cosas así, me termine consiguiendo una por USB y pues era más facil todo

Por cierto, no sale el chipset de la camara con un "lspci"?

Dom, 10/06/2018 - 15:09
gorylong
Imagen de gorylong
Desconectado/a
se unió: 04/12/16

Por cierto, encontre esto, espero te sirva:

https://wiki.archlinux.org/index.php/Webcam_setup_(Espa%C3%B1ol)

Dom, 10/06/2018 - 15:14
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 No suelo usar la cámara, ni integrada ni enchufable, asi que no me ha fijado mucho en como aparece en los mios.

 Veo que tu compu al menos identifica el hardware de la cámara,

 pero veo también muchos 'no' , 'fail' , 'not supported' , etc.

 ¿Has probado de quitar y reinstalar los drivers, y/o el paquete de programas que se encarga de gestionar la webcam?.

 No vaya a ser cosa de que alguno de ellos se haya descompuesto y por eso no hay decodificación y salida de video.

 ¿Has mirado si hay errores de proceso o de acceso a algún hardware en algunos de los log del sistema?, (o de los sysctl y compañía).

 (Aunque veo que lo relativo a ioctls ya está aquí).

 

Lun, 11/06/2018 - 04:41 (Responder a #5)
ejjp80
Imagen de ejjp80
Desconectado/a
se unió: 10/06/18

Muchas gracias por tu mensaje. No hay problema por lo de la camara, no tengo otra webcam pero un familiar me deja su portatil cuando necesite skype).

La webcam yo apenas la utilizo tampoco, por eso no sé cuando dejó funcionar, pero en este ordenador ha funcionado la camara desde el día 1, de eso estoy seguro (hace dos años que le puse Jessie). Lo jodido es que esto se supone que es la rama estable y esto no debería de pasar. A no ser que me haya cargado yo algo por poner las sources list de google hangouts o las de skype...(tengo que poner las de skype porque cambian de versión muy rapido y no dejan que te conectes a sus servidores con una versión un pelín antigua de skype, asi de cabrones son y por eso tuve que dejar su sourcelist activada)

Diría que esta camara integrada esta conectada internamente por usb pero voy a dejar aquí abajo el lspci (no veo nada de la camara aquí)

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
03:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

Lun, 11/06/2018 - 04:43 (Responder a #6)
ejjp80
Imagen de ejjp80
Desconectado/a
se unió: 10/06/18

gracias, voy a leerlo. Ayer lei algo de la wiki de arch pero estaba en inglés, a ver si este setup en español me aclara algo.

Lun, 11/06/2018 - 04:46 (Responder a #7)
ejjp80
Imagen de ejjp80
Desconectado/a
se unió: 10/06/18

Ya probe a reinstalar el v4l. Quitar y poner el module con modprobe...
Tampoco quiero trastear mucho porque el ordenador va como un tiro y solo es la camara que es un problema menor.

Esencialmente, la webcam es detectada y "funciona" el problema es que me da una imagen blanca en todos los programas que uso. Si por ejemplo solo me pasara en skype, ni siquiera hubiera abierto el hilo.

Dom, 17/06/2018 - 14:38
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Entonces, conceptualmente , yo diría que o no te trabaja el sofware de decodificación de la señal,

 O que por alguna causa el chip pueda haberse dañado y presenta como salida un nivel constante.

 Una preguntita. si cuando ves esta pantalla blanca tapas la lente con el dedo, ¿se oscurece la imagen,

 o sigue igual de blanca?.  (A ver si sigue "fotosensible" la cámara).