Debian 9 "Stretch" publicado

 

 

Después de 26 meses de desarrollo, el proyecto Debian se enorgullece de presentar su nueva versión estable 9 (nombre de código "Stretch" ), que tendrá soporte para los próximos 5 años gracias al trabajo combinado del equipo de Seguridad de Debian y del equipo de Debian Long Term Support

Debian 9 está dedicado al fundador del proyecto Ian Murdock, fallecido el 28 de diciembre de 2015.

Entre las novedades que trae Stretch podemos destacar:

  • El sistema de gestión de bases de datos MySQL, han sido reemplazados por su equivalente en MariaDB.
  • Firefox y Thunderbird regresan a Debian para reemplazar a Iceweasel e Icedove, que estuvieron presentes en el archivo por más de 10 años.
  • Los administradores y los que están en entornos sensibles a la seguridad pueden sentirse cómodos al saber que el sistema de visualización X ya no necesita privilegios de "root" para ejecutarse.
  • Gracias al proyecto Reproducible Builds, más del 90% de los paquetes de origen incluidos en Debian 9 crearán paquetes binarios idénticos bit a bit. Esta es una característica de verificación importante que protege a los usuarios de los intentos malintencionados de manipular los compiladores y crear redes. Futuras versiones de Debian incluirán herramientas y metadatos para que los usuarios finales puedan validar la procedencia de paquetes dentro del archivo.
  • El "lanzamiento de Stretch" es la primera versión de Debian para presentar la "moderna" rama de GnuPG en el paquete "gnupg" . Esto trae consigo la criptografía de la curva elíptica, mejores valores predeterminados, una arquitectura más modular y un soporte mejorado para tarjetas inteligentes. Seguiremos suministrando la rama "clásica" de GnuPG como gnupg1 para las personas que la necesiten, pero ahora está obsoleta
  • Los paquetes de depuración son más fáciles de obtener y usar en Debian 9 "Stretch" . Un nuevo repositorio "dbg-sym" se puede agregar a la lista de fuentes de APT para proporcionar símbolos de depuración automáticamente para muchos paquetes.
  • El soporte UEFI ( "Unified Extensible Firmware Interface" ) que se introdujo por primera vez en "Wheezy" continúa mejorándose mucho en "Stretch" y también admite la instalación en el firmware UEFI de 32 bits con un núcleo de 64 bits. Las imágenes en vivo de Debian incluyen ahora también el soporte para el arranque de UEFI como una nueva característica.

Esta versión incluye numerosos paquetes de software actualizados, tales como:

  • Apache 2.4.25
  • Asterisk 13.14.1
  • Chromium 59.0.3071.86
  • Firefox 52.2 (en el paquete firefox-esr)
  • GIMP 2.8.18
  • GNOME 3.22
  • GNU Compiler Collection 6.3
  • GnuPG 2.1
  • Golang 1.7
  • KDE Frameworks 5.28, KDE Plasma 5.8 y KDE Applications 16.08 y 16.04 para componentes PIM
  • LibreOffice 5.2
  • Linux 4.9
  • MariaDB 10.1
  • MATE 1,16
  • OpenJDK 8
  • Perl 5,24
  • PHP 7.0
  • PostgreSQL 9.6
  • Python 2.7.13 y 3.5.3
  • Ruby 2.3
  • Samba 4.5
  • systemd 232
  • Thunderbird 45.8
  • Tomcat 8.5
  • Xen Hypervisor
  • Xfce 4.12
  • Más de 51.000 otros paquetes de software listos para usar, construidos a partir de un poco más de 25.000 paquetes de código fuente.

Entre las diferentes arquitecturas que admite Debian Steatch estan; amd64, arm64, i386, armel, armhf, mips, mipsel, ppc64el, s390x, mips64el. en cambio se ha eliminado powerpc

Para el que quiera instalar la nueva versión de Debian aqui los enlaces de descarga:

Para lo que en cambio prefieran actualizar ya sabéis, después de editar sources.list cambiando Jessie por Stretch ejecutar:

  # apt o aptitude update
# apt o aptitude upgrade
# apt o aptitude full-upgrade

Fuente: https://www.debian.org/News/2017/20170617

moonwatcher
Imagen de moonwatcher
Categoría: 
Dom, 18/06/2017 - 21:16
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

[...]"el sistema de visualización X ya no necesita privilegios de "root" para ejecutarse"[...]

Como usuario de "esdebian" no entiendo esta parte, siempre se dijo, "nunca arrancar el servidor gráfico como root, como lo hace puppy linux o algunos usuarios de windows"

(1) Alguien puede aclarar esta idea, he leído, https://www.debian.org/releases/stretch/amd64/release-notes/ch-whats-new.en.html#x-no-longer-requires-root

"2.2.10. The Xorg server no longer requires root"

En la versión de stretch de Xorg es posible ejecutar el servidor como un usuario normal en lugar de como usuario «root». Esto reduce el riesgo de una posible escalación de privilegios a través de errores en el servidor X. Este cambio, sin embargo, tiene una serie de requisitos para poder funcionar: In the stretch version of Xorg, it is possible to run the Xorg server as a regular user rather than as root. This reduces the risk of privilege escalation via bugs in the X server. However, it has some requirements for working:

Necesita logind y libpam-systemd.

El sistema tiene que tener soporte de “Kernel Mode Setting” (KMS). Por lo que puede no funcionar en algunos entornos de virtualización (p.ej. virtualbox) o si el núcleo no tiene un controlador con soporte de la tarjeta gráfica que hay instalada en el sistema.

Necesita ejecutar en la consola virtual desde la que se inició.

Sólo el gestor de pantallas gdm3 tiene la capacidad de ejecutar X como usuario no privilegiado en stretch. Otros gestores de pantallas ejecutarán siempre X como el usuario «root». Como alternativa, puede ejecutar el servidor X manualmente como un usuario no privilegiado desde un terminal virtual con la orden startx.

Cuando se ejecuta como un usuario normal, el registro de Xorg estará disponible en ~/.local/share/xorg/.

Los viejos usuarios, rockiii, panko, a que se refieren con aquello. ¿?

 

(2) El soporte de Firefox 45.9 termino el 13 de Junio, error al teclear ¿?. La versión actual es la 52.2. Lástima la 45.9 era decente.

 

 

 

Lun, 19/06/2017 - 03:17 (Responder a #1)
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

Berbellon wrote:

2) El soporte de Firefox 45.9 termino el 13 de Junio, error al teclear ¿?. La versión actual es la 52.2. Lástima la 45.9 era decente.

 

 

 

 

Esta mal en la fuente. Lo corrijo, gracias.

We were but stones. Your light made us stars

https://linuxveredas.blogspot.com.es/

Jue, 22/06/2017 - 15:19 (Responder a #2)
cnicolas
Imagen de cnicolas
Desconectado/a
colaborador
se unió: 21/02/16

Creo que el problema de arrancar el servidor como root es precisamente el que se indica que puede usarse como agujero de seguridad, otra coasa es que siempre se ha dicho que en un servidor si se usa usuario root usar X es malgastar memoria en algo que es innecesario

Debian y GNU/Linux en el core informatico.

te puede interesar

GNU cumple 35 años

  El 27 de Septiembre de 1983 Richard Stalman anunció al mundo que se proponía crear un sistema operativo basado en Unix y compatible con él, pero totalmente libre. El proyecto no vio la luz hasta Enero del siguiente año, incluso varios conceptos (...

Debian cumple 25 años

  Cuando Ian Murdock anunció hace 25 años en comp.os.linux.development, «la inminente terminación de una publicación de Linux nueva, [...] la Publicación Debian Linux», nadie habría esperado que la «Publicación Debian Linux» llegara a ser lo que se...

DebConf18 cierra en Hsinchu y DebConf19 anuncian fechas

El domingo 5 de agosto de 2018, la Conferencia anual de Desarrolladores y Contribuidores de Debian llegó a su fin. Con más de 306 personas que asistieron de todo el mundo, y 137 eventos que incluyen 100 charlas, 25 sesiones de discusión o BoFs, 5...