Desinstalar firefox-esr

9 envíos / 0 nuevos
Último envío
#1 Vie, 08/02/2019 - 01:28
ylarguex
Imagen de ylarguex
Desconectado/a
se unió: 18/11/16

Desinstalar firefox-esr

Estado: 
[ACTIVO]

Buenas tardes, 

Tengo un problema, recién me instalé Debian Testing y todo bien, pero tratando de desinstalar Firefox-ESR me encuentro con el detalle que automáticamente me instala Chromium, sin más opciones SI o SI. Al intentar desinstalar Chromium, proceso inverso, me vuelve a instalar Firefox-ESR. Alguna idea de como solucionar?? o tengo que tener uno de los obligatoriamente instalado. Estoy usando #apt purge firefox-esr para el proceso de desinstalación.

 

saludos cordiales y gracias de antemano.

 

----------

root@isabella:/# apt purge firefox-esr
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
El paquete indicado a continuación se instaló de forma automática y ya no es necesario.
  libdbus-glib-1-2
Utilice «apt autoremove» para eliminarlo.
Se instalarán los siguientes paquetes adicionales:
  chromium chromium-common chromium-sandbox
Paquetes sugeridos:
  chromium-l10n chromium-shell chromium-driver
Los siguientes paquetes se ELIMINARÁN:
  firefox-esr*
Se instalarán los siguientes paquetes NUEVOS:
  chromium chromium-common chromium-sandbox
0 actualizados, 3 nuevos se instalarán, 1 para eliminar y 0 no actualizados.
Se necesita descargar 52,0 MB/52,2 MB de archivos.
Se utilizarán 20,7 MB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n] 
 

 

Vie, 08/02/2019 - 09:51
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

fijate utilizando 

apt --no-install-recommends purge firefox-esr

o si no

aptitude purge firefox-esr

 

Vie, 08/02/2019 - 12:36
ylarguex
Imagen de ylarguex
Desconectado/a
se unió: 18/11/16

Buenos dias, 

 

@rockyiii gracias por responder, probé tu sugerencia pero no, me sigue instalando Chromium. Alguna otra idea?

 

root@isabella:~# apt --no-install-recommends purge firefox-esr
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
El paquete indicado a continuación se instaló de forma automática y ya no es necesario.
  libdbus-glib-1-2
Utilice «apt autoremove» para eliminarlo.
Se instalarán los siguientes paquetes adicionales:
  chromium
Paquetes sugeridos:
  chromium-l10n chromium-shell chromium-driver
Los siguientes paquetes se ELIMINARÁN:
  firefox-esr*
Se instalarán los siguientes paquetes NUEVOS:
  chromium
0 actualizados, 1 nuevos se instalarán, 1 para eliminar y 0 no actualizados.
Se necesita descargar 51,8 MB de archivos.
Se utilizarán 18,0 MB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n]

 

Vie, 08/02/2019 - 12:47
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

Fijate si este enlace te da alguna pista 

Vie, 08/02/2019 - 14:13
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

Yo creo que con aptitude tendría que poder lograr purgar firefox-esr y encontrar la copión de no instalar chromium. igualmente puede que el problema este dado con algun meta-paquete que tenga como dependencias a firefox o chromium

https://stackoverflow.com/questions/47725473/debian-apt-get-remove-firefox-esr-forces-installation-of-chromium

apt-cache --installed rdepends firefox-esr

por ejemplo, en caso de usar gnome, si aparece gnome-core podrías probar de desinstalarlo y fijarte si te deja eliminar firefox-esr

Vie, 08/02/2019 - 21:27
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

Que gestor de escritorio estas utilizando?. creo que el escritorio o algun paquete esta requiriendo un navegador, intenta instalar primero el nevegador que quieres utilizar  después desintala el firefox-esr

 Saludos

 

Dom, 10/02/2019 - 15:26
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Se que es hacer trampa, pero ¿y con synaptic, desde el escritorio?.  A ver que hace,  y si nos aclara algo del porqué.

 (Aunque también me gusta el comando en el enlace que ha puesto Rockiii ).

 

Dom, 10/02/2019 - 21:07
Panko
Imagen de Panko
Conectado
moderador
se unió: 18/02/16

Tal y como apunta el compañero rockyiii, independientemente del escritorio que use, se habrá instalado usando un metapaquete, lo que arrastra la dependencia del navegador y por eso mismo el sistema intenta instalar otro al eliminar firefox-sr.

Como bien ha indicado también, la salida de apt-get arrojará varios paquetes que tengan relación con firefox-esr (esta salida es de mi sistema, variará en otro):

~$ apt-cache --installed rdepends firefox
firefox
Reverse Depends:
  libreoffice-help-ca
  libreoffice
 |xsane
  hunspell-en-us
 |lxqt-core
 |lxqt
  libreoffice-help-ca
  libreoffice
  firefox-l10n-ca
  firefox-l10n-ca

Observando estos paquetes usando aptitude o apt, podemos llegar a ver que, en mi caso, lxqt y lxqt-core son Metapaquetes e incluyen firefox/navegador en los paquetes recomendados o en los sugeridos:

 

~$ aptitude show lxqt
...
Recomana: audacious | clementine | qmmp, calibre, cmst | nm-tray | network-manager-gnome |
          plasma-nm | wicd, smplayer, smtube, quassel | quassel-client | hexchat | irssi |
          weechat, qpdfview, gucharmap, firefox | www-browser, thunderbird | claws-mail | mutt
...
Descripció: Metapackage for LXQt
 

~$ aptitude show lxqt-core
...
Suggereix: firefox | www-browser, lxqt, lxqt-openssh-askpass
...
Descripció: Metapackage for the LXQt core

Si nos fijamos en las recomendaciones de lxqt y las sugerencias de lxqt-core, en ambas podemos ver la cadena firefox | www-browser. Esta es la culpable de la instalación de firefox en primer lugar, y de su sustitución por otro navegador en el caso de desintalación del primero.

Pensando en la configuración por defecto (y siempre en mi caso), el culpable tiene que ser el Metapaquete lxqt, ya que es el que la tiene en recomendaciones y no en sugerencias (debian instala las recomendaciones normalmente, no así las sugerencias).

para poder desinstalar firefox-esr y sustituirlo por otro navegador, probaría con aptitude hasta dar con una solución que convenza y, si no es así, desinstalar directamente el Metapaquete correspondiente y luego firefox-esr.

  No hay bar que por bien no venga....
Dom, 24/02/2019 - 10:37
angel.deb
Imagen de angel.deb
Desconectado/a
se unió: 24/02/19

 

En lugar de "apt purge firefox-esr"¿has probado con el viejo apt-get?

apt-get remove --purge firefox-esr