Algunos errores al actualizar a kernel 5.10

8 envíos / 0 nuevos
Último envío
#1 Sáb, 15/05/2021 - 08:06
Vicente Fab Gar
Imagen de Vicente Fab Gar
Desconectado/a
se unió: 13/11/17

Algunos errores al actualizar a kernel 5.10

Estado: 
[SOLUCIONADO]

Buenas tardes,

Tras actualizar el kernel a 5.10, journalctl me lanza los siguientes errores:

may 15 12:53:09 ERAZER-X7745D kernel: tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xdcde3000-0xdcde3fff flags 0x200] vs dcde3000 4000
may 15 12:53:09 ERAZER-X7745D kernel: tpm_crb MSFT0101:00: can't request region for resource [mem 0xdcde3000-0xdcde3fff]
may 15 12:53:09 ERAZER-X7745D kernel: iwlwifi 0000:06:00.0: firmware: failed to load iwl-debug-yoyo.bin (-2)
may 15 12:53:09 ERAZER-X7745D kernel: firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
may 15 12:53:09 ERAZER-X7745D bluetoothd[778]: Sap driver initialization failed.
may 15 12:53:09 ERAZER-X7745D bluetoothd[778]: sap-server: Operation not permitted (1)
may 15 12:53:10 ERAZER-X7745D dhclient[851]: Failed to get interface index: No such device
may 15 12:53:10 ERAZER-X7745D dhclient[851]: 
may 15 12:53:10 ERAZER-X7745D dhclient[851]: If you think you have received this message due to a bug rather
may 15 12:53:10 ERAZER-X7745D dhclient[851]: than a configuration issue please read the section on submitting
may 15 12:53:10 ERAZER-X7745D dhclient[851]: bugs on either our web page at www.isc.org or in the README file
may 15 12:53:10 ERAZER-X7745D dhclient[851]: before submitting a bug.  These pages explain the proper
may 15 12:53:10 ERAZER-X7745D dhclient[851]: process and the information we find helpful for debugging.
may 15 12:53:10 ERAZER-X7745D dhclient[851]: 
may 15 12:53:10 ERAZER-X7745D dhclient[851]: exiting.
may 15 12:53:10 ERAZER-X7745D systemd[1]: Failed to start Raise network interfaces.
may 15 12:53:28 ERAZER-X7745D bluetoothd[778]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
may 15 12:53:28 ERAZER-X7745D bluetoothd[778]: RFCOMM server failed for :1.92/Profile/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb: rfcomm_bind: Address already in use (98)
may 15 12:53:37 ERAZER-X7745D gnome-session-binary[899]: Unrecoverable failure in required component org.gnome.Shell.desktop
 

DEBIAN 10 BUSTER x64

EQUIPO ERAZER CPU: AMD Ryzen 7 1800X (16) @ 3.600GHz 
              `"""            GPU: AMD ATI Radeon RX 480

 

Dom, 16/05/2021 - 05:04
openCHRYSLER
Imagen de openCHRYSLER
Desconectado/a
se unió: 12/05/21

Hola:

La pregunta del millón...¿Te funciona bien todo , por ejemplo la wifi? , porque algunos de esos errores ya fueron reportados.

Además tienes el "incoveniente" de usar Stable con el kernel de Testing. ¿Usas dkms?...¿Está en la versión correspondiente al kernel?

¿Xorg o Wayland?

Saludos.

 

 

Dom, 16/05/2021 - 14:13
Vicente Fab Gar
Imagen de Vicente Fab Gar
Desconectado/a
se unió: 13/11/17

Buenas y gracias por responder:

El todo el hardware del equipo funciona perfecto; unicamente tengo un problema por el cual se me ocurrió (a la desesperada) actualizar el kernel, pero te comento: He vuelto a instalar Debian 10 stable non-free con kernel 4.19. Cuando dejo el equipo funcionando varias horas sin tocarlo, (el modo de suspensión está desactivado) lo dejo con amule funcionando, pero a las pocas horas ni teclado ni ratón ni por supuesto el monitor responden y me toca apagar a lo bestia. Se me ocurre que pudiera ser de la tarjeta madre, pero casi que lo descartaría porque este equipo (ERAZER X7745D) ha sido utilizado con el Ventanas y no ha habido ningún problema. Ahora que tengo la oportunidad (ya que ahora mismo ya no dependo de ningún software exclusivo para el Ventanas) me gustaría meterme ya de lleno con Debian. El teclado es un Logitech G213, el ratón Logitech G203 y el Monitor un HP Omen 25. Cualquier sugerencia es bienvenida.

Muchas gracias.

Editado: Por cierto, uso X-Org, pero he probado con ambos servidores graficos y el problema es el mismo. Prefiero X-Org porque aplicaciones como Synaptic o Gdebi funcionan.

vicfabgar

Dom, 16/05/2021 - 14:33
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

¿qué significa el monitor no responde ? ¿Esta en ahorro de energía ? (negro)

Si es el caso desactiva momentánea la función de ahorro así tenes el monitor en forma permanente 

xset s off
xset s noblank
xset -dpms

Y podes tener un terminal con   top (htop) activado para ver si luego de esas horas hay un exceso de consumo de re cursos y se queda sin memoria por ejemplo .

Para apagar un equipo  "No a lo bestia "  intentas   con las siguientes teclas :

Ctrl + Alt* PrtScr(imprimir pantalla) , y sin dejar de presionar las tres , vas tipeando de a una   r  e   i  s   u  b  , eso  cerrara el sistema y apagara en forma 

sincronizada ( si el teclado responde ) 

¿Intentaste entrar en una TTY ?

Dom, 16/05/2021 - 15:23
Vicente Fab Gar
Imagen de Vicente Fab Gar
Desconectado/a
se unió: 13/11/17

Hola de nuevo,

Tengo Debian para que a los 5 minutos apague la pantalla (el wifi y el bluetooth), a esto añadimos 1 minuto que tarda el monitor en ponerse en suspensión. 

Si acciono el ratón la pantalla debería reaccionar, pero es que no reacciona ni el botón de apagado, tengo que apagar del interruptor en la parte posterior de la torre.

Me apunto lo de REISUB... no tenía ni idea... 

Voy a probar tus sugerencias y ya os cuento. Lo de entrar por tty ni se me había ocurrido... pero claro, necesito que responda el teclado.

 

Muchisimas gracias.

 

vicfabgar

Dom, 16/05/2021 - 17:11
Panko
Imagen de Panko
Conectado
moderador
se unió: 18/02/16

Una vez te haya ocurrido, cuando vuelvas a iniciar el equipo nos pones la salida de:

journalctl -b -1 -p err

ya que la salida de journalctl -b corresponde al arranque actual, donde no te ha ocurrido el error todavía, mientras que con ese -1 le indicas que muestre el journal del arranque inmediatamente anterior al actual, y -p err que solo indique los errores. Seria recomendable que ejecutaras el comando como root, ya que muchas veces no muestra el contenido completo al no tener acceso el usuario al sistema completo.

Habria que buscar también acerca de la cpu y la gráfica, muchos ryzen requieren de configuraciones extra para un correcto funcionamiento, y además son relativamente nuevos sobre todo respecto a Debian 10.

Otro consejillo ya que estamos, viendo lo que falta para que Debian 11 sea lanzado, si vas a realizar una instalación nueva, hazla de Testing en lugar de estable y luego te cambias los repositorios a bullseye, asi te quedarás en estable ya, puesto que lo que hay ahora en testing es lo que va ser la nueva estable en apenas dos meses.

Por otro lado, el error de sap-server del bluetooth se soluciona añadiendo un parametro para que no intente inicializarlo:

con el comando systemctl --full edit bluetooth.service editas el archivo y cambias la linea ExecStart para que te quede

ExecStart=/usr/libexec/bluetooth/bluetoothd --noplugin=sap

 

 

  No hay bar que por bien no venga....
Lun, 17/05/2021 - 06:22
Vicente Fab Gar
Imagen de Vicente Fab Gar
Desconectado/a
se unió: 13/11/17

R-E-I-S-U-B no ha funcionado. Otra vez apagado a huevo... Totalmente bloqueado. De momento no he tocado el monitor con xset hasta que me familiarice con él. Si con Debian 9, cuando lo probé no tuve este problema, no debería tenerlo con 10; la pantalla debería responder en suspensión (en negro total o stand-by).

He editado el bluetoothh.service y la linea propuesta, guardado los cambios, pero al iniciar vuelve a ExecStart=/usr/lib/bluetooth/bluetoothd

No he podido listar journalctl -b -1 -p err puesto que el registro no estaba habilitado. He creado /var/log/journal y modificado journald.conf y cambiado Storage=persistent. Después journalctl --list boots y ya aparecen los registros a partir de este momento.

Ahora a esperar... esta noche lo volveré a dejar conectado y mañana listaré.

Éste es el journalctl -b -p err (actual en Debian 10.9 non-free con 4.19.0-16)

may 17 11:07:56 ERAZER-X7745D kernel: tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xdcde3000-0xdcde3fff flags 0x200] vs dcde3000 4000
may 17 11:07:56 ERAZER-X7745D kernel: tpm_crb MSFT0101:00: can't request region for resource [mem 0xdcde3000-0xdcde3fff]
may 17 11:07:56 ERAZER-X7745D kernel: sp5100-tco sp5100-tco: Watchdog hardware is disabled
may 17 11:07:56 ERAZER-X7745D bluetoothd[781]: Sap driver initialization failed.
may 17 11:07:56 ERAZER-X7745D bluetoothd[781]: sap-server: Operation not permitted (1)
may 17 11:07:57 ERAZER-X7745D dhclient[905]: Failed to get interface index: No such device
may 17 11:07:57 ERAZER-X7745D dhclient[905]: 
may 17 11:07:57 ERAZER-X7745D dhclient[905]: If you think you have received this message due to a bug rather
may 17 11:07:57 ERAZER-X7745D dhclient[905]: than a configuration issue please read the section on submitting
may 17 11:07:57 ERAZER-X7745D dhclient[905]: bugs on either our web page at www.isc.org or in the README file
may 17 11:07:57 ERAZER-X7745D dhclient[905]: before submitting a bug.  These pages explain the proper
may 17 11:07:57 ERAZER-X7745D dhclient[905]: process and the information we find helpful for debugging.
may 17 11:07:57 ERAZER-X7745D dhclient[905]: 
may 17 11:07:57 ERAZER-X7745D dhclient[905]: exiting.
may 17 11:07:57 ERAZER-X7745D systemd[1]: Failed to start Raise network interfaces.
may 17 11:08:10 ERAZER-X7745D bluetoothd[781]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
may 17 11:08:10 ERAZER-X7745D bluetoothd[781]: RFCOMM server failed for :1.90/Profile/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb: rfcomm_bind: Address already in use (98)

Muchas gracias a todos.

vicfabgar

Mié, 19/05/2021 - 04:18
Vicente Fab Gar
Imagen de Vicente Fab Gar
Desconectado/a
se unió: 13/11/17

Buenos días, y muy buenos porque me he levantado de la cama y veo que todo funciona perfectamente y el asunto queda, por fin, solucionado. Después de instalar Debian, después de instalar Ubuntu y después de instalar Fedora y obtener el mismo bloqueo constante me quedó claro que no era una cuestión de software o de SO...  algo debía pasar con la placa base.

Problema parece ser con el módulo ACPI y la configuración de la energía. Si se queda sin memoria en modo ahorro no puede mantener los dispositivos conectados, que también deben de ser compatibles con éste módulo. En fin, más madera...

Solución: Cargar los valores por defecto de la placa base, reiniciar, volver a entrar en UEFI-BIOS, cambiar la información del SO de Win10 a Otro OS reiniciar e instalar Debian 10.

Muchas gracias por vuestra atención. 

Saludos.

 

 

vicfabgar