¡Se lanza Salix Xfce 15.0!

2 envíos / 0 nuevos
Último envío
#1 Dom, 11/09/2022 - 15:46
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

¡Se lanza Salix Xfce 15.0!

Estado: 
[SOLUCIONADO]

Ha sido un largo viaje. ¡Salix 15.0 finalmente está aquí! ¡Con tanto tiempo desde nuestro lanzamiento estable, el registro de cambios es enorme y muchas cosas han cambiado!

¡En un alto nivel, esta versión incluye Xfce 4.16 como entorno principal! Ahora se basa en GTK+3 y casi todo lo demás que viene con una instalación predeterminada se ha actualizado para usar GTK+3. Esto incluye todas nuestras herramientas gráficas del sistema, que han recibido importantes actualizaciones y un aspecto más moderno. La selección de software predeterminada no ha cambiado mucho, pero, por supuesto, todo se ha actualizado a sus últimas versiones, incluidos Firefox 102ESR, LibreOffice 7.4, GIMP 2.10 y más. Whiskermenu se usa ahora como nuestro menú de panel predeterminado. Ha habido extensas discusiones en nuestros foros con respecto a cómo se verá la nueva versión y todo se ha renovado, incluido un nuevo tema GTK, un nuevo tema de iconos, un nuevo tema del administrador de ventanas y un fondo de pantalla predeterminado, especialmente diseñado para Salix 15.0. Si bien las versiones "claras" de las anteriores se usan de forma predeterminada, las versiones "oscuras" están disponibles. En general, nuestros usuarios se encontrarán en un entorno moderno pero familiar.

Una de las razones por las que tomó tanto tiempo hacer este lanzamiento es que nuestros repositorios de software ahora están llenos de paquetes. Hemos creado miles de paquetes con un enorme esfuerzo y están disponibles para su instalación inmediata a través del administrador de paquetes Gslapt. ¡Los repositorios de paquetes para 15.0 son más grandes que los de todas nuestras versiones anteriores combinadas! Además de eso, ¡ahora es posible instalar software usando flatpaks! Salix 15.0 tiene Flathub como una fuente de software preconfigurada y también hemos desarrollado software para una mejor integración de escritorio. Los usuarios solo deben navegar por flathub.org e instalar cualquier software que deseen con unos pocos clics.

El instalador ha recibido varias actualizaciones bajo el capó, pero en la superficie es el mismo instalador clásico basado en diálogos de texto que siempre hemos tenido. Gracias a nuestra maravillosa comunidad de traductores, ahora está disponible en varios idiomas, incluidos catalán, holandés, inglés (EE. UU. y Gran Bretaña), francés, alemán, griego, húngaro, italiano, polaco, portugués (Brasil y Portugal), español ( España y Costa Rica), sueco, turco y ucraniano!

En un nivel inferior, muchas cosas han cambiado considerablemente, en su mayoría heredadas de Slackware, incluida la adopción de PAM y GCC 11, GLIBC 2.33 y kernel 5.15.63 actualizados, mientras que ConsoleKit ha sido reemplazado por elogind. Como siempre, se proporciona un entorno de desarrollo completo con la instalación predeterminada de Salix.

Contra todas las tendencias actuales, Salix 15.0 viene en versiones de 64 y 32 bits, por lo que se puede usar en hardware moderno y antiguo. Como siempre, la iso de 32 bits incluye un kernel i686 con soporte SMP que requiere PAE y un kernel i586 sin soporte SMP que puede ejecutarse en CPU sin PAE.

No podría agradecer lo suficiente a todas las personas que participaron en las pruebas de nuestros prelanzamientos. El aporte de todos fue invaluable. Este lanzamiento no hubiera sido posible sin todos los que estuvieron involucrados de alguna manera. Este es el mayor lanzamiento hasta ahora. ¡Gracias!

Dom, 11/09/2022 - 16:04
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

Descargas,
https://forum.salixos.org/viewtopic.php?f=17&t=8409
https://salixos.org/download.html

(1) Gapan ha compilado una gran cantidad de SlackBuilds para que sean instalados sin problemas con slapt-get. Claro todavía existe la alternativa de pasar por https://slackbuilds.org/, y usar slapt-src para compilar con las opciones que se necesiten.

(2) glibc 2.35 o anterior todavía funciona en hardware antiguo, pero 2.36 no. Salix 15.0 tiene glibc 2.33, por lo que sigue siendo una opción para los viejos, pero supongo que en versiones posteriores ya no será así. Tarde o temprano, solo las distribuciones GNU/Linux basadas en Musl funcionarán en los viejos (como void linux o alpine linux), o FreeBSD y amigos.

(3) Solo un problema tuvo mi instalación Salix 14.2 en mi viejo pentium 4. Se notifico en linuxquestion/slackware y a las pocas horas se soluciono.

Disfruten.