Activar placa de red wifi sin tecla de funcion

8 envíos / 0 nuevos
Último envío
#1 Mar, 08/08/2017 - 10:25
vjavo
Imagen de vjavo
Desconectado/a
se unió: 08/08/17

Activar placa de red wifi sin tecla de funcion

Buenas este es mi primer post. Soy usuario relativamente nuevo de Debían.

Tengo una notebook Exo, con procesador intel i3 y 4 gb de ram, pero hace un tiempo empezó a fallarle algunas teclas. Y la mas problemática era de FUNCION que activa el wifi, ademas de la barra espaciadora (en ese momento tenia instalado Win 10 como SO).

Quise seguir darle mas vida util a esta portátil e instale Debían 9. Sabia que se puede desde la consola activar el wifi, porque la conexion ethernet funciona sin problemas.

Paso a un paste de los comando que he usado y sigue bloqueado el hardaware, en este caso el wifi.
 

root@debian-note:/home/sanvar# ip a show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp2s0f5: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 80:ee:73:32:34:84 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.113/24 brd 192.168.0.255 scope global dynamic enp2s0f5
       valid_lft 81310sec preferred_lft 81310sec
    inet6 fe80::82ee:73ff:fe32:3484/64 scope link
       valid_lft forever preferred_lft forever
3: wlp1s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 86:1a:3e:5f:2e:eb brd ff:ff:ff:ff:ff:ff


root@debian-note:/home/sanvar# ip li set wlp1s0 up
RTNETLINK answers: Operation not possible due to RF-kill
root@debian-note:/home/sanvar# rfkill unblock all
root@debian-note:/home/sanvar# rfkill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Al tratar de debloquear con el comando rfkill, sigue blockeada la misma, ya no se por donde mas intentar. Alguna sugerencia.

Gracias

Mar, 08/08/2017 - 10:54
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Seguramente te falta el controlador privativo firmware-realtek

su
apt update
apt install firmware-realtek

 si al tratar de instalarlo te pone que no lo encuentra o algo por el estilo, pega el contenido del comando

cat /etc/apt/sources.list

saludos...

Mar, 08/08/2017 - 18:29
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Hard Blocked.... si no te funciona la tecla de función, me da que con rfkill no harás nada.... dicha tecla parece que se te bloqueó precisamente estando la wifi desactivada.

Si no fuera problema de que no tuvieses el firmware instalado, como te han dicho ya, puedes mirar con lspci -k que modulo controla la wifi y después usar el comando

modinfo MODULO

para ver los parámetros que acepta dicho módulo. Con suerte hay alguno que te permita desbloquearla. Puedes poner aqui la salida que te da para que la veamos.

Si aún así no consigues desbloquearla, puedes tratar de usar algún teclado en pantalla o, en última instancia, remapear esa combinación de teclas a otra que si te funcione y no utilices.

  No hay bar que por bien no venga....
Mié, 09/08/2017 - 08:48 (Responder a #3)
vjavo
Imagen de vjavo
Desconectado/a
se unió: 08/08/17

ROCKYIII Intente hacer lo que me decias, pero el esta instalado la version correcta aparentemente.

root@debian-note:/home/sanvar# aptitude install firmware-realtek
firmware-realtek ya está instalado en la versión solicitada (20161130-3)
firmware-realtek ya está instalado en la versión solicitada (20161130-3)
No se instalará, actualizará o eliminará ningún paquete.
0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 0 B de ficheros. Después de desempaquetar se usarán 0 B.

 

Mié, 09/08/2017 - 09:01 (Responder a #4)
vjavo
Imagen de vjavo
Desconectado/a
se unió: 08/08/17

Panko wrote:

Hard Blocked.... si no te funciona la tecla de función, me da que con rfkill no harás nada.... dicha tecla parece que se te bloqueó precisamente estando la wifi desactivada.

Si no fuera problema de que no tuvieses el firmware instalado, como te han dicho ya, puedes mirar con lspci -k que modulo controla la wifi y después usar el comando

modinfo MODULO

para ver los parámetros que acepta dicho módulo. Con suerte hay alguno que te permita desbloquearla. Puedes poner aqui la salida que te da para que la veamos.

Si aún así no consigues desbloquearla, puedes tratar de usar algún teclado en pantalla o, en última instancia, remapear esa combinación de teclas a otra que si te funcione y no utilices.

 

Panko utilice el comando lspci -k y me da el modulo que maneja el wifi, te paso la salida:

root@debian-note:/home/sanvar# modinfo rtl8192ce
filename:       /lib/modules/4.9.0-3-686-pae/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8192ce/rtl8192ce.ko
firmware:       rtlwifi/rtl8192cfwU_B.bin
firmware:       rtlwifi/rtl8192cfwU.bin
firmware:       rtlwifi/rtl8192cfw.bin
description:    Realtek 8192C/8188C 802.11n PCI wireless
license:        GPL
author:         Larry Finger    <Larry.Finger@lwfinger.net>
author:         Realtek WlanFAE    <wlanfae@realtek.com>
author:         lizhaoming    <chaoming_li@realsil.com.cn>
alias:          pci:v000010ECd00008176sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008177sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008178sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008191sv*sd*bc*sc*i*
depends:        rtlwifi,rtl_pci,rtl8192c-common,mac80211
intree:         Y
vermagic:       4.9.0-3-686-pae SMP mod_unload modversions 686
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           debug:Set debug level (0-5) (default 0) (int)
 

Dom, 10/09/2017 - 11:45
msnjuegos
Imagen de msnjuegos
Desconectado/a
se unió: 24/08/16

Estimado, ¿pudiste resolver tu problema?  Me pasa lo mismo en mi caso con la tarjeta de wifi Ralink RT3290, tengo instalado el firmware rt2800pci y no hay caso de que puedo desbloquear el wifi, sin embargo en Windows no tengo ningún problema con la activación y desactivación por medio de la tecla de wifi (Fn+F12)

Alan

Dom, 10/09/2017 - 11:58
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

msnjuegos, para hacer una consulta tenes que abrir tu propio tema ,aportando los datos necesarios ,

https://exdebian.org/normas/normas-del-foro

Mar, 12/09/2017 - 06:10
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

@vjavo, como root, descarga el módulo de la tarjeta

~# rmmod rtl8192ce

lo que te dejará sin wifi, como se supone que estás ahora, y vuelve a cargarlo con el comando

~# modprobe rtl8192ce options swenc=1

a ver si de esta forma te funciona. Si no fuera así, realiza la misma operación, descarga el modulo otra vez y vuelve a cargarlo cambiando los otros parámetros que te muestra a ver si con uno de ellos se soluciona. A veces, es necesario usar dos parámetros, asi que puedes hacer modprobe modulo options param1=X param2=X.

Una vez des con lo que te permite desbloquear la wifi, te creas un archivo en /etc/modprobe.d/rtl8192ce.conf y dentro metes las opciones de la forma

options rtl8192ce swenc=1

puedes añadir los parámetros que necesites en la misma línea tras el primero, como ejemplo, un archivo mio

~$ cat /etc/modprobe.d/ath9k.conf 
#Module ath9k options
options ath9k nohwcrypt=1 blink=1 ps_enable=1

 

  No hay bar que por bien no venga....