Actualización fallida a Plasma 5 en portátil Lenovo con Debian Sid

30 envíos / 0 nuevos
Último envío
Lun, 12/09/2016 - 14:31
Panko
Imagen de Panko
Conectado
moderador
se unió: 18/02/16

¿Quieres los drivers de la página de nvidia por alguna razón en particular? Piensa que con esos drivers, tendrás que reinstalar manualmente a cada actualización del kernel, y no es nada seguro que te funcionen en esos casos, ya que si hay algun problema tendrás que esperar a que a nvidia le salga actualizar sus drivers para que compilen con las versiones nuevas.

 

La configuración se hace automáticamente al instalar bumblebee. Éste incluye un archivo con los blacklist necesarios para la correcta configuración del sistema y en la configuración del mismo bumblebee le dices si quieres que se usen los drivers propietarios o nouveau (archivo /etc/bumblebee/bumblebee.conf), usando una detección automática si no lo configuras tu.

 

Respecto a los drivers propietarios, si no quieres los de nvidia por nada en especial, puedes usar el paquete nvidia-detect e instalar desde repositorios el driver privativo acorde a lo que te diga. Por ejemplo:

:~$ nvidia-detect 
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119M [GeForce 610M] [10de:1058] (rev ff)

Checking card:  NVIDIA Corporation GF119M [GeForce 610M] (rev ff)
Your card is supported by all driver versions.
It is recommended to install the
    nvidia-driver

en este caso, el comando a utilizar para instalar el driver propietario sería apt install xserver-xorg-video-nvidia. Dicho comando instalará tanto del driver propietario como los paquetes necesarios para su compilación y configuración, incluyendo el paquete dkms necesario para la recompilación del controlador a cada actualización del kernel automáticamente. Con estos drivers puedes seguir usando CUDA mientras instales los paquetes necesarios.

  No hay bar que por bien no venga....
Mar, 13/09/2016 - 14:28 (Responder a #22)
jgpallero
Imagen de jgpallero
Desconectado/a
se unió: 20/03/16

Panko wrote:

¿Quieres los drivers de la página de nvidia por alguna razón en particular? Piensa que con esos drivers, tendrás que reinstalar manualmente a cada actualización del kernel, y no es nada seguro que te funcionen en esos casos, ya que si hay algun problema tendrás que esperar a que a nvidia le salga actualizar sus drivers para que compilen con las versiones nuevas.

 

La configuración se hace automáticamente al instalar bumblebee. Éste incluye un archivo con los blacklist necesarios para la correcta configuración del sistema y en la configuración del mismo bumblebee le dices si quieres que se usen los drivers propietarios o nouveau (archivo /etc/bumblebee/bumblebee.conf), usando una detección automática si no lo configuras tu.

 

Respecto a los drivers propietarios, si no quieres los de nvidia por nada en especial, puedes usar el paquete nvidia-detect e instalar desde repositorios el driver privativo acorde a lo que te diga. Por ejemplo:

:~$ nvidia-detect 
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119M [GeForce 610M] [10de:1058] (rev ff)

Checking card:  NVIDIA Corporation GF119M [GeForce 610M] (rev ff)
Your card is supported by all driver versions.
It is recommended to install the
    nvidia-driver

en este caso, el comando a utilizar para instalar el driver propietario sería apt install xserver-xorg-video-nvidia. Dicho comando instalará tanto del driver propietario como los paquetes necesarios para su compilación y configuración, incluyendo el paquete dkms necesario para la recompilación del controlador a cada actualización del kernel automáticamente. Con estos drivers puedes seguir usando CUDA mientras instales los paquetes necesarios.

Gracias por tu respuesta. En mi instalación anterior instalaba a mano el driver de nvidia simplemente porque tenía la sensación de que en los repositorios no estaba la última versión, cosas de una versionitis que no debería tener, ya que llevo 10 años con linux.

Ahora mismo tengo instalados los drivers vesa, intel y nouveau, además de los paquetes bumblebee y primus. El problema es que no sé cuál es la GPU que está usando el sistema, si el la Intel o la nvidia. Durante la instalación de bumblebee no me pidió ninguna configuración y en el fichero /etc/bumblebee/bumblebee.conf no encuentro nada que me permita saberlo:

# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d
# Xorg binary to run
XorgBinary=/usr/lib/xorg/Xorg

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method, use at your own risk
#             none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia/nvidia,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

Pone que el driver se selecciona automáticamente y que los disponibles son nouveau y nvidia, pero eso no es cierto, ya que sólo tengo instalados vesa, intel y nouveau.

Yo quiero hacer lo siguiente:

1. El sistema ha de utilizar la GPU integrada de Intel para el trabajo normal (monitor, etc.)

2. Necesito que los driver oficiales de nvidia estén instalados para poder utilizar CUDA con la GPU Quadro K2100M que tiene el portátil

Veo en los repositorios que hay un paquete llamado bumblebee-nvidia. ¿He de instalarlo si quiero trabajar con el driver propietario de nvidia de los repositorios? Y si lo instalo, ¿he de desinstalar el bumblebee del repositorio main? ¿Cómo puedo entonces decirle al sistema que use el driver de Intel?

Gracias

Mar, 13/09/2016 - 16:12
Panko
Imagen de Panko
Conectado
moderador
se unió: 18/02/16

A ver... que hay info por ahi

Tú tienes un equipo que usa tecnología optimus. A diferencia de otros sistemas con dos gráficas, la tecnología Optimus no permite escojer entre una u otra. En este caso, un sistema con Optimus siempre utiliza la gráfica integrada (Intel) para todo (absolutamente para todo). En el momento que quieras utilizar la gráfica dedicada (nvidia), se lo indicas al sistema con el comando optirun o primusrun (hay una ligera diferencia entre uno y otro).

En el caso de utilizar la gráfica dedicada, el sistema lo que hace es utilizar ésta para realizar todo el trabajo, y luego le pasa el resultado a la gráfica integrada para que lo presente en pantalla.

Es decir, tienes dos escenarios, en uno el sistema utiliza la gráfica integrada (la intel) y no usa la dedicada (nvidia), en el otro, el sistema usa las dos gráficas, una para realizar el trabajo y la otra para presentarlo.

 

respecto a tus dudas, bumblebee configurado en auto, busca el driver disponible en el sistema y lo utiliza cuando uses optirun/primus. Si tienes nouveau, usará éste, y si tienes el privativo, usará el privativo. Puedes tener ambos drivers instalados sin problemas (yo lo tengo así por si falla uno usar el otro las pocas veces que uso la nvidia), ya que al momento de instalar bumblebee, se crea el archivo de blacklist donde se incluyen tanto nouveau como nvidia para evitar que el sistema cargue uno u otro e interfiera con bumblebee. En este caso escojerá el más acorde a tu tarjeta.

 

si quieres obligarlo a usar uno u otro, puedes tener solo el que quieres instalado o configurar bumblebee para use uno u otro.

 

Respecto a bumblebee y bumblebee-nvidia, no son lo mismo. Bumblebee es el paquete que añade soporte para Optimus en GNU/Linux (puedes instalar este si vas a usar el driver nouveau), mientras que bumblebee-nvidia suma a ese soporte las dependencias con el driver privativo y los paquetes necesarios (tienes que instalar este para usar el driver nvidia y no tener problemas con la falta de algún paquete). Puedes usar el driver privativo siempre que lo tengas instalado configurando bumblebee, pero para una instalación más sencilla es recomendable instalar bumblebee-nvidia que contiene las dependencias necesarias.

 

En tu caso, si no quieres andar trasteando con los drivers de la página de nvidia, te bastaría con instalar el driver propietario como te dije, añadiendo al comando de instalación el paquete bumblebee-nvidia, es decir, apt install xserver-xorg-video-nvidia-XXX bumblebee-nvidia y, si quieres estar seguro de que se usa ese, configurar en /etc/bumblebee/bumblebee.conf que use el driver nvidia en lugar de nouveau.

 

Por otro lado, en algunos sistemas la gráfica dedicada se queda encendida aun cuando no está siendo usada, eso lo arreglas creando el archivo /etc/modprobe.d/bbswitch.conf y metiendo dentro

options bbswitch load_state=0 unload_state=0

así, de esta forma la nvidia permanecerá apagada al inicio del sistema y se apagará cuando dejes de usarla.

 

Resumiento, para usar el sistema como tu quieres:
 

apt install nvidia-detect

nvidia-detect

apt install bumblebee-nvidia xserver-xorg-video-nvidia(busca el paquete que coincida con lo que te ha devuelto el comando anterior)

Luego edita el archivo /etc/bumblebee/bumblebee.conf y busca las líneas

# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia

y modifica sólo esa Driver=nvidia (puede poner nouveau, p.e.), para asegurarte que queda como lo ves en el ejemplo. Ya puedes usar el sistema como tu quieres, salvo que haya algún otro problema con tu configuración, claro.

  No hay bar que por bien no venga....
Jue, 15/09/2016 - 13:25 (Responder a #24)
jgpallero
Imagen de jgpallero
Desconectado/a
se unió: 20/03/16

Muchas gracias por tu respuesta

Panko wrote:

Tú tienes un equipo que usa tecnología optimus. A diferencia de otros sistemas con dos gráficas, la tecnología Optimus no permite escojer entre una u otra. En este caso, un sistema con Optimus siempre utiliza la gráfica integrada (Intel) para todo (absolutamente para todo). En el momento que quieras utilizar la gráfica dedicada (nvidia), se lo indicas al sistema con el comando optirun o primusrun (hay una ligera diferencia entre uno y otro).

En el caso de utilizar la gráfica dedicada, el sistema lo que hace es utilizar ésta para realizar todo el trabajo, y luego le pasa el resultado a la gráfica integrada para que lo presente en pantalla.

Es decir, tienes dos escenarios, en uno el sistema utiliza la gráfica integrada (la intel) y no usa la dedicada (nvidia), en el otro, el sistema usa las dos gráficas, una para realizar el trabajo y la otra para presentarlo.

En este caso, ¿hay que ejecutar optirun o primusrun a mano o se puede indicar en algún archivo de configuración? ¿Es necesario este comando también para usar CUDA? ¿Es mejor usar optirun o primusrun en este caso de uso sólo para cálculo con CUDA?

Panko wrote:

respecto a tus dudas, bumblebee configurado en auto, busca el driver disponible en el sistema y lo utiliza cuando uses optirun/primus. Si tienes nouveau, usará éste, y si tienes el privativo, usará el privativo. Puedes tener ambos drivers instalados sin problemas (yo lo tengo así por si falla uno usar el otro las pocas veces que uso la nvidia), ya que al momento de instalar bumblebee, se crea el archivo de blacklist donde se incluyen tanto nouveau como nvidia para evitar que el sistema cargue uno u otro e interfiera con bumblebee. En este caso escojerá el más acorde a tu tarjeta.

Entiendo entonces que el driver privativo tiene prioridad sobre el nouveau si están los dos instalados y no tocamos la configuración por defecto de bumblebee

Panko wrote:

Por otro lado, en algunos sistemas la gráfica dedicada se queda encendida aun cuando no está siendo usada, eso lo arreglas creando el archivo /etc/modprobe.d/bbswitch.conf y metiendo dentro

options bbswitch load_state=0 unload_state=0

así, de esta forma la nvidia permanecerá apagada al inicio del sistema y se apagará cuando dejes de usarla.

¿En el caso de crear este fichero hay que usar también el optirun/primusrun?

Panko wrote:

Resumiento, para usar el sistema como tu quieres:
 

apt install nvidia-detect

nvidia-detect

apt install bumblebee-nvidia xserver-xorg-video-nvidia(busca el paquete que coincida con lo que te ha devuelto el comando anterior)

Luego edita el archivo /etc/bumblebee/bumblebee.conf y busca las líneas

# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia

y modifica sólo esa Driver=nvidia (puede poner nouveau, p.e.), para asegurarte que queda como lo ves en el ejemplo. Ya puedes usar el sistema como tu quieres, salvo que haya algún otro problema con tu configuración, claro.

El caso es que, y perdona si soy pesado o no sé explicarme bien, no me queda claro aún que pueda usar el sistema como yo quiero. Es decir, yo lo que quiero es usar la nvidia sólo para calcular con CUDA y que el resto del trabajo (visualización, etc.) lo haga la Intel. Pero entiendo que si tengo bumblebee y ejecuto optirun inmediatamente el sistema utilizará internamente la nvidia no sólo para mis cálculos, sino que también para otras tareas, aunque luego delegue la visualización en la Intel

Jue, 15/09/2016 - 20:21
Panko
Imagen de Panko
Conectado
moderador
se unió: 18/02/16

1º Cualquier cosa que quieras que use la nvidia, si. Tendrás que lanzarlo a mano con el comando optirun o crearte un lanzador que contenga el comando que quieras (optirun comando), no lo puedes decir en ningún archivo de configuración. Por ejemplo, para ejecutar blender tienes su lanzador en el menú, y necesitarías crearte otro lanzador copiado del primero añadiendole tu el comando optirun al inicio. Así uno lanzará blender y otro optirun blender. Desconozco en que casos te convendría usar primusrun u optirun, la verdad.

 

2º Pues no lo he usado en modo auto, lo tengo configurado para nouveau siempre, y lo cambio a nvidia para probar que sigue funcionando. Desconozco como decide que driver usar, así solo puedo conjeturar que preferirá nouveau por ser libre (cuando dije que lo tenía así me refería a que tengo los dos drivers instalados, no que esté configurado en auto. De hecho tengo dos archivos de configuración para no andar editando).

 

3º Si, sigues teniendo que usar optirun. Ese archivo de opciones para el módulo bbswith hace que al cargarse éste (es el que controla el encendido/apagado de la nvidia) la gráfica dedicada se apaga para no consumir energía. El segundo parámetro hace que se apague la nvidia cuando se haya acabado la ejecución del comando con optirun.

 

4º No. El sistema usará la nvidia solo para lo que le indiques con optirun. Si tu ejecutas optirun blender, la nvidia solo se encarga de realizar la ejecución de blender. Todas las demás aplicaciones del sistema seguirán usando la intel solo. Siguiendo éste mismo caso, todo aquello que vayas a hacer usando cuda, tendrás que hacerlo anteponiendo optirun al inicio del comando (sin saber como iría eso, si es un script tuyo, pues sería optirun script.sh. Si no es un script que es un solo comando, lo mismo, optirun comando). Ésto puedes comprobarlo de una forma sencilla: abrete dos consolas, en una de ellas ejecuta el comando optirun glxgears -info y luego ejecuta en la otra glxgears -info. Verás que en la primera te indica que está usando la nvidia, y en la segunda te indica que está usando la intel y no la nvidia aunque esté en marcha.

  No hay bar que por bien no venga....
Vie, 16/09/2016 - 06:40 (Responder a #26)
jgpallero
Imagen de jgpallero
Desconectado/a
se unió: 20/03/16

Panko wrote:

1º Cualquier cosa que quieras que use la nvidia, si. Tendrás que lanzarlo a mano con el comando optirun o crearte un lanzador que contenga el comando que quieras (optirun comando), no lo puedes decir en ningún archivo de configuración. Por ejemplo, para ejecutar blender tienes su lanzador en el menú, y necesitarías crearte otro lanzador copiado del primero añadiendole tu el comando optirun al inicio. Así uno lanzará blender y otro optirun blender. Desconozco en que casos te convendría usar primusrun u optirun, la verdad.

 

2º Pues no lo he usado en modo auto, lo tengo configurado para nouveau siempre, y lo cambio a nvidia para probar que sigue funcionando. Desconozco como decide que driver usar, así solo puedo conjeturar que preferirá nouveau por ser libre (cuando dije que lo tenía así me refería a que tengo los dos drivers instalados, no que esté configurado en auto. De hecho tengo dos archivos de configuración para no andar editando).

 

3º Si, sigues teniendo que usar optirun. Ese archivo de opciones para el módulo bbswith hace que al cargarse éste (es el que controla el encendido/apagado de la nvidia) la gráfica dedicada se apaga para no consumir energía. El segundo parámetro hace que se apague la nvidia cuando se haya acabado la ejecución del comando con optirun.

 

4º No. El sistema usará la nvidia solo para lo que le indiques con optirun. Si tu ejecutas optirun blender, la nvidia solo se encarga de realizar la ejecución de blender. Todas las demás aplicaciones del sistema seguirán usando la intel solo. Siguiendo éste mismo caso, todo aquello que vayas a hacer usando cuda, tendrás que hacerlo anteponiendo optirun al inicio del comando (sin saber como iría eso, si es un script tuyo, pues sería optirun script.sh. Si no es un script que es un solo comando, lo mismo, optirun comando). Ésto puedes comprobarlo de una forma sencilla: abrete dos consolas, en una de ellas ejecuta el comando optirun glxgears -info y luego ejecuta en la otra glxgears -info. Verás que en la primera te indica que está usando la nvidia, y en la segunda te indica que está usando la intel y no la nvidia aunque esté en marcha.

Muchas gracias de nuevo, ahora lo tengo todo muchísimo más claro.

Si hago glxgears -info el sistema me devuelve

GL_RENDERER   = Mesa DRI Intel(R) Haswell Mobile 
GL_VERSION    = 3.0 Mesa 12.0.3
GL_VENDOR     = Intel Open Source Technology Center

que es exactamente lo que dices.

Sin embargo, si hago optirun glxgears -info o primusrun glxgears -info (no tengo instalados aún los paquetes privativos, pero sí xserver-xorg-video-nouveau, bumblebee y primus) obtengo

[  587.563177] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NOUVEAU(0): [drm] failed to set drm interface version.

[  587.563202] [ERROR]Aborting because fallback start is disabled.

¿A qué puede ser debido? La configuración de las X y bumblebee es la que viene por defecto, yo no he tocado nada

Gracias

Vie, 16/09/2016 - 06:45 (Responder a #27)
jgpallero
Imagen de jgpallero
Desconectado/a
se unió: 20/03/16

jgpallero wrote:

Panko wrote:

1º Cualquier cosa que quieras que use la nvidia, si. Tendrás que lanzarlo a mano con el comando optirun o crearte un lanzador que contenga el comando que quieras (optirun comando), no lo puedes decir en ningún archivo de configuración. Por ejemplo, para ejecutar blender tienes su lanzador en el menú, y necesitarías crearte otro lanzador copiado del primero añadiendole tu el comando optirun al inicio. Así uno lanzará blender y otro optirun blender. Desconozco en que casos te convendría usar primusrun u optirun, la verdad.

 

2º Pues no lo he usado en modo auto, lo tengo configurado para nouveau siempre, y lo cambio a nvidia para probar que sigue funcionando. Desconozco como decide que driver usar, así solo puedo conjeturar que preferirá nouveau por ser libre (cuando dije que lo tenía así me refería a que tengo los dos drivers instalados, no que esté configurado en auto. De hecho tengo dos archivos de configuración para no andar editando).

 

3º Si, sigues teniendo que usar optirun. Ese archivo de opciones para el módulo bbswith hace que al cargarse éste (es el que controla el encendido/apagado de la nvidia) la gráfica dedicada se apaga para no consumir energía. El segundo parámetro hace que se apague la nvidia cuando se haya acabado la ejecución del comando con optirun.

 

4º No. El sistema usará la nvidia solo para lo que le indiques con optirun. Si tu ejecutas optirun blender, la nvidia solo se encarga de realizar la ejecución de blender. Todas las demás aplicaciones del sistema seguirán usando la intel solo. Siguiendo éste mismo caso, todo aquello que vayas a hacer usando cuda, tendrás que hacerlo anteponiendo optirun al inicio del comando (sin saber como iría eso, si es un script tuyo, pues sería optirun script.sh. Si no es un script que es un solo comando, lo mismo, optirun comando). Ésto puedes comprobarlo de una forma sencilla: abrete dos consolas, en una de ellas ejecuta el comando optirun glxgears -info y luego ejecuta en la otra glxgears -info. Verás que en la primera te indica que está usando la nvidia, y en la segunda te indica que está usando la intel y no la nvidia aunque esté en marcha.

Muchas gracias de nuevo, ahora lo tengo todo muchísimo más claro.

Si hago glxgears -info el sistema me devuelve

GL_RENDERER   = Mesa DRI Intel(R) Haswell Mobile 
GL_VERSION    = 3.0 Mesa 12.0.3
GL_VENDOR     = Intel Open Source Technology Center

que es exactamente lo que dices.

Sin embargo, si hago optirun glxgears -info o primusrun glxgears -info (no tengo instalados aún los paquetes privativos, pero sí xserver-xorg-video-nouveau, bumblebee y primus) obtengo

[  587.563177] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NOUVEAU(0): [drm] failed to set drm interface version.

[  587.563202] [ERROR]Aborting because fallback start is disabled.

¿A qué puede ser debido? La configuración de las X y bumblebee es la que viene por defecto, yo no he tocado nada

Gracias

Parece que lo recomendado en este caso es pasarse directamente al driver propietario: https://wiki.archlinux.org/index.php/bumblebee#NOUVEAU.280.29:_.5Bdrm.5D_failed_to_set_drm_interface_version

Vie, 16/09/2016 - 10:51
Panko
Imagen de Panko
Conectado
moderador
se unió: 18/02/16

Bueno, nouveau no funciona bien con todas las nvidia, con algunas no va, con otras necesitas obtener un firmware... si has comprobado que es tu caso, pues pasas al driver xserver-xorg-video-nvidia-XXXX y la instalación de cuda y cuda-toolkit, configuras bumblebee si fuera necesario y asunto solucionado. El mismo error que te aparece a tí, lo tuve yo en un par de versiones del controlador nouveau y se arregló con las actualizaciones.

 

P.P.: Desde luego, vaya pedazo de off-topic que nos hemos cascao en este hilo xD

  No hay bar que por bien no venga....
Vie, 16/09/2016 - 11:15 (Responder a #29)
jgpallero
Imagen de jgpallero
Desconectado/a
se unió: 20/03/16

Panko wrote:

Bueno, nouveau no funciona bien con todas las nvidia, con algunas no va, con otras necesitas obtener un firmware... si has comprobado que es tu caso, pues pasas al driver xserver-xorg-video-nvidia-XXXX y la instalación de cuda y cuda-toolkit, configuras bumblebee si fuera necesario y asunto solucionado. El mismo error que te aparece a tí, lo tuve yo en un par de versiones del controlador nouveau y se arregló con las actualizaciones.

 

P.P.: Desde luego, vaya pedazo de off-topic que nos hemos cascao en este hilo xD

He instalado el driver propietario (el nouveau no lo he quitado y no he tocado la configuración de bumblebee) y todo va como la seda; optirun glxgears -info devuelve

GL_RENDERER   = Quadro K2100M/PCIe/SSE2
GL_VERSION    = 4.5.0 NVIDIA 361.45.18
GL_VENDOR     = NVIDIA Corporation

He creado también el /etc/modprobe.d/bbswitch.conf, tal y como habías dicho.

 

Reitero mi agradecimiento por todas tus respuestas. He aprendido muchísimo en este hilo