aMule, no conecta red Kad

11 envíos / 0 nuevos
Último envío
#1 Vie, 23/06/2017 - 18:04
juancuyo
Imagen de juancuyo
Desconectado/a
se unió: 04/05/16

aMule, no conecta red Kad

Hola y buenas tardes, he instalado Debian 9 y entre las configuraciones, esta la de aMule, en principio, el eMule funciona en una PC con windows, pero ahora no se conecta en esta PC con Debian 9, las PC tienen conexion por cable cada una a un router, de alli solo 1 cable sale al moden, y de alli un cable a la antena por UHF (zona rural), asi que todas pasan por el mismo lugar, solo que no se conecta esta con aMule. Esta tildado el UPnP, los puertos de TCP y UDP, no son los que trae por defecto ,se los he cambiado como sugieren, tambien baje unos server.met pero no me apaño para instalarlos, la red ED2K si conecta y esta en verde. Debian 9, escritorio xfce, Lo siento salio asi el lshw, no se si es posible de otra manera, el Router es un AirLive. No se el modelo.Me molesta y me fastidia que instale el eMule en Windows para ver si tenia el mismo problema y resulta que funciona...me cachi!!! Desde ya gracias anticipadas por su buena voluntad.


juan@debian:~$ lshw
WARNING: you should run this program as super-user.
debian
description: Computer
width: 32 bits
*-core
description: Motherboard
physical id: 0
*-memory
description: System memory
physical id: 0
size: 1955MiB
*-cpu
product: Intel(R) Celeron(R) CPU 2.53GHz
vendor: Intel Corp.
physical id: 1
bus info: cpu@0
version: 15.4.9
serial: 0000-0F49-0000-0000-0000-0000
size: 2550MHz
width: 64 bits
capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx x86-64 constant_tsc pebs bts eagerfpu pni dtes64 monitor ds_cpl tm2 cid cx16 xtpr lahf_lm
configuration: id=0
*-pci:0
description: Host bridge
product: CN700/VN800/P4M800CE/Pro Host Bridge
vendor: VIA Technologies, Inc.
physical id: 100
bus info: pci@0000:00:00.0
version: 00
width: 32 bits
clock: 66MHz
configuration: driver=agpgart-via latency=8
resources: irq:0 memory:e8000000-efffffff
*-pci
description: PCI bridge
product: VT8237/VX700 PCI Bridge
vendor: VIA Technologies, Inc.
physical id: 1
bus info: pci@0000:00:01.0
version: 00
width: 32 bits
clock: 66MHz
capabilities: pci normal_decode bus_master cap_list
resources: memory:f4000000-f5ffffff memory:f0000000-f3ffffff
*-display UNCLAIMED
description: VGA compatible controller
product: CN700/P4M800 Pro/P4M800 CE/VN800 Graphics [S3 UniChrome Pro]
vendor: VIA Technologies, Inc.
physical id: 0
bus info: pci@0000:01:00.0
version: 01
width: 32 bits
clock: 66MHz
capabilities: vga_controller bus_master cap_list
configuration: latency=32 mingnt=2
resources: memory:f0000000-f3ffffff memory:f4000000-f4ffffff memory:c0000-dffff
*-ide:0
description: IDE interface
product: VIA VT6420 SATA RAID Controller
vendor: VIA Technologies, Inc.
physical id: f
bus info: pci@0000:00:0f.0
version: 80
width: 32 bits
clock: 33MHz
capabilities: ide bus_master cap_list
configuration: driver=sata_via latency=32
resources: irq:20 ioport:b000(size=8) ioport:b400(size=4) ioport:b800(size=8) ioport:bc00(size=4) ioport:c000(size=16) ioport:c400(size=256)
*-ide:1
description: IDE interface
product: VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE
vendor: VIA Technologies, Inc.
physical id: f.1
bus info: pci@0000:00:0f.1
version: 06
width: 32 bits
clock: 33MHz
capabilities: ide bus_master cap_list
configuration: driver=pata_via latency=32
resources: irq:20 ioport:1f0(size=8) ioport:3f6 ioport:170(size=8) ioport:376 ioport:c800(size=16)
*-usb:0
description: USB controller
product: VT82xx/62xx UHCI USB 1.1 Controller
vendor: VIA Technologies, Inc.
physical id: 10
bus info: pci@0000:00:10.0
version: 81
width: 32 bits
clock: 33MHz
capabilities: uhci bus_master cap_list
configuration: driver=uhci_hcd latency=32
resources: irq:21 ioport:cc00(size=32)
*-usb:1
description: USB controller
product: VT82xx/62xx UHCI USB 1.1 Controller
vendor: VIA Technologies, Inc.
physical id: 10.1
bus info: pci@0000:00:10.1
version: 81
width: 32 bits
clock: 33MHz
capabilities: uhci bus_master cap_list
configuration: driver=uhci_hcd latency=32
resources: irq:21 ioport:d000(size=32)
*-usb:2
description: USB controller
product: VT82xx/62xx UHCI USB 1.1 Controller
vendor: VIA Technologies, Inc.
physical id: 10.2
bus info: pci@0000:00:10.2
version: 81
width: 32 bits
clock: 33MHz
capabilities: uhci bus_master cap_list
configuration: driver=uhci_hcd latency=32
resources: irq:21 ioport:d400(size=32)
*-usb:3
description: USB controller
product: VT82xx/62xx UHCI USB 1.1 Controller
vendor: VIA Technologies, Inc.
physical id: 10.3
bus info: pci@0000:00:10.3
version: 81
width: 32 bits
clock: 33MHz
capabilities: uhci bus_master cap_list
configuration: driver=uhci_hcd latency=32
resources: irq:21 ioport:d800(size=32)
*-usb:4
description: USB controller
product: USB 2.0
vendor: VIA Technologies, Inc.
physical id: 10.4
bus info: pci@0000:00:10.4
version: 86
width: 32 bits
clock: 33MHz
capabilities: ehci bus_master cap_list
configuration: driver=ehci-pci latency=32
resources: irq:21 memory:f6000000-f60000ff
*-isa
description: ISA bridge
product: VT8237 ISA bridge [KT600/K8T800/K8T890 South]
vendor: VIA Technologies, Inc.
physical id: 11
bus info: pci@0000:00:11.0
version: 00
width: 32 bits
clock: 33MHz
capabilities: isa bus_master cap_list
configuration: latency=0
*-multimedia
description: Multimedia audio controller
product: VT8233/A/8235/8237 AC97 Audio Controller
vendor: VIA Technologies, Inc.
physical id: 11.5
bus info: pci@0000:00:11.5
version: 60
width: 32 bits
clock: 33MHz
capabilities: cap_list
configuration: driver=snd_via82xx latency=0
resources: irq:22 ioport:dc00(size=256)
*-communication
description: Communication controller
product: AC'97 Modem Controller
vendor: VIA Technologies, Inc.
physical id: 11.6
bus info: pci@0000:00:11.6
version: 80
width: 32 bits
clock: 33MHz
capabilities: cap_list
configuration: driver=snd_via82xx_modem latency=0
resources: irq:22 ioport:e000(size=256)
*-network
description: Ethernet interface
product: VT6102/VT6103 [Rhine-II]
vendor: VIA Technologies, Inc.
physical id: 12
bus info: pci@0000:00:12.0
logical name: enp0s18
version: 78
serial: 00:19:21:40:f7:fb
size: 100Mbit/s
capacity: 100Mbit/s
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=via-rhine driverversion=1.5.1 duplex=full ip=192.168.1.198 latency=32 link=yes maxlatency=8 mingnt=3 multicast=yes port=MII speed=100Mbit/s
resources: irq:23 ioport:e400(size=256) memory:f6001000-f60010ff
*-pci:1
description: Host bridge
product: CN700/VN800/P4M800CE/Pro Host Bridge
vendor: VIA Technologies, Inc.
physical id: 101
bus info: pci@0000:00:00.1
version: 00
width: 32 bits
clock: 33MHz
*-pci:2
description: Host bridge
product: CN700/VN800/P4M800CE/Pro Host Bridge
vendor: VIA Technologies, Inc.
physical id: 102
bus info: pci@0000:00:00.2
version: 00
width: 32 bits
clock: 33MHz
*-pci:3
description: Host bridge
product: PT890 Host Bridge
vendor: VIA Technologies, Inc.
physical id: 103
bus info: pci@0000:00:00.3
version: 00
width: 32 bits
clock: 33MHz
*-pci:4
description: Host bridge
product: CN700/VN800/P4M800CE/Pro Host Bridge
vendor: VIA Technologies, Inc.
physical id: 104
bus info: pci@0000:00:00.4
version: 00
width: 32 bits
clock: 33MHz
*-pci:5
description: Host bridge
product: CN700/VN800/P4M800CE/Pro Host Bridge
vendor: VIA Technologies, Inc.
physical id: 105
bus info: pci@0000:00:00.7
version: 00
width: 32 bits
clock: 33MHz
*-scsi:0
physical id: 2
logical name: scsi0
capabilities: emulated
*-cdrom
description: DVD reader
product: RW/DVD GCC-4522B
vendor: HL-DT-ST
physical id: 0.1.0
bus info: scsi@0:0.1.0
logical name: /dev/cdrom
logical name: /dev/dvd
logical name: /dev/sr0
version: 1.08
capabilities: removable audio cd-r cd-rw dvd
configuration: ansiversion=5 status=nodisc
*-scsi:1
physical id: 3
logical name: scsi1
capabilities: emulated
*-cdrom
description: DVD-RAM writer
product: DRW-24F1ST d
vendor: ASUS
physical id: 0.0.0
bus info: scsi@1:0.0.0
logical name: /dev/cdrw
logical name: /dev/dvdrw
logical name: /dev/sr1
version: 1.00
capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
configuration: ansiversion=5 status=nodisc
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.
juan@debian:~$

 

Vie, 23/06/2017 - 18:37
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

tenes instalado algún firewall o reglas para iptables???
podrias ejecutar amule desde la terminal y copiar lo que pone

No se que guias seguiste para hacer la conexiones pero en: https://www.adslzone.net/postt163662.html recomiendan https://www.adslzone.net/postt55732.html https://www.adslzone.net/postt106835.html

Sáb, 24/06/2017 - 04:44
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Tienes eMule en un equipo y aMule en otro equipo en la misma red? no es que sea una buena idea, pero deberían de funcionar correctamente.

Unos consejillos para la configuración:

1.-, respecto a los servidores, primero desconecta aMule y borra toda tu lista de servidores. Luego te vas a la configuración, buscas la parte de servidores, y desactivas "actualizar al conectar a un cliente", "actualizar al conectar a un servidor", y dejas marcada actualizar al inicio. En esta última opción tendrás un botón que te abre un editor. En este editor introduces la dirección

http://upd.emule-security.org/server.met

y solo esa, elimina lo que ya exista. Esto te dejará con una lista de unos 10-12 servidores como mucho, fiables y con buen funcionamiento.

 

2.- Respecto a los puertos, e/aMule usan 3 básicamente, tcp y udp (tcp + 3 usualmente), más un tercero para kad creo recordar. Mi consejo es que los cambies a un valor por encima de 16500. en mi caso tenía puesto 16520 tcp, 16523 udp, y 16522 para el kad creo recordar. Si tu router tiene activada la opción uPnP, activala en la configuración de aMule y así no tendrás que andar abriendo puertos en el router tu mismo.

 

Con estas dos configuraciones (teniendo en cuenta, claro está, que no puedes ener los mismo puertos en dos e/aMule corriendo en la misma red local) Debería bastarte para que pasado un periodo de tiempo no muy largo tu amule empiece a funcionar sin problemas y a muy buenas velocidades (yo ya no lo uso, uso mldonkey, pero con estas configuraciones consigo la misma velocidad de descarga tanto en torrent como en ed2k).

 

P.D.: Como otro consejo, ten en cuenta los límites que pones a la velocidad de bajada/subida, si pones un limite de subida muy bajo, aunque pongas uno de bajada muy alto, la relación es tan diferente que la bajada será más lenta automáticamente, una relación, p.e., 800b 10s está bien, una de 2000b o bajada ilimitada y subida 10, hará que tu bajada sea menor). Almenos esto pasa en las líneas ADSL, ya que son asimétrica y la saturación de una afecta a la otra. Si lo que tienes es fibra, por esto no tienes ni que preocuparte.

 

Edit....

La red Kademlia funciona de forma diferente. e/aMule son capaces de funcionar solo con ésta, teniendo desactivada la red ed2k, pero siempre es recomendable tener esta seguna activada, almenos al principio. Ésto ayuda a Kad a encontrar nodos y comenzar a funcionar correctamente. Si te ha funcionado kad alguna vez, te habrás dado cuenta que le cuesta un poco más empezar a funcionar que a la red ed2k.

  No hay bar que por bien no venga....
Sáb, 24/06/2017 - 07:06
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

Sobre Amule/Emule se ha escrito mucho. que si configuraciones, que si abrir puertos.... Te cuento "mi configuración":

Te pongo en situación:

Los puertos TCP y UDP los que trae por defecto pero es igual porque los tengo cerrados en la configuración de iptables. También en el router.

La red Kad --> tras cortafuegos... lo que es lo mismo desconectado.

Resumen ... ID baja.

 

¿Entonces como hago para que pueda descargar en Amule a muy buena velocidad?

Limite de bajada -->  0

Limite de subida --> 66 (tengo conexión de 3 MB)

uPnP  ---> Habilitada

Con solo esto, mi amule descarga al máximo de velocidad de mi conexión ( normalmente 300 - 400 )

Está claro que si le abres los puertos  y demás (yo tuve mi época que lo hacia) vas a tener mucha velocidad y una mula sonriente, pero teniendo la posibilidad de habilitar uPnP no hace falta.

@Panko.. Te copio lo de configurar los servidores. Últimamente han ido desapareciendo todos y me quedaba solo uno (que la verdad iba muy bien)

Saludos.

We were but stones. Your light made us stars

https://linuxveredas.blogspot.com.es/

Sáb, 24/06/2017 - 09:13
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Añado, para la red Kademlia, se que se puede obtener un archivo con nodos (que sería algo asi como el archivo con servidores de ed2k), lo que no se es donde o como, igual en la url que he puesto para ed2k dice algo. Cabe decir que es capaz por si sola de encontrar dichos nodos, por eso tener ed2k conectado acelera un poco el inicio de kad.

  No hay bar que por bien no venga....
Sáb, 24/06/2017 - 11:47 (Responder a #5)
juancuyo
Imagen de juancuyo
Desconectado/a
se unió: 04/05/16

Hola Rockyiii, aqui va la respuesta de la terminal:
juan@debian:~$ amule
2017-06-24 11:27:21: Initialising aMule 2.3.2 compiled with wxGTK2 v3.0.2 and Boost 1.62
2017-06-24 11:27:21: Checking if there is an instance already running...
!2017-06-24 11:27:21: There is an instance of aMule already running
2017-06-24 11:27:21: (lock file: /home/juan/.aMule/muleLock)
2017-06-24 11:27:21: Raising current running instance.
No manejo mucho la terminal.

Sáb, 24/06/2017 - 13:32
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

acabas de ejecutar amule teniendo ya uno en marcha, eso es lo que dice la terminal.

De todas formas, lo de la red Kad no creo que tenga mucho que ver y que la salida de la terminal tampoco ayudará mucho, no sé, me da esa impresión. Prueba las configuraciones que te hemos dado, reinicia amule y pasado un tiempo comprueba como va la cosa, a la red kad le cuesta un poquillo si no tiene nodos conocidos porque tiene que buscarlos antes....

 

Edit...

con el amule abierto, en la parte de conexiones (redes, no recuerdo que pone, es el segundo icono empezando por la izquierda), tendrás dos pestañas, ed2k con los servidores, y otra que pone kad

una captura de la parte de kad no nos vendría mal para ver que te dice y que url tiene puesta

p,d,: asegurate de que en las preferencias está marcada la red kad y que se reconecte al perder la conexión.

 

Edit 2....

Estaría bien que nos pusieras lo que te dice en consola el comando

grep -i kad .aMule/logfile

 

  No hay bar que por bien no venga....
Mar, 27/06/2017 - 16:15
juancuyo
Imagen de juancuyo
Desconectado/a
se unió: 04/05/16

Hola Panko aqui te dejo la captura con respecto a la red Kad. las dos flechas en amarillo y antes era la de subida verde y la de bajada amarilla...

Mié, 28/06/2017 - 05:13
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Me refería a una captura del mismo aMule, donde se vea la pestaña Kad (en redes tienes dos pestañas, ed2k y kad). Viendo la salida del comando que te pedí, kad no intenta conectarse ¿Estás seguro que está activado en las preferencias? Mi salida es distinta a la tuya

~$ grep -i kad .aMule/logfile
 2017-06-24 18:34:11: S'han llegit 154 contactes Kad
!2017-06-24 18:34:11: S'ha engegat la xarxa Kad.
!2017-06-24 18:34:21: S'ha aturat la xarxa Kad.
!2017-06-24 18:34:21: Connectat a Kad (tallafocs)
!2017-06-24 18:34:41: Connectat a Kad (ok)
 2017-06-24 18:36:27: S'han escrit 163 contactes Kad

Traduzco, que tengo el sistema en catalán:

se han leido 154 contactos kad
se ha iniciado la red Kad

se ha parado la red Kad (lo hice yo a propósito).

Conectado a Kad (cortafuegos) <= esto indica que se ha encontrado el puerto cerrado

Conectado a Kad (ok <= esto, que ha visto que ya tiene el puerto abierto)

Se han escrito 163 contactos Kad (esto quiere decir que una vez conectado, ha encontrado nodos para su conexión).

¿podrías poner la salida del comando grep -i kad ~/.aMule/logfile? <= quita la linea CryptoKad... si quieres de la salida.

 

Y, muy importante, recuerda que si vas a tener corriendo eMule en una máquina y aMule en otra en la misma red, tienes que comprobar que no usan los mismos puertos, si no el que inicie después no funcionará (y tener actiado upnp tanto en ambos programas como en el router).

  No hay bar que por bien no venga....
Mié, 28/06/2017 - 18:49
juancuyo
Imagen de juancuyo
Desconectado/a
se unió: 04/05/16

SOlucionado!!! Solucionado!!! Gracias a todos por sus consejos, y por su paciencia!!,  entre una de las cosillas que hice, fue bajar los famosos "nodes.des"  en la pagina que encontre el link los cargaba directamente en aMule, luego cerre y volvi a abrir aMule y solo tenia una flecha verde, al rato se pusieron las 2 verdes y funciona. Sin embargo con el escritorio Xfce funciona perfecto pero cuando cambio de escritorio a Mate ya no cargan las dos flechas verdes no se porque sera, pero bueno descargue Debian con escritorio Xfce, talvez mas adelante al ahcerupdate y upgrade funcione en Mate.

Mié, 28/06/2017 - 19:31
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Pues me alegro, un asunto menos.

Respecto a que en un escritorio te vaya y en otro no, no tiene sentido alguno a mi entender (un firefwall o algo que inicie uno y el otro no? quien sabe). Puede ser por muchas cosas, incluso un fallo en la gestión del icono. La mejor forma que tienes de probarlo, es mirar en la parte de las redes, en el mismo amule, en la parte de abajo tienes unas pestañas y ahí puedes ver el estado de las conexiones.

  No hay bar que por bien no venga....