Arranque dual. [Solucionado]

6 envíos / 0 nuevos
Último envío
#1 Mar, 19/02/2019 - 15:24
wero
Imagen de wero
Desconectado/a
se unió: 15/01/19

Arranque dual. [Solucionado]

Estado: 
[SOLUCIONADO]

Estimados amigos, me acabo de comprar una maquina nueva. Instale windows 10 en la primera partición, sda1, y luego me dispuse a instalar Debian 9 en sda2, cuando termine y reinicie, el Grub solo me daba a elegir para arrancar Debian, ni rastro del windows 10. Pienso que es por el tema de la P... UEFI pero la verdad es que no lo sé. ¿Anularía la UEFI en BIOS y me quedaría con MRB?.

Gracias por vuestra ayuda.

wero

Mar, 19/02/2019 - 15:43
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

¿Anularía la UEFI en BIOS y me quedaría con MRB?

No se como hiciste la instalación de debian pero al instalar win10 no utilizas mbr para la tabla de particiones, asi que en teoria tu debian esta instalado sobre gpt.
Ahoa si tu inquietud es si podes correr win10 sin uefi, la respuesta es si

Mar, 19/02/2019 - 15:46
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16
Mar, 19/02/2019 - 16:01
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Suena tonto pero ...

 Cuando al final de la instalación te pregunta si hay que buscar otros sistemas operativos que haya instalados,

 y si quieres incluirlos en el nuevo arranque, espero que le dirías que si.

 

 Y también, no recuerdo como va porque los mios solo usan bios - mbr, pero recuerdo que para el arranque dual

 con linux+win había que poner el modo de arranque en un modo en concreto, (¿como era, legacy, o, ?).

 Y recordar que se pueden presentar 2 grub distintos, el clásico, grub2 de siempre, y el grub2 para uefi.

 si vas a usar uefi y gpt y todo eso asegúrate de tener ese.

 

 Añado:  Ah, si!, al ver el link de Caliban me he acordado, hay que dejar desactivado el arranque rápido, que se come pasos,

 y hay que desactivar esa opción de  "secure bios", es verdad.

 

Jue, 28/02/2019 - 13:44 (Responder a #4)
wero
Imagen de wero
Desconectado/a
se unió: 15/01/19

Gracias por vuestra ayuda. El particionado lo hice con un live de Ubuntu antes de instalar ningún S.O. y me asegure que la tabla fuera MRB. Desactive, en BIOS, el arranque rápido como me aconsejasteis y actualice el GRUB2 y ya aparecieron el windows y Debian.

Gracias. Saludos cordiales.

wero

Lo importante no es saberlo todo, sino saber como/donde buscar la solución.

Jue, 28/02/2019 - 14:33
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

Me parece raro que windows 10 cora sobre mbr para sacarnos la duda instala gdisk ,ejecútalo y pega su contenido

su
apt install gdisk
gdisk /dev/sda

para salir del programa presionar la letra q

saludos....