Bug de login driver wifi Realtek rtl8192cu

5 envíos / 0 nuevos
Último envío
#1 Dom, 19/11/2017 - 03:32
linux0
Imagen de linux0
Desconectado/a
se unió: 19/11/17

Bug de login driver wifi Realtek rtl8192cu

Estado: 
[ACTIVO]

Buenas, he instalado stretch 9.2.1 con los non-free drivers. Por defecto este driver realtek 8192cu viene con bug, el cual en otras distros debian/ubuntu based, siempre remplazo clonando el driver de github, con los bugs arreglados. Sin embargo esto no me lo solucionó en debian. Sin el driver parchado, me detecta mi red wifi pero se desconecta. Con los parches al conectarme a mi red wifi, me vuelve a pedir autenticación. Quisiera saber si alguien del foro ya lo ha solucionado.

Dom, 19/11/2017 - 11:54
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Si no pones la información técnica, la verdad que resulta muy difícil tratar de ayudarte. Por lo que nos decís, sabemos que esa placa anda con un parche y que lo probaste en otras distros y si funciona. Esto último podria deberse a que el kernel y la version del driver de debian sean mas antiguas a las de los otros sistemas operativos donde probaste el parche
¿cual es la url de donde sacaste el parche? ¿que pasos realizaste para instalarlo? ¿algún tutorial?
¿probaste con con tipo de protocolos de seguridad inalámbrica: WEP, WPA, y WPA2? ¿en todos se desconecta?

¿podes conectarte vía lan?

¿podrías poner el contenido del siguiente comando?
 

su
journalctl -b -p err

que te pone si ejecutas un
 

su
modinfo rtl8192cu

* como no pones información asumo que el driver se llama así

 

saludos...

Dom, 19/11/2017 - 21:46
linux0
Imagen de linux0
Desconectado/a
se unió: 19/11/17

Gracias por la pronta respuesta, voy a probar los comandos que me dices para ver que información me arroja. Efectivamente es un chip realtek rtl8192cu. No intenté con otros protocolos porque yo mismo configuré mi módem/router con seguridad WPA2-Personal / encriptación AES, que es más compatible con los equipos que tengo. 

No tengo una dirección url específica, porque consulté muchas páginas y vi varios videos para solucionar mi problema, lo guardé en un documento de texto. Pero son estas mismas instrucciones del apartado "Instalación": https://github.com/pvaret/rtl8192cu-fixes. (Es básicamente actualizar las headers del kernel, construir e instalar el módulo dkms, agregar el driver roto a la lista negra y reiniciar el equipo). 

Vía Lan si tengo internet, así fué como acabo de remplazar mi driver roto en debian, sin embargo no me funcionó el método. 

Dom, 19/11/2017 - 22:58
linux0
Imagen de linux0
Desconectado/a
se unió: 19/11/17

Que tal, recién he usado los comando que me especificaste y esto fué lo que me arrojó:

 

su
journalctl -b -p err

-- Logs begin at Sun 2017-11-19 18:52:03 CST, end at Sun 2017-11-19 19:03:20 CST. --
nov 19 18:52:07 debian systemd-udevd[234]: Error running install command for rtlwifi
nov 19 18:52:13 debian avahi-daemon[418]: chroot.c: open() failed: No such file or directory
nov 19 18:52:18 debian wpa_supplicant[471]: ioctl[SIOCSIWAP]: Operation not permitted
nov 19 18:52:18 debian wpa_supplicant[471]: ioctl[SIOCSIWENCODEEXT]: Invalid argument
nov 19 18:52:18 debian wpa_supplicant[471]: ioctl[SIOCSIWENCODEEXT]: Invalid argument
nov 19 18:52:24 debian minissdpd[531]: setsockopt(udp, IP_ADD_MEMBERSHIP)(0.0.0.0): No such device
nov 19 18:58:57 debian pulseaudio[706]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.bluez': timed out

 

Lun, 20/11/2017 - 11:31
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Estos son los errores relacionados con la placa wifi

nov 19 18:52:07 debian systemd-udevd[234]: Error running install command for rtlwifi
nov 19 18:52:18 debian wpa_supplicant[471]: ioctl[SIOCSIWAP]: Operation not permitted
nov 19 18:52:18 debian wpa_supplicant[471]: ioctl[SIOCSIWENCODEEXT]: Invalid argument
nov 19 18:52:18 debian wpa_supplicant[471]: ioctl[SIOCSIWENCODEEXT]: Invalid argument

El comando rtlwifi es un driver que viene en linux-image-xxxx  https://packages.debian.org/search?searchon=contents&keywords=rtlwifi&mode=filename&suite=stable&arch=any

Podrias fijarte de instalar un kernel mas moderno, agregando el repositorio de backports he instalando linux-image y linux-headers 4.13