Dar soporte exfat a debian antiguo.

5 envíos / 0 nuevos
Último envío
#1 Dom, 09/05/2021 - 17:33
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

Dar soporte exfat a debian antiguo.

Estado: 
[SOLUCIONADO]

 

 Hola a todos.

 

 Con el tiempo, inevitablemente te van surgiendo pequeñas preguntas que normalmente postearia,

 pero opino que si no puedo estar por aquí para responder en un tiempo razonable, mejor espero,

 para no dejar un tema abierto y colgado, hasta que me pueda pasar y responder o dar los datos

solicitados.

 Bueeenoo, va, uno pequeñito, algo rápido y sencillo, con mis excusas si tardo un poco en responder.

 

 Aunque parezca raro, y dada la edad de mis trastos computacionales,  sigo usando, muy a gusto,

 a jessie.  Es verdad que también tienen instalado buster, pero me preocupa si no les será

 mucho trabajo, aunque funcione.

 Así que sigo con los dos.

 Me está dando la lata, pero, que cuando estoy con jessie, (8.0) no puedo acceder a memorias

 de mas de 32 Gb, porque el sistema no dispone de la información para exfat.

 Yo recuerdo que cuando salió ext4 tenía uno que no lo reconocía.  Lo que al final hice

 fue coger del siguiente debian el fichero con la información para este f.s. , lo copié en el mismo

sitio en la distro anterior, y solucionado.  :)

 (Aunque si os he de ser sincero no recuerdo ya que archivo era ni donde iba colocado).

 

 Al cabo del tiempo hemos seguido avanzando, y, ahora el desfase es con esto del exfat.

 La pregunta:

 ¿Podría hacerse algo parecido ahora con las "instrucciones" para montar y manejar el exfat,

 de manera que pueda montar estas memorias sin salir de jessie?

 ¿De que ficheros depende este protocolo, y,  si puede ser, donde están?

 

   Un saludo a todos.

 

Dom, 09/05/2021 - 18:01
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

¿Tenes instalado  exfat-fuse  y  exfat-utils  ?

Vie, 14/05/2021 - 00:10
elpatosilva
Imagen de elpatosilva
Desconectado/a
moderador
se unió: 22/01/16

Bueno, cuando dijiste antiguo pensé en un debian sarge (creo que tengo por ahi las ISOs de Woody por si te interesa irte a lo antiguo de verdad).

No te lo puedo asegurar porque nunca tuve ese problema con exfat, pero incluso en etch (alla por el 2007 si no me equivoco) recuerdo que tenias el driver FUSE para acceder a NTFS (se llamaba ntfs-3g si no me equivoco) que daba acceso RW de forma razonablemente estable (ya existía de forma nativa ntfs pero era RO).

Por lo tanto me llamaría mucho la atención que no existiera algo similar para exfat desde esos tiempos. Si tienes los paquetes que indica caliban probablemente te este faltando alguna modificación en udev.

 La democracia es el proceso que garantiza que no seamos gobernados mejor de lo que nos merecemos.

Sáb, 15/05/2021 - 04:15
NerveNet
Imagen de NerveNet
Desconectado/a
colaborador
se unió: 14/03/16

Tengo por aquí una Debian 5 (Lenny) funcionando por aquí, Lenny salió en febrero de 2009.

Haciendo un "apt-cache search exfat" no sale absolutamente nada... Hay un paquete fuse-utils versión 2.7.x que según el proyecto debe datar de 2008, hay FUSE para NTFS (paquete ntfs-3g). Pero nada de exFAT.

 

Según la wikipedia, el soporte a exFAT se incorporó a FUSE en 2009. Como pronto estaría disponible en Debian 6 (Squeeze) para los que usasen la rama estable claro.

A un clic de distancia de ti...

Sáb, 22/05/2021 - 10:06
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 A Caliban:

 Ya estoy aquí, con retraso, pero ya estoy aquí. ..Luego te explico.
 
 
 En cuanto a la consulta, vaya crack!, sos un genio, a la primera, macanudo.
 Ya avanzada esta semana pasada asomé la nariz un instante por aquí
 y vi la respuesta.  "Dentro de un rato lo miraré." me dije.
 
 Y efectivamente, algo más tarde, cojo el portátil y lo pongo en marcha.
 ... cojo el portátil y lo pongo en marcha,
...  He dicho, "cojo el portátil y lo pongo en marcha", ...
 
 Pues nada, no se si le falla la bujía o que pasa, pero por más que le doy al power
 no ocurre nada. Tengo encendido el led de alimentación de red, pero no hace nada.
 Solo le falta reírse de mi.  angry .
 Tenía que pasar ahora, justo ahora!.
 Evidentemente tuve que cancelar el plan original de dar mi respuesta el fin de semana.
 
 Durante esta me ha tocado buscar un anfitrión al que implantarle el hdd del otro.
 
 Y en cuanto lo he puesto en marcha, he mirado en el synaptic, y, efectivamente
 ninguno de los dos paquetes está instalado.
 Ya me bailaba a mi por la cabeza de que no estaba seguro de si había experimentado
 algo así antes con jessie. Aunque claro, con varios ordenadores, más de una instalación
 en cada uno y conviviendo jessie con buster, y con alguna otra distro, acabas pensando
 que te has fijado mal, y que es posible que por la edad no trajera soporte exfat.
 Se añade además que las memorias de más de 32 Gb son de llegada reciente, no he
 empezado a tener hasta hace poco, durante la pandemia, al no poder comprar nada
 a la mañana siguiente de necesitarlo.
 
 
 Y aquí estoy pues, tecleando en un PIII, y gracias que se me ocurrió traerlo,
 porque vaya semana!. El lunes pierdo al core2 duo, el más joven del grupo, que
 de repente dejó de encender la pantalla y de dar imagen, ni el mismo ni por vga.
 ¿Posible circuito driver de vídeo a la m.?.
 Pasamos al P4.
 
 Y el jueves, ¿o era viernes?, el P4, que mira que hace años que lo tengo, y
 nunca nada, ni un estornudo, va y se queda así.  angry   angry
 

 Sea como sea, lo dicho, sos macanudo, cojo...  wink

 Gracias.
 

 

 A  Elpatosilva  y NerveNet:

Si, es verdad, yo también me acuerdo. Vaya aventuras que pasabas para intentar

estar al dia, ja ja. :D  .  Ahora me lo tomo con más calma, y hasta que no lo necesito

 De hecho, por ahí iba la cosa, que solucioné uno de estos temas añadiendo cosas

 a la brava, y con el tiempo no me acuerdo que fue ni donde.  [:roll eyes:]

 

 Y me ha hecho gracia que digais que conservais esas isos e instalaciones, porque ...

 Yo también me dio por conservarlas.  :D

 Tengo por ahí, cd-dvd's  de suse, redhat-mandriva, knoppix, un ubuntu casi primigenio,

 slax-live, (aún no se llamaba slax), un-nose-que-cristal, (un escritorio 3-d muy guay,

pero que necesitaba nvidia, en la época de las trident, radeon, ati y similares,

  además de una máquina más bien capaz, no de gama baja).

 Y por supuesto, la colección de isos debian, desde woody, que llegó para ver como

 era "eso de debian" a lenny, que fue el primero nombrado sistema principa,

 Y hasta hoy dia, con buster, con la excepción del 6, que se pasó sin prueba.

Y del 7 con más pena que gloria ya que no se entendía bien con mis máquinas.

Hasta los últimos, 7.7 u 7.8 no conseguí un debian mas o menos usable.

(El único debian de mi historia que ha sido rechazado).

 Y alguna otra distro que ahora no me debo acordar.  Je je, historia encapsulada en plástico. :D

 

 Y porque con los años los discos duros antiguos se van estropeando, que si no, yo

 también tenía varios de ellos aún usables, incluyendo mi primer linux, un suse,

 no recuerdo el número, pero si que incorporaba,  como beta,  un núcleo 2.0.0.

 (madre mia!). Y si querías algo fiable y comprobado tenías la opción de ponerle

 un 1.9. ?.   Increíble!.

 

 Bueno, pues espero que sigaís bien y que los "idus" de mayo os hayan sido más propicios que a mi,

y que no se os hayan "idus" tantas máquinas.

 Espera, ¿estamos en los idus, o en las calendas?. Nunca me acuerdo de cual
 viene primero y cual segundo.
 
  Da igual, Salve!.