Debian 10 en Lenovo IdeaPad300, solo inicia si tiene monitor externo [pantalla negra]

10 envíos / 0 nuevos
Último envío
#1 Vie, 02/08/2019 - 20:36
Ranock Sanchez
Imagen de Ranock Sanchez
Desconectado/a
se unió: 02/08/19

Debian 10 en Lenovo IdeaPad300, solo inicia si tiene monitor externo [pantalla negra]

Estado: 
[ACTIVO]

Buenas tardes compañeros, hace unos días instale debian 10 como único SO en una laptop Lenovo Ideapad 300 [14IBR] con entorno kde-plasma-4, no hubo ningún problema durante la instalación, el problema fue que al primer reinicio entro en pantalla negra, pensado que había problemas con el driver de video [integrado de intel] por lo que primero comprobé la integridad del sistema entrado con "nomodeset", pudiendo ingresar y fallando al ejecutar "startx".

Frustrado pensando que omití algo durante la instalación, me moví a un lugar comodo, conecte la laptop a un monitor y para mi sorpresa cuando me apareció el gestor de usuario [SDDM], ingrese normalmente, instale algunos programas con la terminal, algunos "update" y "upgrade", todo se mostraba bien en ambas pantallas, reinicio y todo funciona bien, el problema es que para que inicie de manera "correcta" plasma, debo tener un monitor externo conectado a la laptop, una vez conectado se quita y sin problemas.

Si dentro de la sesión hiberno la laptop y la enciendo [sin monitor externo] se inicia de manera correcta, tarda 1 minuto aproximado pero inicia.

Intente sin exito la configuracion "libata.noacpi=1". 

De antemano gracias!

 

Vie, 02/08/2019 - 22:03
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

que te pone si ejecutas

su
journalctl -b -p err

y si pones

echo $XDG_SESSION_TYPE

saludos...

Sáb, 03/08/2019 - 01:59
Ranock Sanchez
Imagen de Ranock Sanchez
Desconectado/a
se unió: 02/08/19

Saludos, antes que nada muchas gracias por la pronta respuesta, aqui los resultados de los comandos:

root@IceKing:/home/kary# echo $XDG_SESSION_TYPE
 

x11

root@IceKing:/home/kary# journalctl -b -p err
 

-- Logs begin at Fri 2019-08-02 17:56:51 CDT, end at Fri 2019-08-02 21:53:03 CDT. --
ago 02 17:56:53 IceKing kernel: kvm: disabled by bios
ago 02 17:56:54 IceKing bluetoothd[524]: Sap driver initialization failed.
ago 02 17:56:54 IceKing bluetoothd[524]: sap-server: Operation not permitted (1)
ago 02 17:56:54 IceKing bluetoothd[524]: Failed to set mode: Blocked through rfkill (0x12)
ago 02 18:00:24 IceKing bluetoothd[524]: Sap driver initialization failed.
ago 02 18:00:24 IceKing bluetoothd[524]: sap-server: Operation not permitted (1)
ago 02 18:00:24 IceKing bluetoothd[524]: Failed to set mode: Blocked through rfkill (0x12)
ago 02 18:00:25 IceKing wpa_supplicant[535]: nl80211: Failed to open /proc/sys/net/ipv4/conf/p2p-dev-wlp2s0/drop_unicast_in_l2_multicast: No such file or directory
ago 02 18:00:25 IceKing wpa_supplicant[535]: nl80211: Failed to set IPv4 unicast in multicast filter
ago 02 18:00:25 IceKing wpa_supplicant[535]: nl80211: Failed to open /proc/sys/net/ipv4/conf/p2p-dev-wlp2s0/drop_unicast_in_l2_multicast: No such file or directory
ago 02 18:00:25 IceKing wpa_supplicant[535]: nl80211: Failed to set IPv4 unicast in multicast filter
ago 02 18:18:29 IceKing bluetoothd[524]: Sap driver initialization failed.
ago 02 18:18:29 IceKing bluetoothd[524]: sap-server: Operation not permitted (1)
ago 02 18:18:29 IceKing bluetoothd[524]: Failed to set mode: Blocked through rfkill (0x12)
ago 02 18:18:29 IceKing wpa_supplicant[535]: nl80211: Failed to open /proc/sys/net/ipv4/conf/p2p-dev-wlp2s0/drop_unicast_in_l2_multicast: No such file or directory
ago 02 18:18:29 IceKing wpa_supplicant[535]: nl80211: Failed to set IPv4 unicast in multicast filter
ago 02 18:18:30 IceKing wpa_supplicant[535]: nl80211: Failed to open /proc/sys/net/ipv4/conf/p2p-dev-wlp2s0/drop_unicast_in_l2_multicast: No such file or directory
ago 02 18:18:30 IceKing wpa_supplicant[535]: nl80211: Failed to set IPv4 unicast in multicast filter
ago 02 18:23:55 IceKing wpa_supplicant[535]: dbus: wpa_dbus_property_changed: no property SessionLength in object /fi/w1/wpa_supplicant1/Interfaces/5
ago 02 18:27:35 IceKing kernel: usb 1-1: device descriptor read/64, error -71
ago 02 18:27:35 IceKing kernel: usb 1-1: device descriptor read/64, error -71
ago 02 18:27:35 IceKing kernel: usb 1-1: device descriptor read/64, error -71
ago 02 18:27:35 IceKing kernel: usb 1-1: device descriptor read/64, error -71
ago 02 18:27:37 IceKing kernel: usb 1-1: device not accepting address 6, error -71
ago 02 18:27:37 IceKing kernel: usb 1-1: device not accepting address 7, error -71
ago 02 18:27:37 IceKing kernel: usb usb1-port1: unable to enumerate USB device
ago 02 18:32:48 IceKing kernel: usb 1-1: device descriptor read/64, error -71
ago 02 18:32:58 IceKing kernel: usb 1-1: device descriptor read/64, error -110
ago 02 18:32:58 IceKing kernel: usb 1-1: device descriptor read/64, error -71
ago 02 18:32:59 IceKing kernel: usb 1-1: device descriptor read/64, error -71
ago 02 18:33:00 IceKing kernel: usb 1-1: device not accepting address 11, error -71
ago 02 18:33:00 IceKing kernel: usb 1-1: device not accepting address 12, error -71
ago 02 18:33:00 IceKing kernel: usb usb1-port1: unable to enumerate USB device
ago 02 18:33:18 IceKing kernel: sd 2:0:0:0: [sdc] No Caching mode page found
ago 02 18:33:18 IceKing kernel: sd 2:0:0:0: [sdc] Assuming drive cache: write through
ago 02 18:37:50 IceKing kernel: iwlwifi 0000:02:00.0: offset 0 not used in fw key table.
ago 02 18:37:50 IceKing kernel: wlp2s0: failed to remove key (4, ff:ff:ff:ff:ff:ff) from hardware (-2)
ago 02 18:37:50 IceKing wpa_supplicant[535]: dbus: wpa_dbus_property_changed: no property SessionLength in object /fi/w1/wpa_supplicant1/Interfaces/5
ago 02 18:37:50 IceKing bluetoothd[524]: Sap driver initialization failed.
ago 02 18:37:50 IceKing bluetoothd[524]: sap-server: Operation not permitted (1)
ago 02 18:37:50 IceKing bluetoothd[524]: Failed to set mode: Blocked through rfkill (0x12)
ago 02 18:37:51 IceKing wpa_supplicant[535]: nl80211: Failed to open /proc/sys/net/ipv4/conf/p2p-dev-wlp2s0/drop_unicast_in_l2_multicast: No such file or directory
ago 02 18:37:51 IceKing wpa_supplicant[535]: nl80211: Failed to set IPv4 unicast in multicast filter
ago 02 18:37:51 IceKing wpa_supplicant[535]: nl80211: Failed to open /proc/sys/net/ipv4/conf/p2p-dev-wlp2s0/drop_unicast_in_l2_multicast: No such file or directory
ago 02 18:37:51 IceKing wpa_supplicant[535]: nl80211: Failed to set IPv4 unicast in multicast filter
ago 02 21:39:23 IceKing kernel: iwlwifi 0000:02:00.0: offset 0 not used in fw key table.
ago 02 21:39:23 IceKing kernel: wlp2s0: failed to remove key (4, ff:ff:ff:ff:ff:ff) from hardware (-2)
ago 02 21:39:23 IceKing wpa_supplicant[535]: dbus: wpa_dbus_property_changed: no property SessionLength in object /fi/w1/wpa_supplicant1/Interfaces/7
ago 02 21:39:23 IceKing bluetoothd[524]: Sap driver initialization failed.
ago 02 21:39:23 IceKing bluetoothd[524]: sap-server: Operation not permitted (1)
ago 02 21:39:23 IceKing bluetoothd[524]: Failed to set mode: Blocked through rfkill (0x12)
ago 02 21:39:23 IceKing wpa_supplicant[535]: nl80211: Failed to open /proc/sys/net/ipv4/conf/p2p-dev-wlp2s0/drop_unicast_in_l2_multicast: No such file or directory
ago 02 21:39:23 IceKing wpa_supplicant[535]: nl80211: Failed to set IPv4 unicast in multicast filter
ago 02 21:39:24 IceKing wpa_supplicant[535]: nl80211: Failed to open /proc/sys/net/ipv4/conf/p2p-dev-wlp2s0/drop_unicast_in_l2_multicast: No such file or directory
ago 02 21:39:24 IceKing wpa_supplicant[535]: nl80211: Failed to set IPv4 unicast in multicast filter
lines 14-56/56 (END)

 

Dom, 04/08/2019 - 12:34
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Lo que estas comentando parece un problema de que no te detecta el monitor o la resolución de pantalla, más que de falta de aceleración gráfica, algo asi.
Entrando con el monitor externo, podes ver en las configuraciones de monitor si te detecta el monitor de la notebook o si cambiando la resolucion y poniendo los dos monitores a espejo podes tener video.
Iniciando sin el monitor externo, no se si el gestor de inicio de sesión de kde permite abrir otras tty,  fijate si cuando te queda en pantalla negra si ejecutas un CTRL + Alt + F1 o F2 etc te abre una tty o si te permite entrar desde grub en recovery mode

fijate si tenes instalando el paquete xserver-xorg-video-intel de ser asi desinstalalo y fijate si hay una mejora. Lo mismo con el paquete intel-media-va-driver

también tenes un paquete llamado intel-gpu-tools no se si ese programa permita algún tipo de configuracion.

apt search xserver-xorg-video-intel | grep "instalado"

para ver las resoluciones de pantalla

xrandr

 

AGREGO:------

viendo en la wiki de debian https://wiki.debian.org/InstallingDebianOn/Lenovo/IdeaPad%20300-15ISK recomiendan instalar:

libdrm-intel1 firmware-misc-nonfree libdrm-amdgpu1 libdrm2 libegl1-mesa libegl1-mesa-drivers libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgles1-mesa libgles2-mesa libwayland-egl1-mesa xserver-xorg-video-intel 

saludos...

Lun, 05/08/2019 - 13:13
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Se me hace curioso que recomienden instalar xserver-xorg-video-intel cuando éste apenas tiene ya mantenimiento y es obsoleto, ya que el kernel incluye el driver necesario para las gráficas intel fabricadas desde el año 2012/2013 en adelante. Yo probaría con la recomendación de la wiki pero eliminando ese paquete, ten en cuenta que habla de la instalación y funcionamiento del hardware en una versión de debian anterior (Jessie, que es Debian 8).

  No hay bar que por bien no venga....
Lun, 05/08/2019 - 19:41
Ranock Sanchez
Imagen de Ranock Sanchez
Desconectado/a
se unió: 02/08/19

Adjunto los resultados de los comandos antes mencionados

 

ranock@IceKing:~$ sudo apt search xserver-xorg-video-intel | grep "instalado"

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

xserver-xorg-video-intel/stable,now 2:2.99.917+git20180925-2 amd64 [instalado, automático]
 

ranock@IceKing:~$ xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
eDP-1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 309mm x 174mm
   1366x768      60.00*+
   1360x768      59.80    59.96  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   800x512       60.17  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   720x450       59.89  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   680x384       59.80    59.96  
   640x400       59.88    59.98  
   576x432       60.06  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)

Lun, 05/08/2019 - 19:42
Ranock Sanchez
Imagen de Ranock Sanchez
Desconectado/a
se unió: 02/08/19

Al tratar de instalar los paquetes que indica en la wiki, me indica que los paquetes de mesa no estan disponibles para mi version :,v

 

Lun, 05/08/2019 - 19:50
Ranock Sanchez
Imagen de Ranock Sanchez
Desconectado/a
se unió: 02/08/19

Instale los mesa-tools y al ejecutar el screefetch me sale esto 

 

ranock@IceKing:~$ screenfetch
         _,met$$$$$gg.           raonck@IceKing
      ,g$$$$$$$$$$$$$$$P.        OS: Debian 10 buster
    ,g$$P""       """Y$$.".      Kernel: x86_64 Linux 4.19.0-5-amd64
   ,$$P'              `$$$.      Uptime: 2d 23h 49m
  ',$$P       ,ggs.     `$$b:    Packages: 2161
  `d$$'     ,$P"'   .    $$$     Shell: bash
   $$P      d$'     ,    $$P     Resolution: 1366x768
   $$:      $$.   -    ,d$$'     DE: KDE 5.54.0 / Plasma 5.14.5
   $$\;      Y$b._   _,d$P'      WM: KWin
   Y$$.    `.`"Y$$$$P"'          WM Theme: Breeze
   `$$b      "-.__               GTK Theme: Breeze [GTK2/3]
    `Y$$                         Icon Theme: breeze
     `Y$$.                       Font: Noto Sans Regular
       `$$b.                     CPU: Intel Celeron N3060 @ 2x 2.48GHz
         `Y$$b.                  GPU: Mesa DRI Intel(R) HD Graphics 400 (Braswell) 
            `"Y$b._              RAM: 836MiB / 7890MiB

Lun, 05/08/2019 - 20:58
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

El paquete firmware-misc-nonfree requiere que tengas el repositorio non-free

prueba de eliminar xserver-xorg-video-intel

su -
apt purge xserver-xorg-video-intel

saludos...

Lun, 05/08/2019 - 21:32
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Comprueba si están estos y, si es así, instalalos también, Braswell (aka Broadwell/Cherrytrail) ha dado algunos problemas en según que procesadores/equipos.

libegl1-mesa
libegl1-mesa-drivers
libgl1-mesa-dri
libgl1-mesa-glx
libglapi-mesa
libgles1-mesa
libgles2-mesa
libglu1-mesa
libopenvg1-mesa
libtxc-dxtn-s2tc0
libwayland-egl1-mesa
mesa-utils
mesa-utils-extra
libva-drm1

Edit....

Ten en cuenta, por si acaso, que el nombre es libgl1 (ele 1), que en algunas tipografías es fácil confundir la letra con el número. Posiblemente te resulte mejor copiar los nombres en lugar de escribirlos tu, si es lo que has hecho.

  No hay bar que por bien no venga....