Debian 9 Stretch no arranca si hay disco externo

5 envíos / 0 nuevos
Último envío
#1 Lun, 06/05/2019 - 04:18
Ivan.E
Imagen de Ivan.E
Desconectado/a
se unió: 06/05/19

Debian 9 Stretch no arranca si hay disco externo

Estado: 
[SOLUCIONADO]

Buenos días.

Tengo actualmente un appliance con un diso SSD donde tengo una instalación de Debian 9 Stretch y Proxmox. 

Dentro de Proxmox tengo una MV con Openmediavault donde tengo configurado un disco duro externo conectado por usb para hacer de disco compartido en red.

El sistema funciona perfectamente siempre y cuando a la hora de arrancar Debian ese disco duro externo no esté conectado al usb. En ese caso es como si el sistema tratase de arrancar desde el externo en vez del SSD.

El sistema está configurado para que arranque desde el conector Sata.

 

Gracias de antemano por la ayuda.

Lun, 06/05/2019 - 12:27
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

¿Durante el arranque con el disco usb  conectado ¿da algún mensaje de error ??¿o que ocurre?

Entiendo que en este caso no llega siguiera a la instancia de grub ¿cierto?

Durante el arranque con el disco usb  conectado ,entra en la configuración de la   BIOS, y fijate que dispositivos USB figuran, luego en el orden de booteo ,cual es el orden ( suele estar indicado el dispositivo , si es un disco duro  y hay mas de uno indica su identificación ,en un dispositivo USB lo mismo .

Mar, 07/05/2019 - 14:36
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 A mi me había pasado alguna vez al arrancar con un pendrive enchufado al portátil.  Pero ya hace mucho

 que no he vuelto a ver ese inconveniente, pensaba que estaría ya superado.

 

 Por lo que recuerdo, era después del autochequeo de la máquina, le entraba a iniciar el sistema, y se quedaba

 esperando, sin dar ninguna explicación ni poner nada en pantalla.

 Con solo desenchufar el pendrive ya seguía el solo adelante sin ningún problema.

 Lo que hacía yo, si quería quería tenerlo presente y montado al abrirse el escritorio, era volverlo a enchufar

 apenas había cargado el kernel y estaba revisando la memoria, periféricos, drivers, etc.  ;)

 

 De lo cual se deduce que intentaba arrancar o incluir como posible arranque al pendrive, aún no siendo

arrancable.

 

 

Mié, 08/05/2019 - 06:37 (Responder a #3)
Ivan.E
Imagen de Ivan.E
Desconectado/a
se unió: 06/05/19

caliban wrote:

¿Durante el arranque con el disco usb  conectado ¿da algún mensaje de error ??¿o que ocurre?

Entiendo que en este caso no llega siguiera a la instancia de grub ¿cierto?

Durante el arranque con el disco usb  conectado ,entra en la configuración de la   BIOS, y fijate que dispositivos USB figuran, luego en el orden de booteo ,cual es el orden ( suele estar indicado el dispositivo , si es un disco duro  y hay mas de uno indica su identificación ,en un dispositivo USB lo mismo .

 

No caí en mirar lo que pone. Esta tarde lo reinicio con el disco puesto y a ver que dice.

Vie, 17/05/2019 - 08:25
Ivan.E
Imagen de Ivan.E
Desconectado/a
se unió: 06/05/19

Se puede cerrar el tema.

Al final el problema estaba en el booteo. Había un msata como priemr arranque en vez del sata del disco correspondiente.

 

Gracias por las sugerencias.