Desaparecio el "tapping" o touchpad en debian mate-desktop

10 envíos / 0 nuevos
Último envío
#1 Mié, 25/05/2016 - 22:01
alunado
Imagen de alunado
Desconectado/a
se unió: 10/05/16

Desaparecio el "tapping" o touchpad en debian mate-desktop

Estado: 
[SOLUCIONADO]

Hola gente y muchachada... no estoy tan seguro que pueda ir aqui esta consulta. puede que tenga otra topic..

 Bien, como anticipa el titulo me quede sin la pestaña para configurar el touchpad en el apartado o menu Sistema > Preferencias > harware > raton de Mate-Desktop version 1.12.1-1. Aqui es donde podemos abrir una ventana para configurar este mismo pero desde hace un mes -actualizaciones mediante- no volvio a aparecer la pestaña del "touchpad" -imagen adjunta-

 Estoy en Debian Sid pero al no econtrar solucion mediante la busqueda en la web o reconfigurar el paquete synaptics -tambien me he fijado en los paquetes de mate y no encontre nada relacionado con el touchpad- es que les consulto sobre este problema y como imaginan alguna solucion.

 Muchas gracias y este foro esta muy mucho mejor que el anterior eh!! saludos.

sin touchpad en debian sid

 P.D.: SI!! uso el pez wanda y que?.. y los ojitos tambien (que todo me trae mucha nostalgia, snif...).

 

 

 

Mié, 25/05/2016 - 22:28
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

veo que en sid hay paquetes de mate desktop 1.8.x.x y 1.12.xx, probablemente en poco tiempo entre alguna actualización del paquete correspondiente que configura el ratón / touchpad y vuelva a aparecer. Lo importante es que funcione el touchpad

Mié, 25/05/2016 - 23:36 (Responder a #2)
alunado
Imagen de alunado
Desconectado/a
se unió: 10/05/16

hola rockyiii... no vi las diferentes versiones!!

Ahh, claro, si hice un aptitude search, no un version. Ahi miro todo pero seguro debes llevar razon. Y bueno, en lo que respecta al touchpad no anda el tapping. Podria configurar synaptics con un fichero a mano que ya no recuerdo donde va y supongo que andaria.. pero me da fiaca.

 Miro las versiones y por lo menos ver de encontrar la que corresponde al touchpad para esperarla mediante el nombre proximamente.

 Saludos y gracias!

A nosotros que, sin copa ni vino, estamos contentos.. A nosotros que, despreciados o alabados,estamos contentos.. A nosotros nos preguntan: “¿En qué acabaréis?”.
A nosotros que, sin acabar en nada, estamos contentos!!
Jue, 26/05/2016 - 12:19
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

Otra seria ver si con dconf-editor se puede configurar el touchpad en mate
Sino la otra es editar el xorg https://wiki.debian.org/SynapticsTouchpad

Igualmente lo más seguro es que en poco tiempo, tras las actualizaciones, el problema se soluciones wink

 

saludos

Jue, 26/05/2016 - 22:27
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Antes que nada habría que ver como detecta ahora el touchpad el sistema, ya que se cambiará en un futuro la forma en que se hace, y puede ser que haya entrado alguna actualización o paquete nuevo que provoque esto.

 

Los parámetros del touchpad los puedes ver con el comando synclient, suponiendo que se esté usando el driver de synaptics. Si el comando te dice que no se ha encontrado el driver, es que tu touchpad ha pasado a usar libinput (el driver que se utilizará con wayland para ello) y tendrás que buscar la forma de configurar tu touchpad con dicho driver, o desinstalarlo y así el sistema pasará a utilizar el driver de synaptics otra vez y, creo, ya te volverá a aparecer la opción de configurarlo gráficamente.

 

Si tu problemas está en libinput y vas a quitarlo, y no consigues la configuración gráfica otra vez, un archivo en el directorio adecuado te permitirá configurar tu touchpad (buscando puedes encontrar como configurarlo con libinput en la wiki de Arch linux (si, no es debian y es externa a esta, pero tiene mucha info y se puede aprovechar bastante la que nos falta en nuestras wikis todavía )). Respecto al archivo, es para la configuración de xorg y te funcionará siempre que se use el driver synaptics (el que se ha usado siempre):
 

/etc/X11/xorg.conf.d/50-synaptics.conf

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        Option "HorizEdgeScroll" "1"
        Option "VertEdgeScroll" "1"
        Option "HorizTwoFingerScroll" "1"
        Option "VertTwoFingerScroll" "1"
        Option "TapButton1" "1"
        Option "TapButton2" "2"
        Option "TapButton3" "3"
        Option "PalmDetect" "1"
        Option "SHMConfig"  "on"
EndSection

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"
EndSection

Aqui puedes eliminar algunso parámetros, ya que ahi tengo activados el scrolling en los bordes (horizontal y vertical) y ambos con dos dedos también. La parte de palmdetect es para que detecte que no es un tap y desactive el touchpad si estás escribiendo y lo tocas sin querer, lo de los buttons es la configuración del tap, botón derecho (el mio no lo tiene, asi que lo emula), etc... y shmconfig es la que habilita a diferentes aplicaciones para que puedan acceder a la configuraciónd el touchpad.

  No hay bar que por bien no venga....
Lun, 30/05/2016 - 09:00 (Responder a #5)
alunado
Imagen de alunado
Desconectado/a
se unió: 10/05/16

rockyiii wrote:

Otra seria ver si con dconf-editor se puede configurar el touchpad en mate
Sino la otra es editar el xorg https://wiki.debian.org/SynapticsTouchpad

Igualmente lo más seguro es que en poco tiempo, tras las actualizaciones, el problema se soluciones wink

 

saludos

en el link que brindaste me RE-ENCONTRE con la ruta olvidada: "/etc/X11/xorg.conf.d/synaptics.conf"

Y si, hoy entre en sid.. actualize y con la llegada del 1.14-'algo' se resolvio solo el problema, aunque tambien paso Mate a tener integracion con GTK3 -esta un pelin mas lento, pero... fluido igualmente-.

 Gracias Rocky!

A nosotros que, sin copa ni vino, estamos contentos.. A nosotros que, despreciados o alabados,estamos contentos.. A nosotros nos preguntan: “¿En qué acabaréis?”.
A nosotros que, sin acabar en nada, estamos contentos!!
Lun, 30/05/2016 - 09:13 (Responder a #6)
alunado
Imagen de alunado
Desconectado/a
se unió: 10/05/16

Panko wrote:

Antes que nada habría que ver como detecta ahora el touchpad el sistema, ya que se cambiará en un futuro la forma en que se hace, y puede ser que haya entrado alguna actualización o paquete nuevo que provoque esto.

Los parámetros del touchpad los puedes ver con el comando synclient, suponiendo que se esté usando el driver de synaptics. Si el comando te dice que no se ha encontrado el driver, es que tu touchpad ha pasado a usar libinput (el driver que se utilizará con wayland para ello) y tendrás que buscar la forma de configurar tu touchpad con dicho driver, o desinstalarlo y así el sistema pasará a utilizar el driver de synaptics otra vez y, creo, ya te volverá a aparecer la opción de configurarlo gráficamente.

 Tengo synaptics y libinput en el sistema... resulta que ahora entro Mate 1.14 y se soluciono todo, pero antes de actualizar tire un "synaptics" y el comando no se encontraba tal como vos mencionas. Se ve que usaba libinput o quizas nada (no lo entiendo y no lo vi), porque al momento de esto ya estaba instalando los nuevos paquetes.. Una pena que no me haya podido fijar.

Panko wrote:

Si tu problemas está en libinput y vas a quitarlo, y no consigues la configuración gráfica otra vez, un archivo en el directorio adecuado te permitirá configurar tu touchpad (buscando puedes encontrar como configurarlo con libinput en la wiki de Arch linux (si, no es debian y es externa a esta, pero tiene mucha info y se puede aprovechar bastante la que nos falta en nuestras wikis todavía )). Respecto al archivo, es para la configuración de xorg y te funcionará siempre que se use el driver synaptics (el que se ha usado siempre):

/etc/X11/xorg.conf.d/50-synaptics.conf

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        Option "HorizEdgeScroll" "1"
        Option "VertEdgeScroll" "1"
        Option "HorizTwoFingerScroll" "1"
        Option "VertTwoFingerScroll" "1"
        Option "TapButton1" "1"
        Option "TapButton2" "2"
        Option "TapButton3" "3"
        Option "PalmDetect" "1"
        Option "SHMConfig"  "on"
EndSection

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"
EndSection

Aqui puedes eliminar algunso parámetros, ya que ahi tengo activados el scrolling en los bordes (horizontal y vertical) y ambos con dos dedos también. La parte de palmdetect es para que detecte que no es un tap y desactive el touchpad si estás escribiendo y lo tocas sin querer, lo de los buttons es la configuración del tap, botón derecho (el mio no lo tiene, asi que lo emula), etc... y shmconfig es la que habilita a diferentes aplicaciones para que puedan acceder a la configuraciónd el touchpad.

 Buenisimo el archivo Panko! me lo copio y lo pego para mi 'zim' de soluciones... Interesante lo de libinput y wayland. Todas nuevas cosas/paquetes que parece tarde o temprano tendremos que enfrentar.

Gracias por tu tiempo y atencion!

A nosotros que, sin copa ni vino, estamos contentos.. A nosotros que, despreciados o alabados,estamos contentos.. A nosotros nos preguntan: “¿En qué acabaréis?”.
A nosotros que, sin acabar en nada, estamos contentos!!
Lun, 30/05/2016 - 09:22
alunado
Imagen de alunado
Desconectado/a
se unió: 10/05/16

 No puedo editar el contenido o el titulo de la entrada para marcarla como [SOLUCIONADO]... mmm... sera que no tengo vista o permisos?

A nosotros que, sin copa ni vino, estamos contentos.. A nosotros que, despreciados o alabados,estamos contentos.. A nosotros nos preguntan: “¿En qué acabaréis?”.
A nosotros que, sin acabar en nada, estamos contentos!!
Sáb, 11/06/2016 - 22:26
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

Bueno me han recomendado actualizar a libinput, "xxx-input-synaptics driver is on maintenance mode and xxx-input-libinput driver must be prefered over". Tan sencillo como instalar xxx-input-libinput, pero a su vez tuve que agregar:

/etc/X11/xorg.conf.d/30-touchpad.conf

Section "InputClass"
        Identifier "MyTouchpad"
        MatchIsTouchpad "on"
        Driver "libinput"
        Option "Tapping" "on"
EndSection

Según wiki, todo perfecto, salvo repetidas líneas dentro del /var/log/Xorg.0.log

(EE) libinput bug: invalid tap event when fingers are up
(EE) kernel bug: Touch jump detected and discarded.
See https://wayland.freedesktop.org/libinput/doc/1.3.0/touchpad_jumping_cursor for details
(EE) libinput bug: invalid tap event, no fingers are down

Aunque recalco, al parecer todo funciona de manera normal, no veo errores dentro del journalctl. Pero si alguien sabe de que va aquello, mencionarlo.

Saludos.

PD: Alguien sabe que va pasa con XX-evdev.conf y XX-synaptics.conf. Se eliminan o se mantienen ¿?

Dom, 12/06/2016 - 08:54
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

10-evdev.conf no lo tengo en uso en mi sistema. Si lo tienes en la ruta /usr/share/X11/xorg.conf./, el sistema no hace uso de ellos, lo que se encuentra ahí es más bien a modo de ejemplo o plantilla para que puedas crear el que necesites para tu configuración. Lo mismo se aplica a 70-synaptics.conf.

 

Si por el contrario lo tienes en la ruta /etc/X11/xorg.conf.d/ entonces el sistema si hará uso de dicho archivo de configuración. Si te fijas, en la ruta que he puesto antes también existe un archivo para libinput.

 

Respecto al error que ves y el enlace que provee, solo dice que más que problema del touchpad o driver, es cosa del kernel. Simplemente, en los casos que tienes que mover el cursor y luego hacer click usando otro dedo, se detecta como un "salto" al ser otra posición en el touchpad y genera ese mensaje, nada de lo que preocuparse (de hecho, si te fijas, dice que ha detectado un "salto de toque" y que lo desecha (discarded)).

  No hay bar que por bien no venga....