Driver nvidia gtx 1050ti laptop

53 envíos / 0 nuevos
Último envío
Lun, 05/02/2018 - 14:41
debiatonix
Imagen de debiatonix
Desconectado/a
se unió: 07/01/18

apt-get clean
apt-get update
 

apt-get -t stretch-backports install  bumblebee-nvidia bbswitch-dkms nvidia-kernel-dkms nvidia-driver

Pon una debian en tu vidayes

Lun, 05/02/2018 - 19:00
jlopezjuy
Imagen de jlopezjuy
Desconectado/a
se unió: 31/01/18

Ejecute esos comando de instalación, todo va ok al parecer

sudo apt-get -t stretch-backports install  bumblebee-nvidia bbswitch-dkms nvidia-kernel-dkms nvidia-driver
[sudo] password for jlopez-rog: 
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes adicionales:
  bumblebee libegl-nvidia0 libegl1-glvnd-nvidia libgl1-glvnd-nvidia-glx
  libgl1-nvidia-glvnd-glx libgldispatch0-nvidia libgles-nvidia1
  libgles-nvidia2 libgles1-glvnd-nvidia libgles2-glvnd-nvidia libglx-nvidia0
  libglx0-glvnd-nvidia libnvidia-cfg1 libnvidia-eglcore libnvidia-glcore
  libnvidia-ml1 libopengl0-glvnd-nvidia libvulkan1 libxnvctrl0
  nvidia-driver-bin nvidia-driver-libs nvidia-egl-common nvidia-egl-icd
  nvidia-kernel-common nvidia-kernel-support nvidia-modprobe
  nvidia-persistenced nvidia-settings nvidia-support nvidia-vulkan-common
  nvidia-vulkan-icd primus primus-libs socat xserver-xorg-video-nvidia
Paquetes sugeridos:
  vulkan-utils
Paquetes recomendados:
  nvidia-driver-libs-i386 primus-libs-ia32
Se instalarán los siguientes paquetes NUEVOS:
  bbswitch-dkms bumblebee bumblebee-nvidia libegl-nvidia0 libegl1-glvnd-nvidia
  libgl1-glvnd-nvidia-glx libgl1-nvidia-glvnd-glx libgldispatch0-nvidia
  libgles-nvidia1 libgles-nvidia2 libgles1-glvnd-nvidia libgles2-glvnd-nvidia
  libglx-nvidia0 libglx0-glvnd-nvidia libnvidia-cfg1 libnvidia-eglcore
  libnvidia-glcore libnvidia-ml1 libopengl0-glvnd-nvidia libvulkan1
  libxnvctrl0 nvidia-driver nvidia-driver-bin nvidia-driver-libs
  nvidia-egl-common nvidia-egl-icd nvidia-kernel-common nvidia-kernel-dkms
  nvidia-kernel-support nvidia-modprobe nvidia-persistenced nvidia-settings
  nvidia-support nvidia-vulkan-common nvidia-vulkan-icd primus primus-libs
  socat xserver-xorg-video-nvidia
0 actualizados, 39 nuevos se instalarán, 0 para eliminar y 48 no actualizados.
Se necesita descargar 29,6 MB de archivos.
Se utilizarán 121 MB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n] s
Des:1 http://deb.debian.org/debian stretch/non-free amd64 libgldispatch0-nvidia amd64 375.82-1~deb9u1 [214 kB]
Des:2 http://ftp.debian.org/debian stretch-backports/main amd64 libxnvctrl0 amd64 384.111-1~bpo9+1 [24,0 kB]
Des:3 http://deb.debian.org/debian stretch/non-free amd64 libglx0-glvnd-nvidia amd64 375.82-1~deb9u1 [193 kB]
Des:4 http://deb.debian.org/debian stretch/non-free amd64 libgl1-glvnd-nvidia-glx amd64 375.82-1~deb9u1 [248 kB]
Des:5 http://deb.debian.org/debian stretch/non-free amd64 libnvidia-glcore amd64 375.82-1~deb9u1 [6.421 kB]
Des:6 http://deb.debian.org/debian stretch/non-free amd64 libglx-nvidia0 amd64 375.82-1~deb9u1 [422 kB]
Des:7 http://deb.debian.org/debian stretch/non-free amd64 libgl1-nvidia-glvnd-glx amd64 375.82-1~deb9u1 [323 kB]
Des:8 http://deb.debian.org/debian stretch/non-free amd64 nvidia-egl-common amd64 375.82-1~deb9u1 [172 kB]
Des:9 http://deb.debian.org/debian stretch/non-free amd64 libegl1-glvnd-nvidia amd64 375.82-1~deb9u1 [197 kB]
Des:10 http://deb.debian.org/debian stretch/non-free amd64 libnvidia-eglcore amd64 375.82-1~deb9u1 [6.353 kB]
Des:11 http://deb.debian.org/debian stretch/non-free amd64 libegl-nvidia0 amd64 375.82-1~deb9u1 [336 kB]                                                
Des:12 http://deb.debian.org/debian stretch/non-free amd64 nvidia-egl-icd amd64 375.82-1~deb9u1 [171 kB]                                                
Des:13 http://deb.debian.org/debian stretch/non-free amd64 nvidia-driver-libs amd64 375.82-1~deb9u1 [171 kB]                                            
Des:14 http://deb.debian.org/debian stretch/non-free amd64 libnvidia-ml1 amd64 375.82-1~deb9u1 [550 kB]                                                 
Des:15 http://deb.debian.org/debian stretch/non-free amd64 nvidia-driver-bin amd64 375.82-1~deb9u1 [254 kB]                                             
Des:16 http://deb.debian.org/debian stretch/contrib amd64 nvidia-support amd64 20151021+4 [20,1 kB]                                                     
Des:17 http://deb.debian.org/debian stretch/non-free amd64 xserver-xorg-video-nvidia amd64 375.82-1~deb9u1 [3.186 kB]                                   
Des:18 http://deb.debian.org/debian stretch/contrib amd64 nvidia-kernel-common amd64 20151021+4 [10,3 kB]                                               
Des:19 http://deb.debian.org/debian stretch/contrib amd64 nvidia-modprobe amd64 375.26-1 [16,4 kB]                                                      
Des:20 http://deb.debian.org/debian stretch/non-free amd64 nvidia-kernel-support amd64 375.82-1~deb9u1 [172 kB]                                         
Des:21 http://deb.debian.org/debian stretch/non-free amd64 nvidia-kernel-dkms amd64 375.82-1~deb9u1 [6.763 kB]                                          
Des:22 http://deb.debian.org/debian stretch/non-free amd64 nvidia-driver amd64 375.82-1~deb9u1 [466 kB]                                                 
Des:23 http://deb.debian.org/debian stretch/contrib amd64 nvidia-settings amd64 375.66-1 [882 kB]                                                       
Des:24 http://deb.debian.org/debian stretch/main amd64 bbswitch-dkms amd64 0.8-4 [12,3 kB]                                                              
Des:25 http://deb.debian.org/debian stretch/main amd64 bumblebee amd64 3.2.1-14 [49,7 kB]                                                               
Des:26 http://deb.debian.org/debian stretch/non-free amd64 libgles1-glvnd-nvidia amd64 375.82-1~deb9u1 [180 kB]                                         
Des:27 http://deb.debian.org/debian stretch/non-free amd64 libgles-nvidia1 amd64 375.82-1~deb9u1 [188 kB]                                               
Des:28 http://deb.debian.org/debian stretch/non-free amd64 libgles2-glvnd-nvidia amd64 375.82-1~deb9u1 [182 kB]                                         
Des:29 http://deb.debian.org/debian stretch/non-free amd64 libgles-nvidia2 amd64 375.82-1~deb9u1 [193 kB]                                               
Des:30 http://deb.debian.org/debian stretch/non-free amd64 libnvidia-cfg1 amd64 375.82-1~deb9u1 [226 kB]                                                
Des:31 http://deb.debian.org/debian stretch/non-free amd64 libopengl0-glvnd-nvidia amd64 375.82-1~deb9u1 [197 kB]                                       
Des:32 http://deb.debian.org/debian stretch/main amd64 libvulkan1 amd64 1.0.39.0+dfsg1-1 [59,9 kB]                                                      
Des:33 http://deb.debian.org/debian stretch/contrib amd64 nvidia-persistenced amd64 375.26-2 [20,5 kB]                                                  
Des:34 http://deb.debian.org/debian stretch/non-free amd64 nvidia-vulkan-common amd64 375.82-1~deb9u1 [172 kB]                                          
Des:35 http://deb.debian.org/debian stretch/non-free amd64 nvidia-vulkan-icd amd64 375.82-1~deb9u1 [171 kB]                                             
Des:36 http://deb.debian.org/debian stretch/contrib amd64 bumblebee-nvidia amd64 3.2.1-14 [5.146 B]                                                     
Des:37 http://deb.debian.org/debian stretch/main amd64 socat amd64 1.7.3.1-2+deb9u1 [353 kB]                                                            
Des:38 http://deb.debian.org/debian stretch/main amd64 primus-libs amd64 0~20150328-4 [49,3 kB]                                                         
Des:39 http://deb.debian.org/debian stretch/main amd64 primus amd64 0~20150328-4 [11,0 kB]                                                              
Descargados 29,6 MB en 20s (1.459 kB/s)                                                                                                                 
Extrayendo plantillas para los paquetes: 100%
Preconfigurando paquetes ...
Seleccionando el paquete libgldispatch0-nvidia:amd64 previamente no seleccionado.
(Leyendo la base de datos ... 230727 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../00-libgldispatch0-nvidia_375.82-1~deb9u1_amd64.deb ...
Desempaquetando libgldispatch0-nvidia:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete libglx0-glvnd-nvidia:amd64 previamente no seleccionado.
Preparando para desempaquetar .../01-libglx0-glvnd-nvidia_375.82-1~deb9u1_amd64.deb ...
Desempaquetando libglx0-glvnd-nvidia:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete libgl1-glvnd-nvidia-glx:amd64 previamente no seleccionado.
Preparando para desempaquetar .../02-libgl1-glvnd-nvidia-glx_375.82-1~deb9u1_amd64.deb ...
Desempaquetando libgl1-glvnd-nvidia-glx:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete libnvidia-glcore:amd64 previamente no seleccionado.
Preparando para desempaquetar .../03-libnvidia-glcore_375.82-1~deb9u1_amd64.deb ...
Desempaquetando libnvidia-glcore:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete libglx-nvidia0:amd64 previamente no seleccionado.
Preparando para desempaquetar .../04-libglx-nvidia0_375.82-1~deb9u1_amd64.deb ...
Desempaquetando libglx-nvidia0:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete libgl1-nvidia-glvnd-glx:amd64 previamente no seleccionado.
Preparando para desempaquetar .../05-libgl1-nvidia-glvnd-glx_375.82-1~deb9u1_amd64.deb ...
Desempaquetando libgl1-nvidia-glvnd-glx:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete nvidia-egl-common previamente no seleccionado.
Preparando para desempaquetar .../06-nvidia-egl-common_375.82-1~deb9u1_amd64.deb ...
Desempaquetando nvidia-egl-common (375.82-1~deb9u1) ...
Seleccionando el paquete libegl1-glvnd-nvidia:amd64 previamente no seleccionado.
Preparando para desempaquetar .../07-libegl1-glvnd-nvidia_375.82-1~deb9u1_amd64.deb ...
Desempaquetando libegl1-glvnd-nvidia:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete libnvidia-eglcore:amd64 previamente no seleccionado.
Preparando para desempaquetar .../08-libnvidia-eglcore_375.82-1~deb9u1_amd64.deb ...
Desempaquetando libnvidia-eglcore:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete libegl-nvidia0:amd64 previamente no seleccionado.
Preparando para desempaquetar .../09-libegl-nvidia0_375.82-1~deb9u1_amd64.deb ...
Desempaquetando libegl-nvidia0:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete nvidia-egl-icd:amd64 previamente no seleccionado.
Preparando para desempaquetar .../10-nvidia-egl-icd_375.82-1~deb9u1_amd64.deb ...
Desempaquetando nvidia-egl-icd:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete nvidia-driver-libs:amd64 previamente no seleccionado.
Preparando para desempaquetar .../11-nvidia-driver-libs_375.82-1~deb9u1_amd64.deb ...
Desempaquetando nvidia-driver-libs:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete libnvidia-ml1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../12-libnvidia-ml1_375.82-1~deb9u1_amd64.deb ...
Desempaquetando libnvidia-ml1:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete nvidia-driver-bin previamente no seleccionado.
Preparando para desempaquetar .../13-nvidia-driver-bin_375.82-1~deb9u1_amd64.deb ...
Desempaquetando nvidia-driver-bin (375.82-1~deb9u1) ...
Seleccionando el paquete nvidia-support previamente no seleccionado.
Preparando para desempaquetar .../14-nvidia-support_20151021+4_amd64.deb ...
Desempaquetando nvidia-support (20151021+4) ...
Seleccionando el paquete xserver-xorg-video-nvidia previamente no seleccionado.
Preparando para desempaquetar .../15-xserver-xorg-video-nvidia_375.82-1~deb9u1_amd64.deb ...
Desempaquetando xserver-xorg-video-nvidia (375.82-1~deb9u1) ...
Seleccionando el paquete nvidia-kernel-common previamente no seleccionado.
Preparando para desempaquetar .../16-nvidia-kernel-common_20151021+4_amd64.deb ...
Desempaquetando nvidia-kernel-common (20151021+4) ...
Seleccionando el paquete nvidia-modprobe previamente no seleccionado.
Preparando para desempaquetar .../17-nvidia-modprobe_375.26-1_amd64.deb ...
Desempaquetando nvidia-modprobe (375.26-1) ...
Seleccionando el paquete nvidia-kernel-support previamente no seleccionado.
Preparando para desempaquetar .../18-nvidia-kernel-support_375.82-1~deb9u1_amd64.deb ...
Desempaquetando nvidia-kernel-support (375.82-1~deb9u1) ...
Seleccionando el paquete nvidia-kernel-dkms previamente no seleccionado.
Preparando para desempaquetar .../19-nvidia-kernel-dkms_375.82-1~deb9u1_amd64.deb ...
Desempaquetando nvidia-kernel-dkms (375.82-1~deb9u1) ...
Seleccionando el paquete nvidia-driver previamente no seleccionado.
Preparando para desempaquetar .../20-nvidia-driver_375.82-1~deb9u1_amd64.deb ...
Desempaquetando nvidia-driver (375.82-1~deb9u1) ...
Seleccionando el paquete libxnvctrl0:amd64 previamente no seleccionado.
Preparando para desempaquetar .../21-libxnvctrl0_384.111-1~bpo9+1_amd64.deb ...
Desempaquetando libxnvctrl0:amd64 (384.111-1~bpo9+1) ...
Seleccionando el paquete nvidia-settings previamente no seleccionado.
Preparando para desempaquetar .../22-nvidia-settings_375.66-1_amd64.deb ...
Desempaquetando nvidia-settings (375.66-1) ...
Seleccionando el paquete bbswitch-dkms previamente no seleccionado.
Preparando para desempaquetar .../23-bbswitch-dkms_0.8-4_amd64.deb ...
Desempaquetando bbswitch-dkms (0.8-4) ...
Seleccionando el paquete bumblebee previamente no seleccionado.
Preparando para desempaquetar .../24-bumblebee_3.2.1-14_amd64.deb ...
Desempaquetando bumblebee (3.2.1-14) ...
Seleccionando el paquete libgles1-glvnd-nvidia:amd64 previamente no seleccionado.
Preparando para desempaquetar .../25-libgles1-glvnd-nvidia_375.82-1~deb9u1_amd64.deb ...
Desempaquetando libgles1-glvnd-nvidia:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete libgles-nvidia1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../26-libgles-nvidia1_375.82-1~deb9u1_amd64.deb ...
Desempaquetando libgles-nvidia1:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete libgles2-glvnd-nvidia:amd64 previamente no seleccionado.
Preparando para desempaquetar .../27-libgles2-glvnd-nvidia_375.82-1~deb9u1_amd64.deb ...
Desempaquetando libgles2-glvnd-nvidia:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete libgles-nvidia2:amd64 previamente no seleccionado.
Preparando para desempaquetar .../28-libgles-nvidia2_375.82-1~deb9u1_amd64.deb ...
Desempaquetando libgles-nvidia2:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete libnvidia-cfg1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../29-libnvidia-cfg1_375.82-1~deb9u1_amd64.deb ...
Desempaquetando libnvidia-cfg1:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete libopengl0-glvnd-nvidia:amd64 previamente no seleccionado.
Preparando para desempaquetar .../30-libopengl0-glvnd-nvidia_375.82-1~deb9u1_amd64.deb ...
Desempaquetando libopengl0-glvnd-nvidia:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete libvulkan1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../31-libvulkan1_1.0.39.0+dfsg1-1_amd64.deb ...
Desempaquetando libvulkan1:amd64 (1.0.39.0+dfsg1-1) ...
Seleccionando el paquete nvidia-persistenced previamente no seleccionado.
Preparando para desempaquetar .../32-nvidia-persistenced_375.26-2_amd64.deb ...
Desempaquetando nvidia-persistenced (375.26-2) ...
Seleccionando el paquete nvidia-vulkan-common previamente no seleccionado.
Preparando para desempaquetar .../33-nvidia-vulkan-common_375.82-1~deb9u1_amd64.deb ...
Desempaquetando nvidia-vulkan-common (375.82-1~deb9u1) ...
Seleccionando el paquete nvidia-vulkan-icd:amd64 previamente no seleccionado.
Preparando para desempaquetar .../34-nvidia-vulkan-icd_375.82-1~deb9u1_amd64.deb ...
Desempaquetando nvidia-vulkan-icd:amd64 (375.82-1~deb9u1) ...
Seleccionando el paquete bumblebee-nvidia previamente no seleccionado.
Preparando para desempaquetar .../35-bumblebee-nvidia_3.2.1-14_amd64.deb ...
Desempaquetando bumblebee-nvidia (3.2.1-14) ...
Seleccionando el paquete socat previamente no seleccionado.
Preparando para desempaquetar .../36-socat_1.7.3.1-2+deb9u1_amd64.deb ...
Desempaquetando socat (1.7.3.1-2+deb9u1) ...
Seleccionando el paquete primus-libs:amd64 previamente no seleccionado.
Preparando para desempaquetar .../37-primus-libs_0~20150328-4_amd64.deb ...
Desempaquetando primus-libs:amd64 (0~20150328-4) ...
Seleccionando el paquete primus previamente no seleccionado.
Preparando para desempaquetar .../38-primus_0~20150328-4_amd64.deb ...
Desempaquetando primus (0~20150328-4) ...
Configurando libvulkan1:amd64 (1.0.39.0+dfsg1-1) ...
Configurando nvidia-kernel-common (20151021+4) ...
Configurando libnvidia-eglcore:amd64 (375.82-1~deb9u1) ...
Configurando libgldispatch0-nvidia:amd64 (375.82-1~deb9u1) ...
Configurando nvidia-support (20151021+4) ...
Procesando disparadores para nvidia-alternative (375.82-1~deb9u1) ...
update-alternatives: atención: forzando la reinstalación de la alternativa /usr/lib/nvidia/current porque el grupo de enlaces nvidia está roto
Configurando socat (1.7.3.1-2+deb9u1) ...
Configurando libgles2-glvnd-nvidia:amd64 (375.82-1~deb9u1) ...
Configurando primus-libs:amd64 (0~20150328-4) ...
Configurando libnvidia-glcore:amd64 (375.82-1~deb9u1) ...
Procesando disparadores para initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.14.0-0.bpo.3-amd64
Configurando libglx0-glvnd-nvidia:amd64 (375.82-1~deb9u1) ...
Configurando libegl1-glvnd-nvidia:amd64 (375.82-1~deb9u1) ...
Configurando libegl-nvidia0:amd64 (375.82-1~deb9u1) ...
Procesando disparadores para libc-bin (2.24-11+deb9u1) ...
Configurando nvidia-egl-common (375.82-1~deb9u1) ...
Configurando libgles-nvidia2:amd64 (375.82-1~deb9u1) ...
Configurando libnvidia-cfg1:amd64 (375.82-1~deb9u1) ...
Procesando disparadores para systemd (236-3~bpo9+1) ...
Configurando nvidia-modprobe (375.26-1) ...
Configurando libgles1-glvnd-nvidia:amd64 (375.82-1~deb9u1) ...
Configurando libnvidia-ml1:amd64 (375.82-1~deb9u1) ...
Configurando nvidia-vulkan-common (375.82-1~deb9u1) ...
Procesando disparadores para man-db (2.7.6.1-2) ...
Configurando libgles-nvidia1:amd64 (375.82-1~deb9u1) ...
Configurando xserver-xorg-video-nvidia (375.82-1~deb9u1) ...
Configurando nvidia-driver-bin (375.82-1~deb9u1) ...
Configurando bbswitch-dkms (0.8-4) ...
Loading new bbswitch-0.8 DKMS files...
Building for 4.14.0-0.bpo.3-amd64
Building initial module for 4.14.0-0.bpo.3-amd64
Done.

bbswitch:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-0.bpo.3-amd64/updates/dkms/

depmod...

DKMS: install completed.
Configurando libxnvctrl0:amd64 (384.111-1~bpo9+1) ...
Configurando libgl1-glvnd-nvidia-glx:amd64 (375.82-1~deb9u1) ...
Configurando libopengl0-glvnd-nvidia:amd64 (375.82-1~deb9u1) ...
Configurando nvidia-persistenced (375.26-2) ...
Configurando libglx-nvidia0:amd64 (375.82-1~deb9u1) ...
Configurando nvidia-vulkan-icd:amd64 (375.82-1~deb9u1) ...
Configurando nvidia-egl-icd:amd64 (375.82-1~deb9u1) ...
Configurando nvidia-kernel-support (375.82-1~deb9u1) ...
Configurando nvidia-settings (375.66-1) ...
Configurando nvidia-kernel-dkms (375.82-1~deb9u1) ...
Loading new nvidia-current-375.82 DKMS files...
Building for 4.14.0-0.bpo.3-amd64
Building initial module for 4.14.0-0.bpo.3-amd64
Error! Bad return status for module build on kernel: 4.14.0-0.bpo.3-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-current/375.82/build/make.log for more information.
Configurando bumblebee (3.2.1-14) ...
Configurando libgl1-nvidia-glvnd-glx:amd64 (375.82-1~deb9u1) ...
Configurando nvidia-driver-libs:amd64 (375.82-1~deb9u1) ...
Configurando nvidia-driver (375.82-1~deb9u1) ...
Procesando disparadores para initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.14.0-0.bpo.3-amd64
Configurando bumblebee-nvidia (3.2.1-14) ...
update-alternatives: error: la alternativa /usr/lib/nvidia/bumblebee para glx no está registrada, no se configurará
Configurando primus (0~20150328-4) ...
Procesando disparadores para glx-alternative-nvidia (0.7.4) ...
Procesando disparadores para libc-bin (2.24-11+deb9u1) ...
Procesando disparadores para update-glx (0.7.4) ...
Procesando disparadores para glx-alternative-nvidia (0.7.4) ...
update-alternatives: utilizando /usr/lib/nvidia para proveer /usr/lib/glx (glx) en modo automático
update-alternatives: utilizando /usr/lib/nvidia/bumblebee para proveer /usr/lib/glx (glx) en modo automático
Procesando disparadores para libc-bin (2.24-11+deb9u1) ...
Procesando disparadores para initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.14.0-0.bpo.3-amd64
Procesando disparadores para bumblebee (3.2.1-14) ...

me llama la atencion este mensaje:

Building initial module for 4.14.0-0.bpo.3-amd64
Error! Bad return status for module build on kernel: 4.14.0-0.bpo.3-amd64 (x86_64)

Se termino de instalar y los ventiladores empezaron a girar mucho. Es normal?

Lun, 05/02/2018 - 19:15
jlopezjuy
Imagen de jlopezjuy
Desconectado/a
se unió: 31/01/18

Bueno, no tengo suerte, instale todo eso y del login no pasa, se tilda y empieza a parpadear la pantalla, no llega ni al escritorio. tuve que desinstalar todo. 

Mar, 06/02/2018 - 10:15 (Responder a #24)
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Pues no, no ha ido bien, como has notado

Error! Bad return status for module build on kernel: 4.14.0-0.bpo.3-amd64 (x86_64) Consult /var/lib/dkms/nvidia-current/375.82/build/make.log for more information.

Ese error es el mismo que te ha salido la primera ve que lo hiciste, e indica que no ha construido el driver para nvidia... Viendo el log que has pegado, hay varios paquetes, entre ellos, xserver-xorg-video-nvidia que no se ha instalado desde backports, si no desde el repositorio stable de stretch. Necesitas que ese paquete y nvidia-kernel-dkms sean de backports también. Lo que está haciendo es intentar compilar un módulo para un kernel para el que no está hecho.

Si ejecutas

aptitude versions server-xorg-video-nvidia

verás que te saldrán la versió que se ha instalado (375) y otra, que será 384 posiblemente. La que inclua "bpo" en su versión es la que tienes que instalar. Puedes forzar esa versión de la siguiente manera:

aptitude install xserver-xorg-video-nvidia=VERSION

poniendo en VERSION la que haya  salido con el comando anterior. Ésta arrastrará las dependencias necesarias debería compilar el modulo sin problemas.

  No hay bar que por bien no venga....
Mar, 06/02/2018 - 22:25 (Responder a #25)
jlopezjuy
Imagen de jlopezjuy
Desconectado/a
se unió: 31/01/18

Desinstale todo, hice clean de todo. mi sources list es el siguiente

/etc/apt/sources.list
deb http://deb.debian.org/debian stretch main contrib non-free
deb-src http://deb.debian.org/debian stretch main contrib non-free

deb http://deb.debian.org/debian stretch-updates main contrib non-free
deb-src http://deb.debian.org/debian stretch-updates main contrib non-free

deb http://security.debian.org/debian-security/ stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security/ stretch/updates main contrib non-free
deb http://ftp.debian.org/debian stretch-backports main
deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main
# deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main
deb [arch=amd64] https://download.docker.com/linux/debian stretch stable contrib non-free
# deb-src [arch=amd64] https://download.docker.com/linux/debian stretch stable

que debo sacar y que debo instalar bien para que quede todo ok?

Perdón si soy insistente, pero me acostumbre a usar linux y volver a windows me aburre, jeje

Mié, 07/02/2018 - 09:28
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

A ver... Te acabo de decir lo que te  ha pasado, te acabo de decir como puedes solucionarlo... ¿Podrías explicarme que tiene que ver tu respuesta con lo que te he dicho? Si te digo que compres peras, y luego me preguntas que como están las manzanas  que has comprado... pues nos perdemos...

  No hay bar que por bien no venga....
Mié, 07/02/2018 - 10:47 (Responder a #27)
jlopezjuy
Imagen de jlopezjuy
Desconectado/a
se unió: 31/01/18

vale vale, no te molestes amigo, ya me pongo a ver como lo vuelvo a instalar y que tome todo del backport

Mié, 07/02/2018 - 11:12
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

De todas formas, te sigue faltando algo.... (no entraré en el ppa de xenial y el repo de docker)

la línea

deb http://ftp.debian.org/debian stretch-backports main

tiene que quedarte

deb http://ftp.debian.org/debian stretch-backports main contrin non-free

o volveremos al mismo resultado.... (no voy a releer todo el hilo, pero hasta me suena que te lo han dicho).

  No hay bar que por bien no venga....
Mié, 07/02/2018 - 11:14
jlopezjuy
Imagen de jlopezjuy
Desconectado/a
se unió: 31/01/18

Bueno cambie en el sources.list la url del backports por este

deb http://ftp.de.debian.org/debian stretch-backports main non-free

y aparentemente esta funcionando, luego de que termine de trabajar reinicio para ver si esta todo ok.

 

sudo apt-get -t stretch-backports install  bumblebee-nvidia bbswitch-dkms nvidia-kernel-dkms nvidia-driver
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes adicionales:
  bumblebee libegl-nvidia0 libegl1-glvnd-nvidia libgl1-glvnd-nvidia-glx libgl1-nvidia-glvnd-glx libgles-nvidia1 libgles-nvidia2 libgles1-glvnd-nvidia libgles2-glvnd-nvidia libglvnd0-nvidia libglx-nvidia0
  libglx0-glvnd-nvidia libnvidia-cfg1 libnvidia-egl-wayland1 libnvidia-eglcore libnvidia-glcore libnvidia-ml1 libopengl0-glvnd-nvidia libvulkan1 nvidia-alternative nvidia-driver-bin nvidia-driver-libs
  nvidia-egl-common nvidia-egl-icd nvidia-egl-wayland-common nvidia-egl-wayland-icd nvidia-kernel-common nvidia-kernel-support nvidia-modprobe nvidia-persistenced nvidia-support nvidia-vdpau-driver
  nvidia-vulkan-common nvidia-vulkan-icd primus primus-libs socat xserver-xorg-video-nvidia
Paquetes sugeridos:
  vulkan-utils
Paquetes recomendados:
  nvidia-settings nvidia-driver-libs-i386 primus-libs-ia32
Se instalarán los siguientes paquetes NUEVOS:
  bbswitch-dkms bumblebee bumblebee-nvidia libegl-nvidia0 libegl1-glvnd-nvidia libgl1-glvnd-nvidia-glx libgl1-nvidia-glvnd-glx libgles-nvidia1 libgles-nvidia2 libgles1-glvnd-nvidia libgles2-glvnd-nvidia
  libglvnd0-nvidia libglx-nvidia0 libglx0-glvnd-nvidia libnvidia-cfg1 libnvidia-egl-wayland1 libnvidia-eglcore libnvidia-glcore libnvidia-ml1 libopengl0-glvnd-nvidia libvulkan1 nvidia-driver nvidia-driver-bin
  nvidia-driver-libs nvidia-egl-common nvidia-egl-icd nvidia-egl-wayland-common nvidia-egl-wayland-icd nvidia-kernel-common nvidia-kernel-dkms nvidia-kernel-support nvidia-modprobe nvidia-persistenced
  nvidia-support nvidia-vulkan-common nvidia-vulkan-icd primus primus-libs socat xserver-xorg-video-nvidia
Se actualizarán los siguientes paquetes:
  nvidia-alternative nvidia-vdpau-driver
2 actualizados, 40 nuevos se instalarán, 0 para eliminar y 57 no actualizados.
Se necesita descargar 22,9 MB/32,1 MB de archivos.
Se utilizarán 122 MB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n] s
Des:1 http://deb.debian.org/debian stretch/contrib amd64 nvidia-support amd64 20151021+4 [20,1 kB]
Des:2 http://deb.debian.org/debian stretch/contrib amd64 nvidia-kernel-common amd64 20151021+4 [10,3 kB]
Des:3 http://deb.debian.org/debian stretch/contrib amd64 nvidia-modprobe amd64 375.26-1 [16,4 kB]
Des:4 http://deb.debian.org/debian stretch/main amd64 bbswitch-dkms amd64 0.8-4 [12,3 kB]
Des:5 http://deb.debian.org/debian stretch/main amd64 bumblebee amd64 3.2.1-14 [49,7 kB]
Des:6 http://deb.debian.org/debian stretch/contrib amd64 nvidia-persistenced amd64 375.26-2 [20,5 kB]
Des:7 http://deb.debian.org/debian stretch/contrib amd64 bumblebee-nvidia amd64 3.2.1-14 [5.146 B]
Des:8 http://deb.debian.org/debian stretch/main amd64 socat amd64 1.7.3.1-2+deb9u1 [353 kB]
Des:9 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 libglvnd0-nvidia amd64 384.111-3~bpo9+1 [222 kB]
Des:10 http://deb.debian.org/debian stretch/main amd64 primus-libs amd64 0~20150328-4 [49,3 kB]
Des:11 http://deb.debian.org/debian stretch/main amd64 primus amd64 0~20150328-4 [11,0 kB]
Des:12 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 libglx0-glvnd-nvidia amd64 384.111-3~bpo9+1 [202 kB]
Des:13 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 libgl1-glvnd-nvidia-glx amd64 384.111-3~bpo9+1 [253 kB]
Des:14 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 libnvidia-glcore amd64 384.111-3~bpo9+1 [6.666 kB]
Des:15 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 libglx-nvidia0 amd64 384.111-3~bpo9+1 [436 kB]                                                                                            
Des:16 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 libgl1-nvidia-glvnd-glx amd64 384.111-3~bpo9+1 [333 kB]                                                                                   
Des:17 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 nvidia-egl-common amd64 384.111-3~bpo9+1 [180 kB]                                                                                         
Des:18 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 libegl1-glvnd-nvidia amd64 384.111-3~bpo9+1 [206 kB]                                                                                      
Des:19 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 nvidia-egl-icd amd64 384.111-3~bpo9+1 [180 kB]                                                                                            
Des:20 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 nvidia-driver-libs amd64 384.111-3~bpo9+1 [180 kB]                                                                                        
Des:21 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 xserver-xorg-video-nvidia amd64 384.111-3~bpo9+1 [3.409 kB]                                                                               
Des:22 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 nvidia-kernel-dkms amd64 384.111-3~bpo9+1 [7.618 kB]                                                                                      
Des:23 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 nvidia-driver amd64 384.111-3~bpo9+1 [477 kB]                                                                                             
Des:24 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 libgles1-glvnd-nvidia amd64 384.111-3~bpo9+1 [188 kB]                                                                                     
Des:25 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 libgles-nvidia1 amd64 384.111-3~bpo9+1 [197 kB]                                                                                           
Des:26 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 libgles2-glvnd-nvidia amd64 384.111-3~bpo9+1 [193 kB]                                                                                     
Des:27 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 libgles-nvidia2 amd64 384.111-3~bpo9+1 [202 kB]                                                                                           
Des:28 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 libnvidia-egl-wayland1 amd64 384.111-3~bpo9+1 [192 kB]                                                                                    
Des:29 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 libopengl0-glvnd-nvidia amd64 384.111-3~bpo9+1 [205 kB]                                                                                   
Des:30 http://ftp.de.debian.org/debian stretch-backports/main amd64 libvulkan1 amd64 1.0.65.2+dfsg1-1~bpo9+1 [84,3 kB]                                                                                            
Des:31 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 nvidia-egl-wayland-common amd64 384.111-3~bpo9+1 [180 kB]                                                                                 
Des:32 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 nvidia-egl-wayland-icd amd64 384.111-3~bpo9+1 [180 kB]                                                                                    
Des:33 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 nvidia-vulkan-common amd64 384.111-3~bpo9+1 [180 kB]                                                                                      
Des:34 http://ftp.de.debian.org/debian stretch-backports/non-free amd64 nvidia-vulkan-icd amd64 384.111-3~bpo9+1 [180 kB]                                                                                         
Descargados 18,6 MB en 37s (491 kB/s)                                                                                                                                                                             
Leyendo lista de cambios... Hecho.
Extrayendo plantillas para los paquetes: 100%
Preconfigurando paquetes ...
(Leyendo la base de datos ... 230733 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../00-nvidia-alternative_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-alternative (384.111-3~bpo9+1) sobre (375.82-1~deb9u1) ...
Preparando para desempaquetar .../01-nvidia-vdpau-driver_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-vdpau-driver:amd64 (384.111-3~bpo9+1) sobre (375.82-1~deb9u1) ...
Seleccionando el paquete libglvnd0-nvidia:amd64 previamente no seleccionado.
Preparando para desempaquetar .../02-libglvnd0-nvidia_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libglvnd0-nvidia:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libglx0-glvnd-nvidia:amd64 previamente no seleccionado.
Preparando para desempaquetar .../03-libglx0-glvnd-nvidia_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libglx0-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libgl1-glvnd-nvidia-glx:amd64 previamente no seleccionado.
Preparando para desempaquetar .../04-libgl1-glvnd-nvidia-glx_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libgl1-glvnd-nvidia-glx:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libnvidia-glcore:amd64 previamente no seleccionado.
Preparando para desempaquetar .../05-libnvidia-glcore_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libnvidia-glcore:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libglx-nvidia0:amd64 previamente no seleccionado.
Preparando para desempaquetar .../06-libglx-nvidia0_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libglx-nvidia0:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libgl1-nvidia-glvnd-glx:amd64 previamente no seleccionado.
Preparando para desempaquetar .../07-libgl1-nvidia-glvnd-glx_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libgl1-nvidia-glvnd-glx:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-egl-common previamente no seleccionado.
Preparando para desempaquetar .../08-nvidia-egl-common_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-egl-common (384.111-3~bpo9+1) ...
Seleccionando el paquete libegl1-glvnd-nvidia:amd64 previamente no seleccionado.
Preparando para desempaquetar .../09-libegl1-glvnd-nvidia_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libegl1-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libnvidia-eglcore:amd64 previamente no seleccionado.
Preparando para desempaquetar .../10-libnvidia-eglcore_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libnvidia-eglcore:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libegl-nvidia0:amd64 previamente no seleccionado.
Preparando para desempaquetar .../11-libegl-nvidia0_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libegl-nvidia0:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-egl-icd:amd64 previamente no seleccionado.
Preparando para desempaquetar .../12-nvidia-egl-icd_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-egl-icd:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-driver-libs:amd64 previamente no seleccionado.
Preparando para desempaquetar .../13-nvidia-driver-libs_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-driver-libs:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libnvidia-ml1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../14-libnvidia-ml1_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libnvidia-ml1:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-driver-bin previamente no seleccionado.
Preparando para desempaquetar .../15-nvidia-driver-bin_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-driver-bin (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-support previamente no seleccionado.
Preparando para desempaquetar .../16-nvidia-support_20151021+4_amd64.deb ...
Desempaquetando nvidia-support (20151021+4) ...
Seleccionando el paquete xserver-xorg-video-nvidia previamente no seleccionado.
Preparando para desempaquetar .../17-xserver-xorg-video-nvidia_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando xserver-xorg-video-nvidia (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-kernel-common previamente no seleccionado.
Preparando para desempaquetar .../18-nvidia-kernel-common_20151021+4_amd64.deb ...
Desempaquetando nvidia-kernel-common (20151021+4) ...
Seleccionando el paquete nvidia-modprobe previamente no seleccionado.
Preparando para desempaquetar .../19-nvidia-modprobe_375.26-1_amd64.deb ...
Desempaquetando nvidia-modprobe (375.26-1) ...
Seleccionando el paquete nvidia-kernel-support previamente no seleccionado.
Preparando para desempaquetar .../20-nvidia-kernel-support_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-kernel-support (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-kernel-dkms previamente no seleccionado.
Preparando para desempaquetar .../21-nvidia-kernel-dkms_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-kernel-dkms (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-driver previamente no seleccionado.
Preparando para desempaquetar .../22-nvidia-driver_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-driver (384.111-3~bpo9+1) ...
Seleccionando el paquete bbswitch-dkms previamente no seleccionado.
Preparando para desempaquetar .../23-bbswitch-dkms_0.8-4_amd64.deb ...
Desempaquetando bbswitch-dkms (0.8-4) ...
Seleccionando el paquete bumblebee previamente no seleccionado.
Preparando para desempaquetar .../24-bumblebee_3.2.1-14_amd64.deb ...
Desempaquetando bumblebee (3.2.1-14) ...
Seleccionando el paquete libgles1-glvnd-nvidia:amd64 previamente no seleccionado.
Preparando para desempaquetar .../25-libgles1-glvnd-nvidia_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libgles1-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libgles-nvidia1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../26-libgles-nvidia1_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libgles-nvidia1:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libgles2-glvnd-nvidia:amd64 previamente no seleccionado.
Preparando para desempaquetar .../27-libgles2-glvnd-nvidia_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libgles2-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libgles-nvidia2:amd64 previamente no seleccionado.
Preparando para desempaquetar .../28-libgles-nvidia2_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libgles-nvidia2:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libnvidia-cfg1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../29-libnvidia-cfg1_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libnvidia-cfg1:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libnvidia-egl-wayland1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../30-libnvidia-egl-wayland1_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libnvidia-egl-wayland1:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libopengl0-glvnd-nvidia:amd64 previamente no seleccionado.
Preparando para desempaquetar .../31-libopengl0-glvnd-nvidia_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libopengl0-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libvulkan1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../32-libvulkan1_1.0.65.2+dfsg1-1~bpo9+1_amd64.deb ...
Desempaquetando libvulkan1:amd64 (1.0.65.2+dfsg1-1~bpo9+1) ...
Seleccionando el paquete nvidia-egl-wayland-common previamente no seleccionado.
Preparando para desempaquetar .../33-nvidia-egl-wayland-common_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-egl-wayland-common (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-egl-wayland-icd:amd64 previamente no seleccionado.
Preparando para desempaquetar .../34-nvidia-egl-wayland-icd_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-egl-wayland-icd:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-persistenced previamente no seleccionado.
Preparando para desempaquetar .../35-nvidia-persistenced_375.26-2_amd64.deb ...
Desempaquetando nvidia-persistenced (375.26-2) ...
Seleccionando el paquete nvidia-vulkan-common previamente no seleccionado.
Preparando para desempaquetar .../36-nvidia-vulkan-common_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-vulkan-common (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-vulkan-icd:amd64 previamente no seleccionado.
Preparando para desempaquetar .../37-nvidia-vulkan-icd_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-vulkan-icd:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete bumblebee-nvidia previamente no seleccionado.
Preparando para desempaquetar .../38-bumblebee-nvidia_3.2.1-14_amd64.deb ...
Desempaquetando bumblebee-nvidia (3.2.1-14) ...
Seleccionando el paquete socat previamente no seleccionado.
Preparando para desempaquetar .../39-socat_1.7.3.1-2+deb9u1_amd64.deb ...
Desempaquetando socat (1.7.3.1-2+deb9u1) ...
Seleccionando el paquete primus-libs:amd64 previamente no seleccionado.
Preparando para desempaquetar .../40-primus-libs_0~20150328-4_amd64.deb ...
Desempaquetando primus-libs:amd64 (0~20150328-4) ...
Seleccionando el paquete primus previamente no seleccionado.
Preparando para desempaquetar .../41-primus_0~20150328-4_amd64.deb ...
Desempaquetando primus (0~20150328-4) ...
Configurando libvulkan1:amd64 (1.0.65.2+dfsg1-1~bpo9+1) ...
Configurando nvidia-kernel-common (20151021+4) ...
Procesando disparadores para mime-support (3.60) ...
Configurando libnvidia-eglcore:amd64 (384.111-3~bpo9+1) ...
Procesando disparadores para desktop-file-utils (0.23-1) ...
Configurando nvidia-support (20151021+4) ...
Configurando nvidia-alternative (384.111-3~bpo9+1) ...
Configurando socat (1.7.3.1-2+deb9u1) ...
Configurando primus-libs:amd64 (0~20150328-4) ...
Configurando libnvidia-glcore:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-egl-wayland-common (384.111-3~bpo9+1) ...
Configurando libnvidia-egl-wayland1:amd64 (384.111-3~bpo9+1) ...
Procesando disparadores para initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.14.0-0.bpo.3-amd64
Procesando disparadores para libc-bin (2.24-11+deb9u1) ...
Configurando nvidia-egl-common (384.111-3~bpo9+1) ...
Procesando disparadores para systemd (236-3~bpo9+1) ...
Configurando nvidia-modprobe (375.26-1) ...
Configurando nvidia-vulkan-common (384.111-3~bpo9+1) ...
Procesando disparadores para man-db (2.7.6.1-2) ...
Configurando libglvnd0-nvidia:amd64 (384.111-3~bpo9+1) ...
Procesando disparadores para gnome-menus (3.13.3-9) ...
Configurando bbswitch-dkms (0.8-4) ...
Loading new bbswitch-0.8 DKMS files...
Building for 4.14.0-0.bpo.3-amd64
Building initial module for 4.14.0-0.bpo.3-amd64
Done.

bbswitch:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-0.bpo.3-amd64/updates/dkms/

depmod...

DKMS: install completed.
Configurando libopengl0-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Configurando bumblebee (3.2.1-14) ...
Procesando disparadores para nvidia-alternative (384.111-3~bpo9+1) ...
update-alternatives: atención: forzando la reinstalación de la alternativa /usr/lib/nvidia/current porque el grupo de enlaces nvidia está roto
Configurando xserver-xorg-video-nvidia (384.111-3~bpo9+1) ...
Configurando libgles2-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Configurando libglx0-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-kernel-support (384.111-3~bpo9+1) ...
Configurando nvidia-vdpau-driver:amd64 (384.111-3~bpo9+1) ...
Configurando libegl1-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Configurando libegl-nvidia0:amd64 (384.111-3~bpo9+1) ...
Configurando libgles-nvidia2:amd64 (384.111-3~bpo9+1) ...
Configurando libnvidia-cfg1:amd64 (384.111-3~bpo9+1) ...
Configurando libgles1-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-kernel-dkms (384.111-3~bpo9+1) ...
Loading new nvidia-current-384.111 DKMS files...
Building for 4.14.0-0.bpo.3-amd64
Building initial module for 4.14.0-0.bpo.3-amd64
Done.

nvidia-current:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-0.bpo.3-amd64/updates/dkms/

nvidia-current-modeset.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-0.bpo.3-amd64/updates/dkms/

nvidia-current-drm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-0.bpo.3-amd64/updates/dkms/

nvidia-current-uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-0.bpo.3-amd64/updates/dkms/

depmod...

DKMS: install completed.
Configurando libnvidia-ml1:amd64 (384.111-3~bpo9+1) ...
Configurando libgles-nvidia1:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-driver-bin (384.111-3~bpo9+1) ...
Configurando nvidia-egl-wayland-icd:amd64 (384.111-3~bpo9+1) ...
Configurando libgl1-glvnd-nvidia-glx:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-persistenced (375.26-2) ...
Configurando libglx-nvidia0:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-vulkan-icd:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-egl-icd:amd64 (384.111-3~bpo9+1) ...
Configurando libgl1-nvidia-glvnd-glx:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-driver-libs:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-driver (384.111-3~bpo9+1) ...
Procesando disparadores para initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.14.0-0.bpo.3-amd64
Configurando bumblebee-nvidia (3.2.1-14) ...
update-alternatives: error: la alternativa /usr/lib/nvidia/bumblebee para glx no está registrada, no se configurará
Configurando primus (0~20150328-4) ...
Procesando disparadores para libc-bin (2.24-11+deb9u1) ...
Procesando disparadores para glx-alternative-nvidia (0.7.4) ...
Procesando disparadores para update-glx (0.7.4) ...
Procesando disparadores para glx-alternative-nvidia (0.7.4) ...
update-alternatives: utilizando /usr/lib/nvidia para proveer /usr/lib/glx (glx) en modo automático
update-alternatives: utilizando /usr/lib/nvidia/bumblebee para proveer /usr/lib/glx (glx) en modo automático
Procesando disparadores para libc-bin (2.24-11+deb9u1) ...
Procesando disparadores para initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.14.0-0.bpo.3-amd64
Procesando disparadores para bumblebee (3.2.1-14) ...

Edit:

Algo fallo por que no pasa del login, y nuevamente los ventiladores giran mucho, sera que es para el kernel 4.9 nada mas? 

me llama la atencion 

update-alternatives: error: la alternativa /usr/lib/nvidia/bumblebee para glx no está 

 

Mié, 07/02/2018 - 21:51
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Bueno, ahora si, el driver para nvidia  está compilado correctamente. asi que un problema arreglado.

Me extraña que lo del login tenga que ver con esto, puesto lo que lo unico que has hecho es conseguir que el sistema disponga de un módulo para un dispositivo que no usa para el funcionamiento iniciar que bumblebee tampoco tiene nada que ver con el funcionamiento de la intel ni nada. Eso tiene que venir de otro lado seguro. pero sin logs... poco se puede hacer...

inicia en modo recovery, mete la pass de password, y nos pasas la salida del comando

journalctl -b -1 -p err

Y lo  que comentas de bumblebee, igual ha faltado la instalación de algún paquete... que me extrañaría, pero bueno, la salida de

aptitude search ~ibumblebee

puede decirnos lo que hay instalado de bumblebee.

No, no será porque es para el kernel 4.9, de hecho, lo que hemos hecho es instalar un kernel más moderno, el 4.14 de bakports y los controladores de nvidia para conseguir que te funcione. no debería tener nada que ver en absoluto con el inicio  del  sistema, ya que el sistema usará la gráfica intel. Si llega al login, es que todo va bien,  y juso ahí algo falla, asi que el problema viene de otro lado. La salida del comando journalctl que te he pedido igual nos da una pista sobre ello.

  No hay bar que por bien no venga....
Jue, 08/02/2018 - 10:29 (Responder a #31)
jlopezjuy
Imagen de jlopezjuy
Desconectado/a
se unió: 31/01/18

OK, ahora en la mañana hago esas pruebas, y comparto lo que sale en consola.

Jue, 08/02/2018 - 12:57
debiatonix
Imagen de debiatonix
Desconectado/a
se unió: 07/01/18

Hola jlopezjuy!
Te quería comentar que yo en mi portátil msi con una gtx 1060 instale la debian9
y también me pasó el mismo problema que tu con el cuelgue en el login, pero a mi ni me llegaba al login, intente varias maneras de solucionarlo.

Creo que la ultima que prove fue la siguiente:

1º-Desistalar todo:apt-get remove –purge nvidia-driver, apt-get autoremove
2º-Desistala bumblebee y bbswitch: apt-get remove –purge bbswitch-dkms bumblebee bumblebee-nvidia
3º-Verifica tus sourceslist para que queden tal que así
deb http://ftp.debian.org/debian stretch-backports main contrin non-free

4º-apt-get update apt-get clean
5ºapt-get -t stretch-backports install nvidia-driver
6ºapt-get install bbswitch-dkms bumblebee bumblebee-nvidia
7º mete tu usuario en el grupo de bumblebee: adduser “tu usuario” bumblebee

Esta fue la ultima instalación que hice y me funciono, creo que el driver nvidia 384 difiere un poco del 375 ya que esta pensado para buster que sera la nueva debian.
Sobre todo las sourceslist que al final te quede así: main contrib non-free
Pruevalo haber si a ti te funciona.

Suerte y un saludo!!

Pon una debian en tu vidayes

Jue, 08/02/2018 - 14:22
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

bien, le acabas de dar la solución que le hemos dado varias veces... xD

una pequeña corrección, si se instala kernel y driver de backports, todo lo que tenga que ver con  ello tiene que ser de backports, asi que bbswitch y bumblebee tienen que ser de backports si o si mientras estén disponibles... Son backports, están  pensados precisamente para eso, para añadir versiones que no entrarán nunca en su distro por la condición que impone ser la rama Stable. El problema le viene de otro lado seguro, puesto que los drivers de una gráfica dedicada en un equipo con tecnología Optimus no influyen en absoluto en el inicio del sistema, ya que el mismo opta por la gráfica principal, la  intel si o si. Precisamente estas cosas ocurren cuando piensas que tienes una nvidia y te empeñas en hacer que el equipo funcione con ella, cosa que nunca  conseguirás con esta tecnología.

  No hay bar que por bien no venga....
Vie, 09/02/2018 - 11:12
jlopezjuy
Imagen de jlopezjuy
Desconectado/a
se unió: 31/01/18

hoy pruebo, tenia mucho trabajo y teniamos que entregar todo. pruebo y comento que me paso.

apt-get -t stretch-backports install nvidia-driver

sudo apt-get -t stretch-backports install nvidia-driver
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes adicionales:
  libegl-nvidia0 libegl1-glvnd-nvidia libgl1-glvnd-nvidia-glx libgl1-nvidia-glvnd-glx libgles-nvidia1
  libgles-nvidia2 libgles1-glvnd-nvidia libgles2-glvnd-nvidia libglvnd0-nvidia libglx-nvidia0
  libglx0-glvnd-nvidia libnvidia-cfg1 libnvidia-egl-wayland1 libnvidia-eglcore libnvidia-glcore
  libnvidia-ml1 libopengl0-glvnd-nvidia libvulkan1 libxnvctrl0 nvidia-driver-bin nvidia-driver-libs
  nvidia-egl-common nvidia-egl-icd nvidia-egl-wayland-common nvidia-egl-wayland-icd nvidia-kernel-common
  nvidia-kernel-dkms nvidia-kernel-support nvidia-modprobe nvidia-persistenced nvidia-settings
  nvidia-support nvidia-vulkan-common nvidia-vulkan-icd xserver-xorg-video-nvidia
Paquetes sugeridos:
  vulkan-utils
Paquetes recomendados:
  nvidia-driver-libs-i386
Se instalarán los siguientes paquetes NUEVOS:
  libegl-nvidia0 libegl1-glvnd-nvidia libgl1-glvnd-nvidia-glx libgl1-nvidia-glvnd-glx libgles-nvidia1
  libgles-nvidia2 libgles1-glvnd-nvidia libgles2-glvnd-nvidia libglvnd0-nvidia libglx-nvidia0
  libglx0-glvnd-nvidia libnvidia-cfg1 libnvidia-egl-wayland1 libnvidia-eglcore libnvidia-glcore
  libnvidia-ml1 libopengl0-glvnd-nvidia libvulkan1 libxnvctrl0 nvidia-driver nvidia-driver-bin
  nvidia-driver-libs nvidia-egl-common nvidia-egl-icd nvidia-egl-wayland-common nvidia-egl-wayland-icd
  nvidia-kernel-common nvidia-kernel-dkms nvidia-kernel-support nvidia-modprobe nvidia-persistenced
  nvidia-settings nvidia-support nvidia-vulkan-common nvidia-vulkan-icd xserver-xorg-video-nvidia
0 actualizados, 36 nuevos se instalarán, 0 para eliminar y 57 no actualizados.
Se necesita descargar 31,6 MB de archivos.
Se utilizarán 124 MB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n] s
Des:1 http://deb.debian.org/debian stretch/contrib amd64 nvidia-support amd64 20151021+4 [20,1 kB]
Des:2 http://deb.debian.org/debian stretch/contrib amd64 nvidia-kernel-common amd64 20151021+4 [10,3 kB]
Des:3 http://ftp.debian.org/debian stretch-backports/non-free amd64 libglvnd0-nvidia amd64 384.111-3~bpo9+1 [222 kB]
Des:4 http://ftp.debian.org/debian stretch-backports/non-free amd64 libglx0-glvnd-nvidia amd64 384.111-3~bpo9+1 [202 kB]
Des:5 http://ftp.debian.org/debian stretch-backports/non-free amd64 libgl1-glvnd-nvidia-glx amd64 384.111-3~bpo9+1 [253 kB]
Des:6 http://ftp.debian.org/debian stretch-backports/non-free amd64 libnvidia-glcore amd64 384.111-3~bpo9+1 [6.666 kB]
Des:7 http://ftp.debian.org/debian stretch-backports/non-free amd64 libglx-nvidia0 amd64 384.111-3~bpo9+1 [436 kB]
Des:8 http://ftp.debian.org/debian stretch-backports/non-free amd64 libgl1-nvidia-glvnd-glx amd64 384.111-3~bpo9+1 [333 kB]
Des:9 http://ftp.debian.org/debian stretch-backports/non-free amd64 nvidia-egl-common amd64 384.111-3~bpo9+1 [180 kB]
Des:10 http://ftp.debian.org/debian stretch-backports/non-free amd64 libegl1-glvnd-nvidia amd64 384.111-3~bpo9+1 [206 kB]
Des:11 http://ftp.debian.org/debian stretch-backports/non-free amd64 libnvidia-eglcore amd64 384.111-3~bpo9+1 [6.583 kB]
Des:12 http://ftp.debian.org/debian stretch-backports/non-free amd64 libegl-nvidia0 amd64 384.111-3~bpo9+1 [396 kB]
Des:13 http://ftp.debian.org/debian stretch-backports/non-free amd64 nvidia-egl-icd amd64 384.111-3~bpo9+1 [180 kB]
Des:14 http://ftp.debian.org/debian stretch-backports/non-free amd64 nvidia-driver-libs amd64 384.111-3~bpo9+1 [180 kB]
Des:15 http://ftp.debian.org/debian stretch-backports/non-free amd64 libnvidia-ml1 amd64 384.111-3~bpo9+1 [587 kB]
Des:16 http://ftp.debian.org/debian stretch-backports/non-free amd64 nvidia-driver-bin amd64 384.111-3~bpo9+1 [263 kB]
Des:17 http://ftp.debian.org/debian stretch-backports/non-free amd64 xserver-xorg-video-nvidia amd64 384.111-3~bpo9+1 [3.409 kB]
Des:18 http://ftp.debian.org/debian stretch-backports/contrib amd64 nvidia-modprobe amd64 384.111-1~bpo9+1 [17,7 kB]
Des:19 http://ftp.debian.org/debian stretch-backports/non-free amd64 nvidia-kernel-support amd64 384.111-3~bpo9+1 [181 kB]
Des:20 http://ftp.debian.org/debian stretch-backports/non-free amd64 nvidia-kernel-dkms amd64 384.111-3~bpo9+1 [7.618 kB]
Des:21 http://ftp.debian.org/debian stretch-backports/non-free amd64 nvidia-driver amd64 384.111-3~bpo9+1 [477 kB]
Des:22 http://ftp.debian.org/debian stretch-backports/main amd64 libxnvctrl0 amd64 384.111-1~bpo9+1 [24,0 kB]
Des:23 http://ftp.debian.org/debian stretch-backports/contrib amd64 nvidia-settings amd64 384.111-1~bpo9+1 [896 kB]
Des:24 http://ftp.debian.org/debian stretch-backports/non-free amd64 libgles1-glvnd-nvidia amd64 384.111-3~bpo9+1 [188 kB]
Des:25 http://ftp.debian.org/debian stretch-backports/non-free amd64 libgles-nvidia1 amd64 384.111-3~bpo9+1 [197 kB]
Des:26 http://ftp.debian.org/debian stretch-backports/non-free amd64 libgles2-glvnd-nvidia amd64 384.111-3~bpo9+1 [193 kB]
Des:27 http://ftp.debian.org/debian stretch-backports/non-free amd64 libgles-nvidia2 amd64 384.111-3~bpo9+1 [202 kB]
Des:28 http://ftp.debian.org/debian stretch-backports/non-free amd64 libnvidia-cfg1 amd64 384.111-3~bpo9+1 [238 kB]
Des:29 http://ftp.debian.org/debian stretch-backports/non-free amd64 libnvidia-egl-wayland1 amd64 384.111-3~bpo9+1 [192 kB]
Des:30 http://ftp.debian.org/debian stretch-backports/non-free amd64 libopengl0-glvnd-nvidia amd64 384.111-3~bpo9+1 [205 kB]
Des:31 http://ftp.debian.org/debian stretch-backports/main amd64 libvulkan1 amd64 1.0.65.2+dfsg1-1~bpo9+1 [84,3 kB]
Des:32 http://ftp.debian.org/debian stretch-backports/non-free amd64 nvidia-egl-wayland-common amd64 384.111-3~bpo9+1 [180 kB]
Des:33 http://ftp.debian.org/debian stretch-backports/non-free amd64 nvidia-egl-wayland-icd amd64 384.111-3~bpo9+1 [180 kB]
Des:34 http://ftp.debian.org/debian stretch-backports/contrib amd64 nvidia-persistenced amd64 384.111-1~bpo9+1 [20,7 kB]
Des:35 http://ftp.debian.org/debian stretch-backports/non-free amd64 nvidia-vulkan-common amd64 384.111-3~bpo9+1 [180 kB]
Des:36 http://ftp.debian.org/debian stretch-backports/non-free amd64 nvidia-vulkan-icd amd64 384.111-3~bpo9+1 [180 kB]
Descargados 31,6 MB en 1min 8s (462 kB/s)                                                                 
Extrayendo plantillas para los paquetes: 100%
Preconfigurando paquetes ...
Seleccionando el paquete libglvnd0-nvidia:amd64 previamente no seleccionado.
(Leyendo la base de datos ... 230423 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../00-libglvnd0-nvidia_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libglvnd0-nvidia:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libglx0-glvnd-nvidia:amd64 previamente no seleccionado.
Preparando para desempaquetar .../01-libglx0-glvnd-nvidia_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libglx0-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libgl1-glvnd-nvidia-glx:amd64 previamente no seleccionado.
Preparando para desempaquetar .../02-libgl1-glvnd-nvidia-glx_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libgl1-glvnd-nvidia-glx:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libnvidia-glcore:amd64 previamente no seleccionado.
Preparando para desempaquetar .../03-libnvidia-glcore_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libnvidia-glcore:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libglx-nvidia0:amd64 previamente no seleccionado.
Preparando para desempaquetar .../04-libglx-nvidia0_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libglx-nvidia0:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libgl1-nvidia-glvnd-glx:amd64 previamente no seleccionado.
Preparando para desempaquetar .../05-libgl1-nvidia-glvnd-glx_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libgl1-nvidia-glvnd-glx:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-egl-common previamente no seleccionado.
Preparando para desempaquetar .../06-nvidia-egl-common_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-egl-common (384.111-3~bpo9+1) ...
Seleccionando el paquete libegl1-glvnd-nvidia:amd64 previamente no seleccionado.
Preparando para desempaquetar .../07-libegl1-glvnd-nvidia_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libegl1-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libnvidia-eglcore:amd64 previamente no seleccionado.
Preparando para desempaquetar .../08-libnvidia-eglcore_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libnvidia-eglcore:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libegl-nvidia0:amd64 previamente no seleccionado.
Preparando para desempaquetar .../09-libegl-nvidia0_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libegl-nvidia0:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-egl-icd:amd64 previamente no seleccionado.
Preparando para desempaquetar .../10-nvidia-egl-icd_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-egl-icd:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-driver-libs:amd64 previamente no seleccionado.
Preparando para desempaquetar .../11-nvidia-driver-libs_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-driver-libs:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libnvidia-ml1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../12-libnvidia-ml1_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libnvidia-ml1:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-driver-bin previamente no seleccionado.
Preparando para desempaquetar .../13-nvidia-driver-bin_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-driver-bin (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-support previamente no seleccionado.
Preparando para desempaquetar .../14-nvidia-support_20151021+4_amd64.deb ...
Desempaquetando nvidia-support (20151021+4) ...
Seleccionando el paquete xserver-xorg-video-nvidia previamente no seleccionado.
Preparando para desempaquetar .../15-xserver-xorg-video-nvidia_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando xserver-xorg-video-nvidia (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-kernel-common previamente no seleccionado.
Preparando para desempaquetar .../16-nvidia-kernel-common_20151021+4_amd64.deb ...
Desempaquetando nvidia-kernel-common (20151021+4) ...
Seleccionando el paquete nvidia-modprobe previamente no seleccionado.
Preparando para desempaquetar .../17-nvidia-modprobe_384.111-1~bpo9+1_amd64.deb ...
Desempaquetando nvidia-modprobe (384.111-1~bpo9+1) ...
Seleccionando el paquete nvidia-kernel-support previamente no seleccionado.
Preparando para desempaquetar .../18-nvidia-kernel-support_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-kernel-support (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-kernel-dkms previamente no seleccionado.
Preparando para desempaquetar .../19-nvidia-kernel-dkms_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-kernel-dkms (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-driver previamente no seleccionado.
Preparando para desempaquetar .../20-nvidia-driver_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-driver (384.111-3~bpo9+1) ...
Seleccionando el paquete libxnvctrl0:amd64 previamente no seleccionado.
Preparando para desempaquetar .../21-libxnvctrl0_384.111-1~bpo9+1_amd64.deb ...
Desempaquetando libxnvctrl0:amd64 (384.111-1~bpo9+1) ...
Seleccionando el paquete nvidia-settings previamente no seleccionado.
Preparando para desempaquetar .../22-nvidia-settings_384.111-1~bpo9+1_amd64.deb ...
Desempaquetando nvidia-settings (384.111-1~bpo9+1) ...
Seleccionando el paquete libgles1-glvnd-nvidia:amd64 previamente no seleccionado.
Preparando para desempaquetar .../23-libgles1-glvnd-nvidia_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libgles1-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libgles-nvidia1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../24-libgles-nvidia1_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libgles-nvidia1:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libgles2-glvnd-nvidia:amd64 previamente no seleccionado.
Preparando para desempaquetar .../25-libgles2-glvnd-nvidia_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libgles2-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libgles-nvidia2:amd64 previamente no seleccionado.
Preparando para desempaquetar .../26-libgles-nvidia2_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libgles-nvidia2:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libnvidia-cfg1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../27-libnvidia-cfg1_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libnvidia-cfg1:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libnvidia-egl-wayland1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../28-libnvidia-egl-wayland1_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libnvidia-egl-wayland1:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libopengl0-glvnd-nvidia:amd64 previamente no seleccionado.
Preparando para desempaquetar .../29-libopengl0-glvnd-nvidia_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando libopengl0-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete libvulkan1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../30-libvulkan1_1.0.65.2+dfsg1-1~bpo9+1_amd64.deb ...
Desempaquetando libvulkan1:amd64 (1.0.65.2+dfsg1-1~bpo9+1) ...
Seleccionando el paquete nvidia-egl-wayland-common previamente no seleccionado.
Preparando para desempaquetar .../31-nvidia-egl-wayland-common_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-egl-wayland-common (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-egl-wayland-icd:amd64 previamente no seleccionado.
Preparando para desempaquetar .../32-nvidia-egl-wayland-icd_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-egl-wayland-icd:amd64 (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-persistenced previamente no seleccionado.
Preparando para desempaquetar .../33-nvidia-persistenced_384.111-1~bpo9+1_amd64.deb ...
Desempaquetando nvidia-persistenced (384.111-1~bpo9+1) ...
Seleccionando el paquete nvidia-vulkan-common previamente no seleccionado.
Preparando para desempaquetar .../34-nvidia-vulkan-common_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-vulkan-common (384.111-3~bpo9+1) ...
Seleccionando el paquete nvidia-vulkan-icd:amd64 previamente no seleccionado.
Preparando para desempaquetar .../35-nvidia-vulkan-icd_384.111-3~bpo9+1_amd64.deb ...
Desempaquetando nvidia-vulkan-icd:amd64 (384.111-3~bpo9+1) ...
Configurando libvulkan1:amd64 (1.0.65.2+dfsg1-1~bpo9+1) ...
Configurando nvidia-kernel-common (20151021+4) ...
Configurando libnvidia-eglcore:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-support (20151021+4) ...
Procesando disparadores para nvidia-alternative (384.111-3~bpo9+1) ...
update-alternatives: atención: forzando la reinstalación de la alternativa /usr/lib/nvidia/current porque el grupo de enlaces nvidia está roto
Configurando libnvidia-glcore:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-egl-wayland-common (384.111-3~bpo9+1) ...
Configurando libnvidia-egl-wayland1:amd64 (384.111-3~bpo9+1) ...
Configurando libegl-nvidia0:amd64 (384.111-3~bpo9+1) ...
Procesando disparadores para libc-bin (2.24-11+deb9u1) ...
Configurando nvidia-egl-common (384.111-3~bpo9+1) ...
Configurando libnvidia-cfg1:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-modprobe (384.111-1~bpo9+1) ...
Configurando libnvidia-ml1:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-vulkan-common (384.111-3~bpo9+1) ...
Procesando disparadores para man-db (2.7.6.1-2) ...
Configurando libglvnd0-nvidia:amd64 (384.111-3~bpo9+1) ...
Configurando xserver-xorg-video-nvidia (384.111-3~bpo9+1) ...
Configurando nvidia-driver-bin (384.111-3~bpo9+1) ...
Configurando libxnvctrl0:amd64 (384.111-1~bpo9+1) ...
Configurando nvidia-egl-wayland-icd:amd64 (384.111-3~bpo9+1) ...
Configurando libopengl0-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-persistenced (384.111-1~bpo9+1) ...
Configurando libgles2-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Configurando libglx0-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-kernel-support (384.111-3~bpo9+1) ...
Configurando nvidia-settings (384.111-1~bpo9+1) ...
Configurando libegl1-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Configurando libgles-nvidia2:amd64 (384.111-3~bpo9+1) ...
Configurando libgles1-glvnd-nvidia:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-kernel-dkms (384.111-3~bpo9+1) ...
Loading new nvidia-current-384.111 DKMS files...
Building for 4.14.0-0.bpo.3-amd64
Building initial module for 4.14.0-0.bpo.3-amd64
Done.

nvidia-current:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-0.bpo.3-amd64/updates/dkms/

nvidia-current-modeset.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-0.bpo.3-amd64/updates/dkms/

nvidia-current-drm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-0.bpo.3-amd64/updates/dkms/

nvidia-current-uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-0.bpo.3-amd64/updates/dkms/

depmod...

DKMS: install completed.
Configurando libgles-nvidia1:amd64 (384.111-3~bpo9+1) ...
Configurando libgl1-glvnd-nvidia-glx:amd64 (384.111-3~bpo9+1) ...
Configurando libglx-nvidia0:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-vulkan-icd:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-egl-icd:amd64 (384.111-3~bpo9+1) ...
Configurando libgl1-nvidia-glvnd-glx:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-driver-libs:amd64 (384.111-3~bpo9+1) ...
Configurando nvidia-driver (384.111-3~bpo9+1) ...
Procesando disparadores para glx-alternative-nvidia (0.7.4) ...
Procesando disparadores para libc-bin (2.24-11+deb9u1) ...
Procesando disparadores para update-glx (0.7.4) ...
Procesando disparadores para glx-alternative-nvidia (0.7.4) ...
update-alternatives: utilizando /usr/lib/nvidia para proveer /usr/lib/glx (glx) en modo automático
Procesando disparadores para libc-bin (2.24-11+deb9u1) ...
Procesando disparadores para initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.14.0-0.bpo.3-amd64

 

apt-get install bbswitch-dkms bumblebee bumblebee-nvidia

 

sudo apt-get install bbswitch-dkms bumblebee bumblebee-nvidia
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes adicionales:
  primus primus-libs socat
Paquetes recomendados:
  primus-libs-ia32
Se instalarán los siguientes paquetes NUEVOS:
  bbswitch-dkms bumblebee bumblebee-nvidia primus primus-libs socat
0 actualizados, 6 nuevos se instalarán, 0 para eliminar y 0 no actualizados.
Se necesita descargar 481 kB de archivos.
Se utilizarán 1.595 kB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n] s
Des:1 http://deb.debian.org/debian stretch/main amd64 bbswitch-dkms amd64 0.8-4 [12,3 kB]
Des:2 http://deb.debian.org/debian stretch/main amd64 bumblebee amd64 3.2.1-14 [49,7 kB]
Des:3 http://deb.debian.org/debian stretch/contrib amd64 bumblebee-nvidia amd64 3.2.1-14 [5.146 B]
Des:4 http://deb.debian.org/debian stretch/main amd64 socat amd64 1.7.3.1-2+deb9u1 [353 kB]
Des:5 http://deb.debian.org/debian stretch/main amd64 primus-libs amd64 0~20150328-4 [49,3 kB]
Des:6 http://deb.debian.org/debian stretch/main amd64 primus amd64 0~20150328-4 [11,0 kB]
Descargados 481 kB en 1s (336 kB/s)
Seleccionando el paquete bbswitch-dkms previamente no seleccionado.
(Leyendo la base de datos ... 231124 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../0-bbswitch-dkms_0.8-4_amd64.deb ...
Desempaquetando bbswitch-dkms (0.8-4) ...
Seleccionando el paquete bumblebee previamente no seleccionado.
Preparando para desempaquetar .../1-bumblebee_3.2.1-14_amd64.deb ...
Desempaquetando bumblebee (3.2.1-14) ...
Seleccionando el paquete bumblebee-nvidia previamente no seleccionado.
Preparando para desempaquetar .../2-bumblebee-nvidia_3.2.1-14_amd64.deb ...
Desempaquetando bumblebee-nvidia (3.2.1-14) ...
Seleccionando el paquete socat previamente no seleccionado.
Preparando para desempaquetar .../3-socat_1.7.3.1-2+deb9u1_amd64.deb ...
Desempaquetando socat (1.7.3.1-2+deb9u1) ...
Seleccionando el paquete primus-libs:amd64 previamente no seleccionado.
Preparando para desempaquetar .../4-primus-libs_0~20150328-4_amd64.deb ...
Desempaquetando primus-libs:amd64 (0~20150328-4) ...
Seleccionando el paquete primus previamente no seleccionado.
Preparando para desempaquetar .../5-primus_0~20150328-4_amd64.deb ...
Desempaquetando primus (0~20150328-4) ...
Configurando socat (1.7.3.1-2+deb9u1) ...
Configurando primus-libs:amd64 (0~20150328-4) ...
Procesando disparadores para initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.14.0-0.bpo.3-amd64
Procesando disparadores para systemd (236-3~bpo9+1) ...
Procesando disparadores para man-db (2.7.6.1-2) ...
Configurando bbswitch-dkms (0.8-4) ...
Loading new bbswitch-0.8 DKMS files...
Building for 4.14.0-0.bpo.3-amd64
Building initial module for 4.14.0-0.bpo.3-amd64
Done.

bbswitch:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.14.0-0.bpo.3-amd64/updates/dkms/

depmod...

DKMS: install completed.
Configurando bumblebee (3.2.1-14) ...
Adding members from group(s) 'adm sudo admin' to 'bumblebee':

Created symlink /etc/systemd/system/graphical.target.wants/bumblebeed.service → /lib/systemd/system/bumblebeed.service.
Procesando disparadores para initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.14.0-0.bpo.3-amd64
Configurando bumblebee-nvidia (3.2.1-14) ...
update-alternatives: utilizando /usr/lib/nvidia/bumblebee para proveer /usr/lib/glx (glx) en modo manual
Configurando primus (0~20150328-4) ...
Procesando disparadores para systemd (236-3~bpo9+1) ...
Procesando disparadores para glx-alternative-nvidia (0.7.4) ...
Procesando disparadores para update-glx (0.7.4) ...
Procesando disparadores para glx-alternative-nvidia (0.7.4) ...
Procesando disparadores para libc-bin (2.24-11+deb9u1) ...
Procesando disparadores para initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.14.0-0.bpo.3-amd64
Procesando disparadores para bumblebee (3.2.1-14) ...

 

Vie, 09/02/2018 - 11:50
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

ok, por lo que veo ahi, ha funcionado todo correctamente, ahora faltaría la configuración para dejar la cosa algo más fina

Por mi experiencia, como ya he dicho antes, la configuración posterior

~s su
~# echo -e "options i915 modeset=1 semaphores=1 enable_rc6=7 enable_dc=2 enable_fbc=1" > /etc/modprobe.d/i915.conf
~# echo -e "options bbswitch load_state=0 unload_state=0" > /etc/modprobe.d/bbswitch.conf
~# update-initramfs -u -k all
~# exit

después de eso, configurar lo que te dije en /etc/bumblebee/bumblebee.conf para que el driver a usar sea nvidia, poner en false mantener la gpu encendida al acabar de usarla y poner el false mantener el servidor X al acabar de usarlo, busca en ese archivo las siguientes líneas y asegúrate de que están como estas:

KeepUnusedXServer=false
TurnCardOffAtExit=true
Driver=nvidia
Bridge=auto

Luego, asegúrate de que no existe ningún archivo en /etc/X11/xorg.conf.d/ que haga referencia al driver de intel (o incluso al de nvidia). Si existen, los renombras para que acaben en .conf.bak

Con esto, deberías tener el sistema preparado para que funcione correctamente, solo queda reiniciar y comprobar que funciona.

  No hay bar que por bien no venga....
Vie, 09/02/2018 - 15:27 (Responder a #36)
jlopezjuy
Imagen de jlopezjuy
Desconectado/a
se unió: 31/01/18

OK, pruebo en unos minutos todo esto

Vie, 09/02/2018 - 18:50
jlopezjuy
Imagen de jlopezjuy
Desconectado/a
se unió: 31/01/18

 

 

 

Sigo sin pasar del login, hice lo que me dijeron y nada. mmmmm algo mas pasa

Sáb, 10/02/2018 - 07:47
debiatonix
Imagen de debiatonix
Desconectado/a
se unió: 07/01/18

Prueba de eliminar el archivo xorg.conf que esta en la carpeta /etc/X11/, si no te funciona siempre puedes volver a generarlo.wink

Pon una debian en tu vidayes

Sáb, 10/02/2018 - 10:21
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

vaya, no tienes log persistente....

pues entonces, cambia el comando por journalctl -b -p err, que ese si saldrá

pero es raro, muy raro....

si no funcionara, no te aparecería la pantalla de login, asi que el problema viene de  otro lado...

si por el contrario, te quedas en pantalla negra, alguna config intenta usar la nvidia creo, mira lo de los xorg.conf y lo  que haya en /etc/xorg.conf.d/

 

  No hay bar que por bien no venga....
Dom, 18/02/2018 - 18:07
jlopezjuy
Imagen de jlopezjuy
Desconectado/a
se unió: 31/01/18

Bueno, de tanto renegar, logre instalar todo, y quedo instalado y pude pasar del login, no se que sera, lo probe 3 veces instalando desde cero. pero paso al login. 

Pero al intentar: optirun glxspheres

jlopez@mostro-rog:~$ optirun glxspheres
[  250.824214] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[  250.824290] [ERROR]Aborting because fallback start is disabled.
jlopez@mostro-rog:~$ sudo optirun glxspheres
[sudo] password for jlopez: 
[  259.768186] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[  259.768235] [ERROR]Aborting because fallback start is disabled.

 

sudo primusrun glxgears -info
/usr/bin/primusrun: línea 41: aviso: command substitution: ignored null byte in input
primus: fatal: Bumblebee daemon reported: error: Could not load GPU driver
jlopez@mostro-rog:~$ sudo systemctl restart bumblebeed.service
jlopez@mostro-rog:~$ sudo systemctl status bumblebeed.service
● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/lib/systemd/system/bumblebeed.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2018-02-18 18:40:55 -03; 5s ago
 Main PID: 1754 (bumblebeed)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/bumblebeed.service
           └─1754 /usr/sbin/bumblebeed

feb 18 18:40:55 mostro-rog systemd[1]: Started Bumblebee C Daemon.
feb 18 18:40:55 mostro-rog bumblebeed[1754]: [  171.186537] [ERROR]Module 'bbswitch' not found.
feb 18 18:40:55 mostro-rog bumblebeed[1754]: [  171.186547] [WARN]No switching method available. The 
feb 18 18:40:55 mostro-rog bumblebeed[1754]: [  171.186793] [INFO]/usr/sbin/bumblebeed 3.2.1 started
 ESCOC

























service; enabled; vendor preset: enabled)
8:40:55 -03; 5s ago





blebee C Daemon.
1.186537] [ERROR]Module 'bbswitch' not found.
1.186547] [WARN]No switching method available. The dedicated card will always be on.
1.186793] [INFO]/usr/sbin/bumblebeed 3.2.1 started
~
~
~
~
~
~
~
~
~
~
~