Dual boot - no funciona correctamente el Grub

3 envíos / 0 nuevos
Último envío
#1 Mar, 24/08/2021 - 18:50
Antipani
Imagen de Antipani
Desconectado/a
se unió: 16/07/16

Dual boot - no funciona correctamente el Grub

Estado: 
[CERRADO]

Estimados, buenas tardes.

Realice la instilación de debian 11 desde cero, dividí las particiones en / , /home , /var , /tmp y me hizo una esp (que tengo entendido que es para el grup). Yo tenia ya instalado windows en otro disco, el cual tiene la particion uefi y otra de sistema. Ahora tengo dos particiones UEFI/EFI. 

Tengo dos disco, uno con windows, es un ssd y el otro de 1tb dividido en 500gb datos (windows) y en la otra están las particiones de debian.  

El problema que tengo es que cuando inicio la pc, entra al grub, elijo windows y me sale el cartel de:

error: no such divice: 78ce-ffd1.

error: disco <<hd0,gpt1>> no encontrado.

entonces, lo que hice es entrar a debian, y con el grub customizer, instale de nuevo el grub en la particion sda, donde es el disco que bootea mi pc primero. Reinicio y entra a windows bien, estoy feliz genial lo solucione. Apago la pc y la dejo por lo menos 1h y la vuelvo a encender y el error vuelve a suceder, el mismo. Entonces reinicio la pc y aprieto f12 y pongo que se inicie con el sda/ssd y entra de una a windows sin pasar por el grub. 

si repido lo de instalar el grub, funciona pero igual que antes si la apago la pc me sale el mismo error. 

¿Cual podria ser el problema?¿el problema es que tengo esas particiones efi y esp en distintos discos? 

Dejo la informacion de mis discos y parciones.

Disco 1t

/dev/sdb2      ext4        23G    15G  6,8G  69% /
/dev/sdb5      ext4       1,8G    19M  1,7G   2% /tmp
/dev/sdb1      vfat       511M   3,5M  508M   1% /boot/efi
/dev/sdb3      ext4       9,1G   2,8G  5,9G  32% /var
/dev/sdb6      ext4       342G    33G  293G  10% /home
 

NAME   FSTYPE FSVER LABEL       UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda                                                                                 
├─sda1 vfat   FAT32             78CE-FFD1                                           
├─sda2                                                                              
├─sda3 ntfs                     BA5EF2535EF207C1                                    
└─sda4 ntfs                     A65E500F5E4FD6A9                                    
sdb                                                                                 
├─sdb1 vfat   FAT32             6F6B-903C                             507,6M     1% /boot/efi
├─sdb2 ext4   1.0               083f77f8-5aa2-4183-8481-6d6903230e79    6,8G    65% /
├─sdb3 ext4   1.0               a9a6b075-e3e6-4503-82fc-e9b4f260db8e    5,8G    30% /var
├─sdb4 swap   1                 d32bd6c8-0adf-4791-ab35-5f7fe721cf65                [SWAP]
├─sdb5 ext4   1.0               4f304700-9c48-4f7e-8c2d-5f612473761f    1,7G     1% /tmp
├─sdb6 ext4   1.0               d108b0b6-8c6a-4d52-81cc-218116456450  292,2G     9% /home
└─sdb7 ntfs         juegos      01D5FF078052C660    

 

/dev/sda1: UUID="78CE-FFD1" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="f98f4945-a2b5-426d-befd-e9db1dbe5bf8"
/dev/sda3: BLOCK_SIZE="512" UUID="BA5EF2535EF207C1" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="bcbad2f4-aca9-4fb3-a6ba-bcf9c8fd99ca"
/dev/sda4: BLOCK_SIZE="512" UUID="A65E500F5E4FD6A9" TYPE="ntfs" PARTUUID="023dff03-2fd9-4844-9ac7-262345de834c"

/dev/sdb1: UUID="6F6B-903C" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="0904444b-8a7f-4f77-9a24-c29662bd7014"
/dev/sdb2: UUID="083f77f8-5aa2-4183-8481-6d6903230e79" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="59620dc8-7978-4a27-952e-fd53a19a7396"
/dev/sdb3: UUID="a9a6b075-e3e6-4503-82fc-e9b4f260db8e" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="6e35c83c-3e78-4bca-a785-9cd7dcdd69f5"
/dev/sdb4: UUID="d32bd6c8-0adf-4791-ab35-5f7fe721cf65" TYPE="swap" PARTUUID="2b8f623e-e0f7-4f40-bb9c-7b6ad762e011"
/dev/sdb5: UUID="4f304700-9c48-4f7e-8c2d-5f612473761f" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="bec52537-94d1-4c93-96c0-4a9be2b49a7b"
/dev/sdb6: UUID="d108b0b6-8c6a-4d52-81cc-218116456450" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="54df392e-caa7-4dfa-b1fe-c026b19be338"
/dev/sdb7: LABEL="juegos" BLOCK_SIZE="512" UUID="01D5FF078052C660" TYPE="ntfs" PARTLABEL="Test Partition" PARTUUID="d249e286-2710-0000-bfc1-806e6f6e6963"

/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="71b1e2bd-06d7-402d-80ec-51ec83dd491b"
 

Disco /dev/sda: 223,57 GiB, 240057409536 bytes, 468862128 sectores
Modelo de disco: KINGSTON SV300S3
Unidades: sectores de 1 * 512 = 512 bytes
Tamaño de sector (lógico/físico): 512 bytes / 512 bytes
Tamaño de E/S (mínimo/óptimo): 512 bytes / 512 bytes
Tipo de etiqueta de disco: gpt
Identificador del disco: 7F9E2378-97BE-43D9-9462-F697DCF0548D

Disposit.   Comienzo     Final  Sectores Tamaño Tipo
/dev/sda1       2048    206847    204800   100M Sistema EFI
/dev/sda2     206848    239615     32768    16M Reservado para Microsoft
/dev/sda3     239616 467797258 467557643 222,9G Datos básicos de Microsoft
/dev/sda4  467798016 468858879   1060864   518M Entorno de recuperación de Windows
 

isco /dev/sdb: 931,51 GiB, 1000204886016 bytes, 1953525168 sectores
Modelo de disco: WDC WD10EZEX-00B
Unidades: sectores de 1 * 512 = 512 bytes
Tamaño de sector (lógico/físico): 512 bytes / 4096 bytes
Tamaño de E/S (mínimo/óptimo): 4096 bytes / 4096 bytes
Tipo de etiqueta de disco: gpt
Identificador del disco: D248D116-2710-0000-BFC1-806E6F6E6963

Disposit.   Comienzo      Final   Sectores Tamaño Tipo
/dev/sdb1       2048    1050623    1048576   512M Sistema EFI
/dev/sdb2    1050624   49879039   48828416  23,3G Sistema de ficheros de Linux
/dev/sdb3   49879040   69410815   19531776   9,3G Sistema de ficheros de Linux
/dev/sdb4   69410816   71411711    2000896   977M Linux swap
/dev/sdb5   71411712   75317247    3905536   1,9G Sistema de ficheros de Linux
/dev/sdb6   75317248  806076415  730759168 348,5G Sistema de ficheros de Linux
/dev/sdb7  806076416 1953523711 1147447296 547,1G Datos básicos de Microsoft
 

 

Mié, 25/08/2021 - 13:56
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

pues... no me huele a fallo de grub.... dice que no encuentra el dispositivo 78CE-FFD1, el disco hd0, particion1, que se supone es donde está el arranque. Más bien suena a que cuando ha iniciado grub no ha iniciado todavía ese disco, o el sistema te los cambia de orden a su antojo.

 

  No hay bar que por bien no venga....
Jue, 16/09/2021 - 21:01
Antipani
Imagen de Antipani
Desconectado/a
se unió: 16/07/16

buenas.

Pude solucionar el problema, lo que pasa es que el bios no elegia bien el disco para hacer el booteo. 

lo único que hice fue poner que inicie desde el disco sdd y reinstale el grub en ese disco y empezó a funcionar correctamente. 

 

LIBRE