Error al instalar Piper

7 envíos / 0 nuevos
Último envío
#1 Mar, 15/06/2021 - 18:00
Antipani
Imagen de Antipani
Desconectado/a
se unió: 16/07/16

Error al instalar Piper

Estado: 
[SOLUCIONADO]

 

Hola estoy intentado instalar Piper para poder configurar mi mouse logitec G300s. 

Lo que necesito es configurar DPI, botones, ect. Pero me esta saliendo un error con ratbagd, el cual intento instalar pero me sale un error que no se como solucionar.

root@usuario:/home/usuario# apt-get install ratbagd
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 ratbagd : Depende: libsystemd0 (>= 243) pero 241-7~deb10u7 va a ser instalado
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

Me podrían decir como tengo que instalar esa dependencia para poder usarlo. Busque en github de piper y no encontre solucion.  

Mar, 15/06/2021 - 18:10
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Intenta 

apt install -f

 

Mar, 15/06/2021 - 18:24
Antipani
Imagen de Antipani
Desconectado/a
se unió: 16/07/16

lo intente y me salio lo siguiente:

 

root@usuario:/home/usuario# apt install -f
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 0 no actualizados.

root@usuario:/home/usuario# apt-get install ratbagd
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 ratbagd : Depende: libsystemd0 (>= 243) pero 241-7~deb10u7 va a ser instalado
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
 

intente con aptitude y me sale:

root@usuario:/home/usuario# aptitude install ratbagd
Se instalarán los siguiente paquetes NUEVOS:      
  python3-evdev{a} ratbagd{b} 
0 paquetes actualizados, 2 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 143 kB de ficheros. Después de desempaquetar se usarán 591 kB.
No se satisfacen las dependencias de los siguientes paquetes:
 ratbagd : Depende: libsystemd0 (>= 243) but 241-7~deb10u7 is installed
Las acciones siguientes resolverán estas dependencias

     Mantener los paquetes siguientes en la versión actual:
1)     ratbagd [Sin instalar]                              

¿Acepta esta solución? [Y/n/q/?]y
No se instalará, actualizará o eliminará ningún paquete.
0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 0 B de ficheros. Después de desempaquetar se usarán 0 B.
                                                  
root@usuario:/home/usuario# aptitude install python3-evdev{a}
No se puede encontrar ningún paquete cuyo nombre o descripción coincida con "python3-evdev{a}"
Unable to apply some actions, aborting
 

LIBRE

Mar, 15/06/2021 - 18:33
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

el paquete es   'python3-evdev '

Vamos al inicio ,¿que version de debian tenes instalada ?  actualizaste el sistema ? ¿como ?

Mar, 15/06/2021 - 18:40
Antipani
Imagen de Antipani
Desconectado/a
se unió: 16/07/16

en info de sistema puse la version de debian. Si esta actualizado. 

Lo actualizo con aptitude. 

Comando: lsb_release -a: 

No LSB modules are available.
Distributor ID:    Debian
Description:    Debian GNU/Linux 10 (buster)
Release:    10
Codename:    buster

 

mi sources.list

 

# deb cdrom:[Official Debian GNU/Linux Live 10.6.0 xfce 2020-09-26T13:15]/ buster main

# deb cdrom:[Official Debian GNU/Linux Live 10.6.0 xfce 2020-09-26T13:15]/ buster main

deb http://deb.debian.org/debian/ buster main non-free contrib
deb-src http://deb.debian.org/debian/ buster main non-free contrib

deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb-src http://security.debian.org/debian-security buster/updates main contrib non-free

# buster-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free

# buster-debian-multimedia
deb http://www.deb-multimedia.org buster main non-free

# Repositorio backports de Stable

deb http://ftp.es.debian.org/debian buster-backports main contrib non-free
deb-src http://ftp.es.debian.org/debian buster-backports main contrib non-free
 

LIBRE

Mar, 15/06/2021 - 18:58
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Fujate que te dice  

Depende: libsystemd0 (>= 243) pero 241-7~deb10u7 va a ser instalado

Una version mas actualizada de dicho paquete esta en los backports de buster,, instalalo desde ahi 

 

Mar, 15/06/2021 - 20:05
Antipani
Imagen de Antipani
Desconectado/a
se unió: 16/07/16

si pude instalar: 

aptitude install ratbagd
 

cuando me pidió:

 

     Mantener los paquetes siguientes en la versión actual:
1)     ratbagd [Sin instalar]                              

¿Acepta esta solución? [Y/n/q/?] n

 

puse no y me mostro lo que necesitaba instalar desde backports de buster y después reinicie la pc y esta andando. 

Muchas gracias. 

LIBRE