Error en comando apt-get update

5 envíos / 0 nuevos
Último envío
#1 Jue, 29/12/2016 - 21:38
nomade
Imagen de nomade
Desconectado/a
se unió: 27/12/16

Error en comando apt-get update

Estado: 
[SOLUCIONADO]

Hola, al utilizar el comando apt-get update, en medio de las descargas se interrumpe con este mensaje

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

W: Fallo al obtener cdrom://[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 CD Binary-1 20160917-14:25]/dists/jessie/main/binary-i386/Packages  Utilice «apt-cdrom» para hacer que APT reconozca este CD. No puede utilizar «apt-get update» para añadir nuevos CDs

E: No se han podido descargar algunos archivos de índice, se han omitido, o se han utilizado unos antiguos en su lugar.
E: No se pudo bloquear /var/lib/dpkg/lock - open (11: Recurso no disponible temporalmente)
E: No se pudo bloquear el directorio de administración (/var/lib/dpkg/), ¿quizás haya algún otro proceso utilizándolo?

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

el archivo Sources.list lo tengo de la siguiente forma

#

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 CD Binary-1 20160917-14:25]/ jessie main

deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 CD Binary-1 20160917-14:25]/ jessie main

deb http://ftp.ccc.uba.ar/pub/linux/debian/debian/ jessie main contrib non-free
deb-src http://ftp.ccc.uba.ar/pub/linux/debian/debian/ jessie main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

# jessie-updates, previously known as 'volatile'
deb http://ftp.ccc.uba.ar/pub/linux/debian/debian/ jessie-updates main contrib non-free
deb-src http://ftp.ccc.uba.ar/pub/linux/debian/debian/ jessie-updates main contrib non-free

# Debian 8 "Jessie"
deb http://httpredir.debian.org/debian/ jessie main contrib non-free

Modifique un par de veces el archivo, pero no toque las primeras lineas.

Saliduos.

 

 

Jue, 29/12/2016 - 22:22
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

sobre la advertencia "W: Fallo al obtener cdrom://[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 CD Binary-1 20160917-14:25]/dists/jessie/main/binary-i386/Packages  Utilice «apt-cdrom» para hacer que APT reconozca este CD. No puede utilizar «apt-get update» para añadir nuevos CDs"

tenes que editar tu sources.list y poner # al texto asi

#deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 CD Binary-1 20160917-14:25]/ jessie main

sobre el error "E: No se pudo bloquear /var/lib/dpkg/lock - open (11: Recurso no disponible temporalmente)"

puede ser por 2 motivos:

1- no estes actualizando con permisos de root, la forma correcta seria:

su
apt-get update && apt-get upgrade && apt-get dist-upgrade && apt-get autoclean

2 otro programa este buscando actualizaciones, por ejemplo si tenes gnome, podrías llegar a tener instalado el programa software & updates y configurado para que busque actualizaciones en forma automática y justo estes usando apt ni bien se inicie la sesión

saludos...

Vie, 30/12/2016 - 20:04
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

Además de los que te comenta rockyiii, échale un vistazo a http://exdebian.org/wiki/introducción-los-repositorios-de-debian te ayudara a resolver ese problema y tener nociones de como cambiar de repositorio para actualizar a nueva versión.

 

 

edito: se corrige link, gracias por la informarme.

 Saludos

 

Vie, 30/12/2016 - 06:43 (Responder a #3)
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

gacs wrote:

Además de los que te comenta rockyiii, échale un vistazo a http://http://exdebian.org/wiki/introducci%C3%B3n-los-repositorios-de-debian te ayudara a resolver ese problema y tener nociones de como cambiar de repositorio para actualizar a nueva versión.

 

Off topic:

gacs, edita ese enlace. Me manda a una página extraña. el enlace correcto es:

http://exdebian.org/wiki/introducción-los-repositorios-de-debian

Edito: parece ser que es error de insertar vínculos. Al copiar y pegar se mete esto %C3%B3 dentro del enlace.

We were but stones. Your light made us stars

https://linuxveredas.blogspot.com.es/

Mar, 03/01/2017 - 10:58 (Responder a #4)
nomade
Imagen de nomade
Desconectado/a
se unió: 27/12/16

Gracias a todos, ya lo solucione.. segui los pasos que me indico rockyiii. Saludos