Firefox: La dirección no fue comprendida

8 envíos / 0 nuevos
Último envío
#1 Dom, 25/06/2017 - 21:45
PabliNet
Imagen de PabliNet
Desconectado/a
se unió: 28/10/16

Firefox: La dirección no fue comprendida

Tengo el problema que Firefox no me reconoce el protocolo tg de Telegram,

Intenté en about:config añadir el protocolo manualmente siguiendo las siguientes instrucciones y el nombre de la variable me quedaría: network.protocol-handler.app.tg

También intenté creando una variable booleana con el nombre network.protocol-handler.expose.tg y poniéndola en false para que me pregunte con qué aplicación abrir este tipo de URL.

Siempre llego a:

La dirección no fue comprendida


Firefox no sabe como abrir esta dirección, porque uno de los siguientes protocolos (tg) no está asociado con ningún programa o no está permitido en este contexto.

  • Necesita instalar otro software para abrir esta dirección.

[Intente nuevamente]

Dom, 25/06/2017 - 23:31
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

firefox 52 de debian 9 me dio bastantes problemas, si bien no es lo ideal podrias fijarte si con firefox 53 de testing te lo reconoce 

Lun, 26/06/2017 - 00:50
PabliNet
Imagen de PabliNet
Desconectado/a
se unió: 28/10/16

Me olvidé de aclarar que, cuando tenía Plasma 5, ya había intentado con Firefox 53 y 54 desde experimental.

Lun, 26/06/2017 - 05:29
shicefgo
Imagen de shicefgo
Desconectado/a
se unió: 28/03/16

Hola.

Tal vez quieras intentarlo como dicen en http://kb.mozillazine.org/Register_protocol, aunque está en inglés. Básicamente consiste en "activar" el protocolo, e indicar donde está la aplicación con la que deben abrirse los archivos; copio, pego y medio traduzco smiley

Todas las versiones de Firefox

(Requiere que ciertas bibliotecas de gnome estén instaladas)

En un terminal, teclee:

gconftool-2 -s /desktop/gnome/url-handlers/foo/command '/path/to/app %s' --type String gconftool-2 -s /desktop/gnome/url-handlers/foo/enabled --type Boolean true

Reemplace foo en ambas lineas con el protocolo que quiere registrar y /path/to/app con la ruta a la aplicación que quiere que se ejecute.

En el apartado "versiones de Firefox superiores a 3.0" explican como hacerlo directamente en el navegador con  about:config.

También puede que tengan algo que ver los tipos mime. En mi testing, el archivo en cuestión es:

~/.mozilla/firefox/9sdef8ih.default/mimeTypes.rdf

Borrando (o poniéndola en la papelera por si acaso) la carpeta ~/.mozilla la siguiente vez que se inicie firefox se debería volver a crear. Tal vez sea conveniente tenerlo en cuenta (lo de los tipos mime), como otra cosa a probar por si una vez añadido el protocolo continúa sin funcionar.

Un saludo.

Edito:

Casi me olvido. Ten cuidado con la carpeta ~/.mozilla, porque ahí dentro se guardan los marcadores. Ponlos a salvo si es que vas a borrarla.

Lun, 26/06/2017 - 07:43
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

el parámetro que has puesto en false, ponlo en true. Si aun asi siguiera sin funcionarte, vete a las opciones, aplicaciones, y busca ahi lo referente a telegram y desde ahí lo configuras para que te pregunte o use telegram.

Por cierto, te falta una variable más, son tres las necesarias para que un protocolo funcione correctamente, en concreto, debería ser algo como:

network.protocol-handler.app.tg           /ruta/a/la/aplicación
network.protocol-handler.expose.tg        false (o true si quieres que pregunte)
network.protocol-handler.external.tg      true (creo que indica que se gestiona por una pp externa)

 

  No hay bar que por bien no venga....
Lun, 26/06/2017 - 08:33
shicefgo
Imagen de shicefgo
Desconectado/a
se unió: 28/03/16

Bueno, cierto que son tres, pero asumo que

network.protocol-handler.expose-all = true

Que se supone es su valor por defecto.

Lun, 26/06/2017 - 16:04
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

eso es mucho asumir, ya que ese valor no afecta al que he puesto que te faltaba... si quieres que funcione, pon esos tres valores... y fíjate también en lo que te han dicho de los mimetypes (asociaciones de archivos/aplicaciones por defecto) a ver si te apareciera allí algo de tg.

  No hay bar que por bien no venga....
Mar, 04/07/2017 - 00:19
PabliNet
Imagen de PabliNet
Desconectado/a
se unió: 28/10/16

Pues, probé todas soluciones que me dijeron y ninguna funcionó, volví a intentar y se solucionó solo.

Si bien el problema está solucionado, no llegué a una solución a la que yo pueda explicar. Por eso no le pongo "[solucionado]".

Una cosa que sugiero, por si alguien le vuelve a suceder, que cuando intente escribiendo la dirección lo haga incluyendo el protocolo https://.