Firefox + SSD me bloquea el sistema

4 envíos / 0 nuevos
Último envío
#1 Mié, 18/11/2020 - 07:02
Vctrsnts
Imagen de Vctrsnts
Desconectado/a
se unió: 15/03/16

Firefox + SSD me bloquea el sistema

Estado: 
[ACTIVO]

Buenas,

Actualmente tengo un portatil con un SSD de 256Gb ( Samsung ) que tiene instalado Debian SID y todo va fenomenal, pero tengo problemas a la hora de usar Firefox ( version 82.0.3 ).

Cuando tengo unas cuantas pestañas abiertas ( a veces más 10 ) el sistema se bloquea, se pone a escribir a disco como un loco ( un SSD ) y tengo que reiniciar el sistema, porque no responde.

El otro dia me paso lo mismo, solamente con 6 pestañas , y pude hacer un top y vi que el proceso "web content" estaba consumiendo un monton de recursos y que habia tantos "web contents" como pestañas abiertas tenia. Es normal??

Lo comento, porque anteriormente con el disco duro "mecanico" este comportamiento no lo tenia.

Alguien le ha pasado?? Donde puede estar el problema, porque no se por donde tirar.

Muchas gracias

Mié, 18/11/2020 - 09:13
NerveNet
Imagen de NerveNet
Desconectado/a
colaborador
se unió: 14/03/16

Me ha pasado con discos SSD muy viejos que no soportan TRIM. El efecto es como el que describes. Se puede ver en top donde el valor de wa (wait) se sube a las nubes.

Soporta tu SSD el comando fstrim?

Cuanto espacio libre tienes en el SSD?

A un clic de distancia de ti...

Mié, 18/11/2020 - 12:32 (Responder a #2)
Vctrsnts
Imagen de Vctrsnts
Desconectado/a
se unió: 15/03/16

NerveNet wrote:

Me ha pasado con discos SSD muy viejos que no soportan TRIM. El efecto es como el que describes. Se puede ver en top donde el valor de wa (wait) se sube a las nubes.

Soporta tu SSD el comando fstrim?

Cuanto espacio libre tienes en el SSD?

Buenas.

El SSD es nuevo, un Samsung EVO 870 de 256Gb, asi que lo tendria que soportar.

Si que soporta el comando fstrim, porque lo acabo de provar "a pelo" y me dice que le indique en punto de montaje especifico.

Con respecto a espacio libre te pongo mi particionado, para que veas como esta la cosa :

/ --> 40Gb
/home --> 186Gb
/tmp --> tmpfs --> 2Gb
/var/spool --> tmpfs --> 1Gb
/var/tmp --> tmpfs --> 1Gb
/home/usuario/.cache/chromium --> cache-chromium --> 1Gb

Asi mismo, que a lo mejor no tiene que ver, pero habia una recomendación para los SSD y firefox que es con respecto a la cache. Que no venga por aqui, la modificación era la siguiente :

Escribir about:config en la barra de navegacion.
Buscar el campo browser.cache.disk.enable y ponerle como valor false
Busca el campo browser.cache.memory.enable y ponerle como valor true
Busca el campo browser.cache.memory.max_entry_size y darle el valor en KB que querías asignarles como máximo. Para los que no tengais problemas de RAM poned -1

De nuevo, gracias por todo

Vie, 20/11/2020 - 08:15 (Responder a #3)
debianspirit
Imagen de debianspirit
Conectado
se unió: 16/07/19

Yo he resuelto eso pero como soy muy novato me es algo difícil poder explicartelo. Te lo explico como mas o menos lo recuerdo, ok.
1. En la instalación de Debian dividí según los paremetros de instalación, ya sabes, /home, /tmp /var.....
2. Instalé zram

Creo que eso fue todo. Es posible que haya hecho más cosas, pero hace tiempo que lo hice y como funcionó bien, pues nada.