Instalacion scanner canon pixma G2100 no detectada

1 envío / 0 nuevos
#1 Lun, 16/11/2020 - 22:28
DragonNegro
Imagen de DragonNegro
Desconectado/a
se unió: 23/02/16

Instalacion scanner canon pixma G2100 no detectada

Estado: 
[ACTIVO]

Buenas tardes a todos,

Estuve tratando de configurar un scanner Canon pixma G2100 pero no fue posible intente todo lo que decían en los foros y hasta en la página oficial de Debian pero no fue posible que hiciera funcionar el scanner, lo que hice fue lo siguiente:

Revise que los drivers estuvieran soportados y estos se encontraban

Luego intente configurar los archivos de reglas de los dispositivos usb como decía en los foros, el archivo genesys.conf y no funcionó, también realice los pasos que se encontraban en el foro configurar libsane para que detecte scanner Canon Lide 120 de exDebian con los drivers dados por mi distribución de Debian Buster pero no lo reconocen las aplicaciones xsane o simple scan entre otras. El que si logra reconocerlo es el programa VueScan ejecutándolo con root.

El comando sane-find-scanner reconoce el dispositivos así:

found USB scanner (vendor=0x04a9 [Canon], product=0x1795 [G2000 series]) at libusb:003:006

Pero cuando intento con el comando scanimage -L no lo reconoce:

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Configure archivos que encontré en los diferentes foros con la información que me da el comando lsusb los archivos son:
/etc/sane.d/canon_dr.conf

# PIXMA-G2100
usb 0x04a9 0x1795

/etc/sane.d/G2000.conf

SUBSYSTEMS=="usb", ATTR{idVendor}=="04a9", ATTR{idProduct}=="1795", MODE="0666"
usb 0x04a9 0x1795

/lib/udev/rules.d/60-libsane.rules

#Canon G2100
SUBSYSTEMS=="usb", ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="1795", MODE="0666", GROUP="scanner", ENV{libsane_matched}="yes"
ENV{libsane_matched}=="yes", RUN+="/bin/setfacl -m g:scanner:rw $env{DEVNAME}"

Ustedes podrían darme alguna sugerencia de cómo seguir adelante? eso para mi sería de utilidad muchas gracias.

Saludos