no me funcionan comandos de compilación

10 envíos / 0 nuevos
Último envío
#1 Vie, 28/07/2017 - 00:12
zatarra
Imagen de zatarra
Desconectado/a
se unió: 20/07/17

no me funcionan comandos de compilación

Estado: 
[SOLUCIONADO]

Buenas querido foro no me funcionan los comandos de compilación como el./configure y el make, simplemente el mensaje que me devuelve es no existe fichero o directorio, que paquete debería instalar para solucionarlo?, desde ya muchisimas gracias.

Vie, 28/07/2017 - 03:12
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

¿tienes instalado build-essential y module-assistant?

Tambien puedes mirar aqui:

https://wiki.debian.org/es/BuildingTutorial

We were but stones. Your light made us stars

https://linuxveredas.blogspot.com.es/

Vie, 28/07/2017 - 13:31
zatarra
Imagen de zatarra
Desconectado/a
se unió: 20/07/17

bueno ese articulo que me pasaste era justo lo que tenía en mente me bajé muchos paquetes de compilación para c++ que suelen ser necesarios pero por alguna razón sigue sin reconocer los comandos para compilar paquetes, yo creería que la bronca viene por algo de la variable PATH que está faltando, nunca tve tantos problemas con un sistema recién instalado como esta vez que no tenía ni un repositorio configurado por ejemplo y varias cosas más que se solucionan fácil.

Vie, 28/07/2017 - 14:02
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

Podrías copiar lo que te pone en la terminal al tratar de compilar?

Asumo que el programa esta hecho en c++ ¿Podrias darnos el nombre del programa y de ser posible la url de donde lo descargaste?
y también no estaría de mas si comentaras o muestres el tutorial del procedimiento que haces para compilar
tenes instalado el paquete make???

Vie, 28/07/2017 - 15:14
zatarra
Imagen de zatarra
Desconectado/a
se unió: 20/07/17

todo esto viene a que yo quiero instalar el driver para mi placa de red, lo que me pone la terminal cuando descomprimo el paquete tar.gz y ejecuto el ./configure me sale:

bash: ./configure: No existe el fichero o el directorio.

lo bajé de https://wireless.wiki.kernel.org/en/users/drivers/iwlegacy ejejí la opción para el kernel 2.6.24+

Vie, 28/07/2017 - 16:43
zatarra
Imagen de zatarra
Desconectado/a
se unió: 20/07/17

Ah m olvidaba decir que me fijé que el make estuviera instalado con el comando sudo apt-get install make y me aparece ya instalado configurado manualmente no sé que significa eso.

Vie, 28/07/2017 - 16:51
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

¿Y cual es tu placa de red ,? 

Vie, 28/07/2017 - 19:30
zatarra
Imagen de zatarra
Desconectado/a
se unió: 20/07/17

es la Intel Corporation PRO/Wireless 3945ABG [Golan] Network.

Sáb, 29/07/2017 - 12:13
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

esa placa funciona sin problemas en debian desde hace eones... aunque no se yo si tu kernel (por la versión que dices) la soporta. Yo la tuve en un portátil durante 4 años, del 2008 al 2012 creo recordar. Mira a ver si tienes el paquete iwlwifi-firmware instalado, no sea que le falte el firmware, que ya no recuerdo si era necesario o no.

 

Edit...

el ./configure ese tiene que estar en el directorio en el que lo ejecutas, es decir, que el paquete que has bajado lo incluya. si no está en ese directorio, igual existe un autogen.sh, que tendrás que ejecutar antes. Por otro lado, muchos de los drivers para placas de red, no usan ./configure, suelen venir con instrucciones de como hacerlo y basta con el make.

 

Y a todo esto... ¿Versión de Debian? que tampoco sabemos donde estás compilando y porqué lo estás haciendo.... (si, la wifi, pero igual es que ni lo necesitas... puede estar bloqueada por cualquier cosa, mira a ver que te dice el comando rfkill list que me suena que puede ser problema de una configuración del módulo que no recuerdo ahora mismo...

 

Edit 2....

Ese paquete no tiene nada para configurar/compilar ¿De donde te has sacado lo de ./configure?, esos paquetes solo contienen el firmware. Si no me he equivocado: apt install firmware-iwlifi, reinicio, y asunto arreglado.

 

Edit 3...

Es más, en el mismo archivo te dice que tienes que hacer.... resumiendo: buscar donde van los firmwares, copiar el archivo .ucode y a correr..... (si instalas lo que te he dicho antes, ni eso). Hay que leer lo que hay en lo que nos bajamos, no en lo que encontramos en google....

  No hay bar que por bien no venga....
Jue, 10/08/2017 - 11:53
zatarra
Imagen de zatarra
Desconectado/a
se unió: 20/07/17

se ve que si no era un paquete para compilar, al final lo copie al paquete firmware en el directorio /lib/firmware/ reinicie y listo.